Bug 6077 - Some Centrino laptops forced to use vesa driver & No ACPI
: Some Centrino laptops forced to use vesa driver & No ACPI
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: Cauldron
: All Linux
: High Severity: critical
: ---
Assigned To: Thomas Backlund
:
:
: 4beta2 MGA3TOO
:
:
:
  Show dependency treegraph
 
Reported: 2012-05-24 23:07 CEST by claire robinson
Modified: 2014-02-08 20:52 CET (History)
6 users (show)

See Also:
Source RPM: kernel
CVE:


Attachments
lspcidrake -vvv (3.96 KB, text/plain)
2012-05-24 23:13 CEST, claire robinson
Details
Xorg.0.log.old (6.68 KB, application/octet-stream)
2012-05-24 23:23 CEST, claire robinson
Details
report.bug.gz (105.81 KB, application/x-gzip)
2012-05-24 23:31 CEST, claire robinson
Details
kernel/warnings.log from today (84.19 KB, application/x-download)
2012-05-24 23:38 CEST, claire robinson
Details
Xorg.0.log.old (6.73 KB, application/octet-stream)
2012-05-29 13:48 CEST, Rodger Dean
Details
syslog (107.43 KB, application/octet-stream)
2012-05-29 13:50 CEST, Rodger Dean
Details
Xorg.0.log.old (72.07 KB, text/plain)
2012-05-29 13:50 CEST, Rodger Dean
Details
lspcidrake (4.55 KB, application/octet-stream)
2012-05-29 13:53 CEST, Rodger Dean
Details
dmidecode (8.90 KB, text/plain)
2012-06-22 13:55 CEST, claire robinson
Details
Xorg.0.log from 3alpha2 with acpi=off (6.93 KB, text/x-log)
2012-10-02 11:58 CEST, claire robinson
Details
syslog of boot with kernel-linus 3.4.15 (87.36 KB, text/plain)
2012-10-22 18:50 CEST, claire robinson
Details
dmesg with kernel-desktop-3.4.16 and acpi=off (38.74 KB, text/plain)
2012-11-06 13:19 CET, claire robinson
Details
4beta2 kernel panic pic (368.67 KB, image/jpeg)
2013-12-02 10:01 CET, claire robinson
Details
IBM T43 output of dmidecode (11.80 KB, text/plain)
2014-01-31 19:34 CET, Simon Parsons
Details

Description claire robinson 2012-05-24 23:07:35 CEST
I'd appreciate if we can get this fixed quite quickly as this is the main computer we both use. It is an old Samsung X20

Unless I choose No ACPI it hard locks on boot and has to be forcibly powered off.

After upgrade I was left with no video, using the 'Intel i810 or later' driver gives an error 'No devices found'. I managed to get X up using the vesa driver but it is not running well.


# lspcidrake -v | grep -i 915
unknown         : Intel Corporation|Mobile 915GM/GMS/910GML Express Graphics Controller [DISPLAY_OTHER] (vendor:8086 device:2792 subv:144d subd:c01a) (rev: 03)
Card:Intel 810 and later: Intel Corporation|Mobile 915GM/GMS/910GML Express Graphics Controller [DISPLAY_VGA] (vendor:8086 device:2592 subv:144d subd:c01a) (rev: 03)
unknown         : Intel Corporation|Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [BRIDGE_HOST] (vendor:8086 device:2590 subv:144d subd:c01a) (rev: 03)

$ uname -r
3.3.6-desktop-2.mga2

I'll attach some logs
Comment 1 claire robinson 2012-05-24 23:13:31 CEST
Created attachment 2366 [details]
lspcidrake -vvv
Comment 2 claire robinson 2012-05-24 23:23:28 CEST
Created attachment 2367 [details]
Xorg.0.log.old
Comment 3 claire robinson 2012-05-24 23:31:10 CEST
Created attachment 2368 [details]
report.bug.gz
Comment 4 claire robinson 2012-05-24 23:38:59 CEST
Created attachment 2369 [details]
kernel/warnings.log from today

May 24 20:31:44 localhost kernel: [   28.948848] ACPI Exception: AE_BAD_PARAMETER, Thread 4073907200 could not acquire Mutex [0x1] (20120111/utmutex-276)

Not sure if that is relevant.
Comment 5 claire robinson 2012-05-25 20:22:54 CEST
Tried acpi= with each of force, ht & noirq but the only way to boot the machine is with acpi=off. Otherwise it hard locks.

This was not necessary with mga1.

I cannot now 'sleep' the machine.
Comment 6 claire robinson 2012-05-25 20:57:15 CEST
Booting the linux-nonfb grub option (without acpi=off added) gives a kernel panic.

I don't know of a way to capture it in full but I managed a photo..

https://dl.dropbox.com/u/4147101/Final/dsc01062.jpg
Comment 7 Rodger Dean 2012-05-29 13:48:30 CEST
Created attachment 2395 [details]
Xorg.0.log.old
Comment 8 Rodger Dean 2012-05-29 13:49:36 CEST
I am experience the same issues on a Toshiba L300
Comment 9 Rodger Dean 2012-05-29 13:50:16 CEST
Created attachment 2396 [details]
syslog
Comment 10 Rodger Dean 2012-05-29 13:50:58 CEST
Created attachment 2397 [details]
Xorg.0.log.old
Comment 11 Rodger Dean 2012-05-29 13:53:47 CEST
Created attachment 2399 [details]
lspcidrake
Comment 12 claire robinson 2012-05-29 13:59:42 CEST
Changing to all and updating title as Rodger is experiencing the same issues with x86_64 and more modern centrino dual core laptop
Comment 13 claire robinson 2012-06-22 13:55:30 CEST
Created attachment 2484 [details]
dmidecode

Attaching dmidecode in case it is helpful

The laptop runs very hot with vesa and acpi=off so hope it is :)
Comment 14 Thomas Backlund 2012-07-31 15:14:16 CEST
A few things to test on kernel command line (one at a time, without any acpi=* option)

pci=biosirq
pci=noacpi
pci=assign-busses
pci=use_crs
pci=nocrs
Comment 15 claire robinson 2012-07-31 17:13:34 CEST
Just tested each of these Thomas and the machine hard locks with the fan running quickly and a blank screen. No caps lock light etc so have to power off.
Comment 16 claire robinson 2012-08-20 19:06:42 CEST
See also bug 5835 which is the same model laptop.
Comment 17 claire robinson 2012-10-02 11:50:30 CEST
Valid still with pre mga3 alpha2 gnome livecd i586

It hard locks after loading the linux kernel without acpi=off

Doesn't boot to X then and trying startx on tty2 fails

Xorg.0.log shows No devices found.

I'll attach the log and try with xdriver=vesa :(
Comment 18 claire robinson 2012-10-02 11:58:40 CEST
Created attachment 2902 [details]
Xorg.0.log from 3alpha2 with acpi=off

Adding xdriver=vesa allows it to boot into Gnome fallback mode.

I hope we can fix this, mga2 has been a disaster for this laptop
Comment 19 claire robinson 2012-10-02 12:14:45 CEST
Running XFdrake from gnomeclassic on the livecd and selecting i810 and later, then clicking to Test the settings gives:

An error occurred:
no screens found

I found that selecting what I think is probably the wrong driver, for newer poulsbo cards did seem to work but I'm unable to reboot to test it with a livecd.

Using xdriver=intel does not boot to X however.
Comment 20 claire robinson 2012-10-02 12:43:19 CEST
So acpi-off and xdriver=fbdev allows it to boot to gnome fallback mode with an 800x600 screen, which I guess might be better then vesa if it will resize to 1024x768, so that's a start.
Comment 21 claire robinson 2012-10-10 10:19:14 CEST
See also bug 1803 which may be related.
Comment 22 claire robinson 2012-10-15 10:42:11 CEST
Just an update..

Booting with kernel-linus has allowed me to remove acpi=off from the kernel options. It must be one of our patches causing the regression.

Using the Intel i810 or later graphics driver still causes a hard lock though so stuck with Vesa.
Comment 23 claire robinson 2012-10-15 10:42:42 CEST
I should say the above is in mga2
Comment 24 claire robinson 2012-10-15 12:16:05 CEST
It also works with the intel driver for Vermillion based cards
Comment 25 Thomas Backlund 2012-10-22 10:33:36 CEST
Wich kernel-linus ? the 3.3 series in release & updates or the 3.4 series in updates_testing

Can you also test 3.4.15 from updates_testing, both desktop and linus kernel



Rodger, can you attach output of dmidecode.
Comment 26 claire robinson 2012-10-22 10:35:51 CEST
It's 3.3 at the moment Thomas. I'll test the new one today though if I get a chance to. Thanks.
Comment 27 claire robinson 2012-10-22 18:18:38 CEST
So far so good with the new kernel-linus, kernel-linus-devel, -latest's and kernel-userspace-headers for 3.4.15.

There is alot of info in syslog at boot so I'll attach it.
Comment 28 claire robinson 2012-10-22 18:50:58 CEST
Created attachment 2975 [details]
syslog of boot with kernel-linus 3.4.15
Comment 29 claire robinson 2012-10-22 19:07:57 CEST
kernel-desktop 3.4.15 still won't boot.
Comment 30 Thomas Backlund 2012-10-27 20:12:26 CEST
A few things to test...

Can you try to boot kernel-desktop586-3.4.15-1.mga2

That's to rule out i586 vs i686 issues (the kernel-linus is matching desktop586)


After that please try this one:
http://tmb.mine.nu/Mageia/2/bugs/6077/i586/kernel-desktop-3.4.15-1.1.mga2-1-1.mga2.i586.rpm
http://tmb2.mine.nu/Mageia/2/bugs/6077/i586/kernel-desktop-3.4.15-1.1.mga2-1-1.mga2.i586.rpm
Comment 31 claire robinson 2012-10-28 14:42:48 CET
Thanks Thomas, I'll check later on or Monday morning at the latest.
Comment 32 claire robinson 2012-10-29 12:34:15 CET
I tested with both kernel-desktop586-3.4.15-1.mga2 and http://tmb.mine.nu/Mageia/2/bugs/6077/i586/kernel-desktop-3.4.15-1.1.mga2-1-1.mga2.i586.rpm but both refuse to boot and cause the hard lock.

I also tested with the new kernel-linus-3.4.16-1.mga2 which again, does work.
Comment 33 claire robinson 2012-10-29 12:42:10 CET
One minor unrelated comment you might be able to look at also. When adding a new kernel, the Boot Mageia grub option (/boot/vmlinuz) is created above the newly installed kernel, which is added to the bottom of the list, rather than at the top. 

The result is that the default Boot Mageia option is moved into the middle of the installed kernels and looks messy/confusing. It's a relatively minor problem as it boots the desired kernel but I thought it worth mentioning while you are working on them.
Comment 34 Thomas Backlund 2012-11-06 12:16:14 CET
can you provide /var/log/dmesg from booting with kernel-desktop-3.4* too
Comment 35 claire robinson 2012-11-06 13:19:02 CET
Created attachment 3048 [details]
dmesg with kernel-desktop-3.4.16 and acpi=off
Comment 36 claire robinson 2012-11-06 13:36:27 CET
valid pre-3alpha3 also (gnome i586 livedvd)
Comment 37 Marja van Waes 2012-11-26 21:31:14 CET
Today I tried a Mageia2KDEi586 Live CD on a Compaq Pressario CQ60-202ED (NF273EA) with a Intel GMA 4500MHD video chip.

It seems to have the same bug, it hard locked soon after starting to boot it, xdriver=intel didn't help.

I didn't try vesa, because I only wanted to check whether it would be a good idea to install Mageia on it and I don't think vesa can handle the video's and complicated presentations she likes to watch.

This forum thread seems about the same bug
https://forums.mageia.org/en/viewtopic.php?f=23&t=2712
Comment 38 claire robinson 2012-11-27 00:31:41 CET
Marja, you may find that once you've installed and managed to boot, you can install kernel-linus and the machine will be able to run the correct intel driver then.

It would probably be useful to Thomas to be able to compare logs from different hardware.
Comment 39 claire robinson 2012-11-27 00:32:51 CET
You will probably need acpi=off and xdriver=vesa to get it to boot btw.
Comment 40 Marja van Waes 2012-11-27 07:36:43 CET
(In reply to comment #38)
> Marja, you may find that once you've installed and managed to boot, you can
> install kernel-linus and the machine will be able to run the correct intel
> driver then.
> 
> It would probably be useful to Thomas to be able to compare logs from different
> hardware.

Well, it isn't my laptop, so I'm a very reluctant to try something without being sure it'll lead to a working install.

In case it isn't such a hard freeze as it seems (at first it reminded me of https://bugs.mageia.org/show_bug.cgi?id=7521, where there isn't a hard freeze at all): is there a way to ssh into a system you're booting with the LiveCD? I suppose, if it isn't really frozen, that it gets stuck at the language screen.

TBH, I was planning on trying the Mageia 1 LiveCD next week when I go to her, and to install that one if it works. I know it is EOL, but now she has a Windows-without-admin-password, which is worse. Her windows still works though,  but since it refuses to defragment, there is probably a good chance it'll become unusable when I install Mageia next to it, so I really want to be sure Mageia will work well enough for her to do the same things with her laptop as she does now.

Of course, if the Mageia 1 Live CD works fine, I'll install that one and then install Mageia 2 or 3alpha3 DVD (if you don't prefer the latter, I'll take Mageia 2) next to it.
Comment 41 Marja van Waes 2012-11-28 19:41:12 CET
*** Bug 6167 has been marked as a duplicate of this bug. ***
Comment 42 Marja van Waes 2012-12-10 16:47:33 CET
With Mageia 2 and kernel-linus the intel driver works fine with the Intel GMA 4500MHD video chip

kernel-linus didn't pull in kernel-linus-latest, btw.

Is it better not to install kernel-linus-latest?
Comment 43 claire robinson 2012-12-10 19:02:58 CET
It works the other way around marja, kernel-linus-latest will install the latest kernel-linus.
Comment 44 Thomas Backlund 2012-12-10 19:16:18 CET
Yep.
but I think it is a good idea to have kernel-* suggest kernel-*-latest to get the auto-update function.
Comment 45 claire robinson 2013-01-22 19:47:13 CET
valid 3beta2
Comment 46 claire robinson 2013-03-08 18:25:20 CET
valid 3beta3 booting from gnome livecd

Hard locks without acpi=off and without xdriver=vesa it stops at Reached target Graphical Interface.
Comment 47 Fırat Kutlu 2013-05-14 18:58:57 CEST
I have same issues too.

I installed Mageia 3 RC with live dvd. But when I was reboot system, it is staying on the black screen after grub.  When I tried again to open with splash=verbose or splash=no on the kernel line, system is opening. Also when I opened with safe mode, system is opening.

My computer is hp 530

lspci: http://goo.gl/mnQw1

lspcidrake: http://goo.gl/DZDd6
Comment 48 Fırat Kutlu 2013-05-15 17:16:40 CEST
I wrote "xdriver=vesa" instead of "vga=788" on the kernel line in the menu.lst file and my problem is solved as temporary.
Comment 49 claire robinson 2013-05-15 17:26:52 CEST
Firat, if you install kernel-linus and reboot into it, are you then able to use the proper driver and remove acpi=off?
Comment 50 Fırat Kutlu 2013-05-16 17:26:07 CEST
I tried it but system still isn't opened. I solved my problem after deleting both "xdriver=vesa" and "vga=788" commands on the kernel line in the menu.lst.

Namely:

Old line (it dosen't work well): 

title linux
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=bfcb916c-d268-4acd-a2d5-78928636c295 splash quiet resume=UUID=39f328fd-25fa-478b-a9b1-b729d4fbddfc vga=788
root (hd0,0)
initrd /boot/initrd.img

New line (it work succesfully):

title linux
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=bfcb916c-d268-4acd-a2d5-78928636c295 splash quiet resume=UUID=39f328fd-25fa-478b-a9b1-b729d4fbddfc
root (hd0,0)
initrd /boot/initrd.img

Thank you very much for your interest.
Comment 51 Morgan Leijström 2013-05-30 09:41:40 CEST
If you need a working centrino as reference, my IBM thinkpad T43 have a "centrino" label and works without quirks using "ATI Radeon HD4870 and earlier" on mga3 and also did on mga2.
Comment 52 Thomas Backlund 2013-07-22 23:14:56 CEST
There is now a 3.4.52-1.1.mga2 and a 3.4.52-1.2.mga2 to test at:
http://tmb.mine.nu/Mageia/2/bugs/6077/i586/
Comment 53 claire robinson 2013-07-25 16:58:46 CEST
Sorry Thomas, there is no improvement with either of these.
Comment 54 Marja van Waes 2013-09-25 18:43:55 CEST
(In reply to Marja van Waes from comment #37)
> Today I tried a Mageia2KDEi586 Live CD on a Compaq Pressario CQ60-202ED
> (NF273EA) with a Intel GMA 4500MHD video chip.
> 

The above mentioned system didn't have this bug anymore after installing Mageia 3 

I chose to do a fresh install from the traditional installer DVD (only with a /home that was an exact copy of the Mageia 2 one), and went with the default video setting and the default kernel.
Comment 55 claire robinson 2013-12-02 09:46:53 CET
Valid 4beta2 from the live isos.

Booting with the 'safe mode' option which uses vesa ended in a kernel panic related to acpi, i'll attach a photo when I've manage to get it off my phone.
Comment 56 claire robinson 2013-12-02 10:01:18 CET
Created attachment 4563 [details]
4beta2 kernel panic pic
Comment 57 Simon Parsons 2014-01-31 19:30:09 CET
IBM T43 laptop with Intel 915GM graphics. Black screen on launching X.
Given xdriver=vesa on boot and it loads X, albeit sluggishly.
Comment 58 Simon Parsons 2014-01-31 19:34:10 CET
Created attachment 4911 [details]
IBM T43 output of dmidecode

dmidecode -u
Comment 59 Thomas Backlund 2014-02-02 16:17:40 CET
Can you try on mga3 (from updates_testing)	

kernel-3.10.28-1.mga3 

and mga4 (from updates_testing)

kernel-3.12.9-1.mga4
Comment 60 claire robinson 2014-02-08 13:11:26 CET
Successful boot with kernel-desktop-3.10.28-1.mga3 \o/

Linux laptop 3.10.28-desktop-1.mga3 #1 SMP Sat Feb 1 16:24:06 UTC 2014 i686 i686 i686 GNU/Linux
Comment 61 Thomas Backlund 2014-02-08 20:52:00 CET
Great :)

closing then as same fix is also done for Mageia4 and Cauldron

Note You need to log in before you can comment on or make changes to this bug.