Bug 11946 - Kwrite won't launch in M4RC from a Nvidia KDE desktop
: Kwrite won't launch in M4RC from a Nvidia KDE desktop
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: Cauldron
: All Linux
: High Severity: critical
: ---
Assigned To: Mageia Bug Squad
:
:
:
:
: 12696
: 11704 12079
  Show dependency treegraph
 
Reported: 2013-12-10 22:40 CET by William Kenney
Modified: 2014-02-15 12:46 CET (History)
18 users (show)

See Also:
Source RPM: p11-kit
CVE:


Attachments

Description William Kenney 2013-12-10 22:40:36 CET
M4B2 - Classic Installer, 64-bit, KDE
Mageia-4-beta2-x86_64-DVD.iso
md5sum: acc62e627dd35e0ca6c96124d1f51fa4

Install on real hardware:

Test platform:
Intel Core i7-2600K Sandy Bridge 3.4GHz
GIGABYTE GA-Z68X-UD3-B3 LGA 1155 MoBo
GIGABYTE GV-N440D3-1GI Nvidia GeForce GT 440 (Fermi) 1GB
RTL8111/8168B PCI Express 1Gbit Ethernet
DRAM 16GB (4 x 4GB)

Installs just fine but when I installed the nvidia driver
the Kwrite desktop icon would not launch the application.
Open a user terminal, type kwrite, and it launches just fine.
I'm pretty sure it worked with the nouveau driver before I
updated the install to the Nvidia driver. All the other
applications launch just fine from their KDE desktop icons.
More (re)testing on my part.

Reproducible: 

Steps to Reproduce:
Comment 1 William Kenney 2013-12-11 19:02:39 CET
I have very carefully retraced the above testing using the
latest M4B2 - Classic Installer, 64-bit, KDE

md5sum: a8a021d79fac60a2416ed9fe162315a5
Dated 10 Dec 2013

The initial install was to not allow the Nvidia driver to be
installed, nouveau driver. Once you get to the desktop Kwrite
launches from the desktop icon no problem. I then installed the
Nvidia driver.

MCC - > Hardware -> Set up graphical server

rebooted the system as instructed and the same condition exists.
The Kwrite icon on the KDE desktop no longer works but Kwrite
does in fact launch normally from a terminal:

[user@sherman ~]$ kwrite

For me this would be a "major" Severity and I have so set this
bug to be that. All the other icons seem to work just fine.
Comment 2 Carolyn Rowse 2013-12-15 09:40:17 CET
Confirmed on a Fujitsu PC 32-bit with Nvidia.  Opens fine from Konsole but not from menu.

Carolyn
Comment 3 William Kenney 2013-12-15 13:57:48 CET
(In reply to Carolyn Rowse from comment #2)

> Confirmed on a Fujitsu PC 32-bit with Nvidia.  Opens fine from Konsole but
> not from menu.

Many thanks Carolyn. It seems to be the only M4B2 KDE app that won't
launch from it's desktop icon with Nvidia.
Comment 4 Florian Bauer 2013-12-19 21:57:01 CET
confirmed for kwrite and kate on my system (Mageia Beta 2 64bit with Nvidia)
Comment 5 Florian Bauer 2013-12-19 22:00:11 CET
additional information:
kwrite and kate start fine via terminal but if I want to start them from kmenue or krunner I only get high cpu load and program window don't appear.
very annoying...
Comment 6 Mike Crecelius 2013-12-22 17:59:23 CET
This affects me also.  I installed Mageia 4 Beta 2 on a 64 bit system with Nvidia graphics using the KDE live DVD.
I am unable to launch kwrite with the icon. There is a kwrite bouncing icon next to the mouse pointer that goes away after about 15 seconds.  I can launch kwrite on the command line. My graphics driver is set to "Nvidia GeForce 8100 to GeForce 360".
If I set it to nouveau I can then use the icon to launch kwrite.

If I set it back to the Nvidia driver I can no longer launch kwrite with the icon.
Comment 7 William Kenney 2013-12-22 18:03:41 CET
(In reply to Mike Crecelius from comment #6)

> If I set it to nouveau I can then use the icon to launch kwrite.
> 
> If I set it back to the Nvidia driver I can no longer launch kwrite with the
> icon.

Please share with me how you do that.

Thanks
Comment 8 Mike Crecelius 2013-12-22 18:19:12 CET
Click Tools -> System Tools -> Mageia Control Center
Click Hardware -> Set up the graphical server
Click button next to Graphics Card label

Scroll down and expand Xorg
Scroll down and double click nouveau
restart the system
Comment 9 Florian Hubold 2013-12-23 15:24:24 CET
Confirmed here, also with nvidia and proprietary driver and all updates applied.

One workaround could be also to run via Alt+F2 and then write "kwrite" and select the lower entry "Run kwrite" which works.

Seems it's an issue with kdeinit4:

$ ps aux | grep -v grep | grep kwrite
500       8555 96.6  0.9 564464 40104 ?        R    13:54  81:32 kdeinit4: kwrite [kdeinit]                     
500      26941 49.3  0.9 564636 39852 ?        R    15:15   1:34 kdeinit4: kwrite [kdeinit]                     
500      27296 40.0  0.9 564160 39596 ?        R    15:16   0:46 kdeinit4: kwrite [kdeinit]                     
500      27629 40.4  0.9 564160 39600 ?        R    15:17   0:27 kdeinit4: kwrite [kdeinit]

This can be seen in ~/.xsession-errors:

plasma-desktop(3264)/plasma Kickoff::UrlItemLauncher::Private::openUrl: Opening item with URL "/usr/share/applications/kde4/kwrite.desktop"
plasma-desktop(3264)/plasma Kickoff::RecentApplications::Private::addEntry: Duplicate entry added.  Removing existing entry from queue.
plasma-desktop(3264)/plasma Kickoff::RecentApplications::add: Recent app added "kde4-kwrite.desktop" 3
plasma-desktop(3264)/plasma Kickoff::RecentlyUsedModel::Private::removeExistingItem: Removing existing item 0x4453f90
plasma-desktop(3264)/plasma Kickoff::MenuView::rowsAboutToBeRemoved: 0 0
plasma-desktop(3264)/plasma Kickoff::MenuView::modelReset:
plasma-desktop(3264)/plasma Kickoff::MenuView::rowsInserted: 0 0
plasma-desktop(3264)/plasma Kickoff::MenuView::rowsInserted: new action= "KWrite"
klauncher(3207)/kio (KLauncher) KLauncher::processRequestReturn: "/usr/bin/kwrite" (pid 27629) up and running.
kwrite(27629)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from "/var/tmp/kdecache-doktor5000/ksycoca4"


Attaching to the process via strace shows it does absolutely nothing. Also rebuild ksycoca (as that's the last message from kwrite in .xsession-errors) does not change anything.
Comment 10 Morgan Leijström 2013-12-23 21:33:50 CET
I too have two machines with same Nvidia graphics: G86M [Quadro NVS 140M] and according to mageia hardware reporter they vhave the same sub ID etc identical.
Also they use same driver: NVIDIA GeForce 8100 to GeForce 360.
Only graphic difference i know is the R61 have higher resolution screen.

The Thinkpad T61 is fresh install from mga4b2 DVD 64 bit iso- kwrite launch OK.

The Thinkpad R61 is upgraded from mga2 using the same USB stick: kwrite fail to launch from menu (or i.e doupleclicking a text file).

Another problem on that R61 is that KDE apps fail printing, but i.e firefox can print, see Bug 12025.

The R61 also feel slow...
Comment 11 Florian Bauer 2013-12-24 09:54:50 CET
just tested: changed graphics driver to nouveau -> restart -> kwrite starts via icon in start menu.
also other failures are gone (amarok collection scanner freeze: bug 11742; akonadi fails to start: bug 12055)
Comment 12 William Kenney 2013-12-24 20:57:12 CET
FWIW this may be part of this too:

X11 crashes in a virtualbox guest with cauldron (4) installed
https://bugs.mageia.org/show_bug.cgi?id=10442

Using nouveau it works fine.
Comment 13 Morgan Leijström 2013-12-25 22:59:36 CET
Now i changed to noveau and kwrite starts on my R61 too!

Also the return from suspend is OK (so far) - it was a bit buggy before but not consistently.  Also the machine feel snappier.
Comment 14 Florian Bauer 2013-12-26 08:37:14 CET
nouveau solves a lot of bugs but as vdpau doesn't work for me with nouveau it's no alternative for the proprietary blob. also performance of "steam-games" will get poor I think. :-(
Comment 15 Michał Walenciak 2013-12-27 18:36:55 CET
Florian: I also have problems with kdevelop -> https://bugs.mageia.org/show_bug.cgi?id=12099
Comment 16 Florian Hubold 2013-12-27 19:52:03 CET
*** Bug 12106 has been marked as a duplicate of this bug. ***
Comment 17 William Kenney 2014-01-05 20:55:46 CET
Condition prevails in RC
Comment 18 Manuel Hiebel 2014-01-05 21:01:33 CET
no need to mark all kde bugs as blocker, they are already in a tracker for kde ;)
Comment 19 Manuel Hiebel 2014-01-05 21:07:05 CET
William what for nvidia-current version do you have ? the 325.15 is "supposed" to work : https://ml.mageia.org/l/arc/dev/2014-01/msg00114.html
Comment 20 William Kenney 2014-01-06 00:20:00 CET
(In reply to Manuel Hiebel from comment #19)

> William what for nvidia-current version do you have ? the 325.15 is
> "supposed" to work

[wilcal@localhost ~]$ lspci -k
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd Device 3518
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_current

[root@localhost wilcal]# urpmi dkms-nvidia-current
Package dkms-nvidia-current-325.15-1.mga4.nonfree.x86_64 is already installed

[root@localhost wilcal]# urpmi nvidia
Package x11-driver-video-nvidia-current-325.15-1.mga4.nonfree.x86_64 is already installed
Comment 21 William Kenney 2014-01-11 20:56:38 CET
Still a problem in:
Mageia 4 RC - DVD 64 bits
Date.txt: Fri Jan 10 10:52:13 CET 2014
Iso name: Mageia-4-RC-x86_64-DVD.iso
MD5SUM:  859d3aa0df0563be818ba0c1244ed890
Comment 22 William Kenney 2014-01-14 20:30:08 CET
This bug is now occuring on the latest M4 RC 32-bit Live-CD in Vbox
Mageia-4-RC-LiveCD-KDE4-en-i586-CD  (round 7.1)
DATE.txt: Tue Jan 14 16:25:00 CET 2014
ISO: Mageia-4-RC-LiveCD-KDE4-en-i586-CD.iso
md5sum:  50ca387c0b7b79ad03187bdd26391610
Comment 23 William Kenney 2014-01-22 17:31:47 CET
This bug is still a problem in:
Mageia-4-x86_64-DVD  Classic Installer
MD5: 22614315f8c8aaccfe92d567bf566082
Dated 01/19/14
Comment 24 claire robinson 2014-01-23 21:46:38 CET
Likely the same as bug 12244

kwrite, kdenlive and digikam

also separate bug but claws-mail too
Comment 25 William Kenney 2014-01-23 23:21:10 CET
(In reply to claire robinson from comment #24)

> Likely the same as bug 12244
> 
> kwrite, kdenlive and digikam
> 
> also separate bug but claws-mail too

Yep, I suspect something lurking here.
Comment 26 Florian Bauer 2014-02-03 11:26:18 CET
Hello

Are these Nvidia-driver related bugs still open or did I miss something as MGA4 has been released, already?
If the bugs won't (or can't) be fixed it's no problem for me (I've tested actual alternative distributions (opensuse and netrunner) - both worked for me in combination with Nvidia driver.) but please give me a short information if you still work on a solution or not.  

Thank you!
Florian
Comment 27 Florian Hubold 2014-02-03 12:31:30 CET
Only seems partly fixed. E.g. after upgrading to Mageia 4, with nvidia 325.15 active, kwrite starts just fine. kdenlive and digikam do not, only via strace.

But for the underlying problem with the nvidia driver, there's not much we can do about it. And there are workarounds available (using alternative drivers) and so far it only affects nvidia users.
Comment 28 Florian Hubold 2014-02-03 13:10:13 CET
(In reply to William Kenney from comment #1)
> I then installed the
> Nvidia driver.
> 
> MCC - > Hardware -> Set up graphical server
> 
> rebooted the system as instructed and the same condition exists.
> The Kwrite icon on the KDE desktop no longer works but Kwrite
> does in fact launch normally from a terminal:
> 
> [user@sherman ~]$ kwrite

(In reply to Carolyn Rowse from comment #2)
> Confirmed on a Fujitsu PC 32-bit with Nvidia.  Opens fine from Konsole but
> not from menu.

So this sounds like a slightly different bug than the other nvidia ones, but culprit still seems nvidia driver.

FWIW, can you try the workaround proposed in https://bugs.mageia.org/show_bug.cgi?id=11975#c8 (edit the kwrite launcher -> program -> advanced settings -> enable "run as username" and put your username in there )
Comment 29 Morgan Leijström 2014-02-03 17:11:07 CET
Yep still valid.
Tested both for fresh user account and reused account.

System: fresh network install last night mga4 x86_64 KDE, Nvidia driver 325.15.

Hardware: Lenovo thinkpad R61 TYPE 8918-DFG = Centrino Duo, Nvidia G86M [Quadro NVS 140M]

Workaround as per last line in above comment works.

Changed to noveau, now kwrite can launch from menu, from konsole, and when user double cklicks a text file.
Comment 30 egc 2014-02-05 13:53:40 CET
See also my comment on:
https://bugs.mageia.org/show_bug.cgi?id=11193#c27
Comment 31 William Kenney 2014-02-08 13:45:47 CET
(In reply to Florian Hubold from comment #28)

> FWIW, can you try the workaround proposed in
> https://bugs.mageia.org/show_bug.cgi?id=11975#c8 (edit the kwrite launcher
> -> program -> advanced settings -> enable "run as username" and put your
> username in there )

Sorry could you help me how to exactly get to:

launcher -> program -> advanced settings -> enable "run as username"

Right clicking on the Desktop icon does now show these steps.

Thanks
Comment 32 Morgan Leijström 2014-02-08 14:14:49 CET
It only works for launc icons located on desktop (or in a folder), not on the launch menu. (so if you do not have it on desktop, drag a copy of it from menu to desktop first, then)

Right click the desktop icon, select item at bottom, properties (or similar), then select tab "Program"  and down right click the [Advanced] button.
There you see it.
Comment 33 Florian Hubold 2014-02-08 17:50:27 CET
(In reply to Morgan Leijström from comment #32)
> It only works for launc icons located on desktop (or in a folder), not on
> the launch menu.

How so? Right click the launch menu, edit menu entries and you can change all the menu entries there the same way as those on the desktop or elsewhere.
Comment 34 Morgan Leijström 2014-02-08 20:36:50 CET
Ah, we thought you meant we should click the program icon.
Yes using the menu editor also works:

Launcher menu -> "Edit program" (translated from sv) -> select the program -> click the tab "Advanced"
Comment 35 Luc Menut 2014-02-08 21:49:33 CET
This bug could be due to (or triggered by) an empty config file - /etc/pkcs11/pkcs11.conf - incorrectly handled by a library (AFAIK, /etc/pkcs11/pkcs11.conf is empty by default after install).
To all reporters affected by this bug, if your /etc/pkcs11/pkcs11.conf is empty (ls -l /etc/pkcs11/pkcs11.conf), could you try to remove it (as root), and report if it fixes the bug or not. If /etc/pkcs11/pkcs11.conf isn't empty and some programs doesn't launch correctly, please report too.
Please report precisely which nvidia driver version (nvidia-current 325.15, 304.119 or 173.14.39) is used, which arch (i586, x86_64), and which program works or not.

Thanks in advance,
Luc
Comment 36 Mike Crecelius 2014-02-09 02:04:15 CET
Hi,
That fixes it, thanks.  I have the released Mageia 4 installed. I test again to confirm that the bug still occurs.  I invoke kwrite from the icon in the menu, kwrite does not start.

My pkcs11.conf is empty:
ls -la pkcs11.conf
-rw-r--r-- 1 root root 0 Jan 30 14:25 pkcs11.conf

I rename pkcs11.conf to pkcs11.conf.hide and I am now able to launch kwrite from the menu.  I then rename pkcs11.conf.hide back to pkcs11.conf and again kwrite fails to launch from the menu.

lspci -k
03:00.0 VGA compatible controller: NVIDIA Corporation GT218 [ION] (rev a2)
        Subsystem: ASUSTeK Computer Inc. Device 841f
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_current

[root@523 pkcs11]# urpmi -q nvidia
Package x11-driver-video-nvidia-current-325.15-1.mga4.nonfree.x86_64 is already installed
Comment 37 Morgan Leijström 2014-02-09 09:46:46 CET
I confirm too, thanks :)
Comment 38 Raphaël Vinet 2014-02-09 10:17:44 CET
(In reply to Luc Menut from comment #35)
Hi,

I confirm all is OK when /etc/pkcs11/pkcs11.conf is deleted


kwrite works (for the moment never seen the problem elsewhere)


lspci -k
01:00.0 VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 560M] (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 204b
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_current


urpmi -q nvidia
Le paquetage x11-driver-video-nvidia-current-325.15-1.mga4.nonfree.x86_64 est déjà installé
Comment 39 Morgan Leijström 2014-02-09 10:33:26 CET
Confirming total 2 similar systems mga4-64 KDE.

Strangely, when i tested before renaming pkcs11, today kwrite could launch from konsole. (last updates kernel etc yesterday?)

Yes my pkcs11.conf was empty. renaming it fixed the problem of launching kwrite & kate from menu.

Fresh install on Thinkpad R61, beta2 + updates on Thinkpad T61, identical graphic chips.

01:00.0 VGA compatible controller: NVIDIA Corporation G86M [Quadro NVS 140M] (rev a1)
        Subsystem: Lenovo ThinkPad T61
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_current

# uname -a
Linux bamse.tribun 3.12.9-desktop-1.mga4 #1 SMP Sat Feb 1 18:16:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

urpmi -q nvidia
Paket x11-driver-video-nvidia-current-325.15-1.mga4.nonfree.x86_64 är redan installerat
Comment 40 Nicolas Lécureuil 2014-02-09 12:44:29 CET
gilles caulier just confirmed me that this "workaround" fixed the bug for him.
Comment 41 Sander Lepik 2014-02-09 12:54:08 CET
Regarding https://bugs.mageia.org/show_bug.cgi?id=12021#c32 replacing 

touch %{buildroot}%{_sysconfdir}/pkcs11/pkcs11.conf

http://svnweb.mageia.org/packages/cauldron/p11-kit/current/SPECS/p11-kit.spec?revision=547769&view=markup#l76

with

echo " " > %{buildroot}%{_sysconfdir}/pkcs11/pkcs11.conf

or

echo "# This is a placeholder" > %{buildroot}%{_sysconfdir}/pkcs11/pkcs11.conf

should fix it?

Hmm, it will probably fix it for new users but update will just create new pkcs11.conf.rpmnew?
Comment 42 Deri James 2014-02-09 18:15:21 CET
This fix, adding a comment to /etc/pkcs11/pkcs11.conf, fixes the problem starting digikam as well.
Comment 43 Henrik Christiansen 2014-02-10 09:06:11 CET
Just upgraded two mageia 3, both where hit by this.
Deleting the pkcs11.conf fixed it.
Comment 44 egc 2014-02-11 02:19:42 CET
x86_64
nvidia-current 325.15

On an upgrade the pkcs11.conf file is empty, but everything works fine.
Booting with Live_DVD (KDE) the pkcs11.conf is empty, but kwrite and kdenlive won't appear on the desktop (process is running). Renaming this file both programs work fine.
Comment 45 William Kenney 2014-02-11 18:24:01 CET
All right folks. I'm back and de-jetlagged ( 9-hours for me ) from FOSDEM.

All I did was rename:

/etc/pkcs11/pkcs11.conf

to

/etc/pkcs11/pkcs11.conf.tmp

And Kwrite launches here just fine.

What harm is done by doing this and what is pkcs11.conf used for?
Comment 46 T ex78 2014-02-12 14:18:34 CET
Hello,

Just activated nvidia driver this morning, and fell into the trap.
Found this thread, so I copied /etc/pkcs11/pkcs11.conf.example into pkcs11.conf, rather than renaming or deleting.
Contains one line "user-config: merge", defaule value, they say.
Works well now.
Comment 47 Morgan Leijström 2014-02-12 14:20:46 CET
Having the default value there by default seems like a good idea.
Comment 48 Sander Lepik 2014-02-12 14:24:23 CET
There is now package in core/updates_testing: p11-kit. It should fix the problem.
Comment 49 Mike Crecelius 2014-02-15 00:47:51 CET
Hi,
   I have downloaded a set of updates to my mageia 4 system a few minutes ago and tested kwrite.  Kwrite now launches.  I can see there is new text added to pkcs11.conf.  It looks like this bug can be closed.
Thanks
Comment 50 Sander Lepik 2014-02-15 12:46:42 CET
Closing..

Note You need to log in before you can comment on or make changes to this bug.