Bug 12106 - kwrite and kate hang after being launched
Summary: kwrite and kate hang after being launched
Status: RESOLVED DUPLICATE of bug 11946
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Depends on:
Reported: 2013-12-24 11:36 CET by MichaÅ Walenciak
Modified: 2013-12-27 19:52 CET (History)
3 users (show)

See Also:
Source RPM: kate-4.11.4-1.mga4.src.rpm
Status comment:


Description MichaÅ Walenciak 2013-12-24 11:36:55 CET
Description of problem:
Today I've found similar problem to this bug: https://bugs.mageia.org/show_bug.cgi?id=12099 but with kate and kwrite.

Then I launch kwrite from "start menu" or by clicking on txt file it just hangs (no window appears).
However when I run it from Konsole it just starts normally (what differs from mentioned similar bug, where only running from gdb or strace helps). What's in common for this problem and problem in related bug: a back trace of hanged program. When I attached to hanged kwrite I saw the same bt (problems with plugins).

Here it is:
#0  0x00007fa22ecc3457 in ?? () from /usr/lib64/nvidia-current/libGL.so.1                                                                   
#1  0x00007fa22d8be6cc in ?? () from /usr/lib64/nvidia-current/tls/libnvidia-tls.so.331.20                                                  
#2  0x00007fa220aae361 in p11_mmap_close (map=map@entry=0x247dc30) at compat.c:235                                                          
#3  0x00007fa220a95c36 in _p11_conf_parse_file (                                                                                            
    filename=filename@entry=0x7fa220ab2a48 "/etc/pkcs11/pkcs11.conf", sb=sb@entry=0x0,                                                      
    flags=flags@entry=1) at conf.c:165                                                                                                      
#4  0x00007fa220a962f0 in _p11_conf_load_globals (                                                                                          
    system_conf=system_conf@entry=0x7fa220ab2a48 "/etc/pkcs11/pkcs11.conf",                                                                 
    user_conf=user_conf@entry=0x7fa220ab2a2b "~/.config/pkcs11/pkcs11.conf",                                                                
    user_mode=user_mode@entry=0x7fff21d87e9c) at conf.c:220                                                                                 
#5  0x00007fa220aa23e6 in load_registered_modules_unlocked () at modules.c:504                                                              
#6  0x00007fa220aa3195 in load_registered_modules_unlocked () at modules.c:843
#7  initialize_registered_inlock_reentrant () at modules.c:758
#8  p11_kit_initialize_registered () at modules.c:839
#9  0x00007fa22135a308 in initialize_automatic_p11_kit () at pkcs11.c:442
#10 gnutls_pkcs11_init (flags=0, deprecated_config_file=0x0) at pkcs11.c:508
#11 0x00007fa221343f14 in gnutls_global_init () at gnutls_global.c:278
#12 0x00007fa221cda15a in inf_init (error=<optimized out>) at inf-init.c:78
#13 0x00007fa2230f0288 in KteCollaborativePlugin::KteCollaborativePlugin (this=0x29cb1e0, 
    parent=<optimized out>)
    at /usr/src/debug/kte-collaborative-v0.2.0/kte-plugin/ktecollaborativeplugin.cpp:88
#14 0x00007fa2230f2248 in KPluginFactory::createInstance<KteCollaborativePlugin, QObject> (
    parentWidget=<optimized out>, parent=<optimized out>, args=...)
    at /usr/include/kpluginfactory.h:477
#15 0x00007fa2484e3be3 in KPluginFactory::create (this=0x254e0c0, 
    iface=0x7fa229449370 <qt_meta_stringdata_KTextEditor__Plugin> "KTextEditor::Plugin", 
    parentWidget=0x0, parent=0x29a2150, args=..., keyword=...)
    at /usr/src/debug/kdelibs-4.11.4/kdecore/util/kpluginfactory.cpp:203

As in related bug: my mageia is cauldron updated from mageia 3 (at 20th of dec).
I didn't have this problems with kwrite until yesterday (after some updates I believe).

Version-Release number of selected component (if applicable):

How reproducible:
Anytime I run kwrite

Steps to Reproduce:
1. Run kwrite from "start menu" and it will hang


Steps to Reproduce:
MichaÅ Walenciak 2013-12-24 11:37:21 CET

CC: (none) => Kicer86

Comment 1 Bit Twister 2013-12-24 12:09:21 CET
(In reply to MichaÅ Walenciak from comment #0)
> Then I launch kwrite from "start menu" or by clicking on txt file it just
> hangs (no window appears).
>> Here it is:
> #0  0x00007fa22ecc3457 in ?? () from /usr/lib64/nvidia-current/libGL.so.1   

My WAG is nvidia driver problem. I can launch kwrite from KDE menu without problem.

Clean install of Mageia-4-beta2-x86_64-DVD.iso, runlevel is 3, 
lspci | grep -i vga snippet

[AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
Thierry Vignaud 2013-12-26 19:06:54 CET

CC: (none) => mageia
Summary: kwrite and kate hang after being lanuched => kwrite and kate hang after being launched

Comment 2 Manuel Hiebel 2013-12-26 23:50:56 CET
Michael can you confirm, was is your video driver ?

certainly a duplicate of bug 11946 (there is some kde bugs with nvidia)
Comment 3 MichaÅ Walenciak 2013-12-27 18:35:10 CET
Yeah it seems I've exactly the same problem ( I do use nvidia's driver).

Thank you.
Comment 4 Florian Hubold 2013-12-27 19:52:03 CET
Marking as duplicate, caused by nvidia driver.

*** This bug has been marked as a duplicate of bug 11946 ***

CC: (none) => doktor5000
Resolution: (none) => DUPLICATE

Note You need to log in before you can comment on or make changes to this bug.