Bug 2226 - Update candidate for KDE 4.6.5
Summary: Update candidate for KDE 4.6.5
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 1
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard:
Keywords: validated_update
Depends on: 2227
Blocks: 2450
  Show dependency treegraph
 
Reported: 2011-07-21 14:58 CEST by John Balcaen
Modified: 2011-08-19 14:21 CEST (History)
12 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
List of kde 4.6.5 rpm (30.26 KB, text/plain)
2011-07-21 15:33 CEST, John Balcaen
Details

Description John Balcaen 2011-07-21 14:58:28 CEST
This update provides KDE SC 4.6.5
It's also fixes some mageia bugs 
#1287 konqueror is now able to play flash video 
#897  the next/forwad button were not working in help 
#1740  Kopete needs to be updated for the new ICQ cert

What to test :
- Test that upgrade is correctly working (no files conflicts)
- test that the 3 bugs reported before are fixed

Know issue :
If you're testing upgrade from beta 2 & older please read this https://www.mageia.org/pipermail/mageia-dev/20110503/004364.html


Proposal Advisory :
« This update provides KDE SC 4.6.5 which is a bugfix only release.»
Comment 1 John Balcaen 2011-07-21 15:33:48 CEST
Created attachment 664 [details]
List of kde 4.6.5 rpm
Comment 2 José Jorge 2011-07-21 16:09:44 CEST
Tested on x86_64 :
- update OK
- bugs #1287 and #897 fixed (with 64bit flash plugin)
- bug #1740 I don't have an ICQ account to test.
Comment 3 Dave Hodgins 2011-07-22 00:29:38 CEST
Found one minor problem.  On logout (with confirm logout enabled), the
entire screen, except the confirmation dialog goes white, with jagged
horizontal black lines.  Can't get a screen shot, and the screen returns
to normal if I cancel the logout.

I have an Radeon 9200 SE, using the x11-driver-video-ati-6.14.1-4.mga1
video driver on an i586 system.

I don't know if this is a general problem, or if it only happens with my
video card.  It's a very minor/cosmetic issue only though.
Comment 4 John Balcaen 2011-07-22 01:07:35 CEST
(In reply to comment #3)
> Found one minor problem.  On logout (with confirm logout enabled), the
> entire screen, except the confirmation dialog goes white, with jagged
> horizontal black lines.  Can't get a screen shot, and the screen returns
> to normal if I cancel the logout.
> 
> I have an Radeon 9200 SE, using the x11-driver-video-ati-6.14.1-4.mga1
> video driver on an i586 system.
> 
> I don't know if this is a general problem, or if it only happens with my
> video card.  It's a very minor/cosmetic issue only though.
It's a know issue in fact with the free radeon driver.
If 3d effects are enable you won't see it again.
Comment 5 Dave Hodgins 2011-07-23 03:29:49 CEST
I've updated bug 1287 indicating that this update doesn't fully fix the problem,
but with a workaround to fix it.

The navigation in help, bug 897 is fixed.

For bug 1740, I created an icq account, and used kopete to connect to it.

Can someone from the sysadmin team push the packages listed in attachment 664 [details]
from Core Updates Testing to Core Updates please.

The srpms packages ...
kdeaccessibility4-4.6.5-0.mga1.src.rpm      
kdeadmin4-4.6.5-0.mga1.src.rpm              
kdeartwork4-4.6.5-0.mga1.src.rpm            
kdebase4-4.6.5-0.mga1.src.rpm               
kdebase4-runtime-4.6.5-0.mga1.src.rpm       
kdebase4-workspace-4.6.5-0.4.mga1.src.rpm   
kdebindings4-4.6.5-0.mga1.src.rpm           
kdeedu4-4.6.5-1.mga1.src.rpm                
kdegames4-4.6.5-0.mga1.src.rpm              
kdegraphics4-4.6.5-0.mga1.src.rpm           
kde-l10n-4.6.5-0.mga1.src.rpm              
kdelibs4-4.6.5-0.1.mga1.src.rpm            
kdemultimedia4-4.6.5-0.1.mga1.src.rpm      
kdenetwork4-4.6.5-0.mga1.src.rpm           
kdepim4-4.4.11.1-2.1.mga1.src.rpm          
kdepim4-runtime-4.4.11.1-0.1.mga1.src.rpm  
kdepimlibs4-4.6.5-0.mga1.src.rpm           
kdeplasma-addons-4.6.5-0.mga1.src.rpm      
kdesdk4-4.6.5-0.mga1.src.rpm               
kdetoys4-4.6.5-0.1.mga1.src.rpm            
kdetoys4-4.6.5-0.mga1.src.rpm              
kdeutils4-4.6.5-0.1.mga1.src.rpm           
kdewebdev4-4.6.5-0.1.mga1.src.rpm
Comment 6 Samuel Verschelde 2011-07-23 16:34:11 CEST
A KDE update is a big update, I think we need more testers for that, who use it one regular basis for example for one week, to make sure there are no regressions. Or maybe wait for the end of the testing party beginning tomorrow (24) and lasting for 3 days.

I'm removing the validated_update keyword until we decide about it, there is no need to rush the update.
Comment 7 Thomas Backlund 2011-07-23 16:40:07 CEST
Good call Samuel, I agree with you... 

it's important to get it right...
Comment 8 John Balcaen 2011-07-23 17:11:08 CEST
Yep.
In fact maybe we can have a « minimal » numbers of testers for big update like KDE/GNOME/LXDE/XFCE ?
Comment 9 Sander Lepik 2011-07-23 17:21:27 CEST
I will run it on x86_64.
Comment 10 Samuel Verschelde 2011-07-23 20:40:08 CEST
(In reply to comment #8)
> Yep.
> In fact maybe we can have a « minimal » numbers of testers for big update like
> KDE/GNOME/LXDE/XFCE ?

Yes as well as a minimum amount of time I think.
Comment 11 Samuel Verschelde 2011-07-23 20:43:49 CEST
I have been using this new version on my i586 as soon as it was available in the core/updates_testing media and saw no regression so far.
Comment 12 José Jorge 2011-07-23 21:22:39 CEST
The same in x86_64 : no regression since it was in mirrors. I use it daily.
Comment 13 Manuel Hiebel 2011-07-26 18:49:11 CEST
Hi, I have ask user of the french forum to test the update.
http://www.mageialinux-online.org/forum/topic-10891-1+appel-a-test-de-la-mise-a-jour-de-kde.php

Except some orphans:
lib64iodbc2-3.52.7-2.mga1.x86_64
lib64sopranoindex1-2.6.0-0.1.mga1.x86_64
soprano-2.6.0-0.1.mga1.x86_64
soprano-plugin-virtuoso-2.6.0-0.1.mga1.x86_64
virtuoso-opensource-6.1.2-1.mga1.x86_64

and a conflict with the US-locale, know issue see on the the description of this bug, all seems ok.
Comment 14 Samuel Verschelde 2011-07-26 19:16:57 CEST
Hmm, it's annoying to see this conflict issue (I got it too), I'm afraid of bad updates image if lots of users have started to use mageia with the 2nd beta. I still think we need at the very least to warn in the advisory.
Comment 15 José Jorge 2011-07-26 20:11:22 CEST
1. No user that is NOT a developper would use a stable system from a Beta.
2. It was never said that people could upgrade from beta to final.
3. I don't know any "end user" that has done that. What a large poll ;-)

I think this should not be fixed, it is like the problems with upgrade from Mandriva with backports enabled : people that do that are not users that expect everything to work flawlessly.
Comment 16 Samuel Verschelde 2011-07-26 20:20:12 CEST
(In reply to comment #15)
> 1. No user that is NOT a developper would use a stable system from a Beta.
> 2. It was never said that people could upgrade from beta to final.
> 3. I don't know any "end user" that has done that. What a large poll ;-)
> 
> I think this should not be fixed, it is like the problems with upgrade from
> Mandriva with backports enabled : people that do that are not users that expect
> everything to work flawlessly.

I reserve the right to say "told ya" if we get bad PR about that.
Comment 17 David GEIGER 2011-07-27 14:28:08 CEST
(In reply to comment #13)
> Hi, I have ask user of the french forum to test the update.
> http://www.mageialinux-online.org/forum/topic-10891-1+appel-a-test-de-la-mise-a-jour-de-kde.php
> 
> Except some orphans:
> lib64iodbc2-3.52.7-2.mga1.x86_64
> lib64sopranoindex1-2.6.0-0.1.mga1.x86_64
> soprano-2.6.0-0.1.mga1.x86_64
> soprano-plugin-virtuoso-2.6.0-0.1.mga1.x86_64
> virtuoso-opensource-6.1.2-1.mga1.x86_64
> 
And this one for me too:

lib64iptables5-1.4.10-3.mga1.x86_64
Comment 18 John Balcaen 2011-07-27 14:40:20 CEST
(In reply to comment #17)
[...]
> And this one for me too:
> 
> lib64iptables5-1.4.10-3.mga1.x86_64
It is not related to KDE upgrade but to iptables updates (where this library is not used anymore.
Comment 19 Frédéric Buclin 2011-07-28 02:03:17 CEST
I had no conflicts while upgrading from 4.6.3 to 4.6.5.
Comment 20 John Balcaen 2011-07-30 13:48:44 CEST
I(In reply to comment #17)
> (In reply to comment #13)
> > Hi, I have ask user of the french forum to test the update.
> > http://www.mageialinux-online.org/forum/topic-10891-1+appel-a-test-de-la-mise-a-jour-de-kde.php
> > 
> > Except some orphans:
> > lib64iodbc2-3.52.7-2.mga1.x86_64
> > lib64sopranoindex1-2.6.0-0.1.mga1.x86_64
> > soprano-2.6.0-0.1.mga1.x86_64
> > soprano-plugin-virtuoso-2.6.0-0.1.mga1.x86_64
> > virtuoso-opensource-6.1.2-1.mga1.x86_64
I push a new kdebase4-runtime package with soprano as requires since, the changes from requires to suggests allow urpmi to mark this package as auto-orphans :
if the user was previously using nepomuk & used the auto-orphans functionnality he might end up with a non working nepomuk installation without knowing.
Comment 21 David GEIGER 2011-07-31 22:51:16 CEST
Just for info, since the update packages in Core_Updates_Testing :

->kdebase4-runtime-4.6.5-1.1.mga1.x86_64.rpm 
->kwallet-daemon-4.6.5-1.1.mga1.x86_64.rpm ->lib64kwalletbackend4-4.6.5-1.1.mga1.x86_64.rpm ->lib64molletnetwork4-4.6.5-1.1.mga1.x86_64.rpm
->lib64nepomuksync4-4.6.5-1.1.mga1.x86_64.rpm

I have a new orphan package:

->soprano-plugin-redland-2.6.0-0.1.mga1.x86_64

I did a: urpmi soprano-plugin-redland-2.6.0-0.1.mga1.x86_64
Comment 22 John Balcaen 2011-08-01 06:04:52 CEST
(In reply to comment #21)
> Just for info, since the update packages in Core_Updates_Testing :
> 
> ->kdebase4-runtime-4.6.5-1.1.mga1.x86_64.rpm 
> ->kwallet-daemon-4.6.5-1.1.mga1.x86_64.rpm
> ->lib64kwalletbackend4-4.6.5-1.1.mga1.x86_64.rpm
> ->lib64molletnetwork4-4.6.5-1.1.mga1.x86_64.rpm
> ->lib64nepomuksync4-4.6.5-1.1.mga1.x86_64.rpm
> 
> I have a new orphan package:
> 
> ->soprano-plugin-redland-2.6.0-0.1.mga1.x86_64
> 
> I did a: urpmi soprano-plugin-redland-2.6.0-0.1.mga1.x86_64
soprano-plugin-redland is not used by nepomuk so you can safely remove it.
Indexing still works without this plugin (virtuoso is the required plugin)
Comment 23 Florian Hubold 2011-08-03 20:03:20 CEST
Update went fine so far, only thing i've noticed is the "Delete" context menu entry disappeared and has to be enabled again in Dolphin. Will check back in some days after more thorough testing.
Comment 24 Frédéric Buclin 2011-08-03 20:09:04 CEST
And I didn't find any regression either. The KDE bugs which are present in 4.6.5 were already present in 4.6.3.
Comment 25 John Balcaen 2011-08-03 20:29:15 CEST
(In reply to comment #24)
> And I didn't find any regression either. The KDE bugs which are present in
> 4.6.5 were already present in 4.6.3.
Are they fixed upstream  (aka in 4.7 hopefully or master then) ? maybe i can try to backport the fixes eventually.
Comment 26 Frédéric Buclin 2011-08-03 20:32:15 CEST
(In reply to comment #25)
> Are they fixed upstream  (aka in 4.7 hopefully or master then) ? maybe i can
> try to backport the fixes eventually.

AFAIK no. They are still marked as unconfirmed:
https://bugs.kde.org/show_bug.cgi?id=277193
https://bugs.kde.org/show_bug.cgi?id=277082
https://bugs.kde.org/show_bug.cgi?id=265870
Comment 27 Florian Hubold 2011-08-03 20:50:16 CEST
One regression since KDE 4.5 is also fixed now as a bonus with the 4.6.5 update :)
https://bugs.kde.org/show_bug.cgi?id=261443

I'm really thankful for that as drag&drop is used really often here.
Comment 28 David GEIGER 2011-08-04 08:58:45 CEST
I also noticed a slight bug in KDE 4.6.5 (which is existed for some time now).

When you open Dolphin ->> Network tab ->> Network ,I've got a blank page (white).

By cons, if you now click Configuration ->> Configure Dolphin while remaining in the folder Network ,just click OK without changing anything and then just appeared folders Workstation.

At home for example, there's my PC and my wife's PC, so two files David (Worstation) and Valy (Workstation).

And of course this operation it must be done at each reboot.

I hope I well expressed.
Comment 29 John Balcaen 2011-08-04 11:07:09 CEST
(In reply to comment #26)
[...]
> https://bugs.kde.org/show_bug.cgi?id=277193
> https://bugs.kde.org/show_bug.cgi?id=277082
> https://bugs.kde.org/show_bug.cgi?id=265870
Ok i'm on cc on thoses bugs (well i was already on one)

(In reply to comment #27)
> One regression since KDE 4.5 is also fixed now as a bonus with the 4.6.5 update
> :)
> https://bugs.kde.org/show_bug.cgi?id=261443
> 
> I'm really thankful for that as drag&drop is used really often here.
From this bug report it does not seems that the drag & drop functionality is fixed.

(In reply to comment #28)
> I also noticed a slight bug in KDE 4.6.5 (which is existed for some time now).
[...]
> And of course this operation it must be done at each reboot.
> 
> I hope I well expressed.
Hum, did you report it upstream eventually ?
i'll check if i can reproduce here.
Comment 30 Florian Hubold 2011-08-04 11:32:18 CEST
(In reply to comment #29)

> > One regression since KDE 4.5 is also fixed now as a bonus with the 4.6.5 update
> > :)
> > https://bugs.kde.org/show_bug.cgi?id=261443
> > 
> > I'm really thankful for that as drag&drop is used really often here.
> From this bug report it does not seems that the drag & drop functionality is
> fixed.

These are the relevant commits making it work again:
https://bugs.kde.org/show_bug.cgi?id=261443#c11
https://bugs.kde.org/show_bug.cgi?id=261443#c13

Whatever, drag&drop to taskbar does raise applications again for all MIME types i tried so far, which did only partly work in 4.6.3.
Comment 31 David GEIGER 2011-08-04 12:08:59 CEST
> (In reply to comment #28)
> > I also noticed a slight bug in KDE 4.6.5 (which is existed for some time now).
> [...]
> > And of course this operation it must be done at each reboot.
> > 
> > I hope I well expressed.
> Hum, did you report it upstream eventually ?
> i'll check if i can reproduce here.


Sorry, but no I have not reported it upstream the bug .Perhaps it is better that other users check before, Not that I'm the only one having this problem.
Comment 32 John Balcaen 2011-08-04 12:26:09 CEST
(In reply to comment #30)
> (In reply to comment #29)
> 
> > > One regression since KDE 4.5 is also fixed now as a bonus with the 4.6.5 update
> > > :)
> > > https://bugs.kde.org/show_bug.cgi?id=261443
> > > 
> > > I'm really thankful for that as drag&drop is used really often here.
> > From this bug report it does not seems that the drag & drop functionality is
> > fixed.
> 
> These are the relevant commits making it work again:
> https://bugs.kde.org/show_bug.cgi?id=261443#c11
> https://bugs.kde.org/show_bug.cgi?id=261443#c13
> 
> Whatever, drag&drop to taskbar does raise applications again for all MIME types
> i tried so far, which did only partly work in 4.6.3.

Oups i did not check the websvn part, i'll check if they're part of KDE SC & if not i'll try to do it.

(In reply to comment #31)
> > (In reply to comment #28)
> > > I also noticed a slight bug in KDE 4.6.5 (which is existed for some time now).
> > [...]
> > > And of course this operation it must be done at each reboot.
> > > 
> > > I hope I well expressed.
> > Hum, did you report it upstream eventually ?
> > i'll check if i can reproduce here.
> 
> 
> Sorry, but no I have not reported it upstream the bug .Perhaps it is better
> that other users check before, Not that I'm the only one having this problem.
Did you try eventually another workaround :
start dolphin , go to network, close dolphin & restart it ?
Comment 33 David GEIGER 2011-08-05 07:54:44 CEST
 
> (In reply to comment #31)
> > > (In reply to comment #28)
> > > > I also noticed a slight bug in KDE 4.6.5 (which is existed for some time now).
> > > [...]
> > > > And of course this operation it must be done at each reboot.
> > > > 
> > > > I hope I well expressed.
> > > Hum, did you report it upstream eventually ?
> > > i'll check if i can reproduce here.
> > 
> > 
> > Sorry, but no I have not reported it upstream the bug .Perhaps it is better
> > that other users check before, Not that I'm the only one having this problem.
> Did you try eventually another workaround :
> start dolphin , go to network, close dolphin & restart it ?


Ah yes, this works too. This is a possible alternative.OK

Finally: is it a bug or is this normal?
Comment 34 John Balcaen 2011-08-05 12:08:28 CEST
(In reply to comment #33)
> Ah yes, this works too. This is a possible alternative.OK
> 
> Finally: is it a bug or is this normal?
I would say (but i'm might be wrong) that's normal & just a delay in network scan.
It could of course be a dolphin bug when it's refreshing (i guess you already used F5 for refreshing the network:/ kio ? )
Comment 35 David GEIGER 2011-08-05 17:15:23 CEST
(In reply to comment #34)

> I would say (but i'm might be wrong) that's normal & just a delay in network
> scan.
> It could of course be a dolphin bug when it's refreshing (i guess you already
> used F5 for refreshing the network:/ kio ? )

Oh no! I did not know to refresh network with F5.
Excellent, this works fine too.

A bug or not I do not know either.But with Mandriva 2010.2 and KDE 4.4.5 the  refreshing network (or dolphin) is done automatically.

Thanks.
Comment 36 John Balcaen 2011-08-06 01:36:57 CEST
(In reply to comment #30)
> (In reply to comment #29)
> 
> > > One regression since KDE 4.5 is also fixed now as a bonus with the 4.6.5 update
> > > :)
> > > https://bugs.kde.org/show_bug.cgi?id=261443
> > > 
> > > I'm really thankful for that as drag&drop is used really often here.
> > From this bug report it does not seems that the drag & drop functionality is
> > fixed.
> 
> These are the relevant commits making it work again:
> https://bugs.kde.org/show_bug.cgi?id=261443#c11
> https://bugs.kde.org/show_bug.cgi?id=261443#c13
> 
> Whatever, drag&drop to taskbar does raise applications again for all MIME types
> i tried so far, which did only partly work in 4.6.3.

Ok in fact both commits are for the first in trunk & the second in 4.6 branch so it's already applied with KDE SC 4.6.5 ( https://projects.kde.org/projects/kde/kdebase/kde-workspace/repository/revisions/b4eca90184cb43ce689724f5dab6f052361fb075 )
Comment 37 John Balcaen 2011-08-06 22:15:19 CEST
(In reply to comment #3)
> Found one minor problem.  On logout (with confirm logout enabled), the
> entire screen, except the confirmation dialog goes white, with jagged
> horizontal black lines.  Can't get a screen shot, and the screen returns
> to normal if I cancel the logout.
> 
> I have an Radeon 9200 SE, using the x11-driver-video-ati-6.14.1-4.mga1
> video driver on an i586 system.
> 
> I don't know if this is a general problem, or if it only happens with my
> video card.  It's a very minor/cosmetic issue only though.

Ok i finally found the upstream bug report here : https://bugs.kde.org/show_bug.cgi?id=199965
Comment 38 Florian Hubold 2011-08-07 22:07:56 CEST
I have found one regression to 4.6.3
Remeberthemilk forgot its authorization, and if you want to login to authorize it again, then a browser integrated into the plasmoid (maybe webkit, don't know) should open. Browser never opens and plasmoids shows forever the loading animation.

Basically, RTM is useless now for me with 4.6.5. But will try again with a fresh configuration.

Can you tell me how to debug this and how the browser is called? plasmoidviewer shows nothing about this ...
Comment 39 John Balcaen 2011-08-08 00:09:28 CEST
(In reply to comment #38)
> I have found one regression to 4.6.3
> Remeberthemilk forgot its authorization, and if you want to login to authorize
> it again, then a browser integrated into the plasmoid (maybe webkit, don't
> know) should open. Browser never opens and plasmoids shows forever the loading
> animation.
I can confirm here ;o)

> Basically, RTM is useless now for me with 4.6.5. But will try again with a
> fresh configuration.
> 
> Can you tell me how to debug this and how the browser is called? plasmoidviewer
> shows nothing about this ...
Not really since you're already using plasmoidviewer.
I guess you did not forgot to increase the debug via kdebudialog ?
Comment 41 John Balcaen 2011-08-08 00:16:01 CEST
Ok it's an upstream bug at least ( https://bugs.kde.org/show_bug.cgi?id=279029 )
Comment 42 Florian Hubold 2011-08-08 11:02:40 CEST
(In reply to comment #39)
> Not really since you're already using plasmoidviewer.
> I guess you did not forgot to increase the debug via kdebudialog ?

Yes, that was the problem. But shouldn't this be written down somewhere, or have i simply missed it? Commented upstream and voted, hope they fix it fast.
Comment 43 John Balcaen 2011-08-08 13:28:35 CEST
I pushed a new kdelibs4 package with more upstream fixs  :
 - patch201 to add some translations
 - patch202 to fix a regression about input text clearButton stopping to work on khtml forms (kde #246513)
 - patch203 should fix a crash after waking up from sleep (kde #270037)
 - patch204 to fix filename security check (kde #278643)
 - patch205 to fix an infinite loop in khtml/rendering (kde #205348)
 - patch206 to unbreak completion on tab-out in khtml (kde #277457)

Most of the fix are related to khtml (patch 202,204,205 & 206).
Comment 44 Frédéric Buclin 2011-08-08 13:33:10 CEST
When you say upstream, do you mean 4.6.6 or 4.7.0?
Comment 45 John Balcaen 2011-08-08 13:44:33 CEST
(In reply to comment #44)
> When you say upstream, do you mean 4.6.6 or 4.7.0?
There's no 4.6.6 but thoses patchs come from the 4.6. branch of kdelibs
(the rpm changelog is more accurate because i wrote - Add more 4.6 branch patchs: ) since some dev still fix bugs for the 4.6 branch ;)

the patch from 4.7.x (or master) are in the #trunk section
( see http://svnweb.mageia.org/packages/updates/1/kdelibs4/current/SPECS/kdelibs4.spec?revision=132311&view=markup )
of course as exception patch200 should be my trunk section since it's came from trunk/4.7 branch.
Comment 46 Florian Hubold 2011-08-08 17:14:17 CEST
Found another problem.

In Dolphin -> View -> Panels -> Filter
The filter panel appears, but everything is greyed out.
Please don't tell me this is due to deactivated Nepomuk and Strigi, which seems to provide this ...
Comment 47 John Balcaen 2011-08-08 18:30:58 CEST
(In reply to comment #46)
> Found another problem.
not a problem ;)
> In Dolphin -> View -> Panels -> Filter
> The filter panel appears, but everything is greyed out.
> Please don't tell me this is due to deactivated Nepomuk and Strigi, which seems
> to provide this ...

sorry but it's nepomuk *and* strigi related ;)
Comment 48 David GEIGER 2011-08-08 18:34:57 CEST
(In reply to comment #46)
> Found another problem.
> 
> In Dolphin -> View -> Panels -> Filter
> The filter panel appears, but everything is greyed out.
> Please don't tell me this is due to deactivated Nepomuk and Strigi, which seems
> to provide this ...

I do not have this problem in Dolphin -> View -> Panels -> Filter
I can use the filter and it works properly.
Tested on Mageia release 1 (Official) for x86_64.
Comment 49 John Balcaen 2011-08-08 18:46:14 CEST
(In reply to comment #48)
> I do not have this problem in Dolphin -> View -> Panels -> Filter
> I can use the filter and it works properly.
> Tested on Mageia release 1 (Official) for x86_64.

with nepomuk & strigi enabled i guess ?
Comment 50 David GEIGER 2011-08-08 19:42:18 CEST
(In reply to comment #49)
> 
> with nepomuk & strigi enabled i guess ?


Yes of course with nepomuk & strigi enabled. Anyway I use it.
Comment 51 John Balcaen 2011-08-09 08:44:01 CEST
(In reply to comment #38)
> I have found one regression to 4.6.3
> Remeberthemilk forgot its authorization, and if you want to login to authorize
> it again, then a browser integrated into the plasmoid (maybe webkit, don't
> know) should open. Browser never opens and plasmoids shows forever the loading
> animation.
It's now fixed with the next kdeplasma-addons package (please note that you need to restart plasma before to test )
Comment 52 Franklin Weng 2011-08-09 09:54:02 CEST
Count me one if you need further KDE testing.

I've upgraded to 4.6.5 from update_testing and didn't find anything annoy so far.
I'm running on an i586 machine with built-in intel910 graphic driver.
Comment 53 Florian Hubold 2011-08-10 16:48:38 CEST
(In reply to comment #51)

> It's now fixed with the next kdeplasma-addons package (please note that you
> need to restart plasma before to test )

Yes, Rememberthemilk works again after re-authorization.
As all original bugs are fixed, and you added some bonus upstream bugfixes, is there any ETA for this update for Mageia 1?


Only thing that would be nice to be fixed is Amarok playing Audio-CDs,
but that's a seperate issue. Will file another bug report for that.
Comment 54 Frédéric Buclin 2011-08-12 12:44:10 CEST
John, could you apply the patch from https://bugs.kde.org/show_bug.cgi?id=188528#c80 please? It reverts a part of the patch from https://bugs.kde.org/show_bug.cgi?id=188528#c30 which shouldn't have been committed.
Comment 55 David GEIGER 2011-08-17 09:23:40 CEST
Hello,

Today update of 126 packages KDE 4.6.5. The installation went smoothly.

Now he has 9 orphaned packages:

# urpme --auto-orphans
writing /var/lib/rpm/installed-through-deps.list
Pour satisfaire les dépendances, les 9 paquetages suivants vont être désinstallés (7.7Mo):

(paquetages orphelins)
  google-gadgets-common-0.11.2-5.mga1.x86_64
  google-gadgets-qt-0.11.2-5.mga1.x86_64
  kdebase4-workspace-googlegadgets-4.6.5-1.2.mga1.x86_64
  lib64ggadget-dbus1.0_0-0.11.2-5.mga1.x86_64
  lib64ggadget-js1.0_0-0.11.2-5.mga1.x86_64
  lib64ggadget-qt1.0_0-0.11.2-5.mga1.x86_64
  lib64ggadget-webkitjs0-0.11.2-5.mga1.x86_64
  lib64ggadget-xdg1.0_0-0.11.2-5.mga1.x86_64
  lib64ggadget1.0_0-0.11.2-5.mga1.x86_64
Supprimer 9 paquetages ? (o/N)

Is what I can uninstall them? safely ?
Comment 56 D Morgan 2011-08-17 09:31:08 CEST
I think yes because of this commit log : 


Log Message

Don't suggests kdebase4-workspace-googlegadgets since googlegadgets is broken (mga #1755)
Comment 57 John Balcaen 2011-08-17 15:09:28 CEST
(In reply to comment #54)
> John, could you apply the patch from
> https://bugs.kde.org/show_bug.cgi?id=188528#c80 please? It reverts a part of
> the patch from https://bugs.kde.org/show_bug.cgi?id=188528#c30 which shouldn't
> have been committed.
It's available with the new kdebase package, could you please test ?

(In reply to comment #55)
> Hello,
> Today update of 126 packages KDE 4.6.5. The installation went smoothly.
> 
> Now he has 9 orphaned packages:
[...]
> 
> Is what I can uninstall them? safely ?
As pointed by dmorgan, it's related to the suggests removed by me due to mga #1775
Comment 58 David GEIGER 2011-08-17 16:37:59 CEST
Ok ,it's good ,i uninstall them.

Thank you very much John Balcaen and D Morgan.
Comment 59 Dave Hodgins 2011-08-18 21:15:46 CEST
Does anyone have any objections to validating the kde 4.6.5 updates?

Do we have a complete list of the srpm packages?
Comment 60 John Balcaen 2011-08-19 01:07:11 CEST
Here is the list of src.rpm

kdeaccessibility4-4.6.5-0.mga1.src.rpm     kdebindings4-4.6.5-0.mga1.src.rpm  kdemultimedia4-4.6.5-0.1.mga1.src.rpm    kdeutils4-4.6.5-0.1.mga1.src.rpm                                 
kdeadmin4-4.6.5-0.mga1.src.rpm             kdeedu4-4.6.5-1.mga1.src.rpm       kdenetwork4-4.6.5-0.mga1.src.rpm         kdewebdev4-4.6.5-0.1.mga1.src.rpm                                
kdeartwork4-4.6.5-0.mga1.src.rpm           kdegames4-4.6.5-0.mga1.src.rpm     kdepimlibs4-4.6.5-0.mga1.src.rpm         oxygen-icon-theme-4.6.5-0.mga1.src.rpm                           
kdebase4-4.6.5-1.0.mga1.src.rpm            kdegraphics4-4.6.5-0.mga1.src.rpm  kdeplasma-addons-4.6.5-1.2.mga1.src.rpm  task-kde4-4.6.5-0.mga1.src.rpm                                   
kdebase4-runtime-4.6.5-1.1.mga1.src.rpm    kde-l10n-4.6.5-0.mga1.src.rpm      kdesdk4-4.6.5-0.mga1.src.rpm                                                                              
kdebase4-workspace-4.6.5-1.2.mga1.src.rpm  kdelibs4-4.6.5-1.1.mga1.src.rpm    kdetoys4-4.6.5-0.1.mga1.src.rpm
Comment 61 Dave Hodgins 2011-08-19 02:10:42 CEST
Can someone from the sysadmin team push kde 4.6.5 from
Core Updates Testing to Core Updates please.

See Comment 60 for the list of srpm packages.

Advisory:
This update provides KDE SC 4.6.5
It's also fixes some mageia bugs 
#1287 konqueror is now able to play flash video 
#897  the next/forwad button were not working in help 
#1740  Kopete needs to be updated for the new ICQ cert
Comment 62 D Morgan 2011-08-19 14:21:39 CEST
update pushed.

Note You need to log in before you can comment on or make changes to this bug.