Bug 18992 - M6 does not connect to my HP printer/scanner
Summary: M6 does not connect to my HP printer/scanner
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
: High normal
Target Milestone: Mageia 6
Assignee: Martin Whitaker
QA Contact:
URL:
Whiteboard:
Keywords: 6sta1.5
: 19348 (view as bug list)
Depends on:
Blocks: 18367
  Show dependency treegraph
 
Reported: 2016-07-19 19:09 CEST by William Kenney
Modified: 2017-05-13 22:38 CEST (History)
9 users (show)

See Also:
Source RPM: hplip-3.16.10-1.mga6.src.rpm
CVE:
Status comment:


Attachments
No USB print system files (485.66 KB, application/zip)
2016-07-19 19:16 CEST, William Kenney
Details
No USB print system files (485.66 KB, application/zip)
2016-07-19 19:19 CEST, William Kenney
Details

Description William Kenney 2016-07-19 19:09:45 CEST
Description of problem:

All printer files seem to have installed correctly.
But running the HP Device Manager the system ( CUPS? ) does not see the printer.
This is a Printer/Scanner combo and Xsane also does not see the device and
reports a blocking firewall error "ports like (5353/udp)"
journalctl reports a "Invalid usb_open: Permission denied" error
All system files are attached in a ZIP file to this bug.
Same system, same printer with an M5 install printer works just fine.
Comment 1 William Kenney 2016-07-19 19:16:06 CEST
Created attachment 8211 [details]
No USB print system files
Comment 2 William Kenney 2016-07-19 19:19:30 CEST
Created attachment 8212 [details]
No USB print system files
Comment 3 James Kerr 2016-07-19 22:49:48 CEST
I have the same model 

I was able to get it to print by setting it up using system-config-printer in MCC

Setup scanning in MCC tells me that the scanner is available, but it is not found by Xsane.

HP device manager reports a "device communication error"

I haven't yet had time to do any further investigation
Comment 4 William Kenney 2016-07-20 04:29:19 CEST
OK set the printer up with the MCC -> Hardware -> Configure printing

That did in fact work. I can now print to the printer from the host M6
system under test and from an M5 system on the LAN. Xsane still does not
see the scanner. The HP Device Manager still does not see it.
usbview does see the printer on the USB buss. The error reported by
Xsane is here:

HPLIP cannot detect devices in your network. This may be due to
existing firewall settings blocking the required ports like
(5353/udp). When you are in a trusted network environment, you
may open the ports for network services like mdns and slp in the
firewall. For detailed steps follow the link.

http://hplipopensource.com/node/375

HPLIP Status Service does not seem to be working.
Comment 5 William Kenney 2016-07-20 04:32:36 CEST
Note: there is no firewall on the M6 test system.
The firewall is turned off.
All ports are available in and out.
Comment 6 claire robinson 2016-07-20 09:48:23 CEST
Jul 19 09:45:08 localhost python[4377]: io/hpmud/musb.c 2093: Invalid usb_open: Permission denied
Jul 19 09:45:08 localhost python[4377]: io/hpmud/musb.c 2093: Invalid usb_open: Permission denied
Jul 19 09:45:08 localhost python[4377]: io/hpmud/musb.c 2093: Invalid usb_open: Permission denied
Jul 19 09:45:08 localhost python[4377]: io/hpmud/musb.c 2093: Invalid usb_open: Permission denied
Jul 19 09:45:08 localhost hp-setup[4377]: hp-setup[4377]: error: No devices found on bus: usb
Comment 7 Marja van Waes 2016-07-21 15:27:06 CEST
Assigning to all packagers collectively, since there is no maintainer for this package.
Comment 8 James Kerr 2016-07-21 19:15:15 CEST
Additional info:

1. Xsane functions normally when launched as root.

2. If I create the file /etc/udev/rules.d/10-scanner.rules
containing the single line

ATTR{idVendor}=="03f0", ATTR{idProduct}=="c511", GROUP:="jim", MODE:="0660"

where jim is my username, Xsane functions normally, but printing no longer works.

I'll try to do some more investigation and capture log files etc. sometime this weekend.
Comment 9 Marja van Waes 2016-07-21 19:32:03 CEST
(In reply to James Kerr from comment #8)

> I'll try to do some more investigation and capture log files etc. sometime
> this weekend.

Thanks!
Comment 10 James Kerr 2016-07-26 12:15:25 CEST
I was able to get scanning, printing and Device Manager all to work properly by changing MODE:="0660" to MODE:="0777" in the file that I added to /etc/udev/rules.d/

Something more restrictive than 777 would probably work. I haven't tried.

It seems that Mageia is setting up this device with the wrong permissions. It would take someone with more expertise than I have to know the "correct" way of fixing this.
Comment 11 Philippe Makowski 2016-07-29 14:32:29 CEST
(In reply to James Kerr from comment #10)
> I was able to get scanning, printing and Device Manager all to work properly
> by changing MODE:="0660" to MODE:="0777" in the file that I added to
> /etc/udev/rules.d/
> 
> Something more restrictive than 777 would probably work. I haven't tried.
> 
> It seems that Mageia is setting up this device with the wrong permissions.
> It would take someone with more expertise than I have to know the "correct"
> way of fixing this.

hplip set it up as 
OWNER="root", GROUP="lp", MODE="0664"

strange that it does not work work you
Comment 12 James Kerr 2016-07-29 16:18:29 CEST
The problem was that my user did not belong to the lp group. After I added my user to the lp group, scanning, printing and Device Manager all work correctly without the udev "hack". Thanks.
Comment 13 James Kerr 2016-07-29 17:02:20 CEST
FWIW in Mageia 5, this device works perfectly even though my user is not a member of the lp group.
Comment 14 William Kenney 2016-07-29 17:31:51 CEST
(In reply to James Kerr from comment #13)

> FWIW in Mageia 5, this device works perfectly even though my user is not a
> member of the lp group.

Same here
Comment 15 Philippe Makowski 2016-08-05 09:32:05 CEST
do you have the same issue with simple-scan ?
Comment 16 William Kenney 2016-08-05 16:30:46 CEST
(In reply to Philippe Makowski from comment #15)

> do you have the same issue with simple-scan ?

Gave it a try today. I've never used simple-scan. It launched just
fine then a window indicated that it sensed the HP printer and needed
to download a "driver". After a few minutes it issued the following:

You appear to have an HP scanner
X Failed to install drivers
Once installed you will need to restart Simple Scan.
Comment 17 Frédéric Buclin 2016-08-09 17:54:59 CEST
Same issues as what has already been reported here:

- xsane is unable to detect the scanner (HP ENVY 4500 on USB) despite MCC > Hardware > Configure Scanners says it's available.

- SimpleScan detects my HP scanner, tries to download/install relevant drivers, but fails to do so.


But printing works fine. MCC > Hardware > Configure Printers installed all relevant RPMs automatically.
Comment 18 Frédéric Buclin 2016-08-09 17:58:37 CEST
BTW, this looks like a duplicate of bug 16253. wilcal, agree?
Comment 19 William Kenney 2016-08-09 18:44:52 CEST
(In reply to Frédéric Buclin from comment #18)

> BTW, this looks like a duplicate of bug 16253. wilcal, agree?

I would tend to agree but I am not having any problems working
with this printer with M5.
Comment 20 Marja van Waes 2016-08-10 19:41:17 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:

    system-config-printer-1.5.7-5.mga6.i586
    system-config-printer-applet-1.5.7-5.mga6.i586
    system-config-printer-udev-1.5.7-5.mga6.i586

    system-config-printer-libs-1.5.7-5.mga6.noarch

    system-config-printer-1.5.7-5.mga6.x86_64
    system-config-printer-applet-1.5.7-5.mga6.x86_64
    system-config-printer-udev-1.5.7-5.mga6.x86_64


@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.
Comment 21 William Kenney 2016-08-10 23:47:32 CEST
On Real Hardware, M6, Plasma, 64-bit

Package(s) under test:
system-config-printer system-config-printer-udev
system-config-printer-libs system-config-printer-applet

default install of packages:

[root@localhost wilcal]# urpmi system-config-printer
Package system-config-printer-1.5.7-3.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi system-config-printer-udev
Package system-config-printer-udev-1.5.7-3.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi system-config-printer-libs
Package system-config-printer-libs-1.5.7-3.mga6.noarch is already installed
[root@localhost wilcal]# urpmi system-config-printer-applet
Package system-config-printer-applet-1.5.7-3.mga6.x86_64 is already installed

See Description above

install packages from updates_testing:
system-config-printer system-config-printer-udev
system-config-printer-libs system-config-printer-applet

[root@localhost wilcal]# urpmi system-config-printer
Package system-config-printer-1.5.7-5.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi system-config-printer-udev
Package system-config-printer-udev-1.5.7-5.mga6.x86_64 is already installed
[root@localhost wilcal]# urpmi system-config-printer-libs
Package system-config-printer-libs-1.5.7-5.mga6.noarch is already installed
[root@localhost wilcal]# urpmi system-config-printer-applet
Package system-config-printer-applet-1.5.7-5.mga6.x86_64 is already installed

Congratulations to Phillipem. Printer now works fine locally and from another
system on the LAN. The HP Device Manager opens, sees, installs and manages the printer.
XSane opens, sees the scanner, scans an image and outputs that image to a pnm file.
Gimp opens that pnm file and can convert it to a jpg file.
Well done all.
Comment 22 Marja van Waes 2016-08-11 08:32:54 CEST
Thanks for testing, wilcal :-)

i feel tempted to already close this report, but let's wait till new s-c-p is pushed to core/release.
Comment 23 Frédéric Buclin 2016-08-11 13:12:48 CEST
(In reply to Marja van Waes from comment #20)
> On the 25th of July, Phillipem uploaded the following packages to 
> Cauldron's core/updates_testing:

Those are already what I have on my machine, and this doesn't help, see comment 17.
Comment 24 James Kerr 2016-08-11 13:43:30 CEST
$ rpm -qa | grep system-config-printer
system-config-printer-1.5.7-5.mga6
system-config-printer-udev-1.5.7-5.mga6
system-config-printer-applet-1.5.7-5.mga6
system-config-printer-libs-1.5.7-5.mga6

These packages do not resolve the bug for me. I've tested on two systems - one on which printing had not previously been configured and one where it had. 

In each case I could get printing to work with s-c-p but scanning did not and Device Manager reported a communication error. This was the situation with the previous packages.

As before, adding my user to the lp group resulted in the device functioning correctly in all respects.
Comment 25 Marja van Waes 2016-08-11 14:27:18 CEST
(In reply to Frédéric Buclin from comment #23)
> Those are already what I have on my machine, and this doesn't help, see
> comment 17.

So it's too early to close this report :-(

(In reply to James Kerr from comment #24)
> 
> These packages do not resolve the bug for me. I've tested on two systems -
> one on which printing had not previously been configured and one where it
> had.

Thanks for testing both! 

> 
> As before, adding my user to the lp group resulted in the device functioning
> correctly in all respects.

@ Thierry
@ Philippem

Can adding (existing and new) users to the lp group be automated (at least for regular workstations with default security etc. settings)?
Comment 26 Philippe Makowski 2016-08-12 17:48:19 CEST
(In reply to Marja van Waes from comment #25)
> @ Thierry
> @ Philippem
> 
> Can adding (existing and new) users to the lp group be automated (at least
> for regular workstations with default security etc. settings)?

It seems that we need this, yes

see https://bugs.launchpad.net/debian/+source/hplip/+bug/530746
we don't use this patch to make it clear :
http://svnweb.mageia.org/packages/cauldron/hplip/current/SOURCES/hp-check-groups.dpatch?view=markup&pathrev=496265

the question now, is how to add (existing and new) users to the lp group, or how to avoid this
Comment 27 William Kenney 2016-09-14 04:47:30 CEST
(In reply to Philippe Makowski from comment #26)

> the question now, is how to add (existing and new) users to the lp group, or
> how to avoid this

Correct. I just experienced this with a brand new from the ground up
install of Cauldron. The printer worked but the scanner and HP Device Mgr
did not. Whey I manually added the user to the lp group they worked.
Comment 28 Marja van Waes 2016-09-14 08:47:10 CEST
*** Bug 19348 has been marked as a duplicate of this bug. ***
Comment 29 Marja van Waes 2016-09-14 08:50:16 CEST
Making the summary more general, so that it covers LAN and WLAN and other USB HP printers, too (because of duplicate 19348)
Comment 30 William Kenney 2016-09-14 14:35:52 CEST
Why is this not set up at the install of the printer apps.
How is an end user supposed to know this?
Comment 31 Nicolas Lécureuil 2016-10-25 15:29:06 CEST
can you test with new s-c-p ?
Comment 32 James Kerr 2016-10-26 15:00:16 CEST
$ rpm -q system-config-printer hplip
system-config-printer-1.5.7-10.mga6
hplip-3.16.9-2.mga6

No change from before:
s-c-p sets up printing OK, but Xsane does not find the scanner (although "Add a scanner" in MCC does find the scanner) and HP Device manager reports a communication error.

As before, adding my user to the lp group enables printing, scanning and Device Manager to all function correctly.

I don't think that this bug is a bug in s-c-p. Rather it is a bug in hplip, specifically the permissions assigned to the device. The bug first appeared when hplip 3.15 was packaged for mga5. Because of it, those packages were placed in backports. See bug#16498.

There are other open hplip bugs that may involve device permissions, such as #18507 and #18940
Comment 33 James Kerr 2016-11-05 14:14:09 CET
No change with the latest hplip-3.16.10-1.mga6

It is still necessary to add the user to the lp group to make this device fully functional.
Comment 34 Thomas Andrews 2017-01-02 19:25:50 CET
This is still valid as of earlier today. HP Device Manager reports communication error on both an Officejet 6110 and a Deskjet 5650 when the device would be idle, but when examining status is showing messages from past printing events.

Confirmed that adding the user to the lp group makes the "communication error" notices go away.
Comment 35 Maurice Batey 2017-04-27 13:38:16 CEST
Using an HP5520:

  On Mageia-5 with user in 'lp' group, Xsane does find the scanner now.

    N.B. In previous weeks it was not finding the scanner, so some recent update must have fixed it ...

  On Mageia-6-rc, the scanner was not found until I added user to the 'lp' group.
Comment 36 Martin Whitaker 2017-04-29 12:38:33 CEST
I've fixed this in svn. Please retest when hplip-model-data-3.16.11-3 becomes available.
Comment 37 Martin Whitaker 2017-04-29 16:24:42 CEST
Unfortunately, although this fixes the problem for HP Device Manager, it does stop system-config-printer (in MCC) from discovering the printer when you try to add a new printer. I'm investigating this. Meanwhile, you can add the printer in HP Device Manager (after which, system-config-printer will see it).
Comment 38 Martin Whitaker 2017-04-29 20:26:10 CEST
(In reply to Martin Whitaker from comment #37)
> Unfortunately, although this fixes the problem for HP Device Manager, it
> does stop system-config-printer (in MCC) from discovering the printer when
> you try to add a new printer.

Looks like this is another manifestation of bug 17593.
Comment 39 Frédéric Buclin 2017-05-13 16:54:01 CEST
My HP ENVY 4500 printer/scanner can now be detected correctly with the recent RPMs, and I can now scan correctly. Closing this bug as fixed.

wilcal, please reopen if this is still an issue for you.
Comment 40 William Kenney 2017-05-13 22:33:08 CEST
In VirtualBox, M6, Plasma, 64-bit

(In reply to Frédéric Buclin from comment #39)

> wilcal, please reopen if this is still an issue for you.

I just connected my HP USB printer to my M6, Plasma, x86_64 Vbox host then
created an M6 x86_64, Plasma Vbox client. I then forwarded the printer
to the test client. All the hp-utils rpms installed correctly in the client
and I was able to set up the Vbox client to both print and scan. The HP
Device Manager set the printer up and I was able to use all the
functions of that. More to do over the next days but initially
it looks like this bug is fixed.

Many thanks all.
Comment 41 William Kenney 2017-05-13 22:38:43 CEST
In VirtualBox, M6, Plasma, 64-bit

Using the Vbox client described in Comment # 40 I bridged it
to the network and was able to print from an M5.1 KDE system
on the LAN.

Note You need to log in before you can comment on or make changes to this bug.