Bug 17593 - system-config-printer doesn't discover some USB connected printers
Summary: system-config-printer doesn't discover some USB connected printers
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: release_blocker normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard:
Keywords: 6RC
Depends on:
Blocks: 18367
  Show dependency treegraph
 
Reported: 2016-01-24 00:38 CET by ben mcmonagle
Modified: 2017-05-13 22:04 CEST (History)
8 users (show)

See Also:
Source RPM: system-config-printer-1.5.7-1.mga6
CVE:
Status comment: Mismatch between actual group for devices and the udev rules


Attachments
output of plugging in printer (6.23 KB, text/plain)
2016-02-07 21:51 CET, ben mcmonagle
Details
output of system-config-printer 2>&1 | tee /[...]/output.txt (58.19 KB, text/plain)
2016-02-08 06:53 CET, ben mcmonagle
Details

Description ben mcmonagle 2016-01-24 00:38:20 CET
Description of problem:Attempting to add a USB connected Canon mp280 printer from MCC -"set up printers" installs task-printing-server and t-p-hp packages. then choosing "add" does not discover the printer. 
Mageia 5 uses config-system-printer, is it missing?

Version-Release number of selected component (if applicable):
Mageia-6-dev1-x86_64-DVD.iso
DATE.txt: Tue Jan 19 22:17:34 CET 2016


How reproducible:every time


Steps to Reproduce:
1.install any of the current mga6-dev1 .isos and reboot
2.login to any desktop and attempt to add a USB connected printer
3.


Reproducible: 

Steps to Reproduce:
Comment 1 Marja van Waes 2016-02-05 18:50:40 CET
doesn't system-config-printer get installed?

What is the output of


    rpm -qa | grep system-config-printer


Did this printer work fine in Mga5?

Whiteboard: (none) => 6dev1
Keywords: (none) => NEEDINFO
CC: (none) => marja11

Comment 2 ben mcmonagle 2016-02-07 09:49:37 CET
(In reply to Marja van Waes from comment #1)
> doesn't system-config-printer get installed?
> 
> What is the output of
> 
> 
>     rpm -qa | grep system-config-printer

[home@localhost ~]$ rpm -qa | grep system-config-printer
system-config-printer-udev-1.5.7-1.mga6
system-config-printer-libs-1.5.7-1.mga6
system-config-printer-1.5.7-1.mga6
[home@localhost ~]$ 

> 
> 
> Did this printer work fine in Mga5?
yes, Mga4 and 5
Comment 3 Marja van Waes 2016-02-07 10:28:18 CET
(In reply to ben mcmonagle from comment #2)

> > 
> > Did this printer work fine in Mga5?
> yes, Mga4 and 5

Thanks for the replies :-)

Can you please 
* start your computer with _detached_ printer
* open a terminal and as root run the following command:

      journalctl -f 2>&1 | tee output.txt

* plug in the printer
* wait a few minutes
* then stop the command with "Ctrl"+"C"
* attach the file output.txt to the bug report. 

Assigning to all packagers collectively for now, because system-config-printer has no maintainer, even if the printer might just not be detected at all :-/ 

Please reassign if it becomes clear the real culprit is somewhere else

Source RPM: task-printing-server 2011 8.mga5 x86_64 ? => system-config-printer-1.5.7-1.mga6
Assignee: bugsquad => pkg-bugs

Comment 4 ben mcmonagle 2016-02-07 21:51:38 CET
Created attachment 7422 [details]
output of plugging in printer

could not find where tee output was placed - sorry

copied terminal output to text file.

hope this is what is required
Comment 5 Marja van Waes 2016-02-07 23:37:03 CET
Yeah, that's fine

The good new is, that the printer is well detected:

Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: device devpath is /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6
Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: MFG:Canon MDL:MP280 series SERN:- serial:B12867

So I'm not sure what the problem is when you try to add it in MCC.

Can you start 

   system-config-printer 2>&1 | tee /path/to/where/you/can/find/it/output.txt

as root from a terminal, again try to add the printer and after that failed, attach output.txt to this bug report?
Comment 6 Nic Baxter 2016-02-08 00:27:17 CET
Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: CheckAndInstallDrivers()
Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: CheckInstalledDrivers()
Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: MissingDriver()
Feb 08 09:38:26 localhost.localdomain udev-configure-printer[2658]: FAIL HERE

Doesn't this mean cups doesn't have a driver for the printer? 

Ben in the past have you installed any extra drivers possibly downloaded from Canon?

CC: (none) => nic

Comment 7 ben mcmonagle 2016-02-08 06:53:09 CET
Created attachment 7424 [details]
output of system-config-printer 2>&1 | tee /[...]/output.txt
Comment 8 ben mcmonagle 2016-02-08 07:00:22 CET
(In reply to Nic Baxter from comment #6)

> 
> Doesn't this mean cups doesn't have a driver for the printer? 
> 
> Ben in the past have you installed any extra drivers possibly downloaded
> from Canon?

For Mageia-3 needed to download drivers from Canon and some "time" needed to get to function

For Mageia-4+5 just set up  via MCC - automatic find and install of drivers that were built in.

hope this helps
Comment 9 Marja van Waes 2016-02-08 07:35:12 CET
(In reply to Nic Baxter from comment #6)

> 
> Doesn't this mean cups doesn't have a driver for the printer? 
> 

Yes, but I thought that was normal, because he hadn't been able to add the printer in MCC
Comment 10 Marja van Waes 2016-02-08 07:52:04 CET
(In reply to ben mcmonagle from comment #7)
> Created attachment 7424 [details]
> output of system-config-printer 2>&1 | tee /[...]/output.txt

Thanks, Ben :-)

Looks like system-config-printer has a problem with current gtk+3.0

First, there's a lot of:

   (system-config-printer.py:24419): Gtk-WARNING **: Theme parsing error:

and then there is:

   sys:1: PyGIWarning: Polkit was imported without specifying a version first.
   Use gi.require_version('Polkit', '1.0') before import to ensure that the 
   right version gets loaded.
   sys:1: PyGIWarning: GdkPixbuf was imported without specifying a version 
   first. Use gi.require_version('GdkPixbuf', '2.0') before import to ensure
   that the right version gets loaded.
   sys:1: PyGIWarning: Gdk was imported without specifying a version first.
   Use gi.require_version('Gdk', '3.0') before import to ensure that the right
   version gets loaded.
   sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use
   gi.require_version('Gtk', '3.0') before import to ensure that the right 
   version gets loaded.
   sys:1: PyGIWarning: Notify was imported without specifying a version first.
   Use gi.require_version('Notify', '0.7') before import to ensure that the 
   right version gets loaded.
   sys:1: PyGIWarning: GnomeKeyring was imported without specifying a version 
   first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure
   that the right version gets loaded.
   /usr/share/system-config-printer/ToolbarSearchEntry.py:45: 
   PyGIDeprecationWarning: GObject.PARAM_READWRITE is deprecated; use 
   GObject.ParamFlags.READWRITE (glib 2.42+) instead
   GObject.PARAM_READWRITE)

system-config-printer is broken in cauldron, probably since a recent gtk3.0 update

However, I'd like one person to reproduce this, before I add Olav and some others to the CC (I'm running mga5 at this very moment)

Source RPM: system-config-printer-1.5.7-1.mga6 => system-config-printer-1.5.7-1.mga6 gtk3.0
Summary: [mga6-dev1] Unable to add usb connected canon mp280 => system-config-printer is broken [(system-config-printer.py:24419): Gtk-WARNING **: Theme parsing error:]
Keywords: NEEDINFO => (none)

Comment 11 Florian Hubold 2016-02-08 10:43:23 CET
(In reply to Marja van Waes from comment #10)
> Looks like system-config-printer has a problem with current gtk+3.0
> 
> First, there's a lot of:
> 
> Gtk-WARNING **: Theme parsing error:
> 
> and then there is:
> some more warnings
> 
> system-config-printer is broken in cauldron

Apart from the _warnings_ why do you think it's broken and how is it broken?
And are there other reports that users are not able to install printers at all using s-c-p?

I think there's no relation between those gtk warnings and the udev backend udev-configure-printer not finding a driver.

CC: (none) => doktor5000

Comment 12 Marja van Waes 2016-02-08 12:07:07 CET
because i assumed that clicking on 'add' in s-c-p would have led to visible probing in the output.

i don't know of other reports, that's why i wrote that i'd like someone to reproduce it
Comment 13 Marja van Waes 2016-02-08 12:13:27 CET
so, especially because adding this printer worked before, and because there were big gtk+3.0 changes, i thought it very possible that clicking add no longer works... however, i should have asked whether clicking add gave a different screen or not, instead of assuming it didn't
Comment 14 Marja van Waes 2016-02-08 19:44:22 CET
(In reply to Florian Hubold from comment #11)

> 
> I think there's no relation between those gtk warnings and the udev backend
> udev-configure-printer not finding a driver.

OK, it looks like I was wrong with my assumptions :-þ

I just started system-config-printer in cauldron, and after clicking on Add, the next screen appears without problem.

(I didn't have a printer attached, though, so could not try to reproduce Ben's issue)

However, does udev-configure-printer not finding a driver result in s-c-p not seeming to discover the printer? Ben reported the printer was not discovered after clicking on Add.

It was possible in my cauldron - that was _not_ installed from a 6dev1 iso - to manually add a Canon-MP280, there were 4 driver/PPD-files available. The only odd thing was, that the Cups and the Foomatic drivers were in two separate lists: there was a list for Canon MP280 printers, and one for Canon MP280-series printers.

Summary: system-config-printer is broken [(system-config-printer.py:24419): Gtk-WARNING **: Theme parsing error:] => system-config-printer doesn't discover Canon mp280 printer

Comment 15 Marja van Waes 2016-04-05 19:37:27 CEST
@ Ben

Is this bug still valid?

Keywords: (none) => 6dev1
Whiteboard: 6dev1 => (none)

Comment 16 ben mcmonagle 2016-04-06 07:51:03 CEST
still valid
Marja van Waes 2016-05-05 14:44:00 CEST

Blocks: (none) => 18367

Comment 17 Marja van Waes 2016-08-10 19:41:31 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:

    system-config-printer-1.5.7-5.mga6.i586
    system-config-printer-applet-1.5.7-5.mga6.i586
    system-config-printer-udev-1.5.7-5.mga6.i586

    system-config-printer-libs-1.5.7-5.mga6.noarch

    system-config-printer-1.5.7-5.mga6.x86_64
    system-config-printer-applet-1.5.7-5.mga6.x86_64
    system-config-printer-udev-1.5.7-5.mga6.x86_64


@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => makowski.mageia

Comment 18 ben mcmonagle 2016-08-11 12:42:21 CEST
updated system to latest.
added Cauldron updates_testing.

installed: 

    system-config-printer-1.5.7-5.mga6.i586
    system-config-printer-applet-1.5.7-5.mga6.i586
    system-config-printer-udev-1.5.7-5.mga6.i586

not available:
   system-config-printer-libs-1.5.7-5.mga6.noarch

added 43 packages with "configure printing and scanning"
 "set up the printers, the print job queues"

attempted to configure printer: canon mp280
not discovered.

rebooted system

attempted to configure printer : canon mp280
not discovered.
Comment 19 Marja van Waes 2016-08-11 12:59:00 CEST
(In reply to ben mcmonagle from comment #18)
> updated system to latest.
> added Cauldron updates_testing.

Thanks for testing :-)
> 
> installed: 
> 
>     system-config-printer-1.5.7-5.mga6.i586
>     system-config-printer-applet-1.5.7-5.mga6.i586
>     system-config-printer-udev-1.5.7-5.mga6.i586
> 
> not available:
>    system-config-printer-libs-1.5.7-5.mga6.noarch

Not available? Please install:

ftp://mageia.webconquest.com/distrib/cauldron/i586/media/core/updates_testing/system-config-printer-libs-1.5.7-5.mga6.noarch.rpm

(The description of system-config-printer-libs is:
"The common code used by both the graphical and non-graphical parts of
the configuration tool"
I cannot imagine that s-c-p can work well without this package)
Comment 20 ben mcmonagle 2016-08-12 10:56:01 CEST
(In reply to Marja van Waes from comment #19)

> 
> (The description of system-config-printer-libs is:
> "The common code used by both the graphical and non-graphical parts of
> the configuration tool"
> I cannot imagine that s-c-p can work well without this package)

and tonight it installed (shrug)

but not discovering printer.

[root@localhost ~]# system-config-printer 
/usr/share/system-config-printer/system-config-printer.py:31: PyGIWarning: Polkit was imported without specifying a version first. Use gi.require_version('Polkit', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Polkit
/usr/share/system-config-printer/system-config-printer.py:35: PyGIWarning: GdkPixbuf was imported without specifying a version first. Use gi.require_version('GdkPixbuf', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkPixbuf
/usr/share/system-config-printer/system-config-printer.py:37: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gdk
/usr/share/system-config-printer/system-config-printer.py:38: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/share/system-config-printer/jobviewer.py:28: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
/usr/share/system-config-printer/jobviewer.py:55: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GnomeKeyring
task-printing-server-2011-9.mga6
task-printing-hp-2011-9.mga6
Comment 21 Nicolas Lécureuil 2016-10-25 09:41:37 CEST
is this bug still valid ?

CC: (none) => mageia

Comment 22 Nicolas Lécureuil 2016-10-25 09:41:38 CEST
is this bug still valid ?
Comment 23 ben mcmonagle 2016-10-28 11:20:46 CEST
yes.

after / during update today the following messages during install of:

task-printing-hp-2011-9.mga6.i586
task-printing-server-2011-9.mga6.i586
+ dependencies

retrieving rpm files from medium "Core Release (distrib1)"...
    $MIRRORLIST: media/core/release/foomatic-db-4.0-3.20150819.1.mga6.noarch.rpm                              
    $MIRRORLIST: media/core/release/pnm2ppa-1.13-6.mga6.i586.rpm                                              
    $MIRRORLIST: media/core/release/gutenprint-ijs-5.2.11-2.mga6.i586.rpm                                     
    $MIRRORLIST: media/core/release/gutenprint-foomatic-5.2.11-2.mga6.i586.rpm                                
    $MIRRORLIST: media/core/release/avahi-0.6.32-1.mga6.i586.rpm                                              
    $MIRRORLIST: media/core/release/printer-testpages-2006-12.mga6.noarch.rpm                                 
    $MIRRORLIST: media/core/release/gutenprint-common-5.2.11-2.mga6.i586.rpm                                  
    $MIRRORLIST: media/core/release/libgutenprint2-5.2.11-2.mga6.i586.rpm                                     
retrieved $MIRRORLIST media/core/release foomatic-db-4.0-3.20150819.1.mga6.noarch.rpm pnm2ppa-1.13-6.mga6.i586.rpm gutenprint-ijs-5.2.11-2.mga6.i586.rpm gutenprint-foomatic-5.2.11-2.mga6.i586.rpm avahi-0.6.32-1.mga6.i586.rpm printer-testpages-2006-12.mga6.noarch.rpm gutenprint-common-5.2.11-2.mga6.i586.rpm libgutenprint2-5.2.11-2.mga6.i586.rpm
...retrieving done
installing foomatic-db-4.0-3.20150819.1.mga6.noarch.rpm pnm2ppa-1.13-6.mga6.i586.rpm avahi-0.6.32-1.mga6.i586.rpm gutenprint-ijs-5.2.11-2.mga6.i586.rpm gutenprint-foomatic-5.2.11-2.mga6.i586.rpm printer-testpages-2006-12.mga6.noarch.rpm gutenprint-common-5.2.11-2.mga6.i586.rpm libgutenprint2-5.2.11-2.mga6.i586.rpm from /var/cache/urpmi/rpms
starting installing packages
created transaction for installing on / (remove=0, install=0, upgrade=8)
configuration error - unknown item 'PASS_MIN_LEN' (notify administrator)
configuration error - unknown item 'PASS_MIN_LEN' (notify administrator)
removing installed rpms (foomatic-db-4.0-3.20150819.1.mga6.noarch.rpm pnm2ppa-1.13-6.mga6.i586.rpm avahi-0.6.32-1.mga6.i586.rpm gutenprint-ijs-5.2.11-2.mga6.i586.rpm gutenprint-foomatic-5.2.11-2.mga6.i586.rpm printer-testpages-2006-12.mga6.noarch.rpm gutenprint-common-5.2.11-2.mga6.i586.rpm libgutenprint2-5.2.11-2.mga6.i586.rpm) from /var/cache/urpmi/rpms

not sure if this is important
Comment 24 ben mcmonagle 2016-10-28 11:25:10 CEST
and also when starting "set up the printer(s), the print job queues" 

task-printing-server-2011-9.mga6                                                                          
task-printing-hp-2011-9.mga6
Redirecting to /bin/systemctl start cups.service
rmmod: ERROR: Module lp is not currently loaded

again, not sure if this is important
Comment 25 Robert Wood 2016-11-27 20:12:35 CET
I'm finding the same issue with a Canon MP495 USB device. Tried installing task-printing-canon manually to no avail. When you plug in the printer it does not come up in add printer in MCC like it did on Mageia 5.

CC: (none) => robert.wood

Comment 26 Marc Krämer 2016-12-15 14:45:17 CET
I have a similar issue with an Brother DCP-8060 printer (USB-Printer). Systemlog says "MissingDriver", but this had worked in mga5. The output of systemlog (in reverse):

Dez 15 12:02:26 localhost cupsd[904]: Failed to open device, code: -3
Dez 15 12:02:26 localhost cupsd[904]: libusb_get_device_list=9
Dez 15 12:02:22 localhost systemd[1]: configure-printer@usb-001-012.service: Failed with result 'exit-code'.
Dez 15 12:02:22 localhost systemd[1]: configure-printer@usb-001-012.service: Unit entered failed state.
Dez 15 12:02:22 localhost systemd[1]: configure-printer@usb-001-012.service: Main process exited, code=exited, status=1/FAILURE
Dez 15 12:02:22 localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=configure-printer@usb-001-012 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Dez 15 12:02:22 localhost kernel: audit: type=1131 audit(1481799742.980:134): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=configure-printer@usb-001-012 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=?
Dez 15 12:02:22 localhost udev-configure-printer[8347]: FAIL HERE
Dez 15 12:02:22 localhost udev-configure-printer[8347]: MissingDriver()
Dez 15 12:02:22 localhost udev-configure-printer[8347]: CheckInstalledDrivers()
Dez 15 12:02:22 localhost udev-configure-printer[8347]: CheckAndInstallDrivers()
Dez 15 12:02:22 localhost udev-configure-printer[8347]: MFG:Brother MDL:DCP-8060 SERN:- serial:000G9J899943
Dez 15 12:02:22 localhost udev-configure-printer[8347]: device devpath is /devices/pci0000:00/0000:00:13.5/usb1/1-3
Dez 15 12:02:22 localhost udev-configure-printer[8347]: add usb-001-012
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:21 localhost cupsd[904]: Warte darauf dass der Drucker verfügbar wird.
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:21 localhost cupsd[904]: Failed to open device, code: -3
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:21 localhost cupsd[904]: libusb_get_device_list=9
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:16 localhost cupsd[904]: Warte darauf dass der Drucker verfügbar wird.
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:16 localhost cupsd[904]: Failed to open device, code: -3
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:16 localhost cupsd[904]: libusb_get_device_list=9
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:11 localhost cupsd[904]: Warte darauf dass der Drucker verfügbar wird.
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:11 localhost cupsd[904]: Failed to open device, code: -3
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:11 localhost cupsd[904]: libusb_get_device_list=9
Dez 15 12:02:22 localhost udev-configure-printer[8347]: Dec 15 12:02:06 localhost cupsd[904]: Warte darauf dass der Drucker verfügbar wird.
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ6219 /usr/local/Brother/lpd/rawtobr2 -pi /usr/local/Brother/inf/paperinf -rc /usr/local/Brother/inf/brDCP8060rc
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ6191 /bin/sh /usr/local/Brother/lpd/filterDCP8060
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ6160 usb://dev/usblp0 616 anonymous Test Page 1 job-uuid=urn:uuid:328923cf-de7c-3db4-7abb-56503e48909c job-originating-host-name=localhost date-time-at-creation= date-
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ6159 /bin/sh /usr/lib/cups/filter/brlpdwrapperDCP8060 616 anonymous Test Page 1 job-uuid=urn:uuid:328923cf-de7c-3db4-7abb-56503e48909c job-originating-host-name=localh
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ1654 /usr/lib/cups/notifier/dbus dbus://
Dez 15 12:02:22 localhost udev-configure-printer[8347]:            ââ 904 /usr/sbin/cupsd -l
Dez 15 12:02:22 localhost udev-configure-printer[8347]:    CGroup: /system.slice/cups.service
Dez 15 12:02:22 localhost udev-configure-printer[8347]:    Status: "Scheduler is running..."
Dez 15 12:02:22 localhost udev-configure-printer[8347]:  Main PID: 904 (cupsd)
Dez 15 12:02:22 localhost udev-configure-printer[8347]:      Docs: man:cupsd(8)
Dez 15 12:02:22 localhost udev-configure-printer[8347]:    Active: active (running) since Thu 2016-12-15 11:02:16 CET; 1h 0min ago
Dez 15 12:02:22 localhost udev-configure-printer[8347]:    Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
Dez 15 12:02:22 localhost udev-configure-printer[8347]: â cups.service - CUPS Scheduler

CC: (none) => mageia

Comment 27 ben mcmonagle 2017-02-14 06:52:14 CET
still valid :

Mageia-6-sta2-LiveDVD-xfce4-x86_64-DVD.iso
DATE: Mon Feb  6 23:53:46 CET 2017

installed and fully updated

# system-config-printer 
task-printing-server-2011-10.mga6
task-printing-hp-2011-10.mga6

Keywords: 6dev1 => 6sta2

Comment 28 ben mcmonagle 2017-04-10 08:50:37 CEST
valid for

Mageia-6-rc-i586-DVD.iso
DATE.txt: Fri Apr  7 23:11:51 CEST 2017

Keywords: 6sta2 => 6RC
Priority: Normal => release_blocker

Comment 29 ben mcmonagle 2017-04-10 08:50:59 CEST
valid for

Mageia-6-rc-i586-DVD.iso
DATE.txt: Fri Apr  7 23:11:51 CEST 2017
Comment 30 ben mcmonagle 2017-04-10 08:52:47 CEST
(In reply to ben mcmonagle from comment #29)
> valid for
> 
> Mageia-6-rc-i586-DVD.iso
> DATE.txt: Fri Apr  7 23:11:51 CEST 2017

somehow there was a clash when adding comment#28 (midair collision)
Comment 31 ben mcmonagle 2017-04-10 08:53:34 CEST
(In reply to ben mcmonagle from comment #29)
> valid for
> 
> Mageia-6-rc-i586-DVD.iso
> DATE.txt: Fri Apr  7 23:11:51 CEST 2017

somehow there was a clash when adding comment#28 (midair collision)

and 

"Wide character in subroutine entry at Bugzilla/Bug.pm line 1250, <DATA> line 751."
Comment 32 ben mcmonagle 2017-04-10 08:54:00 CEST
(In reply to ben mcmonagle from comment #29)
> valid for
> 
> Mageia-6-rc-i586-DVD.iso
> DATE.txt: Fri Apr  7 23:11:51 CEST 2017

somehow there was a clash when adding comment#28 (midair collision)

and 

"Wide character in subroutine entry at Bugzilla/Bug.pm line 1250, <DATA> line 751."
Comment 33 Nicolas Lécureuil 2017-04-10 09:42:17 CEST
is it better when task-printing-canon is installed ?
ben mcmonagle 2017-04-10 09:57:09 CEST

Summary: system-config-printer doesn't discover Canon mp280 printer => system-config-printer doesn't discover some USB connected printers

Rémi Verschelde 2017-04-26 10:49:25 CEST

Summary: system-config-printer doesn't discover some USB connected printers => system-config-printer doesn't discover some USB connected printers (Canon)

Comment 34 Rémi Verschelde 2017-04-26 11:00:04 CEST
(In reply to Nicolas Lécureuil from comment #33)
> is it better when task-printing-canon is installed ?

According to comment 25, it seems not.


We currently ship s-c-p 1.5.7 from 2015. It seems there is a new 1.5.9 release in the GitHub repository, might be worth trying to update and see if it helps? https://github.com/zdohnal/system-config-printer/releases

Source RPM: system-config-printer-1.5.7-1.mga6 gtk3.0 => system-config-printer-1.5.7-1.mga6
Summary: system-config-printer doesn't discover some USB connected printers (Canon) => system-config-printer doesn't discover some USB connected printers
Status comment: (none) => Canon and Brother USB printers can't find driver (MissingDriver()), updating system-config-printer may help, otherwise no clue yet

Comment 35 Martin Whitaker 2017-04-29 19:58:05 CEST
I think I have stumbled across the reason for this whilst trying to fix bug 18992.

/usr/lib/udev/rules.d/60-libsane.rules detects scanner devices (including all-in-one devices), and applies the rule

  ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner"

This means the device has a user.group of root.scanner. But cupsd runs with a user.group of lp.lp, so can't open the device.

This wasn't a problem in mga5 because there was an additional rules file, 74-printers_lp_user_fix.rules (part of the cups package), which applied the rule

  RUN+="/usr/bin/setfacl -m user:lp:rw $env{DEVNAME}"

to all printer devices. But that file has been removed in mga6. From the comment in that file, it's likely this was cleanup after cupsd was changed to run with a user.group of lp.lp instead of lp.sys.

I don't know what the right way to fix this bug is, but changing the rule in /usr/lib/udev/rules.d/60-libsane.rules to

  ENV{libsane_matched}=="yes", RUN+="/usr/bin/setfacl -m group:scanner:rw $env{DEVNAME}"

fixes it for my HP device.

CC: (none) => mageia

Comment 36 ben mcmonagle 2017-05-02 09:49:41 CEST
(In reply to Martin Whitaker from comment #35)

> 
> /usr/lib/udev/rules.d/60-libsane.rules detects scanner devices (including 
> all-in-one devices), and applies the rule
>
> ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner"


> I don't know what the right way to fix this bug is, but changing the rule in
> /usr/lib/udev/rules.d/60-libsane.rules to
> 
>   ENV{libsane_matched}=="yes", RUN+="/usr/bin/setfacl -m group:scanner:rw
> $env{DEVNAME}"
> 


unfortunately, this did not work for me, Canon PIXMA MP280 (Multi Function Device)

(It may be because I did not correctly apply the change)
Comment 37 Martin Whitaker 2017-05-02 09:59:38 CEST
(In reply to ben mcmonagle from comment #36)
> unfortunately, this did not work for me, Canon PIXMA MP280 (Multi Function
> Device)
> 
> (It may be because I did not correctly apply the change)

Did you get udev to reread the rules? Either

  udevadm control -R

or reboot.
Comment 38 ben mcmonagle 2017-05-02 10:23:47 CEST
(In reply to Martin Whitaker from comment #37)

> 
> or reboot.

reboot

just tried : udevadm control -R (as root) but made no difference - no printer found to configure
Comment 39 Martin Whitaker 2017-05-02 23:37:53 CEST
@Ben, could you first check the system log to confirm the USB bus/unit number of your printer is still 001-005, e.g. from the attached log

Feb 08 09:38:26 localhost.localdomain systemd[1]: configure-printer@usb-001-005.service: Main process exited, code=exited, status=1/FAILURE

then post the output of

  getfacl /dev/bus/usb/001/005

(changing the numbers if necessary)
Comment 40 ben mcmonagle 2017-05-03 10:58:08 CEST
(In reply to Martin Whitaker from comment #39)
> @Ben, could you first check the system log to confirm the USB bus/unit
> number of your printer is still 001-005, e.g. from the attached log
> 
> Feb 08 09:38:26 localhost.localdomain systemd[1]:
> configure-printer@usb-001-005.service: Main process exited, code=exited,
> status=1/FAILURE


current result of # journalctl -f 2>&1 | tee output.txt

May 03 20:52:54 localhost.localdomain systemd[1]: configure-printer@usb-001-007.service: Job configure-printer@usb-001-007.service/start failed with result 'dependency'.

> 
> then post the output of
> 
>   getfacl /dev/bus/usb/001/005
> 
> (changing the numbers if necessary)

# getfacl /dev/bus/usb/001/007
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/007
# owner: root
# group: scanner
user::rw-
user:home:rw-
group::rw-
mask::rw-
other::r--
Comment 41 Martin Whitaker 2017-05-05 09:52:29 CEST
Thanks Ben. That's what I saw before I modified 60-libsane.rules. So we need to figure out why that change doesn't work on your system.

To check we really are seeing the same bug, try executing the command

  chgrp lp /dev/bus/usb/001/007

as root, modifying the device number if necessary. s-c-p should then discover your printer and allow you to configure it.
Comment 42 ben mcmonagle 2017-05-05 11:28:37 CEST
(In reply to Martin Whitaker from comment #41)
> Thanks Ben. That's what I saw before I modified 60-libsane.rules. So we need
> to figure out why that change doesn't work on your system.
> 
> To check we really are seeing the same bug, try executing the command
> 
>   chgrp lp /dev/bus/usb/001/007
> 
> as root, modifying the device number if necessary. s-c-p should then
> discover your printer and allow you to configure it.

That works,
printer found, configured in almost no time, and test page printed.

system: Live Xfce UEFI x86.
will reboot and see if the change is saved - it should be.
Comment 43 ben mcmonagle 2017-05-05 12:12:23 CEST
(In reply to ben mcmonagle from comment #42)


> will reboot and see if the change is saved - it should be.

changes were not saved when rebooting from Live to installed system.


used the above info and configured - ok.

how-ever if I unplug the printer and plug it back in, because the 
configure-printer@usb-001-005.service  changes to something else ie:
configure-printer@usb-001-012.service, the printer no longer works again.
Comment 44 Martin Whitaker 2017-05-06 00:45:29 CEST
(In reply to ben mcmonagle from comment #43)
> changes were not saved when rebooting from Live to installed system.
> 
> used the above info and configured - ok.
> 
> how-ever if I unplug the printer and plug it back in, because the 
> configure-printer@usb-001-005.service  changes to something else ie:
> configure-printer@usb-001-012.service, the printer no longer works again.

Yes, the devices under /dev/bus/usb are added by udevd when they are plugged in and removed when they are unplugged. So we need to fix the udev rules to automatically set the correct access permissions. But I've looked at it again, and I can't see why the change to 60-libsane.rules shouldn't work for you. That's the only rule file I can find that sets GROUP="scanner".
Comment 45 Marc Krämer 2017-05-06 11:27:29 CEST
what about rules in /etc/udev/rules.d/ ?
can you check whether 
  grep scanner /etc/udev/rules.d/*

has any output.
Comment 46 ben mcmonagle 2017-05-06 11:32:56 CEST
(In reply to M K from comment #45)
> what about rules in /etc/udev/rules.d/ ?
> can you check whether 
>   grep scanner /etc/udev/rules.d/*
> 
> has any output.

$ grep scanner /etc/udev/rules.d/*
grep: /etc/udev/rules.d/*: No such file or directory

# grep scanner /etc/udev/rules.d/*
grep: /etc/udev/rules.d/*: No such file or directory
Comment 47 Martin Whitaker 2017-05-06 11:55:52 CEST
Just a thought Ben - did you test the change on the Live system? Rebooting would lose any changes you made...
Rémi Verschelde 2017-05-06 22:04:06 CEST

Status comment: Canon and Brother USB printers can't find driver (MissingDriver()), updating system-config-printer may help, otherwise no clue yet => Mismatch between actual group for devices and the udev rules

Comment 48 Martin Whitaker 2017-05-06 23:38:19 CEST
Ben, could you try this test:

unplug your printer

  cd /lib/udev/rules.d/
  mv 60-libsane.rules 60-libsane.rules.hidden
  udevadm control -R

plug in your printer

  ls -l /dev/bus/usb/001
Comment 49 ben mcmonagle 2017-05-07 03:07:08 CEST
(In reply to Martin Whitaker from comment #47)
> Just a thought Ben - did you test the change on the Live system? Rebooting
> would lose any changes you made...

see comment #41.

Yes, was in a live system.

the only change was:

chgrp lp /dev/bus/usb/001/00* where * = output of 
# journalctl -f 2>&1 | tee output.txt
Comment 50 ben mcmonagle 2017-05-07 03:10:47 CEST
(In reply to Martin Whitaker from comment #48)
> Ben, could you try this test:
> 
> unplug your printer
> 
>   cd /lib/udev/rules.d/
>   mv 60-libsane.rules 60-libsane.rules.hidden
>   udevadm control -R
> 
> plug in your printer
> 
>   ls -l /dev/bus/usb/001

LXDE fresh x86_64 install, with updates added

as root, the above works.


adding printer via MCC works, can print a test page.

unplugging the printer  and reconnecting the printer allows printing of a test page.

will reboot and see if things remain ok
Comment 51 ben mcmonagle 2017-05-07 03:17:28 CEST
(In reply to ben mcmonagle from comment #50)

> 
> will reboot and see if things remain ok

on reboot and login, connecting the printer allows printing of a test page.

(now, to test a Live system, install, and see if everything is still configured ok)
Comment 52 ben mcmonagle 2017-05-07 03:26:46 CEST
just thought I would check the scanner function.

MCC finds and configures the scanner.

Simple-scan does not scan the document.
Comment 53 ben mcmonagle 2017-05-07 03:30:06 CEST
how do I disable a tv-card - it thinks it is the scanner?
Comment 54 ben mcmonagle 2017-05-07 09:11:27 CEST
ok.

installed a new system (Mate) from x86_64 Classical Installer.iso

installed a scanner.
simple-scan scans document from Canon MP280.

perform :
> unplug your printer
> 
>   cd /lib/udev/rules.d/
>   mv 60-libsane.rules 60-libsane.rules.hidden
>   udevadm control -R
> 
> plug in your printer
> 
>   ls -l /dev/bus/usb/001

printer now works,

Simple-scan now tries to scan from tv card, canon is not available as a scanner.
Comment 55 Martin Whitaker 2017-05-07 11:04:33 CEST
(In reply to ben mcmonagle from comment #49)
> (In reply to Martin Whitaker from comment #47)
> > Just a thought Ben - did you test the change on the Live system? Rebooting
> > would lose any changes you made...
> 
> see comment #41.
> 
> Yes, was in a live system.

Sorry Ben, I wasn't clear enough - I meant your test in comment 36. From your results in comment 50, it seems certain it's 60-libsane.rules that's changing the group ownership to "scanner". Can you try this:

Restore the rules file (if you haven't done so already)

  mv 60-libsane.rules.hidden 60-libsane.rules

Change the rule at the end of the file from

  ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner"

to

  ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner", RUN+="/usr/bin/setfacl -m group:lp:rw $env{DEVNAME}"

(note that should all be on one line, in case Bugzilla wraps it)

Reread the rules

  udevadm control -R

Unplug and replug your printer.
Comment 56 ben mcmonagle 2017-05-09 08:45:41 CEST
(In reply to Martin Whitaker from comment #55)

install and check simple-scan -success

> 
> Restore the rules file (if you haven't done so already)

booted into a new Live session
> 
>   mv 60-libsane.rules.hidden 60-libsane.rules
> 
> Change the rule at the end of the file from
> 
>   ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner"
> 
> to
> 
>   ENV{libsane_matched}=="yes", MODE="664", GROUP="scanner",
> RUN+="/usr/bin/setfacl -m group:lp:rw $env{DEVNAME}"

tick (done)

> 
> (note that should all be on one line, in case Bugzilla wraps it)
> 
> Reread the rules
> 
>   udevadm control -R

tick (done)

> 
> Unplug and replug your printer.

tick (done)

set up printer via MCC (success)
print test page (success)

recheck simple scan (success)

unplug and replug printer

recheck printer -test page (success)

recheck simple-scan (success)

will install system and reboot, then recheck
Comment 57 ben mcmonagle 2017-05-09 09:31:07 CEST
upon reboot:

check simple scan (success)

check printer -test page (success)

unplug USB lead and reconnect:

recheck simple scan (success)

recheck printer -test page (success)


thanks Martin
Comment 58 Martin Whitaker 2017-05-09 10:10:14 CEST
Thanks for testing this Ben.

To others: I've added this fix to the sane-backends package. When version 1.0.25-5 is available on your favourite mirror, please update and test if it works for you. You will need to unplug and replug your printer after update. I believe the udev rules get reread automatically when the new package is installed, but if not you can trigger that manually as per comment 55.
Comment 59 ben mcmonagle 2017-05-10 11:46:17 CEST
installed Cinnamon DE only from Classical pre-release Iso
(Mageia-6-rc-x86_64-DVD.iso
DATE.txt: Mon May  8 00:48:36 CEST 2017)

reboot, configure on-line media.
check for and apply updates (included sane-backends 1.0.25-5)
kernel updated so rebooted.

configured USB attached Canon MP280 MFD printer and printed testpage -ok
configured USB attached Canon MP280 MFD (scanner)

invoke simple scan and scanned document - ok

unplugged and reconnected USB attached Canon MP280 MFD
invoke simple scan and scanned document - ok
print scanned image from simple scan - ok

checks ok, Martin

Thanks.
Comment 60 ben mcmonagle 2017-05-11 09:16:49 CEST
my final test.

Mate only DE installed from:
Mageia-6-rc-i586-DVD.iso
DATE.txt: Mon May  8 00:38:50 CEST 2017

Configure USB connected Canon Pixma MP280 MFD (scanner) from MCC. success.
scan document - ok
attempt to configure USB connected Canon Pixma MP280 MFD (printer) from MCC. fail

check for and apply updates (included sane-backends 1.0.25-5)and kernel.

attempt to configure USB connected Canon Pixma MP280 MFD (printer) from MCC. fail
as root (su -) # udevadm control -R

attempt to configure USB connected Canon Pixma MP280 MFD (printer) from MCC. fail

reboot for kernel update
.......................

Configure USB connected Canon Pixma MP280 MFD (printer) from MCC. success.

recheck simple scan success

unplug and re-plug MFD

recheck simple scan - ok
print document from simple scan - ok


really need some-one else to confirm, so this can be closed
Comment 61 Frédéric Buclin 2017-05-13 16:56:44 CEST
Assuming bug 18992 is another manifestation of this bug, then I can confirm that the recent commits fix the problem for me too, using a HP ENVY 4500 printer/scanner.

Can we close this bug?

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=18992

Comment 62 Nicolas Lécureuil 2017-05-13 22:04:14 CEST
closing if this is fixed for you too.


Please reopen if still needed

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.