Bug 11105 - RAID ( ddf / isw ) broken for new install
Summary: RAID ( ddf / isw ) broken for new install
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: High critical
Target Milestone: ---
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
: 7505 9467 9684 9910 11139 (view as bug list)
Depends on:
Blocks: 14330
  Show dependency treegraph
 
Reported: 2013-08-29 15:03 CEST by Nicolas Lécureuil
Modified: 2016-10-17 12:07 CEST (History)
17 users (show)

See Also:
Source RPM: drakx-installer-stage2
CVE:
Status comment: Old bug fixed in mga3 that was reopened several times, the new issue(s) should probably be moved to new bug report(s)


Attachments
report.bug for drakx 16.75 (191.11 KB, application/octet-stream)
2015-04-04 05:17 CEST, Vladimir Zawalinski
Details

Description Nicolas Lécureuil 2013-08-29 15:03:16 CEST
Description of problem:

RAID ( ddf / isw ) broken for new install

Version-Release number of selected component (if applicable):


How reproducible:
on a real RAID machine or in a VM  

here how to create such a RAID ( ddf )
1.Start a LiveCD on a VM with 2 disks
2.mdadm -C /dev/md/ddf -e ddf -l container -n 2 /dev/sda /dev/sdb
mdadm -C /dev/md/array1 -l raid1 -n 2 /dev/md/ddf
3.reboot on the installer
4.see

I tested all the mageia and here my result:

Mageia 1:  OK install on RAID and boot
Mageia 2, 3, 4: Doesn't install ( tell the partition table is corrupted )

on my physical machine with ISW RAID i have the same issue

Reproducible: 

Steps to Reproduce:
Nicolas Lécureuil 2013-08-29 15:07:47 CEST

CC: (none) => thomas.backlund, tmb
Assignee: bugsquad => thierry.vignaud

Nicolas Lécureuil 2013-08-30 10:55:37 CEST

Priority: Normal => release_blocker

Nicolas Lécureuil 2013-08-30 15:17:08 CEST

CC: (none) => pterjan

Comment 1 Manuel Hiebel 2013-09-03 16:53:00 CEST
*** Bug 11139 has been marked as a duplicate of this bug. ***

CC: (none) => eon

Comment 2 Nicolas Lécureuil 2013-09-03 17:52:03 CEST
https://bugs.mageia.org/attachment.cgi?id=4317&action=diff

patch fixing the bug, ( need test ) ( in progress here )
Comment 3 Nicolas Lécureuil 2013-09-04 00:50:32 CEST
tested in my mga4 custom stage2 ( stage2 + the patch ). 

and no more pb, the raid is correctly detected.


mga1  it shows in the partitionning  only the raid

without the patch in mga4a2 it shows in the partitionning step 3 disk sda sdb and the raid

with the patch in mga4a2 it shows in the partitionning step only the raid
Nicolas Lécureuil 2013-09-04 00:50:49 CEST

CC: (none) => mageia

Comment 4 Thierry Vignaud 2013-09-13 11:26:57 CEST
I simplified your patch. I The issue was a simple typo.
Please test again.
Comment 5 Nicolas Lécureuil 2013-09-13 14:11:15 CEST
i just  saw your commit, thanks a lot.

i am starting tests now.
Comment 6 Nicolas Lécureuil 2013-09-14 23:01:04 CEST
install work as expected but it doesn't boot.
Comment 7 stephane FLAVIGNY 2013-09-22 10:47:17 CEST
Dear, 

I test n fresh install on my raid system this morning, don't work! dmraid with silicon image.

Stéphane.

CC: (none) => megastorage

stephane FLAVIGNY 2013-09-22 10:48:26 CEST

Hardware: i586 => All

Comment 8 Nicolas Lécureuil 2013-10-04 18:42:06 CEST
what is "silicon image" ?
Comment 9 stephane FLAVIGNY 2013-10-05 23:40:19 CEST
Dear Nicolas,

On the motherboard I have two controller:
-nvidia
-silicon image

Stéphane.
Comment 10 Anne Nicolas 2013-12-27 23:50:30 CET
ping ? how can we go on on that one ? anyone has tested it with last isos ?

CC: (none) => ennael1

Comment 11 Thierry Vignaud 2013-12-28 09:10:46 CET
I think other reports show it's fixed.
Though it would be nice if reporters of _this_ bug report could confirm it.

Keywords: (none) => NEEDINFO

Comment 12 Nicolas Lécureuil 2013-12-30 14:08:51 CET
i will test this week.
Comment 13 Thierry Vignaud 2014-01-14 01:24:07 CET
ping?
Comment 14 Nicolas Lécureuil 2014-01-15 13:31:08 CET
it is not better at all now the installer does not see the raid but show me 2 HD
Comment 15 Thierry Vignaud 2014-01-15 19:28:02 CET
Please attach the corresponding report.bug.xz
Comment 16 stephane FLAVIGNY 2014-01-23 22:56:29 CET
Dear all,

I'm testing tonight. It works with nvidia and silicon image system raid.

Possible expect more information from Nicolas, he don't have the same hardware configuration.

Stéphane.
Comment 17 stephane FLAVIGNY 2014-08-21 08:16:36 CEST
*** Bug 9684 has been marked as a duplicate of this bug. ***

CC: (none) => j.nieborak

Comment 18 stephane FLAVIGNY 2014-08-21 08:21:07 CEST
*** Bug 9910 has been marked as a duplicate of this bug. ***

CC: (none) => diodak

Comment 19 stephane FLAVIGNY 2014-09-20 10:50:37 CEST
*** Bug 7505 has been marked as a duplicate of this bug. ***

CC: (none) => jeff

Thomas Backlund 2014-09-21 13:57:47 CEST

CC: thomas.backlund => (none)

Comment 20 Vladimir Zawalinski 2014-10-20 09:56:22 CEST
(In reply to Nicolas Lécureuil from comment #0)
> Description of problem:
> 
> RAID ( ddf / isw ) broken for new install
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> on a real RAID machine or in a VM  
> 
> here how to create such a RAID ( ddf )
> 1.Start a LiveCD on a VM with 2 disks
> 2.mdadm -C /dev/md/ddf -e ddf -l container -n 2 /dev/sda /dev/sdb
> mdadm -C /dev/md/array1 -l raid1 -n 2 /dev/md/ddf
> 3.reboot on the installer
> 4.see
> 
> I tested all the mageia and here my result:
> 
> Mageia 1:  OK install on RAID and boot
> Mageia 2, 3, 4: Doesn't install ( tell the partition table is corrupted )
> 
> on my physical machine with ISW RAID i have the same issue
> 
> Reproducible: 
> 
> Steps to Reproduce:

CC: (none) => vzawalin1

Vladimir Zawalinski 2014-10-20 10:12:13 CEST

Blocks: (none) => 14330

Comment 21 jeff deifik 2014-10-20 14:21:32 CEST
I have seen the error message 'the partition table is corrupted', many times.

It is a bug, but you can continue anyway, select a partition for install, and the array eventually gets detected.

Quite scary to continue, but it hasn't destroyed my data.
Comment 22 Dick Gevers 2014-12-01 17:07:58 CET
@mageia@nicolaslecureuil.fr: ping?
Comment 23 Nicolas Lécureuil 2014-12-01 17:50:07 CET
tested on my RAID0 Physical machine and impossible to install with still the same error
Comment 24 Dick Gevers 2014-12-01 18:29:56 CET
Cabün you atrach the report.bug.xz that tv requested please?
Comment 25 Vladimir Zawalinski 2014-12-08 07:33:59 CET
Re comment 20:  The text shown in comment 20 is the same as the text of comment 0.  However, I did encounter similar issues in a UEFI context, which I reported in bug 14330 for MGA5-live alpha 2. Briefly MGA5 seems to support recognition and mounting of isw_ arrays once live-booted, but because drakinstall-live <- diskdrake encounters errors, it is impossible to install, either through the classical installer with UEFI enabled (Bug 13471), or live install (errors raised in 14330). Please refer there for test diagnostic outputs.
Comment 26 Vladimir Zawalinski 2014-12-08 07:47:00 CET
 Afterthought to comment 25: dmraid handles the isw raid correctly. dmadm reports error?
claire robinson 2015-02-05 22:55:25 CET

CC: (none) => eeeemail

Comment 27 Thomas Backlund 2015-02-05 23:05:41 CET
will look into this...

Assignee: thierry.vignaud => tmb

Florian Hubold 2015-03-16 23:21:39 CET

CC: (none) => doktor5000

Comment 28 Markus Mertens 2015-03-18 01:12:31 CET
mga5b3:

A RAID 1 with two drives has been created in the BIOS (Intel RSTe Oprom RAID). This RAID (/dev/mapper/isw_*) is correctly detected with gparted on a LiveDVD (KNOPPIX). Calling "mdadm --examine --scan" in a terminal on KNOPPIX shows the correct assembly of drives. However, this RAID is not detected during the hardware scanning procedure in the Mageia installer. And later - during partitioning - you cannot select this RAID. But the two drives of the RAID are visible.

CC: (none) => Mertens.MPT

Comment 29 Vladimir Zawalinski 2015-03-18 02:26:21 CET
Markus, I find that that after installation  is completed, typing dmraid -ay in the new MGA and rebooting shows md126p1... in /dev. Mounting that partition allows access to that RAID array. The only partitioner that shows no errors relating to RAID is Gnome-Disks. Gparted does some things and errors out on others.

The installation process where isw_ raid pre-exists is a minefield. Naturally, answer no to the corrupted partitions message, use only custom partitioning and define your installation partitions manually. Auto-allocate can propose partitions on your RAID disks while 'erase and use disk' can do this without warning, destroying the array and causing problems in fstab as well.

Please let me know how you get on.
Rémi Verschelde 2015-03-20 00:59:03 CET

CC: (none) => remi

Comment 30 Thierry Vignaud 2015-04-03 15:59:42 CEST
Could someone affected could attach report.bug after seeing the bug, attaching a USB key then typing the "bug" command on tty2?

CC: (none) => thierry.vignaud

Comment 31 Vladimir Zawalinski 2015-04-04 05:08:44 CEST
@ Thierry:
Here is the report.bug, taken after aborting the installer at the partitioning stage. Please advise if you require the full version, but this one shows the offending "Invalid argument during seek for read on /dev/sdb" and crashes various partitioners. Note that only the raid member disk appeared on the dracx partitioner exactly as in comment 28 above.
Comment 32 Vladimir Zawalinski 2015-04-04 05:17:02 CEST
Created attachment 6180 [details]
report.bug for drakx 16.75

After the message "Partition of sdb is too corrupted  ..." and just before committing the partitioner.
Comment 33 Vladimir Zawalinski 2015-04-04 05:25:51 CEST
Comment on attachment 6180 [details]
report.bug for drakx 16.75

The corrupted message is not logged in report.bug, contrary to what I said.
However, 'unknown partition table' for disks sdb and sdc occurs many times, especially around 15.698660 - and this is at the root of every problem in this area.
Marja van Waes 2015-04-06 21:33:20 CEST

CC: (none) => marja11
Keywords: NEEDINFO => (none)

Comment 34 Thierry Vignaud 2015-04-07 10:46:15 CEST
Please do not mix the issues.
The original bug was installer wasn't detecting raid disks which was fixed in 2013 then it was highjacked for the faillure to boot (which was fixed in dmraid+dracut)

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 35 Vladimir Zawalinski 2015-04-07 11:10:09 CEST
I didn't know that the original bug had been fixed in 2013. There was no intent to hijack the agenda, but I can see that the two situations are different.
Comment 36 Thierry Vignaud 2015-05-22 14:10:26 CEST
*** Bug 9467 has been marked as a duplicate of this bug. ***

CC: (none) => fboyrie

Comment 37 jeff deifik 2015-05-22 16:21:03 CEST
(In reply to Thierry Vignaud from comment #34)
> Please do not mix the issues.
> The original bug was installer wasn't detecting raid disks which was fixed
> in 2013 then it was highjacked for the faillure to boot (which was fixed in
> dmraid+dracut)

Perhaps it was fixed in 2013. However, the bug *is* present in mageia 4, which came out in 2014. I have had the installer be unable to detect my raid 5 array many times.
Comment 38 Samuel Verschelde 2015-05-22 16:28:51 CEST
(In reply to jeff deifik from comment #37)
> (In reply to Thierry Vignaud from comment #34)
> > Please do not mix the issues.
> > The original bug was installer wasn't detecting raid disks which was fixed
> > in 2013 then it was highjacked for the faillure to boot (which was fixed in
> > dmraid+dracut)
> 
> Perhaps it was fixed in 2013. However, the bug *is* present in mageia 4,
> which came out in 2014. I have had the installer be unable to detect my raid
> 5 array many times.

Does it still happen with Mageia 5 RC?
Comment 39 jeff deifik 2015-05-22 16:39:16 CEST
I have no idea. I have not tried 5 RC.
Comment 40 Thierry Vignaud 2015-05-22 17:39:49 CEST
This bug is open against Cauldron and is fixed in Cauldron (future Mga5).
Mga4 installer is frozen and cannot be updated.
Comment 41 jeff deifik 2015-06-21 22:50:39 CEST
This bug exists with mageia-5 64 bit.
I did a fresh install.
My 7 disk raid-5 array was not detected.
When grub was installed, it cleverly was installed on /dev/sda, which was part of my raid array, destroying the array.

Grub should have been installed on the disk that I did the installation on, which was /dev/sdd.

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Rémi Verschelde 2016-09-08 10:12:25 CEST

Assignee: tmb => mageiatools
Source RPM: (none) => drakx-installer-stage2

Comment 42 Rémi Verschelde 2016-10-17 12:07:16 CEST
What's the status on this bug report? It's marked as a blocker for Mageia 6, though it was presumably fixed for Mageia 3, then reopened, then reclosed, then reopened...

Thierry, could you assess comment 41 and see if it warrants reopening this issue, or if it should be moved to a new bug report?

Decreasing priority until this is reviewed.

Priority: release_blocker => High

Rémi Verschelde 2016-10-17 12:07:58 CEST

Status comment: (none) => Old bug fixed in mga3 that was reopened several times, the new issue(s) should probably be moved to new bug report(s)


Note You need to log in before you can comment on or make changes to this bug.