Bug 13471 - partial display on screen (preventing completing the installation) with UEFI
Summary: partial display on screen (preventing completing the installation) with UEFI
Status: RESOLVED DUPLICATE of bug 12422
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: High major
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard: MGA4TOO, 5beta2
Keywords:
: 13670 (view as bug list)
Depends on:
Blocks: 15014
  Show dependency treegraph
 
Reported: 2014-06-02 13:29 CEST by gérard haxaire
Modified: 2015-04-27 17:58 CEST (History)
8 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
What I saw (truncated text installer after Graphical installer fails to start up) (489.83 KB, image/jpeg)
2014-06-17 08:05 CEST, gérard haxaire
Details
X failling to starts on tty1 (on UEFI) (845.20 KB, image/jpeg)
2014-06-18 12:29 CEST, gérard haxaire
Details
ddebug.log file (12.16 KB, text/plain)
2014-06-20 07:47 CEST, gérard haxaire
Details
Xorg.0.log file (7.04 KB, text/plain)
2014-06-20 07:47 CEST, gérard haxaire
Details
File stage1.log (1.76 KB, text/plain)
2014-06-23 07:36 CEST, gérard haxaire
Details
File Xorg.0.log with fbdev informations before overwrite because of the try to start of vesa (7.97 KB, text/plain)
2014-06-23 07:38 CEST, gérard haxaire
Details
File syslog (62.30 KB, text/plain)
2014-06-23 07:39 CEST, gérard haxaire
Details
File of install with display OK (mageia 4 x86_64 gnome) (35.40 KB, application/octet-stream)
2014-07-09 12:51 CEST, gérard haxaire
Details
File of install with display OK (Mageia 4 x86_64 GNOME) (71.33 KB, text/plain)
2014-07-09 12:53 CEST, gérard haxaire
Details
Screen 1 of abort during the try of install Mageia 5 (686.59 KB, image/jpeg)
2014-09-02 14:00 CEST, gérard haxaire
Details
Screen 2 of abort during the try of install Mageia 5 (631.64 KB, image/jpeg)
2014-09-02 14:00 CEST, gérard haxaire
Details
Screen 3 of abort during the try of install Mageia 53 (880.96 KB, image/jpeg)
2014-09-02 14:01 CEST, gérard haxaire
Details
Screen 4 of abort during the try of install Mageia 5 (879.75 KB, image/jpeg)
2014-09-02 14:02 CEST, gérard haxaire
Details
Contain of /tmp when the install og Mageia5 aborted (74.74 KB, text/plain)
2014-09-02 14:03 CEST, gérard haxaire
Details
The file of the try of install Mageia5 (142.94 KB, application/x-gzip)
2014-09-02 15:42 CEST, gérard haxaire
Details

Description gérard haxaire 2014-06-02 13:29:19 CEST
Bonjour à tous,


Je n'arrive pas à installer MAGEIA 4 sur mon ordinateur portable Toshiba

* Il s'agit d'un ordinateur Toshiba Satellite L70-A-12Z
Ecran de 17 pouces
Intel Core i7 4700M 2,4 Ghz
Disque dur de 1 Téra
4000 Mo
740 M Windows 8
* Il possède une carte graphique NVIDIA GeForce GT 740M
* Pas d'accès à Internet sur le lieu d'installation
* Cet ordinateur a été livré avec windows 8.1 préinstallé en UEFI
* Le logiciel Acronis True Image 2014 a été installé et a du enregistrer des données quelque part sur le disque dur

Afin de pouvoir installer Mageia, la partition système windows a été réduite sous windows.
Plusieurs partitions ont été créées pour des données windows et de la place a été faite pour Mageia4.
La commande gdisk -l /dev/sda1 retourne :
=========================================================================
[root@localhost ~]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 821E4257-20C1-11E3-B43E-FABF95B36670
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 3437 sectors (1.7 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         2099199   1024.0 MiB  2700  
   2         2099200         2303999   100.0 MiB   EF00  
   3         2304000         2566143   128.0 MiB   0C01  Basic data partition
   4         2566144       145926143   68.4 GiB    0700  
   5       145926144      1210884095   507.8 GiB   0700  Basic data partition
   6      1210884096      1640964095   205.1 GiB   0700  Basic data partition
   7      1640964096      1725956095   40.5 GiB    0700  Basic data partition
   8      1725956096      1751146495   12.0 GiB    0700  
   9      1751146496      1759338495   3.9 GiB     0700  
  10      1759338496      1931307007   82.0 GiB    0700  
  11      1931307008      1953523711   10.6 GiB    2700  
[root@localhost ~]#
=========================================================================
Les partitions 8 et 10 sont réservées à Mageia.
La partition 9 étant la partition de swap


*********************************************************************************
*  Mon objectif est d'installer Magéia 4 en dual boot avec windows 8.1 en UEFI  *
*********************************************************************************


Peu après le début de l'installation de  Mageia-4-x86_64-DVD.iso, je suis confronté au bug de driver graphique.
Comme indiqué sur le site de Magéia, au bout de quelques minutes, l'installation re-démarre.
Mais l'affichage ne se fait que sur la partie gauche de l'écran (environ 40%)
Je vois donc le message "Mageia installation |Language" en haut de l'écran côté gauche
et le message "<Tab>/<Alt-Tab> between elements" en bas de l'écran côté gauche
Mais je ne vois pas la boite de dialogue qui permet la sélection des options. (Rien n'est affiché au milieu et à droite de l'écran.
Le côté gauche du cadre de la boite de dialogue est toutefois affiché.
=> Il m'est impossible de poursuivre l'installation.
******************************************************************
*  Y aurait il un moyen de contourner ce problème d'affichage ?  *
******************************************************************

=========================================================================
Résultat de la commande lspcidrake -v :
***************************************
[root@localhost ~]# lspcidrake -v
alx             : Qualcomm Atheros|AR8161 Gigabit Ethernet [NETWORK_ETHERNET] (vendor:1969 device:1091 subv:1179 subd:fa82) (rev: 10)
ath9k           : Qualcomm Atheros|QCA9565 / AR9565 Wireless Network Adapter [NETWORK_OTHER] (vendor:168c device:0036 subv:11ad subd:0612) (rev: 01)
Card:NVIDIA GeForce 400 series and later: NVIDIA Corporation|GK208M [GeForce GT 740M] [DISPLAY_3D] (vendor:10de device:1292 subv:1179 subd:fa89) (rev: a1)
i2c_i801        : Intel Corporation|8 Series/C220 Series Chipset Family SMBus Controller [SERIAL_SMBUS] (vendor:8086 device:8c22 subv:1179 subd:fa89) (rev: 04)
unknown         : Intel Corporation|8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [STORAGE_SATA] (vendor:8086 device:8c03 subv:1179 subd:fa89) (rev: 04)
lpc_ich         : Intel Corporation|HM86 Express LPC Controller [BRIDGE_ISA] (vendor:8086 device:8c49 subv:1179 subd:fa89) (rev: 04)
ehci_pci        : Intel Corporation|8 Series/C220 Series Chipset Family USB EHCI #1 [SERIAL_USB] (vendor:8086 device:8c26 subv:1179 subd:fa89) (rev: 04)
shpchp          : Intel Corporation|8 Series/C220 Series Chipset Family PCI Express Root Port #4 [BRIDGE_PCI] (vendor:8086 device:8c16) (rev: d4)
shpchp          : Intel Corporation|8 Series/C220 Series Chipset Family PCI Express Root Port #3 [BRIDGE_PCI] (vendor:8086 device:8c14) (rev: d4)
shpchp          : Intel Corporation|8 Series/C220 Series Chipset Family PCI Express Root Port #1 [BRIDGE_PCI] (vendor:8086 device:8c10) (rev: d4)
snd_hda_intel   : Intel Corporation|8 Series/C220 Series Chipset High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:8c20 subv:1179 subd:fa89) (rev: 04)
ehci_pci        : Intel Corporation|8 Series/C220 Series Chipset Family USB EHCI #2 [SERIAL_USB] (vendor:8086 device:8c2d subv:1179 subd:fa89) (rev: 04)
unknown         : Intel Corporation|8 Series/C220 Series Chipset Family MEI Controller #1 [COMMUNICATION_OTHER] (vendor:8086 device:8c3a subv:1179 subd:fa89) (rev: 04)
xhci_hcd        : Intel Corporation|8 Series/C220 Series Chipset Family USB xHCI [SERIAL_USB] (vendor:8086 device:8c31 subv:1179 subd:fa89) (rev: 04)
snd_hda_intel   : Intel Corporation|Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:0c0c subv:1179 subd:fa89) (rev: 06)
Card:Intel 810 and later: Intel Corporation|4th Gen Core Processor Integrated Graphics Controller [DISPLAY_VGA] (vendor:8086 device:0416 subv:1179 subd:fa89) (rev: 06)
shpchp          : Intel Corporation|Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [BRIDGE_PCI] (vendor:8086 device:0c01) (rev: 06)
unknown         : Intel Corporation|Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller [BRIDGE_HOST] (vendor:8086 device:0c04 subv:1179 subd:fa89) (rev: 06)
hub             : Linux 3.12.8-desktop-2.mga4 xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0003)
hub             : Linux 3.12.8-desktop-2.mga4 xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
Removable:memory_card: JMTek, LLC.|TS128MJFLASHA [Mass Storage|SCSI|Bulk-Only] (vendor:0c76 device:0005)
usbhid          : Belkin|Mouse [Human Interface Device|Boot Interface Subclass|Mouse] (vendor:1241 device:1111)
btusb           : Toshiba Corp.|Unknown [Wireless|Radio Frequency|Bluetooth] (vendor:0930 device:0220)
uvcvideo        : Chicony Electronics Co.,Ltd.|TOSHIBA Web Camera - HD [Video|Video Control] (vendor:04f2 device:b3b1)
hub             : Linux 3.12.8-desktop-2.mga4 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Intel Corp.|Unknown [Hub|Unused|Full speed (or root) hub] (vendor:8087 device:8000)
hub             : Linux 3.12.8-desktop-2.mga4 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Intel Corp.|Unknown [Hub|Unused|Full speed (or root) hub] (vendor:8087 device:8008)
hid_generic     : HID 1241:1111
[root@localhost ~]# 
=========================================================================


Merci pour votre aide et conseils.








Reproducible: 

Steps to Reproduce:
Comment 1 Manuel Hiebel 2014-06-12 01:15:23 CEST
A photo of what you have seen ?

CC: (none) => thierry.vignaud

Comment 2 gérard haxaire 2014-06-17 08:05:14 CEST
Created attachment 5194 [details]
What I saw
(truncated text installer after Graphical installer fails to start up)
Comment 3 gérard haxaire 2014-06-17 08:12:13 CEST
Bonjour,


Mon ordinateur peut utiliser un écran extérieur en plus de l'écran intégré.
Cela est géré par windows8.1 et peut être paramétré dans le bios : Il y a 3 possibilités (automatique, intérieur, extérieur)
Lors de mes tentatives d'installation de Mageia4, j'ai testé ces 3 possibilités.
1) Lorsque j'utilise l'écran extérieur, j'obtiens au début de l'installation 
- "Mageia installation |Language" en haut de l'écran côté gauche
- "<Tab>/<Alt-Tab> between elements" en bas de l'écran côté gauche
- et rien d'autre sur l'écran
2) Lorsque j'utilise l'écran incorporé, j'obtiens ce qui a sur la photo_04.jpg
Et après 2 appuis sur la touche <TAB>, la surbrillance s'est déplacée et se trouve en bas et à droite de la ligne verticale

J'ai également tenté d'installer Mageia4 à partir d'une clé USB. Et j'arrive au même bug d'affichage vidéo. 


Cordialement
Comment 4 Manuel Hiebel 2014-06-17 23:08:51 CEST
It looks like you are using the text installer. Is it not the case ?

Also please use english, as not all reader here understand the language...
Comment 5 gérard haxaire 2014-06-18 12:29:45 CEST
Created attachment 5196 [details]
X failling to starts on tty1 (on UEFI)
Comment 6 gérard haxaire 2014-06-18 12:33:57 CEST
Hello,

My English is not good. So I am not sure to have understand what you mean.
I think I am not using the text installer. (what is the text installer and how use it ?)

In fact I have processed like this :
I put the DVD in the reader's DVD 
I boot again
Then a "menu" (several lines of texts) appears on the screen
I choose "Install Mageia"
After I have seen the photo_03.jpg
And after, I have seen the photo_04.jpg (Where I can't choose the language because it is not appear on screen)

Sincerely yours
Comment 7 Thierry Vignaud 2014-06-18 13:28:32 CEST
Peux tu relancer une install, attendre le timeout de 60 secondes pour l'echec du démarrage de l'interface graphique, puis une fois que tu vois la fenêtre en mode texte (attachment #5194 [details]), aller sur la 2e console (alt+ctrl+f2) et monter à la main une clé USB pour récupérer le fichier /tmp/ddebug.log:

d'abord plugger une clé USB

1) soit lancer la commande "bug")

2) si cette commande échoue, repérer le device de la clé USB (par exemple /dev/sdb1) et lancer:
mkdir /USB
mount /dev/sdb1 /USB
cp /tmp/ddebug.log /tmp/stage1.log /USB
umount /USB

Keywords: (none) => NEEDINFO

Comment 8 gérard haxaire 2014-06-20 07:47:18 CEST
Created attachment 5200 [details]
ddebug.log file
Comment 9 gérard haxaire 2014-06-20 07:47:56 CEST
Created attachment 5201 [details]
Xorg.0.log file
Comment 10 gérard haxaire 2014-06-20 07:55:21 CEST
More informations :
1) When I try to install Mageia-4-GNOME-LiveDVD, I have not problem of video driver. I can begin the install (But I can not finish the install because of a grug's bug : 13472 = 11675)

2) In case of trying install Mageia with a USB stick : I think I can modify some files before the install. Like this, I could try others parameters. But I do not know what to try
Comment 11 gérard haxaire 2014-06-20 07:58:23 CEST
J'ai oublié /tmp/stage1.log : je vais le récupérer
Thierry Vignaud 2014-06-20 10:56:53 CEST

Attachment 5201 mime type: application/octet-stream => text/plain

Thierry Vignaud 2014-06-20 10:56:57 CEST

Attachment 5200 mime type: application/octet-stream => text/plain

Comment 12 Thierry Vignaud 2014-06-20 11:25:02 CEST
Humm, that's "Card:Intel 810 and later: Intel Corporation|4th Gen Core Processor Integrated Graphics Controller [DISPLAY_VGA] (vendor:8086 device:0416 subv:1179 subd:fa89) (rev: 06)"

Sadly, we don't have the fbdev error as Xorg.log was overwritten when we automatically tried vesa.
I wonder why fbdev failed.
And no special argument was given to the kernel (such as vga=...)...

@Gérard: could you attach the output of the dmesg command too?
eg: "dmesg > dmesg.txt; cp dmesg.txt /where/is/your/usb/key"
(in the installer)
BTW you used the 64bit installer not the 32 bit one (i586).

@Thomas: very old i810 (aka the first ones 15 years ago) were buggy (ie they didn't support VESA 2.0 and the like). Are there any modern intel gfx cards that could have similar issues?

CC: (none) => tmb
Hardware: i586 => x86_64
Summary: Affichage partiel sur l'écran ne permettant pas la poursuite de l'installation => partial display on screen (preventing completing the installation)

Comment 13 Thierry Vignaud 2014-06-20 11:36:47 CEST
Gérard, you can just copy /tmp/syslog instead of running dmesg
Thierry Vignaud 2014-06-20 11:37:51 CEST

Attachment 5194 description: Ce que j'ai vu => What I saw
(truncated text installer after Graphical installer fails to start up)

Thierry Vignaud 2014-06-20 11:38:28 CEST

Attachment 5196 description: video driver KO on UEFI => X failling to starts on tty1 (on UEFI)

Thierry Vignaud 2014-06-20 11:38:45 CEST

Attachment 5200 description: File ddebug.log => ddebug.log file

Thierry Vignaud 2014-06-20 11:38:57 CEST

Attachment 5201 description: File Xorg.0.log => Xorg.0.log file

Mark Kay 2014-06-21 22:14:04 CEST

Priority: Normal => High
CC: (none) => markkuehn
Severity: normal => major

Comment 14 Mark Kay 2014-06-21 22:18:46 CEST
I am having the exact same problem attempting to install Mageia 4.1 on my UEFI-enabled Asus laptop using a USB instaler.  When Xorg finally starts after multiple failures as seen in the initial poster's screenshot, the next screen only can be partially seen.  I cannot complete installation because of this.

I'm attempting to install on an Asus Q501LA with an Intel HD Graphics 4400.
Comment 15 Thierry Vignaud 2014-06-21 22:52:28 CEST
Can you try Mageia4.1 updated installer?
See http://blog.mageia.org/en/2014/06/20/pulling-mageia-4-1-out-of-the-hat/

Summary: partial display on screen (preventing completing the installation) => partial display on screen (preventing completing the installation) with UEFI
Source RPM: Problème de driver video => (none)

Comment 16 Mark Kay 2014-06-21 23:10:54 CEST
(In reply to Thierry Vignaud from comment #15)
> Can you try Mageia4.1 updated installer?
> See http://blog.mageia.org/en/2014/06/20/pulling-mageia-4-1-out-of-the-hat/

I tried it with the new 4.1 installer as well as the previous Mageia 4 installer - same result.  I'm in the process of finding a workaround.
Comment 17 gérard haxaire 2014-06-23 07:36:53 CEST
Created attachment 5209 [details]
File stage1.log
Comment 18 gérard haxaire 2014-06-23 07:38:44 CEST
Created attachment 5210 [details]
File Xorg.0.log with fbdev informations before overwrite because of the try to start of vesa
Comment 19 gérard haxaire 2014-06-23 07:39:20 CEST
Created attachment 5211 [details]
File syslog
Thierry Vignaud 2014-06-23 07:56:40 CEST

Attachment 5209 mime type: application/octet-stream => text/plain

Thierry Vignaud 2014-06-23 07:57:07 CEST

Attachment 5211 mime type: application/octet-stream => text/plain

Thierry Vignaud 2014-06-23 07:57:10 CEST

Attachment 5210 mime type: application/octet-stream => text/plain

Comment 20 Thierry Vignaud 2014-07-04 11:14:21 CEST
*** Bug 13670 has been marked as a duplicate of this bug. ***
Comment 21 Thierry Vignaud 2014-07-04 11:16:42 CEST
@Thomas: you've a Haswell system.
Can you check out why fb & vesa fails on Haswell & the like?

Version: 4 => Cauldron
Whiteboard: (none) => MGA4TOO

Comment 22 gérard haxaire 2014-07-09 12:49:06 CEST
In fact when we try to install Mageia x86_64 on some UEFI computer :
- with Mageia-4-x86_64-DVD.iso : I only have a text display (No graphic)
- with Mageia-4.1 x86_64 DVD : Someone have a text display (No graphic)
- with Mageia-5-alpha1-x86_64-DVD on a USB 3.0 drive (bug 13670) : Another one have a text display (No graphic)

- with Mageia-4.1-LiveDVD-KDE4-x86_64-DVD.iso : I have a black screen

- But with Mageia-4-LiveDVD-GNOME-x86_64-DVD.iso : I can begin the install. I haven't problem of display (As I report in bug 13472)
In that case, at the beginning of the install I see on screen : "switch_root: failed to unlink live: Directory not empty"
And after, many line "[OK]" and after I can choose the language with the mouse...

I think it may be a good idea to search the differences between Mageia-4-LiveDVD-GNOME-x86_64-DVD.iso 
and the others DVD of Mageia. (Perhaps the install of Mageia 4 LiveDVD x86_64 KDE on UEFI is OK too. I haven't download these version. So I can't try this)


Yesterday, I try again to install Mageia-4-LiveDVD-GNOME-x86_64-DVD.iso. 
When the windows of grub options appeared, I did not choose option. I did this :
 atl + crtl + F2
 login as live
 su -
 mkdir /usb
 mount /dev/sdb1 /usb
 dmesg > dmesg.txt
I couldn't find /tmp. So I couldn't find /tmp/ddebug.log, /tmp/stage1.log and /tmp/syslog

I attach the files of these install : Xorg.0.log and dmesg.txt
Comment 23 gérard haxaire 2014-07-09 12:51:40 CEST
Created attachment 5272 [details]
File of install with display OK (mageia 4 x86_64 gnome)
Comment 24 gérard haxaire 2014-07-09 12:53:17 CEST
Created attachment 5273 [details]
File of install with display OK (Mageia 4 x86_64 GNOME)
Comment 25 Mark Kay 2014-08-05 01:19:59 CEST
Update - MGA5 Alpha 2 still has same issue.
Comment 26 Yves Gaël Chény 2014-08-17 13:24:20 CEST
Exactly same bug when i try to install Mageia 4.1 DVD 64 bits KDE on my asus ( i7/GTX850M + intel (optimus ).

CC: (none) => yves

Comment 27 Muhammad Tailounie 2014-08-18 15:32:42 CEST
The exact same problem on a Toshiba laptop with i5 processor and UEFI enabled. It is worth noting though that this laptop CANNOT boot Mageia when UEFI is enabled. Other distros like ubuntu boot and install fine..!

CC: (none) => linuxero

Comment 28 Thierry Vignaud 2014-08-22 09:03:40 CEST
Can you try latest cauldron install (uploaded this morning)?
eg if you use http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/cauldron/x86_64/ VERSION should contains 16.40.

also you need to use this morning install/images/boot.iso (or install/images/boot-nonfree.iso if you've hardware that needs firmware)

then after the install is completed, your /root/drakx/report.bug.xz should tell us why xorg/vesa failed
Comment 29 Muhammad Tailounie 2014-08-22 22:33:17 CEST
I'll give it a shot tomorrow then report back.
Comment 30 Muhammad Tailounie 2014-08-23 13:59:30 CEST
Hi;

I have just tried the latest cauldron install. on Toshiba Portege Z930-148, you may refer to: http://www.linlap.com/toshiba_portege_z930, but it won't even boot with UEFI enabled..
Comment 31 Mark Kay 2014-08-24 05:43:20 CEST
I just tried installing using the directions in Comment 28 and no dice.  It's still only partially showing, limiting the ability for me to complete (or even really start) installation.
Comment 32 gérard haxaire 2014-08-26 08:17:35 CEST
Yesterday I have downloaded install/images/boot.iso and install/images/boot-nonfree.iso from
http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/cauldron/x86_64/

In boot.iso there is a file named VERSION which contains :
Mageia release 5 - Wed Aug  6 12:08:34 2014 - 3.15.6-desktop-1.mga5

In boot-nonfree.iso there is a file named VERSION which contains :
Mageia release 5 - Fri May 30 00:00:00 2014 - 3.14.4-desktop-3.mga5

I think there are not the files for a new try.
I think that the file VERSION should contains 16.40.

Where can I get the file ".iso" for the new try.
Comment 33 Thierry Vignaud 2014-08-26 09:59:37 CEST
The boot-nonfree.iso was updated but not boot.iso which I uploaded again this morning.

@Thomas: are the UEFI really uptodate?
Your latest update makes VERSION goes from:
Mageia release 5 - Wed Aug  6 12:08:34 2014 - 3.15.6-desktop-1.mga5
to:
Mageia release 5 - Fri May 30 00:00:00 2014 - 3.14.4-desktop-3.mga5
Comment 34 gérard haxaire 2014-08-26 10:34:51 CEST
Yesterday, I have put boot-nonfree.iso on a DVD. And I boot with the DVD.
The configuration of the keyboard wasn't good. But the install started.
I saw a choice screen who ask something as "ftp" or "DVD" or "web"...
And at this state, there was no /root/drakx/report.bug.xz

So I probably must download more files to continue the install.
But where I made the try of install, I have no Internet Connexion.
So, how can I made a DVD for try a install with boot.iso and a little number of file.

(Only the files for obtain /root/drakx/report.bug.xz)
Comment 35 Thierry Vignaud 2014-08-26 11:21:07 CEST
boot*.iso are mini ISO: they don't include the graphical installer (the installer stage2.
This is just the stage1 (which is automated on the full DVD to just look for the DVD).
(installer is like a multistage rocket

So you're actually expected to choose either "FTP server" or "HTTP server".
Then you'll be asked about networking configuration (you'll probably choose DHCP) then if you want to choose from the mirror lists or manually type an install server IP: you'll just pick a random one from the mirror list.

See https://wiki.mageia.org/en/Boot.iso_install
Comment 36 Thomas Backlund 2014-08-26 12:11:47 CEST
(In reply to Thierry Vignaud from comment #33)


> @Thomas: are the UEFI really uptodate?
> Your latest update makes VERSION goes from:
> Mageia release 5 - Wed Aug  6 12:08:34 2014 - 3.15.6-desktop-1.mga5
> to:
> Mageia release 5 - Fri May 30 00:00:00 2014 - 3.14.4-desktop-3.mga5


Yep, just checked... 
seems I've screwed the VERSION file but the initrd and vmlinuz are 3.15.6-1

I will start cleaning up EFI support soon
Comment 37 gérard haxaire 2014-09-02 14:00:19 CEST
Created attachment 5395 [details]
Screen 1 of abort during the try of install Mageia 5
Comment 38 gérard haxaire 2014-09-02 14:00:46 CEST
Created attachment 5396 [details]
Screen 2 of abort during the try of install Mageia 5
Comment 39 gérard haxaire 2014-09-02 14:01:17 CEST
Created attachment 5397 [details]
Screen 3 of abort during the try of install Mageia 53
Comment 40 gérard haxaire 2014-09-02 14:02:20 CEST
Created attachment 5398 [details]
Screen 4 of abort during the try of install Mageia 5
Comment 41 gérard haxaire 2014-09-02 14:03:44 CEST
Created attachment 5399 [details]
Contain of /tmp when the install og Mageia5 aborted
Comment 42 gérard haxaire 2014-09-02 14:05:27 CEST
I have try to install the lastest cauldron Mageia5 as you said in comment-28
I try to install on my Toshiba laptop using "boot-nonfree.iso" and a livebox orange for the internet connexion
- The network connexion is KO for wifi
- The network connexion is OK with a link
- Every time, I have tried to install cauldron Mageia5, I have met the graphical bug. So it was not possible to continue the install.

- But in fact I have be able to continue the install by typing on the keyboard without knowing what I was doing (Because of the graphic bug). Many rpm were downloading and after about 40 minutes, the install abort (See the files M5_bug_1.jpg, M5_bug_2.jpg, M5_bug_3.jpg and M5_bug_4.jpg)
At this time, there was no /root/drakx/report.bug.xz so I have saved the contain of /tmp.
There is the contain of /tmp in the file contain_of_tmp.txt.
If you are interesting by one or more files of /tmp, tell me the names of the files.
Comment 43 Thierry Vignaud 2014-09-02 15:27:35 CEST
Comment on attachment 5399 [details]
Contain of /tmp when the install og Mageia5 aborted

We need you to start the installer and once it starts in text mode to copy your /tmp/ddebug.log on some USB key and attach it here (preferably compressed)

Attachment 5399 is obsolete: 0 => 1

Comment 44 gérard haxaire 2014-09-02 15:42:03 CEST
Created attachment 5400 [details]
The file of the try of install Mageia5
Comment 45 gérard haxaire 2014-09-21 10:36:02 CEST
@Thierry
1) Have you found enough informations in the file ddebug.log (of the attachment 5400 [details] of the comment 44) ? Have you found the reason of the graphic bug or do you still wait for more information ?

2) As I have said in comment 22, generaly I meet the graphic bug during the installation of Mageia.
Except with Mageia-4-LiveDVD-GNOME-x86_64-DVD.iso.
So, I have installed Mageia-4-LiveDVD-GNOME-x86_64-DVD again. I want to catch some files of log
I haven't found the ddebug.log 
I have the files of /var/log (For examples : boot.log, dmesg, Xorg.0.log...) when the box for the choise of language appeared.
I can attach these files if you want.

3) When I try to install Mageia-4-x86_64-DVD.iso I meet the graphic bug. So when the box for the choise of language appears, I can only see the left of the box. I can't see the lines of text.
And if I disable (in the BIOS) the "technologie EDB" (Exécute Disable Bit) I have a black  screen. The box for the choise of language doesn't appear. (Overflow ?)
Comment 46 Dick Gevers 2014-11-16 13:34:23 CET
Per #c45 waiting for Thierry ?

[ Relevance for 5beta1 cannot be judged from here ]

Whiteboard: MGA4TOO => MGA4TOO, 5alpha2

papoteur 2014-12-21 08:00:30 CET

CC: (none) => yves.brungard_mageia

Comment 47 Marja van Waes 2015-01-12 08:40:47 CET
Vladimir reported on QA ml that he hit this bug with the classical 64bits new pre-5beta2, which was written on a USB stick

removing "NEEDINFO" because the information was given in comment 44 (attachment 5400 [details])

Keywords: NEEDINFO => (none)
CC: (none) => marja11
Whiteboard: MGA4TOO, 5alpha2 => MGA4TOO, 5beta2

Stephane 2015-01-12 11:35:18 CET

CC: (none) => stephane_oss

Comment 48 Stephane 2015-02-03 10:55:31 CET
I reproduce the same bug with my laptop Asus X751LN (Nvidia 840M Optimus + intel Graphic) and Mageia5 prebeta3.

It is impossible to install in mode text due to screen truncated.
Rémi Verschelde 2015-02-04 20:17:01 CET

Blocks: (none) => 15014

Comment 49 Stephane 2015-02-17 21:22:43 CET
This bug has been solved with Mageia5 beta3 for my laptop.

I succeeded to start the installation via GUI.
Comment 50 Mageia Robot 2015-02-27 20:06:02 CET
commit a674dfbf7d84330dca4f3bf58f61f4ef35fd15fc
Author: Thierry Vignaud <thierry.vignaud@...>
Date:   Fri Feb 27 20:02:20 2015 +0100

    fix too wide buttons
    
    closing mga#12422, mga#13471, mga#14839, mga#15379
    
    issue introduced in commit 1d4957dddcbf98c3a985186b8b61be2b3f004b3c
    but was showing only in some cases
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx/commit/?id=a674dfbf7d84330dca4f3bf58f61f4ef35fd15fc

 Bug links:
   Mageia
      https://bugs.mageia.org/12422
      https://bugs.mageia.org/13471
      https://bugs.mageia.org/14839
      https://bugs.mageia.org/15379
Comment 51 Thierry Vignaud 2015-02-27 21:04:19 CET
Dup

*** This bug has been marked as a duplicate of bug 12422 ***

Status: NEW => RESOLVED
Resolution: (none) => DUPLICATE

Comment 52 Mageia Robot 2015-04-27 17:58:44 CEST
commit 77cd051688f1e8aae47aed0c8ac40ea45360461a
Author: Thierry Vignaud <thierry.vignaud@...>
Date:   Fri Feb 27 20:02:20 2015 +0100

    fix too wide buttons
    
    closing mga#12422, mga#13471, mga#14839, mga#15379
    
    issue introduced in commit 1d4957dddcbf98c3a985186b8b61be2b3f004b3c
    but was showing only in some cases
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx/commit/?id=77cd051688f1e8aae47aed0c8ac40ea45360461a

 Bug links:
   Mageia
      https://bugs.mageia.org/12422
      https://bugs.mageia.org/13471
      https://bugs.mageia.org/14839
      https://bugs.mageia.org/15379

Note You need to log in before you can comment on or make changes to this bug.