Bug 9541 - Network installer stage 1 doesn't support WPA2 encrypted wifi
Summary: Network installer stage 1 doesn't support WPA2 encrypted wifi
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: Mageia 8
Assignee: Martin Whitaker
QA Contact:
URL: http://gitweb.mageia.org/software/dra...
Whiteboard:
Keywords: Triaged
: 12071 23390 23752 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-26 15:16 CET by Morgan Leijström
Modified: 2020-12-18 22:53 CET (History)
12 users (show)

See Also:
Source RPM: drakx-installer-binaries
CVE:
Status comment:


Attachments
Output of lsmod from my T43 booted on 7.1 Live i586 and wifi working. (6.82 KB, text/plain)
2020-11-30 19:00 CET, Morgan Leijström
Details
dmesg from installer, TKIP fail (12.69 KB, application/x-xz)
2020-12-02 19:46 CET, Morgan Leijström
Details
wpa_supplicant.log from installer, TKIP fail (720 bytes, application/x-xz)
2020-12-02 19:47 CET, Morgan Leijström
Details
wpa_supplicant.conf from installer, TKIP fail (133 bytes, text/plain)
2020-12-02 19:48 CET, Morgan Leijström
Details
dmesg from mga7 Live, TKIP works (14.99 KB, application/x-xz)
2020-12-02 19:49 CET, Morgan Leijström
Details
lsmod from mga7 Live, TKIP works (1.80 KB, application/x-xz)
2020-12-02 19:49 CET, Morgan Leijström
Details
Output of lsmod from an M8 Live Plasma with wifi working on a Probook (7.31 KB, text/plain)
2020-12-04 03:03 CET, Thomas Andrews
Details
output of lsmod with a working Cauldron with WiFi (7.59 KB, text/plain)
2020-12-04 14:53 CET, Aurelien Oudelet
Details
Output of "dmesg | grep iwl" on a Probook (119.48 KB, image/jpeg)
2020-12-04 16:10 CET, Thomas Andrews
Details
Missing firmware reported by dracut when building installer images (13.65 KB, text/plain)
2020-12-05 18:42 CET, Martin Whitaker
Details

Description Morgan Leijström 2013-03-26 15:16:15 CET
Using mga3b3 network install boot.iso, i intended to connect to my urpmi-proxy over wifi. It detected the interface correctly: Intel BG 2200.
Then it asked for WEP key.
I entered the pre-shared WPA2 key.  fail.

It should either use the correct mode, or say it cannot handle it, or say lets try WEP because i cannit see teh difference... or something...

Reproducible: 

Steps to Reproduce:
Comment 1 Manuel Hiebel 2013-03-26 21:38:36 CET
well seems it cannot manage wpa connection http://svnweb.mageia.org/soft/drakx/trunk/mdk-stage1/wireless.c?view=markup

Summary: Network installer stage 1 asks for WEP key on WPA2 encrypted wifi. => Network installer stage 1 doesn't support WPA2 encrypted wifi
Source RPM: (none) => drakx-installer-images

Manuel Hiebel 2013-03-26 21:39:20 CET

Source RPM: drakx-installer-images => drakx-installer-binaries

Thierry Vignaud 2013-04-04 15:40:03 CEST

CC: (none) => mageia, thierry.vignaud

Comment 2 Manuel Hiebel 2013-12-21 22:16:06 CET
*** Bug 12071 has been marked as a duplicate of this bug. ***
Comment 3 Thierry Vignaud 2013-12-21 22:20:13 CET
patch welcome :-)

Hardware: i586 => All

Comment 4 Samuel Verschelde 2015-04-25 09:52:22 CEST
I suppose this bug is still valid. Can you confirm?

Severity: normal => major
Keywords: (none) => NEEDINFO, Triaged
Assignee: bugsquad => thierry.vignaud

Comment 5 Otto Leipälä 2015-05-02 12:12:26 CEST
Yes bug is still valid not supportted still in stage1 netinstall.

CC: (none) => ozkyster

Morgan Leijström 2015-05-02 14:08:37 CEST

Keywords: NEEDINFO => (none)

Comment 6 Thierry Vignaud 2015-05-11 11:09:24 CEST
Stage1 only support WEP for now
Florian Hubold 2016-01-14 20:44:52 CET

CC: (none) => doktor5000

Comment 7 Morgan Leijström 2017-06-07 22:29:39 CEST
There seem to be problem even for WEP now using ipw2200 : bug 21042
Comment 8 Marja Van Waes 2018-08-05 09:41:01 CEST
*** Bug 23390 has been marked as a duplicate of this bug. ***

CC: (none) => hamnisdude

Marja Van Waes 2018-08-05 09:41:54 CEST

CC: (none) => isobuild, marja11
Assignee: thierry.vignaud => mageiatools
URL: (none) => http://gitweb.mageia.org/software/drakx/tree/mdk-stage1/wireless.c

Comment 9 Marja Van Waes 2018-10-25 17:25:22 CEST
*** Bug 23752 has been marked as a duplicate of this bug. ***
Comment 10 Marc Krämer 2019-06-02 11:56:07 CEST
still valid :(

CC: (none) => mageia

Comment 11 Aurelien Oudelet 2020-11-06 16:15:54 CET
And this is still valid for Netinstall nonfree ISO for Cauldron (M8).

Workaround:
1) use WEP on your Router during install... not satisfying from a security point of view.
2) use a RJ45-cable during install and use WiFi WPA2 after in Desktop Environment.
3) use Classic ISO for installing offline and go online after with Desktop environment and do updates.

CC: (none) => ouaurelien

Comment 12 Martin Whitaker 2020-11-29 10:47:42 CET
Please try the latest cauldron netinstall. You'll need to use the nonfree version for most wireless devices.

Tested and working with my access point using:

  - No security
  - WEP Open Key (40-bit)
  - WEP Shared Key (40-bit)
  - WPA-Personal with TKIP encryption
  - WPA2-Personal with TKIP encryption
  - WPA2-Personal with AES encryption

Assignee: mageiatools => mageia
CC: (none) => mageia
Status: NEW => ASSIGNED

Comment 13 Morgan Leijström 2020-11-30 00:59:39 CET
Using network install, nonfree i586 fetched last hour.

Machine: Thinkpad T43 with Intel PRO/Wireless 2200; [Calexico2]; ipw2200

Tried to connect to two routers using WPA2-Personal (TKIP or AES i have forgotten).  I am entering the same ESSID and key as i do in my mobile phone at the same time.

Error popup say
 unable to start wpa_supplicant daemon for interface "wlp11s2": 65280

/var/log/wpa_supplicant say:
 Driver does not support authentication/association or connect commands

Alt-F4 for kernel messages do not work (Bug 21041).
Morgan Leijström 2020-11-30 01:03:08 CET

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=21042

Comment 14 Morgan Leijström 2020-11-30 09:00:45 CET
Same 32 bit nonfree netinstall iso works with same wifi router using WPA2-Personal in Dell Dimension M4400; different wifi hardware.   :)

Well done!

So we just have to figure out why it do not work on ipw2200 (and maybe others) - that same T43 works great with that card and Mageia for then years +


Sidenote: My preferred mirror http://ftp.acc.umu.se/ was not listed.  It is a predefined list that need to be updated or is it some automagics that glitched?
Comment 15 Martin Whitaker 2020-11-30 11:01:00 CET
(In reply to Morgan Leijström from comment #14)
> So we just have to figure out why it do not work on ipw2200 (and maybe
> others) - that same T43 works great with that card and Mageia for then years
> +

Could be there's a kernel module missing on the ISO. In the installer, use Alt-F2 to switch to the debug shell and type 'dmesg | less' to view  the kernel messages and see if there are any hints there.

Also in the debug shell, try running

  /usr/sbin/wpa_supplicant -Dwext -i wlp11s2 -c /etc/wpa_supplicant.conf

to see if that works any better.

Also attach the output from 'lsmod' when running on that machine with working wireless.

> Sidenote: My preferred mirror http://ftp.acc.umu.se/ was not listed.  It is
> a predefined list that need to be updated or is it some automagics that
> glitched?

The mirror list is fetched from mirrors.mageia.org.
Comment 16 Morgan Leijström 2020-11-30 14:24:08 CET
(In reply to Martin Whitaker from comment #15)
> Could be there's a kernel module missing on the ISO. In the installer, use
> Alt-F2 to switch to the debug shell and type 'dmesg | less' to view  the
> kernel messages and see if there are any hints there.

No hints i can see.  Even not after exercising the commands per below i see anything regarding driver.  Possibly this, rather early in boot:

platform regulatory.0: Direct firmware load for regulatory.db failed with error -2


> Also in the debug shell, try running
> 
>   /usr/sbin/wpa_supplicant -Dwext -i wlp11s2 -c /etc/wpa_supplicant.conf

sh-5.0# /usr/sbin/wpa_supplicant -Dwext -i wlp11s2 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Line 9: unknown global field 'Successfully initialized wpa_supplicant'.
Line 9: Invalid configuration line 'Successfully initialized wpa_supplicant'.
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
sh-5.0#

I saw in Alt-F3 terminal what command it executed, and i tried the same:

sh-5.0# /usr/sbin/wpa_supplicant -B -i wlp11s2 -c /etc/wpa_supplicant.conf -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid


/var/log/wpa_supplicant.log now consist of same four lines as output of previous command, and before them:

nl80211: Driver does not support authentication/association or connect commands
nl80211: deinit ifname=wlp11s2 disabled_11b_rates=0
wlp11s2: Failed to initialize driver interface


> Also attach the output from 'lsmod' when running on that machine with
> working wireless.

Coming.
Comment 17 Martin Whitaker 2020-11-30 14:45:02 CET
I realise my instructions weren't precise enough - you need to run the command I specified after entering your wireless details and getting the failure message, otherwise /etc/wpa_supplicant.conf won't have been created.

In the debug shell you can mount one of the partitions on your hard disk, e.g. something like

  mkdir /mnt
  mount /dev/sda1 /mnt

(replace sda1 with a suitable partition). Then you can copy debug info to /mnt. Best to manually

  umount /mnt

when you are done.

Can you save a copy of /etc/wpa_supplicant.conf, /var/log/wpa_supplicant.log,  and the output from dmesg and attach them here (redact your passphrase in /etc/wpa_supplicant.conf)
Comment 18 Morgan Leijström 2020-11-30 19:00:41 CET
Created attachment 12039 [details]
Output of lsmod from my T43 booted on 7.1 Live i586 and wifi working.
Comment 19 Martin Whitaker 2020-11-30 19:09:36 CET
I didn't need to look far down the list to see the answer :-)
Those lib80211_crypt_* modules aren't on the netinstall ISO.
Comment 20 Morgan Leijström 2020-11-30 19:36:20 CET
Good  :)

So no more test needed until next spin?
Comment 21 Thomas Backlund 2020-11-30 21:00:28 CET
thanks martin for working on this.

When fully done, this should also be added to release notes for Mageia 8

Keywords: (none) => FOR_RELEASENOTES8

Comment 22 Martin Whitaker 2020-11-30 21:14:14 CET
Morgan, new build in progress, so please test again when it reaches the mirrors.
Comment 23 Thierry Vignaud 2020-12-01 16:52:21 CET
(In reply to Thomas Backlund from comment #21)
> thanks martin for working on this.

+1

> When fully done, this should also be added to release notes for Mageia 8

Actually this is already done

The "bad" things are:
- I'ven't explained it will mostly work with all-nonfree.rdz or with Mageia-Cauldron-netinstall-x86_64.iso due to lack of firmwares
- that classic ISOs is based off !nonfree boot.iso and thus suffer the same issue (not as important as adding extra repos over wifi would be less common)

Keywords: FOR_RELEASENOTES8 => (none)

Comment 24 Thierry Vignaud 2020-12-01 16:57:34 CET
We could maybe use sg like ../perl-install/list_firmware.pm & http://gitweb.mageia.org/software/drakx/tree/perl-install/install/any.pm#n397 in order to report that a firmware is needed and it won't work w/o boot-nonfree.iso ?
Comment 25 Martin Whitaker 2020-12-01 21:04:37 CET
@Thierry, when/where would you report that? At least with my hardware, loading the wireless module fails if the firmware isn't found, so no network device is added, and stage1 doesn't ask which device you want to use. We'd have to insert an extra dialogue, which no doubt would lead to complaints.

The lack of working wireless on the classic ISOs is a perennial source of complaints from our users. We could add an extra boot menu option to enable use of nonfree drivers/firmware (like what we have on the Live ISOs to enable the nvidia drivers). Something to consider for Mageia 9 perhaps.

@Morgan, the new images are now built and have reached distrib-coffee.
Comment 26 Morgan Leijström 2020-12-01 21:38:46 CET
Yes, even umu.se. already.

And well done Martin!  The same setup as in Comment 13 now works.

One little oddity: I have two wifi routers, and tested sitting in the same spot where i know it normally have best signal strength and performance to connect to when i used Live Mageia 7.1, but the installer got timeout during DHCP.  Then I tried the more remote router, and that worked.  I will try to check up if they differ in TKIP/AES.

Is it time to call in other testers?
Comment 27 Morgan Leijström 2020-12-01 22:33:43 CET
BTW, one thing that could be improved - easily i believe - is to sort the list of mirrors alphabetically.

( Another improvement if it could search and list found wifi ESSIDs, but that is more work, and user normally knows his networks names. )
Comment 28 Morgan Leijström 2020-12-01 23:16:39 CET
Problem with TKIP:

Using router D-Link DIR-868L Firmware Version : 1.09
Selecting "WPA Personal" (WPA-PSK), "WPA2 Only", "TKIP" (only): do not work :(
After a while Error dialogue "No DHCP reply received".
Last line from dmesg:
 lib80211_crypt: registered algorithm 'TKIP'
So it seem to detect correct protocol, but ??

Changing TKIP to AES, current netinstaller nonfree i586 works :)
This is when using wifi adapter ipw2200, in Thinkpad T43.

An updated Mageia 7 Live persistence USB stick booted on same machine works with both TKIP and AES.

Other settings used in both Live and installer: DHCP, no proxy.
Tested TKIP again just to be sure. Same negative result.
All tests performed four metres from the router.

So some bit for TKIP is still missing in netinstaller iso, I believe.
Comment 29 Martin Whitaker 2020-12-02 17:53:41 CET
Can you attach
1. dmesg output and /var/log/wpa_supplicant.log from installer when using TKIP
   (see comment 17 for how).
2. dmesg and lsmod output from Live when using TKIP.
Comment 30 Morgan Leijström 2020-12-02 19:46:24 CET
Created attachment 12045 [details]
dmesg from installer, TKIP fail
Comment 31 Morgan Leijström 2020-12-02 19:47:30 CET
Created attachment 12046 [details]
wpa_supplicant.log from installer, TKIP fail
Comment 32 Morgan Leijström 2020-12-02 19:48:02 CET
Created attachment 12047 [details]
wpa_supplicant.conf from installer, TKIP fail
Comment 33 Morgan Leijström 2020-12-02 19:49:01 CET
Created attachment 12048 [details]
dmesg from mga7 Live, TKIP works
Comment 34 Morgan Leijström 2020-12-02 19:49:25 CET
Created attachment 12049 [details]
lsmod from mga7 Live, TKIP works
Comment 35 Morgan Leijström 2020-12-02 19:50:45 CET
(mga7.1 Live Xfce i586 persistent, configured and rebooted several times but system is not updated)
Comment 36 Martin Whitaker 2020-12-03 01:13:10 CET
I think I've identified the missing module. Please try the new build when it becomes available.
Comment 37 Morgan Leijström 2020-12-03 11:05:43 CET
Yes!  Good work.  It works with TKIP now.

I am calling other testers from QA to test it more, because this is a significant step ahead and as tmb say should be in release notes, so we should test it thoroughly.

What I understand, for this bug testers only need to see that stage 2 get loaded.

To test: different wifi hardware and protocols.

Right Martin?

BTW should we need to test WEP more?   Bug 21042

Target Milestone: --- => Mageia 8

Comment 38 Aurelien Oudelet 2020-12-03 11:33:43 CET
Tested Mageia-Cauldron-netinstall-nonfree-x86_64.iso from 2020-Dec-03 02:01:34.

Dumped this to a USB drive.
Rebooted the machine.
Menus goes through selecting Network type connection.

BUT this always try to connect via Ethernet card (on the motherboard) than try to setup the WiFi present on a PCIE card. Not that Ethernet card has no wire in it!
(RJ45 was unplugged while testing this).

My WiFi is well functioning under an installed M8/M7 system.

Hardware as see by inxi -nn command:

Device-1: Intel Ethernet I219-V driver: e1000e 
IF: enp0s31f6 state: down

Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi 
IF: wlp5s0 state: up

stage1 never proposes to setup WiFI.

Stop testing this.
Comment 39 Morgan Leijström 2020-12-03 11:40:29 CET
Good you found that.
Back to Martin then.

---

When Cauldron netinstaller is tested enough, would it be much work to update mga7 netinstaller?

Could be something to blog about, especially as mga7 isos are getting old.
Comment 40 Martin Whitaker 2020-12-03 11:57:28 CET
@Aurelian, please attach output from 'lsmod' on Mageia 8 system with wireless working.
Comment 41 Aurelien Oudelet 2020-12-03 13:39:45 CET Comment hidden (obsolete)
Comment 42 Thierry Vignaud 2020-12-03 17:59:12 CET
(In reply to Martin Whitaker from comment #25)
> @Thierry, when/where would you report that? At least with my hardware,
> loading the wireless module fails if the firmware isn't found, so no network
> device is added, and stage1 doesn't ask which device you want to use. We'd
> have to insert an extra dialogue, which no doubt would lead to complaints.

Since we have the list of the modules that need a firmware, we could check first to see if the firmware exists and at least log one line about the situation and a 2nd line advising to use boot-nonfree instead, in order to help advanced users…

(In reply to Aurelien Oudelet from comment #41)
> Here is the requested output:

When as ask you attach, please attach a file instead of pasting hundred of lines that makes the bug report unreadable
Thomas Andrews 2020-12-03 23:01:46 CET

CC: (none) => andrewsfarm

Comment 43 Thomas Andrews 2020-12-04 00:48:00 CET
All tests were done with a home network on a Linksys EA7400 router, using WPA2-PSK encryption.

Tested the 32-bit non-free iso on a Dell inspiron 5100 with an Atheros AR2413/AR2414 Wireless Network Adapter. It worked perfectly, detecting both Ethernet and wifi devices, with no Ethernet cable attached.

Tested the 64-bit non-free iso on a Dell Dimension e520 with a Realtec rtl8192cu usb dongle. It worked perfectly, detecting both Ethernet and wifi devices, with no Ethernet cable attached.

Tested the 64-bit non-free iso on an AMD Phenom II X4 desktop with an Atheros AR92BX PCI Express card and an Ethernet cable connected to a different, older router. It worked perfectly, detecting both devices, connecting with wifi even with an Ethernet cable attached.

Tested both non-free isos on an HP Probook 6550b, with an Intel Centrino Advanced N 6200 wifi adapter, and no Ethernet cable attached. Both failed, apparently not detecting the wifi adapter at all. I was not asked which device to use. In contrast, using the M8 Beta1 Live Xfce iso in Live mode, the net_applet has no problem detecting the wifi adapter, and connecting to the network.
Comment 44 Thomas Andrews 2020-12-04 01:08:12 CET
Tested the Probook again, this time plugging a Ralink mt7601u dongle into a usb port. That worked perfectly, with the usb dongle and Ethernet devices detected, but still not the internal Intel wifi adapter.
Comment 45 Martin Whitaker 2020-12-04 01:12:39 CET
Thanks for the tests TJ. The failure with the Probook is most likely a missing kernel driver or subsidiary kernel module. Please could you attach the output of 'lsmod' when running in Live mode with the Intel wireless working.
Comment 46 Morgan Leijström 2020-12-04 01:16:10 CET
Is there a way to add all wifi related modules/drivers in one go instead of finding one missing at a time...?  Maybe sneak peaking on what is included on the live systems?
Comment 47 Thomas Andrews 2020-12-04 03:01:01 CET
Interesting that, so far, both of the wifi devices that have failed are Intel devices...
Comment 48 Thomas Andrews 2020-12-04 03:03:14 CET
Created attachment 12053 [details]
Output of lsmod from an M8 Live Plasma with wifi working on a Probook
Comment 49 Martin Whitaker 2020-12-04 13:02:23 CET
I can't see any likely candidates for missing kernel modules in TJ's lsmod output.
The cmac crypto module is a possibility for Aurelien.

Looking at the contents of iwlwifi-firmware-20201118-1.mga8.nonfree.noarch.rpm, we only include a subset of the available firmware.

@Thierry, is there some policy on that?

@Aurelien and TJ, in the installer, when you get to the "Please select your network connection type" dialogue, press Alt-F2 to get to the debug console and type "dmesg | grep iwl". There should be an error message if the problem is missing firmware.
Comment 50 Aurelien Oudelet 2020-12-04 14:53:44 CET
Created attachment 12054 [details]
output of lsmod with a working Cauldron with WiFi

Obsoleting Comment 41
Added lsmod.txt file here.

$ inxi -n
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: enp0s31f6 state: down mac: 1c:1b:0d:66:1d:12 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi 
           IF: wlp5s0 state: up mac: 14:f6:d8:66:c6:1e
Comment 51 Aurelien Oudelet 2020-12-04 15:04:19 CET
Output of "dmesg | grep iwl" while booting Netinstall nonfree Cauldron ISO from 3-12-2020 here: https://i.imgur.com/xDB7qX5.jpg (Too large to fit bugzilla).

Below is same output from a working Cauldron installation on SAME hardware.

$ dmesg | grep iwl
[    2.137387] iwlwifi 0000:05:00.0: enabling device (0000 -> 0002)
[    2.146153] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-cc-a0-56.ucode failed with error -2
[    2.147335] iwlwifi 0000:05:00.0: api flags index 2 larger than supported by driver
[    2.147343] iwlwifi 0000:05:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.22
[    2.147344] iwlwifi 0000:05:00.0: Found debug destination: EXTERNAL_DRAM
[    2.147345] iwlwifi 0000:05:00.0: Found debug configuration: 0
[    2.147497] iwlwifi 0000:05:00.0: loaded firmware version 55.d9698065.0 cc-a0-55.ucode op_mode iwlmvm
[    2.198926] iwlwifi 0000:05:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[    2.379708] iwlwifi 0000:05:00.0: base HW address: 14:f6:d8:66:c6:1e
[    2.395883] iwlwifi 0000:05:00.0 wlp5s0: renamed from wlan0

Very strange, isn't it? Same packages, same hardware,...
Comment 52 Thomas Andrews 2020-12-04 16:10:46 CET
Created attachment 12055 [details]
Output of "dmesg | grep iwl" on a Probook

(Used The Gimp to crop and scale the photo to make the file small enough)

Note that there are fewer messages on mine, but that the actual fault seems to be the same - the proper firmware wasn't found.
Comment 53 Thomas Andrews 2020-12-04 16:15:38 CET
One relatively minor niggle: when the non-free iso is dumped to a USB stick by Isodumper, the stick label is the same as the one for the free version. I think "non-free" should be added to that label, so one might know the difference at a later date if one neglected to put a physical label on the device.
Comment 54 Thomas Andrews 2020-12-04 16:39:34 CET
Following Aurelien's lead, I booted into Live mode from the Beta1 Plasma iso, used the net_applet to configure wifi and connect, then immediately used the "dmesg | grep iwl" command. This is the result:

live@localhost ~]$ dmesg | grep iwl
[   17.302004] iwlwifi 0000:43:00.0: can't disable ASPM; OS doesn't have ASPM control
[   17.318667] iwlwifi 0000:43:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[   17.318799] iwlwifi 0000:43:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
[   17.464843] iwlwifi 0000:43:00.0: loaded firmware version 9.221.4.1 build 25532 6000-4.ucode op_mode iwldvm
[   17.465227] iwlwifi 0000:43:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[   17.585425] iwlwifi 0000:43:00.0: CONFIG_IWLWIFI_DEBUG enabled
[   17.585428] iwlwifi 0000:43:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[   17.585430] iwlwifi 0000:43:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[   17.585432] iwlwifi 0000:43:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
[   17.619235] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   17.880348] iwlwifi 0000:43:00.0 wlo1: renamed from wlan0
[   37.655136] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[   37.890798] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[   38.040251] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[   38.274632] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[  187.465531] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[  187.700937] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[  187.811130] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
[  188.046220] iwlwifi 0000:43:00.0: Radio type=0x1-0x3-0x1
Comment 55 Thierry Vignaud 2020-12-04 16:45:28 CET
(In reply to Martin Whitaker from comment #49)
> Looking at the contents of
> iwlwifi-firmware-20201118-1.mga8.nonfree.noarch.rpm, we only include a
> subset of the available firmware.
> 
> @Thierry, is there some policy on that?

In the old days we only filtered ou some:
See http://gitweb.mageia.org/software/drakx/commit/images/make_boot_img?id=77964056ffe63d87bee4e4afe8ddec541b0b5ce2 for the logic

But now this is handled by dracut
Comment 56 Thierry Vignaud 2020-12-04 16:47:15 CET
Humm, I just added a BR on iwlwifi-firmware in the spec file.
Comment 57 Thierry Vignaud 2020-12-04 17:01:07 CET
It might be interested to look at any other missing firmware package as BR
Comment 58 Dave Hodgins 2020-12-04 20:59:39 CET
(In reply to Thomas Andrews from comment #53)
> One relatively minor niggle: when the non-free iso is dumped to a USB stick
> by Isodumper, the stick label is the same as the one for the free version. I
> think "non-free" should be added to that label, so one might know the
> difference at a later date if one neglected to put a physical label on the
> device.

# blkid /dev/sdf*
/dev/sdf: UUID="2020-01-30-05-36-22-00" LABEL="Mageia-8-x86_64-netinstall" TYPE="iso9660" PTUUID="365ad177" PTTYPE="dos"
/dev/sdf1: UUID="2020-01-30-05-36-22-00" LABEL="Mageia-8-x86_64-netinstall" TYPE="iso9660" PTUUID="365ad177" PTTYPE="dos" PARTUUID="365ad177-01"
/dev/sdf2: SEC_TYPE="msdos" UUID="B569-A60E" TYPE="vfat" PARTUUID="365ad177-02"
/dev/sdf3: UUID="2ce10a8f-8c6d-48ed-9f75-c86aa99976f8" TYPE="crypto_LUKS" PARTUUID="365ad177-03"

From "man genisoimage" ...
-V volid
              Specifies the volume ID (volume name or label) to be written into the master block.  There is space for 32 characters.

The current label is 26 characters. I don't know if the 32 character limit
includes the trailing null in the string or not. Either way there is non enough
room to add "-nonfree", so perhaps just add "-nf" so the label becomes
Mageia-8-x86_64-netinstall-nf

CC: (none) => davidwhodgins

Comment 59 Martin Whitaker 2020-12-05 18:42:40 CET
Created attachment 12060 [details]
Missing firmware reported by dracut when building installer images

The attached list was generated by adding --debug to the dracut command and grepping for "missing firmware".

Looking at the iwlwifi driver in particular, the problem appears to be that the driver will accept a range of firmware versions, but modinfo only reports a single (latest?) version. So for example, TJ's screenshot shows the driver searching for iwlwifi-6000-4.ucode .. iwlwifi-6006-6.ucode. But

% /sbin/modinfo iwlwifi | grep iwlwifi-6000-
firmware:       iwlwifi-6000-6.ucode

% urpmq -l iwlwifi-firmware-20201118-1.mga8.nonfree.noarch.rpm | grep iwlwifi-6000-
/lib/firmware/iwlwifi-6000-4.ucode

hence dracut doesn't find a match.
Comment 60 Martin Whitaker 2020-12-09 14:34:11 CET
It appears the iwlwifi driver supports firmware API versions they have never publicly released, and the driver only reports the latest API version for each firmware type. To my mind, this is a bug in the iwlwifi driver, but I guess the chances of getting that fixed are slim. Google finds me references to iwlwifi-6000-6 not being found going back years.

Without hacking dracut to treat iwlwifi as a special case, I think our only option is to explicitly add /lib/firmware/iwlwifi*.
Comment 61 Martin Whitaker 2020-12-15 21:37:13 CET
The latest netinstall ISO should include the missing Intel firmware.
Comment 62 Thomas Andrews 2020-12-15 22:29:09 CET
Both nonfree versions are now working as expected on my Probook.
Comment 63 Morgan Leijström 2020-12-15 22:49:34 CET
\o/ :)
Comment 64 Martin Whitaker 2020-12-18 22:53:58 CET
Thanks for testing TJ. I'm going to set this to fixed. If there are still missing drivers or firmware, they should be separate bug reports.

Status: ASSIGNED => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.