Bug 5263 - Pressing f2-f6 to change kernel options also moves selection from boot to install
Summary: Pressing f2-f6 to change kernel options also moves selection from boot to ins...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: High normal
Target Milestone: ---
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA5
: 5504 5551 14032 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-07 02:34 CEST by Dave Hodgins
Modified: 2017-07-10 14:23 CEST (History)
12 users (show)

See Also:
Source RPM: mageia-gfxboot-theme-4.4.5.18-2.mga5.src.rpm
CVE:
Status comment:


Attachments

Description Dave Hodgins 2012-04-07 02:34:19 CEST
Booting Mageia-2-beta3-LiveCD-KDE4-Europe1-Americas-i586-CD.iso
under VirtualBox, when I press f6 to alter the kernel options,
the highlighted entry changes from boot to install, and the
kernel options has install at the end, indicating it did change
the selection, not just the display.
Manuel Hiebel 2012-04-07 21:27:12 CEST

Blocks: (none) => 4299
Whiteboard: (none) => livecd

Comment 1 Manuel Hiebel 2012-04-07 21:42:21 CEST
valid for all fx (F1 to F6)

Summary: Pressing f6 to change kernel options also moves selection from boot to install => Pressing fx to change kernel options also moves selection from boot to install

Comment 2 Manuel Hiebel 2012-04-07 21:43:56 CEST
ah no sorry

Summary: Pressing fx to change kernel options also moves selection from boot to install => Pressing f2-f6 to change kernel options also moves selection from boot to install
CC: (none) => tmb

Comment 3 Manuel Hiebel 2012-04-20 12:43:05 CEST
*** Bug 5504 has been marked as a duplicate of this bug. ***

CC: (none) => philippedidier

Comment 4 Philippe Didier 2012-04-20 18:42:48 CEST
Bug 5504 is a duplicate ... but it shows the problem is still existing on LiveCD beta3 downloaded from the repo with the version that is provided since 2012-04-18
and available for tests as Ennael announced it in dev-mailing list april 18th

This bug (5263) was written on the 7th of April ... 11 days before we can find the last iso that I have used 

Was it already Mageia-2-beta3-LiveCD-KDE4-Europe1-Americas-i586-CD.iso when Dave tested it ?
Comment 5 Manuel Hiebel 2012-04-20 19:37:16 CEST
>Was it already Mageia-2-beta3-LiveCD-KDE4-Europe1-Americas-i586-CD.iso when
>Dave tested it ?

Yes the QA has make a lot of pre-release tests ( and some blocker bugs was found, that's why it was delayed)

https://ml.mageia.org/l/arc/qa-discuss/2012-04/
Comment 6 Dave Hodgins 2012-04-20 23:41:25 CEST
Btw, there is a workaround.  After you press the f? key, press escape,
use the cursor keys to go back to the boot option, then press the f?
key again.  Seems the selection only jumps the first time it's pressed.
Comment 7 Manuel Hiebel 2012-04-22 12:11:09 CEST
*** Bug 5551 has been marked as a duplicate of this bug. ***

CC: (none) => piscestong

Manuel Hiebel 2012-04-25 22:48:01 CEST

Priority: Normal => release_blocker
Whiteboard: livecd => (none)
CC: (none) => ennael1, erwanaliasr1

Comment 8 Anne Nicolas 2012-04-26 07:54:59 CEST
I'm afraid it will not be fixed as all gfxboot theme is blured and would ask to modify install also. So delayed after Mageia 2 is out

Priority: release_blocker => High

Comment 9 Manuel Hiebel 2012-04-29 18:19:54 CEST
strange that this bug affect "only" the livecd :/
Comment 10 Thomas Backlund 2012-04-29 18:29:02 CEST
(In reply to comment #9)
> strange that this bug affect "only" the livecd :/

Nope. its on the DVD too.

but since DVD has "boot from hd" as topmost entry, and defaults to second entry (install...) so no-one reacts on it.

That's why pressing F2-F6 jumps to line 2 as that is what the DVDs expect...
Comment 11 Guillaume Rousse 2012-05-02 21:48:05 CEST
Target set to mageia 3, as installer changes are needed.

CC: (none) => guillomovitch
Target Milestone: --- => Mageia 3

Guillaume Rousse 2012-05-02 21:49:07 CEST

Blocks: 4299 => (none)

Comment 12 Marja van Waes 2012-05-26 13:06:22 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja

Keywords: (none) => NEEDINFO

Comment 13 Philippe Didier 2012-05-26 19:30:20 CEST
still valid with final release
Sander Lepik 2012-05-26 19:31:07 CEST

CC: (none) => sander.lepik
Keywords: NEEDINFO => (none)

Comment 14 Dave Hodgins 2012-05-27 04:20:26 CEST
Since this is a problem with the installer itself, it has to be kept assigned
to cauldron, and is now for Mageia 3.
Comment 15 Greg McGee 2012-08-04 07:07:17 CEST
Note: This bug goes back several Mandriva releases as well...
Do a few dozen installs and you get used to it ;-)

CC: (none) => gjmcgee

Comment 16 claire robinson 2012-10-01 18:17:11 CEST
Valid pre mga3 alpha2 livecd gnome i586

Whiteboard: (none) => 3alpha2

Comment 17 Philippe Didier 2012-10-27 14:06:06 CEST
Valid Mga3 alpha2 Live DVD KDE i586
Comment 18 claire robinson 2012-11-06 11:29:20 CET
valid pre-3alpha3

Whiteboard: 3alpha2 => 3alpha2 3alpha3

Comment 19 Philippe Didier 2012-11-16 11:49:26 CET
Valid Mga3 alpha23 Live DVD KDE i586
claire robinson 2012-12-10 13:15:03 CET

Hardware: i586 => All
Whiteboard: 3alpha2 3alpha3 => 3alpha2 3alpha3 3beta1

Comment 20 Philippe Didier 2012-12-27 12:17:42 CET
still valid Mga3 Beta1 Live DVD KDE i586
Dave Hodgins 2013-03-25 03:27:04 CET

Whiteboard: 3alpha2 3alpha3 3beta1 => 3alpha2 3alpha3 3beta1 3beta4

Comment 21 Greg McGee 2013-03-25 05:32:26 CET
..still valid on MGA3B3 i586 and x64 live DVDs as well.

Perhaps we should simply remarket this as a feature? >;-}
Comment 22 Dave Hodgins 2013-04-22 22:01:03 CEST
What about changing the order of the entries, so that
boot is the second option, but still the default?
Dave Hodgins 2013-08-05 01:37:51 CEST

Whiteboard: 3alpha2 3alpha3 3beta1 3beta4 => 4alpha1

Comment 23 Greg McGee 2013-08-11 10:14:50 CEST
Still present in all Mga3 release isos I tried.
Guillaume Rousse 2013-08-12 14:23:43 CEST

CC: guillomovitch => (none)

Comment 24 papoteur 2014-04-09 19:10:15 CEST
Found this problem in Live-DVD-KDE in Mageia 4.
The entry jumps to line 2.

CC: (none) => yves.brungard_mageia

Comment 25 Manuel Hiebel 2014-09-03 21:52:27 CEST
*** Bug 14032 has been marked as a duplicate of this bug. ***

CC: (none) => 231036448

Comment 26 nikos papadopoulos 2014-11-14 23:00:49 CET
Still valid in
   Mageia 5
   beta 1
   32 bit
   Live
   KDE
   DVD
Comment 27 Dick Gevers 2014-11-15 12:13:30 CET
Confirmed

Target Milestone: Mageia 3 => Mageia 5
Whiteboard: 4alpha1 => 5beta1
Source RPM: mageia-gfxboot-theme-4.1.19.32-1.mga1.src.rpm => mageia-gfxboot-theme-4.4.5.18-2.mga5.src.rpm

Comment 28 Samuel Verschelde 2015-05-16 18:53:48 CEST
I've seen commits recently, not sure they fixed this issue, but just in case, could you confirm if the bug is still present in Mageia 5 RC?

Keywords: (none) => NEEDINFO

Comment 29 Thomas Backlund 2015-05-16 19:18:31 CEST
Afaik still valid
Samuel Verschelde 2015-05-16 19:20:50 CEST

Whiteboard: 5beta1 => 5final
Keywords: NEEDINFO => (none)
Target Milestone: Mageia 5 => ---

Comment 30 Greg McGee 2015-05-17 23:03:57 CEST
Still valid on the latest MGA5 RC.
Its been going on so long it's "normal" to longtime users, it dates back to Mandrake instaler of yore.
. (The current Mandriva installer is still broken in exactly the same way FWIW)
Comment 31 Greg McGee 2015-05-21 10:50:42 CEST
Perhaps we should just add a line in the installer explaining it as normal operation so its not a bug anymore.;-)
Samuel Verschelde 2015-05-21 10:55:17 CEST

Whiteboard: 5final => 5final FOR_ERRATA

Comment 32 papoteur 2015-05-31 16:44:29 CEST
Added to errata:
https://wiki.mageia.org/en/Mageia_5_Errata#Kernel_options_selection
Kernel options selection
Pressing f2-f6 to change kernel options also moves selection from boot to install 5263. Delete manually the word install on the kernel options line to run the live mode instead of installation.

Whiteboard: 5final FOR_ERRATA => 5final IN_ERRATA

Comment 33 Samuel Verschelde 2016-10-10 17:11:54 CEST
Is this bug still present in Mageia 6?

Keywords: (none) => NEEDINFO

Comment 34 Greg McGee 2016-10-10 20:08:56 CEST
Will check ASAP.
Comment 35 Greg McGee 2016-10-11 08:54:31 CEST
Yes, still does it,
... at least it has been consistent since ~mandriva 2008ish? ;-)
Sadly, it may bite new users...
Its only mildly annoying if you are used to it.
Comment 36 Greg McGee 2016-10-11 09:00:54 CEST
Where is the installer code?
(I assume its not a package per se)
Marja van Waes 2016-10-18 22:31:05 CEST

Whiteboard: 5final IN_ERRATA => (none)
Keywords: NEEDINFO => FOR_ERRATA6, IN_ERRATA5
CC: (none) => marja11
Assignee: bugsquad => mageiatools

Marja van Waes 2017-03-06 16:38:55 CET

Keywords: FOR_ERRATA6 => IN_ERRATA6

Comment 37 Martin Whitaker 2017-04-09 19:21:15 CEST
This has become more critical since we removed the "Boot from hard disk" option from the Live ISOs (bug 16038). Now users trying to change the Live boot options end up running the installer instead.

The bug was introduced by

commit 5ce8d30439463838f845c78bc926cc9b310a8743
Author: Pascal Rigaux <pixel@mandriva.com>
Date:   Tue Jan 27 17:30:08 2009 +0000

    imported openSUSE.tar.bz2 (from gfxboot-4.1.19-2.1.src.rpm)

The following commit includes the comment

    (nb: i wonder what panel.extra is)

panel.extra is the subroutine that causes this strange behaviour. Presumably it made some sense in openSUSE...

I will fix this.

CC: (none) => mageia

Comment 38 Thierry Vignaud 2017-04-10 15:08:48 CEST
Thx again Martin for digging here into one of the less known/loved bits of Mageia that we'll have to resync with upstream at some time...

CC: (none) => thierry.vignaud

Comment 39 Thierry Vignaud 2017-04-10 15:09:59 CEST
For the record, there was already an open bug report back at that time in the mdv bugzilla...
Comment 40 Mageia Robot 2017-04-14 23:22:16 CEST
commit 1f79888c83717dd42701a9d37e5ae46b9885b0e3
Author: Martin Whitaker <mageia@...>
Date:   Sun Apr 9 21:45:22 2017 +0100

    Don't change menu selection when F2-F6 are pressed (mga#5263).
    
    This was part of the functionality imported from openSUSE in commit
    5ce8d30439463838f845c78bc926cc9b310a8743, but is not something we
    want.
---
 Commit Link:
   http://gitweb.mageia.org/software/design/bootloader-theme/commit/?id=1f79888c83717dd42701a9d37e5ae46b9885b0e3
Comment 41 Martin Whitaker 2017-04-26 09:37:12 CEST
Fixed in cauldron, will be on next Live ISO build.

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 42 Samuel Verschelde 2017-07-10 14:23:48 CEST
Removing the IN_ERRATA6 keyword since it's been fixed and is not present anymore in the Errata.

Keywords: IN_ERRATA6 => (none)


Note You need to log in before you can comment on or make changes to this bug.