Bug 523 - Enhancement: Release media should have/point to non-free drivers
: Enhancement: Release media should have/point to non-free drivers
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: Release (media or process)
: Cauldron
: All Linux
: Normal Severity: enhancement
: Mageia 3
Assigned To: Mageia Bug Squad
:
:
: (MGA2)
: USABILITY
: 3793
:
  Show dependency treegraph
 
Reported: 2011-03-24 10:42 CET by Wolfgang Bornath
Modified: 2013-01-21 22:23 CET (History)
10 users (show)

See Also:
Source RPM:
CVE:


Attachments

Description Wolfgang Bornath 2011-03-24 10:42:02 CET
Description of problem:

For setting up an internet connection with WiFi you need non-free drivers which can not be part of the free distribution. Therefore you have to have a cable bound connection first to install these non-free drivers from the net.

This is not always possible. Quote from a user in the ML: "My desktop and my router are located in opposite places in my house, I can't run a cable all the way through just for installation."

Suggested Solution:

A small dual-arch ISO with non-free drivers / firmware. People who need these can download the ISO together with the distribution ISO of their choice. The routine to include this driver cd is already present in the installer.



Reproducible: 

Steps to Reproduce:
Comment 1 Frank Griffin 2011-03-24 12:54:55 CET
I would actually like to extend this idea.  

Give all network-related stuff that can't be on the Free DVD for reasons of either space or philosophy its own repository directory, and build it into a small ISO as well.  Then have both stage 1 and stage 2 incorporate support for this repository or ISO, with an opt-in prompt.

This would solve several problems at once.

Giving stage 1 access to this would make network installs over wireless possible.  At least I think that the only things blocking this were space and proprietary issues.  

Having this stuff in a repository structure would give advanced wireless users the ability to do totally wireless installs from a cached copy of the isolinux and new wireless directories.  

Currently, I maintain a local copy of the Mageia trees on NFS, but before I start a fresh install on a working laptop, I first run a script which rsync's the isolinux directories to local harddisk on the laptop.  

All of my systems use a grub menu which has an entry for booting from this local isolinux image, which means I don't have to fuss with boot.iso.  For absolutely initial fresh installs, you would of course still need the ISO format for both boot and network, but with new repository support for network/wireless, the same sort of prompt now used by the install for the source directory on an NFS install could ask for the local directory for the network/wireless stuff, or it could simply be found in its assigned place in the tree by default before presenting the opt-in prompt.

The sequence would be something like:

)begin install; boot from either boot.iso or isolinux HD

)if not a DVD distro, prompt for the distro tree location (NFS, etc.)

)prompt for the opt-in; if the network/wireless repository can be found in the distro tree *and* is accessible (e.g. network available for network-type installs), set it as the location by default, otherwise, prompt for a local repository directory

)if the user opts-in, use the new repository to try to bring up the network if it isn't already there.  In any case, remember the location and that the user opted-in, so that stage 2 can add the necessary packages and configuration later on.

)during stage 2, if a full distro tree is available (and the user opted-in), use the network/wireless repository from there for consistency, otw use whatever the user gave in stage 1.


This would solve the issue for newbies by providing a small network/wireless ISO and requiring a little bit of DVD/CD shuffling up front (the network/wireless ISO could be copied to HD for later).  It would also provide a truly seamless totally wireless install for advanced users.
Comment 2 andré blais 2011-03-24 20:02:00 CET
2 isos for one installation is a little less than "seamless", particularly for "newbies".

I would suggest a much simpler, pragmatic solution to help ensure that all isos work "out of the box", whether or not an internet connexion is available, without the hassle of a supplementary iso.

Include all necessary drivers on every iso.
By necessary, I would include at least video, ethernet, and wifi drivers.
If no reliable equivalent "free" driver is available, include a "non-free" driver.
Evidently not all drivers for all hardware can be included, but all more or less common hardware should be covered.  Since a lot of drivers are very small in size, these should probably be included even if not very common - to minimize those affected by a lack of drivers.
It is not reasonable to expect that everyone installing Mageia will have an internet connexion available at installation time.

Simply put, let's let common sense prevail over idealogical correctness.

We don't want to discourage potential Mageia Linux users by having an installation that doesn't work "out of the box".
Remember that many users will be much less advanced than most of us here.  And even experienced/advanced users should appreciate the increased ease of installation.

Whether we put the drivers in "core", as is sometimes done in other distros, or keep these non-free drivers in "non-free", is not important to working "out of the box".
For those concerned about a driver being non-free, a warning could always be put in the summary or description.
(Personally it seems simpler to put such drivers in "core" if no reliable free equivalent exists.)
Comment 3 Frank Griffin 2011-03-24 20:13:11 CET
>2 isos for one installation is a little less than "seamless", particularly for
"newbies".

Any newbie who can mount the original DVD can also mount the network CD when he's asked to.  That's hardly rocket science, and it doesn't subtract from "seamless" any more than picking languages, partitioning the disk, and all of the other interactions we require.

In any case, my reason for suggesting a second ISO was not ideological, but practical.  The MDV single-layer DVDs are full to the hilt, and there's a constant discussion over adding packages and dropping others.  So, having a second ISO is just a matter of conserving space on the first, and a recognition that not everyone will need it.  

Granted, the Mageia ISOs aren't quite that full yet, but then again we didn't have everything built the first time around, either.  I'm sure we'll be knocking on the 4.7GB door before you know it.  Previous discussions in the cooker ML saw flame wars about going to a DL DVD or even someday a Blu-Ray, but if that were ever done, I would have no problem combining the ISOs.
Comment 4 andré blais 2011-03-24 23:22:54 CET
No offense intended, but your argument is then essentially for having a second iso.

My point is that having one DVD with everything necessary to install a system is better than requiring two.
I have no problem with a second ISO, as long as the base DVD is complete.

Considering that most packages on the DVD aren't installed by most users (there is a lot of duplication, which also means choice),
 and that drivers are generally smaller than many other packages, excluding the required drivers doesn't do much to adresse the lack of space.

However having a supplementary developer's DVD might be a good idea, for example ?

Alternately, a double sided DVD might be a good idea, as long as the single sided DVD is maintained.  (Many users don't have a writer capable of writing double sided.)
In that case, it would be better if the double sided DVD had all the drivers as well.

Don't forget that if a desired (but non-essential) package is missing from the DVD, one can always download it at a later time.  But without essential drivers, one has a partially functional system.
A bit like a car without tires.  Or a computer without a keyboard.

Of course, as you say, it can be difficult to decide what goes on the DVD, as space will always be limited (even if we go to blueray :) )
Comment 5 Anne Nicolas 2011-03-31 15:43:30 CEST
Problem for now is dual arch space is just nearly full. And we can hardly remove more components
Comment 6 Frank Griffin 2011-04-04 18:14:07 CEST
(In reply to comment #5)
> Problem for now is dual arch space is just nearly full. And we can hardly
> remove more components

What about a second, optional, targeted ISO as described above ?
Comment 7 Real Name 2011-06-07 06:40:20 CEST
Some response would be nice for this good idea.
Or it's just gonna die slow in the old MDV tradition?
Comment 8 Anne Nicolas 2011-06-07 09:12:41 CEST
(In reply to comment #7)
> Some response would be nice for this good idea.
> Or it's just gonna die slow in the old MDV tradition?

Jumping on short conclusions will not help to solve it... Maybe wait a bot for people to come back after last weeks of hard work. 

BTW we cannot afford to have multiple isos for everyone. It means as much effort in term of QA and for now QA team size is much too small. 

First we have to solve that pb and also decide a final set of isos to avoid changes at every releases...
Comment 9 Real Name 2011-06-07 09:55:34 CEST
It wasn't a conclusion but a question.
 
"BTW we cannot afford to have multiple isos for everyone."
Does this means that the issue is solved as in won't happen?
No one wants to throw more burdens on your shoulders, you're already doing a great job IMO.
But this is not an enhancement, it's a necessity.

If in the end, if a supplementary iso will be not feasible, could at least use that USB/Debian method of providing necessary network drivers/firmware?
Comment 10 Anne Nicolas 2011-06-07 10:09:05 CEST
(In reply to comment #9)
> It wasn't a conclusion but a question.
> 
> "BTW we cannot afford to have multiple isos for everyone."
> Does this means that the issue is solved as in won't happen?
> No one wants to throw more burdens on your shoulders, you're already doing a
> great job IMO.
> But this is not an enhancement, it's a necessity.

well you think it's a necessity. Still we have to define what would suit for the most frequent uses of Mageia. We wil collect all proposals but at the end we need to define a reasonable list of isos to be released, provided we have QA guys enough to work on it. As an idea, it took 5 tests days for final release for all isos. Still tests were not complete because people were lacking and the existing team had to work late in the night to finalize this.h

> 
> If in the end, if a supplementary iso will be not feasible, could at least use
> that USB/Debian method of providing necessary network drivers/firmware?

This is doable of course. This can be one proposal. We will take time to collect all this and choose the best way to satisfy Mageia users.
Comment 11 Real Name 2011-06-07 10:46:29 CEST
""well you think it's a necessity.""

When you have finished a Mageia 1 installation and you stare at it useless because you have no means to connect to the internet and do your intended job...believe me, it is a necessity.

This is not a frivolous wish about a pink theme with fluffy icons, it is something that could make the difference between a usable PC and a bricked PC.
How could that be not a necessity?
Comment 12 andré blais 2011-06-07 11:34:17 CEST
Having a separate driver cd is not the only solution.
(That was a common solution in the days of multiple cd's, when the driver cd was one of many packaged with a commercial product.  Seems outdated with the advent of DVD's)

In my mind it is much better to put the drivers on the base iso.  Collectively they don't take much space relative to many applications.
It is the most reliable way to ensure that users, especially those less advanced, don't get stuck.

In any case, I agree that it is extremely important to ensure that drivers are available on first installation.  Even if during installation, there is no internet access.
Comment 13 andré blais 2011-06-07 11:46:48 CEST
Saying that one can't put non-free drivers on a free iso is somewhat incoherant, considering that there are non-free parts of the kernel, and of course, almost if not all computers on which it is to be installed contain non-free hardware.
In terms of free, what counts is what one installs.
Who would boycott Mageia (or any other distribution) because it distributes non-free software ?
That doesn't mean that a "free" iso shouldn't be essentially free software, but non-free drivers (obviously destined for non-free hardware) should be an evident exception, where no reliable free driver exists.
Comment 14 Anne Nicolas 2011-06-07 12:00:06 CEST
(In reply to comment #13)
> Saying that one can't put non-free drivers on a free iso is somewhat
> incoherant, considering that there are non-free parts of the kernel, and of
> course, almost if not all computers on which it is to be installed contain
> non-free hardware.
> In terms of free, what counts is what one installs.
> Who would boycott Mageia (or any other distribution) because it distributes
> non-free software ?
> That doesn't mean that a "free" iso shouldn't be essentially free software, but
> non-free drivers (obviously destined for non-free hardware) should be an
> evident exception, where no reliable free driver exists.

I'm not saying it's not needed. And free supporter may not agree with your point of view. That's why we have to summarize all this and take decisions.
Comment 15 andré blais 2011-06-07 14:51:59 CEST
I appreciate that not everyone shares my point of view.
But I do feel very strongly that complete base iso will contribute to ensuring that Mageia always works "out of the box".
And of course it is important to reflect carefully on the issue.

On the mailing lists there has been the suggestion that, on installation from iso, there is a request for authorisation to install a non-free driver, if such a driver is needed.
We could present the options "(1) never install non-free drivers, or (2) install this driver, or (3) install all non-free drivers required"
(The order chosen to please only-free advocates.)

Perhaps using "open source" or an explanation of "free" to ensure that new users don't think that they would be required to pay for "non-free".
Comment 16 Marja van Waes 2011-10-07 22:59:09 CEST
I guess this bug should stay open, but dormant for now
Comment 17 Thierry Vignaud 2011-11-17 12:37:08 CET
I think that this one will be fixed along bug #66 with a media screen/step for enabling tainted, non-free and the like
Comment 18 Wolfgang Bornath 2011-11-17 13:02:58 CET
bug #66 (and this one as well) is about having a downloadable additional iso with with non-free/tainted stuff (firmware) to be used as additional source in the installation process (activated in the "media screen"). It is not about enabling online repositories.

Maybe I misunderstood what you wrote?
Comment 19 Varrin Swearingen 2011-11-20 18:54:38 CET
It appears from the discussion here and at bug #66 that the idea would be to allow either or (online and/or iso).  That (or a version of it) would be required to fix this problem, but this requires an additional step: decide how to provide non free software during the install process.  Use an additional iso or include it in some existing iso(s)?  

I submit that it would be better to, instead of making an additional *separate* ISO for non free software, to make an additional *complete* ISO ala Powerpack.  

The arguments above (and on the forum in several threads) about free software v.s. usability are not trivial.  Both are important and both require solutions that work for real users.  Count this as my vote for a single DVD (or one per architecture) that includes sufficient non free drivers (network, video, etc.) to get as many systems as possible started.  

I'm happy to download separate media (ala Powerpack) or to click "yes I intend to do that", thereby turning the all free DVD into an almost all free DVD.  I'm not happy to fish around for separate installation media, and it's an absolute show stopper to have to get network drivers online when you can't get online due to lack of network drivers (result = *ZERO* free software from Mageia being used).  

V-
Comment 20 Dick Gevers 2011-12-09 20:08:08 CET
*** Bug 1082 has been marked as a duplicate of this bug. ***
Comment 21 Marja van Waes 2012-05-26 13:01:45 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja
Comment 22 Frank Griffin 2012-06-11 16:40:52 CEST
Yes, it's still valid.

Basically, it comes down to the question of whether a "free ISO" is an ISO that allows for the installation of a free system if the user wants one, or whether it's an ISO that prevents anything but a free install whether the user wants one or not.  Obviously, I and others here would opt for the former interpretation.

As cauldron is back, and as the situation exists in both mga2 and cauldron, I'll leave it to you to decide what the release here should be.
Comment 23 Marja van Waes 2012-06-11 19:54:51 CEST
(In reply to comment #22)

> As cauldron is back, and as the situation exists in both mga2 and cauldron,
> I'll leave it to you to decide what the release here should be.

Thanks for the reply. We don't clone bugs anymore for different versions, but instead set the report to the highest version and then put MGA2TOO and/or MGA1TOO on the whiteboard.
However, installer bugs are always cauldron only. I put (MGA2) on the whiteboard to show this isn't an old cauldron bug from before Mga2 release.
Comment 24 Frank Griffin 2012-09-26 00:13:41 CEST
Ping ?  I realize that this is currently under  discussion on the ML, but there's a lot of pertinent material here that should not go unconsidered.
Comment 25 Manuel Hiebel 2013-01-21 22:22:46 CET
fixed since alpha3 of mageia3

Note You need to log in before you can comment on or make changes to this bug.