Bug 30909 - brasero won't burn large ISOs - no error given
Summary: brasero won't burn large ISOs - no error given
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Depends on:
Reported: 2022-09-29 03:33 CEST by Frank Griffin
Modified: 2023-02-26 15:55 CET (History)
2 users (show)

See Also:
Source RPM: brasero
Status comment:


Description Frank Griffin 2022-09-29 03:33:48 CEST
I have an ISO which pushes the size limits:

[ftg@ftgme2 /data/DVDFab/ISO/Clone]$ ls -l ANNA*
-rw-r--r-- 1 ftg ftg 8518033408 Sep 27 16:44 ANNA.iso

When I try to burn this to a DVD R+DL (from which it came), brasero simply ejects the blank disk with no error message.  Presumably, this requires something like "overburn" (or whatever we used to call it), but brasero isn't having any of it.
Morgan Leijström 2022-09-29 17:31:15 CEST

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=30908

Comment 1 Lewis Smith 2022-10-01 21:00:35 CEST
As noted elsewhere, Bug 30908 (Xfburn), Bug 30910 (k3b), it would be nice to know whether this failure happened with Mageia 8. I would try this ISO with a better download speed, but it would take hours. And Ionly haver DVD-RW if that is relevant.
It looks here like a generic [Linux or Mageia?) problem, possibly for Release Notes?

CC: (none) => lewyssmith

Comment 2 Frank Griffin 2022-10-02 19:57:49 CEST
I don't have an MGA8, but I'll install one and try it.  I've had this problem occasionally with other ISOs, but it never occurred to me to question the ISO length, which may have been the problem all along.

The other thing I'll try is using a Windows-based burner in a VM.  I'd still like to know where the "overburn" option went on Linux burners.
Comment 3 Morgan Leijström 2022-10-03 09:53:56 CEST
Setting for errata - in case it is really a problem; remove if it is somehow a local problem or we are wrong that it is a problem...

Overburning means using the less reliable lead-out area after the intended data space, radially outside of data track.  Different drives allow this more or less so i guess you observe problems of the software not recognising the drives capabilities plus also not reporting to the user neither the failure nor cause.  So there is at least one bug in every three software you have tried, possibly triggered by some common library or such.

Keywords: (none) => FOR_ERRATA9
CC: (none) => fri
See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=30910

Comment 4 Lewis Smith 2022-10-03 21:33:37 CEST
> Overburning means using the less reliable lead-out area after the
> intended data space, radially outside of data track
This could certainly explain the exact ISO size question. It looks good practice to avoid this feature.
OTOH the file in question seems within the 'dual layer' limits below, from Wikipedia:
DVD-R SL = 4,707,319,808
DVD+R SL = 4,700,372,992
DVD-R DL = 8,543,666,176
DVD+R DL = 8,547,991,552

Frank: DVD R+DL, 8,518,033,408

Is it possible that the Linux applications cannot handle this format?
We deliberately keep our ISO sizes to 4.7Gb.

Just to experiment, Frank, can you try trimming your file by various amounts (head -c Gn or Mn ?) to see what gets accepted by k3b, Brasero, Xfburn? I know the result would be useless, but instructive.
Comment 5 Jani Välimaa 2022-10-09 20:48:47 CEST
I think we should drop brasero as it's been unmaintained in upstream since a long time.

Comment 6 Lewis Smith 2022-10-09 20:58:33 CEST
Added Brasero to the redundant packages Tracker bug 30163.
Comment 7 Frank Griffin 2022-10-13 18:48:40 CEST
This seems to have nothing to do with ISO size.  I tried truncating, first to 8500000000 and then to 8000000000.  Both got the error.  However, I then successfully burned three other ISOs each exceeding 8000000000.  Assuming that all these burning apps on Linux are using wodim, there's something about this particular ISO that wodim doesn't like.

I'll try burning it under Windows.
Comment 8 Frank Griffin 2022-10-15 02:03:15 CEST
Closing this as INVALID since the title is misleading.  I'll open another on wodim if more information comes in.

Resolution: (none) => INVALID

Morgan Leijström 2023-02-26 15:55:47 CET

Keywords: FOR_ERRATA9 => (none)

Note You need to log in before you can comment on or make changes to this bug.