Bug 29473 - Update request Gimp 2.10.32 released
Summary: Update request Gimp 2.10.32 released
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact: QA Team
Whiteboard: MGA8-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2021-09-18 13:34 CEST by Jose Manuel López
Modified: 2022-12-30 23:40 CET (History)
9 users (show)

See Also:
Source RPM: gimp-2.10.24-1.mga8.src.rpm
Status comment:

Gimp 2.10.30 spec (35.70 KB, text/x-rpm-spec)
2022-01-10 09:57 CET, Jose Manuel López

Description Jose Manuel López 2021-09-18 13:34:07 CEST
Description of problem: Gimp 2.10.28 released with bugsfixed.

Version-Release number of selected component (if applicable): Gimp and Mageia 8

How reproducible: Checked the Gimp version in Mageia is 2.10.24

Steps to Reproduce:
1. Install Gimp
2. Cheched version of Mageia 8
3. The last version in Mageia 8 is 2.10.24. Gimp released 2.10.28
Comment 1 Lewis Smith 2021-09-18 20:23:00 CEST
Thank you for the hint.
In fact we already have 2.10.24 in Cauldron.

Assigning to Stig who did that, and the latest meaningful update.
CC'ing DavidG.

Assignee: bugsquad => smelror
CC: (none) => geiger.david68210
Source RPM: Gimp => gimp-2.10.24-1.mga8.src.rpm

Comment 2 Jose Manuel López 2021-12-24 18:07:47 CET

Gimp 2.10.30 has been announced with improvements and bugfixes.

Announcement here: https://www.gimp.org/news/2021/12/21/gimp-2-10-30-released/
Comment 3 Jose Manuel López 2022-01-05 10:57:29 CET

I have packaged gimp 2.10.30 for mga8 from srpm of gimp 2.10.24.

The new packages versions is here: https://mega.nz/folder/DpNTyaQZ#O1450joyPeEtwfSFwlW36Q

If some packager can check and update in mga8.

Jose Manuel López 2022-01-05 10:58:07 CET

Summary: Gimp 2.10.28 released => Update request Gimp 2.10.28 released

Comment 4 Morgan Leijström 2022-01-05 11:57:34 CET
Info for packager:
Jose is new apprentice, also working on Darktable bug 29812, Nicolas L supervise him from next week.

CC: (none) => fri

Comment 5 Morgan Leijström 2022-01-05 11:58:38 CET
- and thank you Jose for steaming on :)
Comment 6 Jose Manuel López 2022-01-10 09:57:06 CET

Updated Gimp package provides latest release:

  - This update provides Gimp 2.10.30, which is the latest upstream release.
  - It adds a many fixes and incremental improvements, see referenced release     notes for details on the changes since Mageia 8's original 2.10.24.


- https://www.gimp.org/news/2021/12/21/gimp-2-10-30-released/

I attach spec for upload to cor/update testing:

I am using currently in a Vbox Mga 8 Plasma X64 and on my real installation of Mageia 8. Works fine for me, import and export image, layers, filters, settings, brush, pencil don't issues for the moment.

Comment 7 Jose Manuel López 2022-01-10 09:57:57 CET
Created attachment 13080 [details]
Gimp 2.10.30 spec

This is spec of the new version 2.10.30.
Jose Manuel López 2022-01-10 09:59:04 CET

CC: (none) => pkg-bugs

John L. ten Wolde 2022-06-04 23:23:26 CEST

CC: (none) => johnltw

Frédéric "LpSolit" Buclin 2022-06-05 14:46:33 CEST

Summary: Update request Gimp 2.10.28 released => Update request Gimp 2.10.30 released

Comment 8 Jose Manuel López 2022-06-22 16:23:26 CEST

Updated Gimp package provides latest release:

  - This update provides Gimp 2.10.32, which is the latest upstream release.
  - It adds a many fixes and incremental improvements, see referenced release     notes for details on the changes since Mageia 8's original 2.10.24.


- https://www.gimp.org/news/2022/06/14/gimp-2-10-32-released/

I have tried package it the new version, and it requires gegl-0.4.36. In Mga8 we have the version 0.4.34.
Comment 9 Dave Hodgins 2022-06-22 18:09:23 CEST
It's occurred before, that new gimp versions included a gegl update. For
example, bug 28712.

Gimp support for a version ends when the next version has been released,
making it an allowed exception for the Version policy.

The gegl update is needed to support the gimp update. It's a leaf package that
as far as I know is not used by anything other then gimp.

So updates for both gimp and gegl are allowed as per 

CC: (none) => davidwhodgins

Comment 10 Stig-Ørjan Smelror 2022-06-22 20:16:10 CEST
I believe Gimp needs both gegl and babl.

Can look into it if wanted.
Comment 11 Frédéric "LpSolit" Buclin 2022-07-12 14:40:36 CEST
Gimp 2.10.30 is needed on Mageia 8 to fix https://gitlab.gnome.org/GNOME/gimp/-/issues/5785

"Screenshot fails with "process is not authorized" error in KDE Plasma 5.20"

If you try to take a screenshot of the whole screen from Gimp (File > Create > Screenshot), you get the following error message:

"GDBus.Error:org.kde.kwin.Screenshot.Error.NoAuthorized: The process is not authorized to take a screenshot"

Upstream has implemented a patch in 2.10.30 to fix this problem:


CC: (none) => LpSolit

Comment 12 Frédéric "LpSolit" Buclin 2022-07-12 14:45:17 CEST
See also the last point of the "OS evolutions" section:


"Screenshot plug-in now also uses in priority the Freedesktop API rather than specific KDE or GNOME API (which are getting restricted for security reasons since KDE Plasma 5.20 and GNOME Shell 41)."
Comment 13 Jose Manuel López 2022-07-13 19:57:49 CEST

I have tried to create a screenshoot in Gimp 2.10.30 packaged by me with the spec file attached here. The issue is fixed, i have a screenshot of fullscreen or the option that I have specified in options window.

As I have commented in comment 8 Gimp 2.10.32 is released, but I can't packaged because requires gegl-0.4.36.

Comment 14 Jose Manuel López 2022-12-22 11:59:24 CET

Updated Gimp package provides latest release:

  - This update provides Gimp 2.10.32, which is the latest upstream release.
  - It adds a many fixes and incremental improvements, see referenced release     notes for details on the changes since Mageia 8's original 2.10.24.


- https://www.gimp.org/news/2022/06/14/gimp-2-10-32-released/

Updated packages in core/updates_testing:

Gimp 2.10.32 need updates of bab and gegl that are in testin repos too.

Waiting for validate this by QA Team.
Jose Manuel López 2022-12-22 12:01:51 CET

QA Contact: (none) => qa-bugs

Jose Manuel López 2022-12-22 12:02:14 CET

Assignee: smelror => qa-bugs

Comment 15 Herman Viaene 2022-12-22 16:37:51 CET
MGA8-64 MATE on Acer Aspire 5253
When selecting gimp I get:
"Sorry, the following package cannot be selected:

- gimp-2.10.32-1.mga8.x86_64 (due to unsatisfied lib64gimp2.0_0[== 2:2.10.32])"

Selecting and installing babl and gegl separately works OK.

CC: (none) => herman.viaene

Comment 16 Thomas Andrews 2022-12-22 20:37:03 CET
It's there, Herman. Jose just didn't have it on the list. But there are other list omissions. My test install didn't have babl or gegl installed, and they indicated they would have installed for me OK using Jose's list. But on a hunch, I added the following in qarepo:

That brought in this list from updates_testing:


Mageia Update updated gimp, lib64gimp2.0_0, lib64babl0.1_0, and lib64gegl0.4_0, with no issues. And a quick test indicates Gimp is probably working OK.

But I have to ask, Jose, was anything else missing from your list? I can't be sure I'm doing a proper test without the answer.

CC: (none) => andrewsfarm

Comment 17 Jose Manuel López 2022-12-22 22:01:50 CET
I think nothing else is missing.

Anyway, I have tried to install Gimp in a Mageia installation without it being installed, activating the testing repos. From konsole with "urpmi gimp", Mageia installs all the necessary packages for me:

Para satisfacer las dependencias, se instalarán los paquetes siguientes:
  Paquete                        Versión      Revisión      Arq.    
(soporte «Core Release (distrib1)»)
  allegro4                   6.mga8        x86_64  (Recomendado)
  lib64allegro4.4            6.mga8        x86_64  
  lib64amd2                      4.4.6        4.mga8        x86_64  
  lib64camd2                     4.4.6        4.mga8        x86_64  
  lib64ccolamd2                  4.4.6        4.mga8        x86_64  
  lib64cholmod3                  4.4.6        4.mga8        x86_64  
  lib64colamd2                   4.4.6        4.mga8        x86_64  
  lib64devil1                    1.7.8        32.mga8       x86_64  
  lib64gexiv2_2                  0.12.1       2.mga8        x86_64  
  lib64mng2                      2.0.3        3.mga8        x86_64  
  lib64mypaint0                  1.6.1        4.mga8        x86_64  
  lib64suitesparseconfig4        4.4.6        4.mga8        x86_64  
  lib64umfpack5                  4.4.6        4.mga8        x86_64  
  mypaint-brushes                2.0.2        1.mga8        noarch  
(soporte «Core Updates (distrib3)»)
  graphviz                       2.44.1       2.1.mga8      x86_64  
  lib64gvpr2                     2.44.1       2.1.mga8      x86_64  
  lib64lab_gamut1                2.44.1       2.1.mga8      x86_64  
(soporte «Core Updates Testing (distrib5)»)
  gimp                           2.10.32      1.mga8        x86_64  
  lib64babl0.1_0                 0.1.98       1.mga8        x86_64  
  lib64gegl0.4_0                 0.4.36       1.mga8        x86_64  
  lib64gimp2.0_0                 2.10.32      1.mga8        x86_64  
se utilizarán 131MB de espacio de disco adicional.
se descargarán 30MB de paquetes.
¿Efectuar la instalación de los 21 paquetes? (S/n) 

Once installed, Gimp 2.10.32 works fine in my computer.

I hope I have answered your questions about this.
Comment 18 Thomas Andrews 2022-12-23 01:03:21 CET
Yes, thank you. If you haven't yet seen it, please read https://wiki.mageia.org/en/QA_Repo#Introduction 

It will explain why Herman wrote Comment 15, and why I asked the question. Essentially, use of qarepo is an additional check to make sure we don't miss a dependency when testing. We have been tripped up by that before, and do not wish it to happen again. If the list of rpms to be tested is incomplete, qarepo will usually let us know.

MGA8-64 Plasma system, i5-2500, Intel graphics. Once all the rpms had been downloaded with qarepo, there were no installation issues.

Tested by loading and manipulating an old map created with Gimp several years ago for the purpose of reporting to the USDA which crops had been planted where that year on a farm in New York State. Starting with a satellite photo of the farm as a base, areas were overlayed, color-coded according to crop, and labeled with field number and size. The fields, labels, and other information totaled over 70 layers when finished.

I was able to use various selection tools to select areas and change the fill pattern, erase and draw lines, edit text labels, and do other manipulations. There is a LOT of stuff I didn't test, but everything I did worked as it should.

Giving this an OK, and validating. There is a suggested advisory in Comment 14.

Whiteboard: (none) => MGA8-64-OK
CC: (none) => sysadmin-bugs
Summary: Update request Gimp 2.10.30 released => Update request Gimp 2.10.32 released
Keywords: (none) => validated_update

Comment 19 Jose Manuel López 2022-12-23 09:25:35 CET
ok, ok, rookie mistakes. I'm sorry. I'll take a look at the link discussed in comment 18.

Comment 20 Thomas Andrews 2022-12-23 13:55:12 CET
No problem. 

Mistakes are usually the best teachers. I know they have been with me, here and in Life in general.
Comment 21 Dave Hodgins 2022-12-23 22:36:09 CET
Just to clarify, three lists are expected. The rpm package list for i586 and
the list for x86_64. Those should include all of the rpm packages, with one
package per line so the appropriate list can be copy/pasted into qarepo. The
list of srpm package names is needed for the advisory. It's the srpm list
that controls what gets pushed from updates-testing to updates.
Dave Hodgins 2022-12-30 22:10:55 CET

Keywords: (none) => advisory

Comment 22 Mageia Robot 2022-12-30 23:40:30 CET
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.