Bug 22752 - Kjots complains about double used shortcut, no systray icon
Summary: Kjots complains about double used shortcut, no systray icon
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL: https://drive.google.com/open?id=1hxP...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 17:05 CET by Mauricio Andrés Bustamante Viveros
Modified: 2018-12-07 21:30 CET (History)
4 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Mauricio Andrés Bustamante Viveros 2018-03-12 17:05:27 CET
Description of problem:
If the end user tries to start kjots (a note keeper for plasma) the app seems that tries to open (the taskbar blinking message) but closes without reason
If tries to start kjots using the konsole, the undefinied symbol message appears

Version-Release number of selected component (if applicable):
5.0.2

How reproducible:
Every time

Steps to Reproduce:
Open kjost... nothing happen after disappearing of taskbar message
Open konsole and try to open the app, message appears
Marja Van Waes 2018-03-13 18:22:16 CET

CC: (none) => marja11
Assignee: bugsquad => kde

Comment 1 David GEIGER 2018-03-14 16:00:52 CET
should be fixed with kjots-5.0.2-1.2.mga6 in Core/Updates_testing repo.

Please test it, thanks in adavance!

CC: (none) => geiger.david68210

Comment 2 Mauricio Andrés Bustamante Viveros 2018-03-15 05:48:57 CET
Installing using MCC

Opening without issues except the "Bold and Add bookmark, wants to use the same key strokes (Control B) may be this is an error
Please report using bugs.kde.org" message


Link of the message (Spanish language)
https://drive.google.com/open?id=1UrRrxwO1SxTnxwgMcsYS3nWZWITOksLJ

PD:
In the bookmark menu, only one item is without translation: New bookmark folder
Comment 3 Morgan Leijström 2018-03-19 11:22:07 CET
I see the same popup here ( but in Swedish )

In my bookmark menu all three items are translated, so i guess there is a translation error only in Spanish version.

When starting it in konsole there is this output:

$ kjots                                                                                                                                              
Shortcut for action  "format_text_bold" "&Fetstil" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.                         
Shortcut for action  "format_text_italic" "&Kursiv" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.                        
Shortcut for action  "format_text_underline" "Stryk &under" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.                    
Shortcut for action  "format_text_strikeout" "Str&yk över" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.                     
Performing Akonadi migration. Good luck!                                                                                                                              
Akonadi migration failed!                                                                                                                                             
command was:  ("", "--interactive-on-change")                                                                                                                         
exit code:  0
QIODevice::read (KProcess): device not open
stdout:  ""
QIODevice::read (KProcess): device not open
stderr:  ""
     

When i close it by clicking the window frame [x] button, windows close but kjots is still running in the background.  I expected it to be seen in system tray but   it is not visible, nor is system tray settings.

This install have all updates to Plasma5.12/QT5/KF5

It was years since i used kjots, maybe never before on this install.

CC: (none) => fri

Comment 4 Morgan Leijström 2018-03-19 11:24:49 CET
", nor is system tray settings." -> ", nor in system tray settings."

Summary: Kjots complains about undefinied symbol => Kjots complains about double used shortcut, no systray icon

Comment 5 Lewis Smith 2018-12-07 10:40:38 CET
This looks the same as bug 20428. Perhaps one could be closed as a duplicate.

CC: (none) => lewyssmith

Comment 6 Mauricio Andrés Bustamante Viveros 2018-12-07 12:46:57 CET
No, is not the same
This bug was for the grandupdate problem, that the app did not open and using consolé this app closes after trying generate the taskbar icon

After the patch, the update opens but the keyboard shorcut problem is detected, because this bug was only for the not opening app, must be closed
Comment 7 Lewis Smith 2018-12-07 21:30:39 CET
This bug never went individually through QA, but as Maurice says:
> This bug was for the grandupdate
I have kjots-5.0.2-1.2.mga6 (comment 1) and only see the duplicate Ctl/B popup on starting KJots. Dismissing that OK, the application starts. This is a normal windowed application; it is KNotes that goes to SysTray.

> No, is not the same
So closing this bug FIXED, and leaving bug 20428 outstanding. That scacely matters.

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.