Bug 19377 - Sound level raised to its maximum without user intervention
Summary: Sound level raised to its maximum without user intervention
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: High normal
Target Milestone: Mageia 6
Assignee: Colin Guthrie
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA6
: 20688 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-15 21:40 CEST by Samuel Verschelde
Modified: 2017-08-17 23:10 CEST (History)
10 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Samuel Verschelde 2016-09-15 21:40:45 CEST
I don't know if it's a plasma issue or pulseaudio or something else. Everytime I boot my computer and start plasma, sound level is raised to 100%.
Samuel Verschelde 2016-09-15 21:40:59 CEST

CC: (none) => kde

Comment 1 Nicolas Lécureuil 2016-09-15 21:41:53 CEST
how is the sound in pavucontrol ?

CC: (none) => mageia

Comment 2 Samuel Verschelde 2016-09-15 21:52:09 CEST
I'll check next time I reboot. I forgot to say that I can control the sound level afterwards, it works well. It simply comes back to 100% after a reboot.
Comment 3 Bit Twister 2016-09-15 22:26:42 CEST
(In reply to Samuel Verschelde from comment #0)
> I don't know if it's a plasma issue or pulseaudio or something else.
> Everytime I boot my computer and start plasma, sound level is raised to 100%.

My guess it is a pulseaudio problem.

I have modified /etc/pulse configuration files to set sink and audio levels.
pavucontrol shows my settings.

First time an application sends an alarm sound it comes out at 100%
I can crank it back to the usual 25% and next alarm sound is within setting.

For instance you get into systemsettings5, make a change and try to leave without saving the change will cause the app to send sound to pulse.

CC: (none) => bittwister2

Comment 4 Bit Twister 2016-09-16 12:25:27 CEST
"pacmd dump" shows
    set-source-volume alsa_output.pci-0000_00_14.2.analog-stereo.monitor 0x10000
after setting my analog output at 25%
Comment 5 Nicolas Lécureuil 2016-09-18 13:09:43 CEST
i think this is ca pulseaudio issue.

Assignee: bugsquad => mageia

Comment 6 Bit Twister 2016-09-18 13:24:10 CEST
(In reply to Nicolas Lécureuil from comment #5)
> i think this is ca pulseaudio issue.

Yep, about 3 hours ago I hit the problem again when running xfce DE.
Samuel Verschelde 2017-01-04 20:39:18 CET

Priority: Normal => High
Target Milestone: --- => Mageia 6

Comment 7 Thomas Andrews 2017-01-05 20:43:06 CET
I'm running into this problem too, but not just on login. 

If I have Notifications set to play an ogg file at log out, the volume jumps to 100% just before it plays, no matter where the volume control is set. The same thing happens if I play the file while in System Settings, to see what it sounds like. (I downloaded these ogg files to personalize my system. They work fine with Mageia 5.)

The setting in pavucontrol is set at around 50%, and is ignored. Possibly related, Notifications volume control refuses to change from within System Settings, and there is no "Apply" button to save the settings if they could be changed.

CC: (none) => andrewsfarm

Comment 8 Ben Bullard 2017-02-17 14:49:27 CET
Also having this issue in Mageia 6 sta 1/Plasma5.

CC: (none) => benbullard79

Samuel Verschelde 2017-03-16 11:10:59 CET

Summary: My plasma system always starts with sound at maximum level => Sound level raised to its maximum without user intervention

Comment 9 Marja van Waes 2017-04-17 22:13:57 CEST
*** Bug 20688 has been marked as a duplicate of this bug. ***

CC: (none) => herman.viaene

Sébastien GUERIN 2017-06-07 11:08:22 CEST

CC: (none) => sebastien.guerin.news

Comment 10 Sébastien GUERIN 2017-06-07 11:12:47 CEST
Bug still present in Mageia 6 RC / Plasma
Comment 11 Sébastien GUERIN 2017-06-14 11:51:54 CEST
Steps to reproduce : 
- set sound level to 10% with plasma applet
- open system settings
- open shortcuts
- try to affect a keyboard shortcut which already exists to a command
- a warning window appears and a warning sound is emitted with sound level at 100%
- sound level is now at 100%
Comment 13 Sébastien GUERIN 2017-06-14 12:23:15 CEST
For your information, the default value for this setting is no in Ubuntu 16.10
Comment 14 Thomas Andrews 2017-06-14 14:14:04 CEST
Unfortunately, the scenario described in Comment 7 doesn't appear to be affected by the change from Comment 12, even after a reboot. Playing a notification sound still raises the volume to 100%. The notifications volume setting in system settings/multimedia is ignored.
Comment 15 Stephen Pettin 2017-06-28 19:57:31 CEST
I noticed when I right click the volume icon, Audio Volume Settings, Maximum Volume defaults to 100%. Making any changes does not keep. It always reverts back to 100%. If I adjust the volume from Playback Devices, it will accept the change until a reboot. Mga6 Sta2 iso since March.

CC: (none) => saptech

Comment 16 Samuel Verschelde 2017-07-10 16:12:54 CEST
This one needs to enter the Errata given how annoying it is. Ideally with a workaround if someone knows one.

Keywords: (none) => FOR_ERRATA6

Comment 17 Sébastien GUERIN 2017-07-10 18:09:39 CEST
(In reply to Samuel Verschelde from comment #16)
> This one needs to enter the Errata given how annoying it is. Ideally with a
> workaround if someone knows one.

A workaround is given in Comment 12.
Comment 18 Filip Komar 2017-07-25 18:55:34 CEST
A workaround given in Comment 12 is not perfect but at least I'll keep my hearing ;). Thanks for link Sébastien.

CC: (none) => filip.komar

Comment 19 Filip Komar 2017-07-27 21:36:17 CEST
Already in Errata:
https://wiki.mageia.org/en/Mageia_6_Errata#The_volume_of_the_sound_changes_suddenly_to_100.25_during_a_Plasma_session

Keywords: FOR_ERRATA6 => (none)

Filip Komar 2017-07-27 21:48:15 CEST

Keywords: (none) => IN_ERRATA6

Comment 20 Stephen Pettin 2017-07-28 06:42:54 CEST
I haven't had the issue in the past few weeks. I'm not certain what fixed it or how but it's working normally now. I do keep up with updates.
Ulrich Beckmann 2017-07-29 13:02:50 CEST

CC: (none) => bequimao.de

Comment 21 Rémi Verschelde 2017-08-07 11:30:24 CEST
Can you check if the update candidate in bug 21284 comment 13 fixes this issue?
Rémi Verschelde 2017-08-07 11:30:31 CEST

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=21010

Comment 22 Herman Viaene 2017-08-07 13:56:13 CEST
Unfortunately the workaround in Comment 12 solves only half of the issue. It makes sure that the overall volume setting remains as I select  (in my case at around 50%). But when I start listening to an internet radio (wwww.classicalmusicamerica.com), the Firefox audio setting jumps back to 100% after each reboot.
Comment 23 Filip Komar 2017-08-16 00:33:53 CEST
I have reinstalled with the same image but different USB. This issue is gone for me.
Comment 24 Nicolas Lécureuil 2017-08-16 01:45:21 CEST
This fixed by http://advisories.mageia.org/MGAA-2017-0054.html is all worked as expected.
Comment 25 Nicolas Lécureuil 2017-08-17 23:10:00 CEST
closing then

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.