Bug 21284 - Sound not working for snd-hda-intel device under Plasma; required phonon4-qt5-gstreamer installing
Summary: Sound not working for snd-hda-intel device under Plasma; required phonon4-qt5...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: x86_64 Linux
Priority: High major
Target Milestone: Mageia 6
Assignee: QA Team
QA Contact:
URL:
Whiteboard: advisory MGA6-64-OK MGA6-32-OK
Keywords: IN_ERRATA6, validated_update
: 20972 (view as bug list)
Depends on:
Blocks: 21340
  Show dependency treegraph
 
Reported: 2017-07-19 10:31 CEST by Andy Jefferson
Modified: 2017-08-08 00:17 CEST (History)
8 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Andy Jefferson 2017-07-19 10:31:29 CEST
Description of problem:
I did a clean INSTALL of mga6 via DVD on a laptop (Dell XPS 1530).
I formatted the whole hard disk, setting partitions as required, and then formatting all partitions. I selected PLASMA as the desktop.#
The sound driver required on this laptop is "snd-hda-intel".
The install process installed phonon4-qt5-vlc, but not phonon4-qt5-gstreamer.
When I go in to the installed system any KDE system notification sound does not play correctly ... comes out as a very short beep.

Install of phonon4-qt5-gstreamer resolves this, since that is then used instead of the "vlc" variant.

I reproduced the same problem on a desktop PC that also used "snd-hda-intel" for sound (not Dell).

Version-Release number of selected component (if applicable):
MGA6

How reproducible:
Very

Steps to Reproduce:
1. MGA clean install, format hard disk
2. Select Plasma and let it install
3. Take defaults
Rémi Verschelde 2017-07-19 10:41:44 CEST

Target Milestone: --- => Mageia 6
Assignee: bugsquad => kde
Priority: Normal => High

Comment 1 Andy Jefferson 2017-07-19 11:10:26 CEST
Further debug info for the laptop Dell XPS 1530

/usr/sbin/lsmod | grep snd
snd_hda_codec_idt      57344  1
snd_hda_codec_generic    69632  1 snd_hda_codec_idt
snd_hda_intel          36864  4
snd_hda_codec         126976  3 snd_hda_intel,snd_hda_codec_idt,snd_hda_codec_generic
snd_hda_core           77824  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_idt,snd_hda_codec_generic
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               118784  3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              32768  1 snd_pcm
snd                    81920  15 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_hda_codec_idt,snd_timer,snd_hda_codec_generic,snd_pcm
soundcore              16384  1 snd


lspcidrake -v | grep -i audio
snd_hda_intel   : Intel Corporation|82801H (ICH8 Family) HD Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:284b subv:1028 subd:022e) (rev: 02)


ps aux | grep pulseaudio
andy      3494  0.0  0.3 1143456 11412 ?       S<sl 10:02   0:00 /usr/bin/pulseaudio --daemonize=no
andy     12511  0.0  0.0  12288   968 pts/0    S+   10:15   0:00 grep --color pulseaudio


    pactl stat
    Currently in use: 1 blocks containing 63.9 KiB bytes total.
    Allocated during whole lifetime: 3512 blocks containing 37.4 MiB bytes total.
    Sample cache size: 0 B

    pactl list sink-inputs



Code: Select all
    systemctl status osspd.service
    ● osspd.service - OSS (Open Sound System) Proxy Daemon
       Loaded: loaded (/usr/lib/systemd/system/osspd.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2017-07-17 10:01:58 BST; 14min ago
      Process: 804 ExecStart=/usr/sbin/osspd (code=exited, status=0/SUCCESS)
     Main PID: 805 (osspd)
       CGroup: /system.slice/osspd.service
               └─805 /usr/sbin/osspd

    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
Comment 2 Martin Volf 2017-07-21 16:17:07 CEST
Hi,

I have to confirm the same fault on my all three computers with a driver snd_hda_intel in Plasma Environment. System sounds play too shortly + no sound (bubbles) for volume slider.

Solution:
- install a missing "phonon4qt5-gstreamer" and "phonon-gstreamer-common"
- logoff/login to Plasma. System sound notifications work well (System Setting → Notification → Plasma Desktop → choose some notification with a audio file → play)

Thank you Andy for the bug report!

CC: (none) => yullaw

Comment 3 Martin Volf 2017-07-21 16:26:58 CEST
*** Bug 20972 has been marked as a duplicate of this bug. ***

CC: (none) => antonin.roussel

Comment 4 Rémi Verschelde 2017-07-24 14:23:07 CEST
Adding to the upgrade bugs tracker for visibility, even though comment 0 makes it clear that it happens also on clean installs.

Severity: normal => major
Blocks: (none) => 21340

Trou Du Cul Merdeux 2017-07-26 20:51:45 CEST

CC: (none) => trouducul
Severity: major => critical

Comment 5 Samuel Verschelde 2017-07-26 21:38:55 CEST
Restoring bug fields to how they were before a troll changed them.

CC: trouducul => (none)
Severity: critical => major

Comment 6 Florian Hubold 2017-07-27 12:00:34 CEST
@neoclust: Could you please take a look at this? Many users seem to be affected by this after new installations and upgrades, seems the default phonon4qt5-vlc is not working properly and people have to install phonon4-qt5-gstreamer to get KDE notification sounds working.

See https://forums.mageia.org/en/viewtopic.php?f=26&t=11805 and also https://forums.mageia.org/en/viewtopic.php?f=7&t=11871

CC: (none) => doktor5000, mageia

Comment 7 Samuel Verschelde 2017-07-27 12:12:23 CEST
Related to bug #20954 ?
Comment 8 Florian Hubold 2017-07-29 00:23:07 CEST
(In reply to Samuel Verschelde from comment #7)
> Related to bug #20954 ?

I don't think so - vlc works fine here, but regular KDE notifications only play a chopped-up sound, until phonon4qt5-gstreamer has been installed.

Although other applications may also be affected, see bug #20988.
Florian Hubold 2017-07-29 00:25:24 CEST

Keywords: (none) => IN_ERRATA6

Comment 9 John L. ten Wolde 2017-08-04 08:42:22 CEST
Hi guys.  I did a clean install of Mageia 6 on one of my laptops today and ran headlong into this problem.  My machine also uses snd_hda_intel, but I don't believe this issue is specific to cards using that driver.

From my experience this afternoon, not only does the notification sound get cut off as a sort of lame *blurp!* but it also hikes the master volume up to 100%, which is to say that the two points in the errata ( "No sound from Plasma notifications" and "The volume of the sound changes suddenly to 100% during a Plasma session" ) are two side-effects of the same bug.

Hopefully someone else has pointed this out already, but digging into the problem more or less confirmed my suspicion by leading me to this KDE bug report from 2013:

https://bugs.kde.org/show_bug.cgi?id=345651 (RESOLVED FIXED... or is it?)

There the bug is batted around by the likes of Colin Guthrie, Wolfgan Bauer, and a couple of other names I recognized (as I'm sure anyone who's been around a while will).  The thread left me with the impression that Hrvoje Senjan may have been the originator of the "flat-volumes = no" workaround.  If you haven't read through it before, you may find the discussion there informative as to the bug's  origin and underlying causes.  And sadly, no it is most definitely neither resolved nor fixed.

As some of the reporters in that thread point out, unsuspecting users listening to music through headphones in a Plasma 5 environment (as well as more recent KDE4 configurations) risk sudden hearing damage when a system notification spontaneously cranks the volume to 100%.  IMO this is a fairly serious concern and Mageia should have shipped with gstreamer as the default Phonon backend rather than VLC.

So far Mageia 6 seems great, though for a number of reasons Plasma 5 is leaving me feeling rather underwhelmed. (What have they done to ALT-TAB switching?  Ungh!  I want my cover switcher back...)

CC: (none) => johnltw

Comment 10 John L. ten Wolde 2017-08-04 08:48:27 CEST
Oh silly me. I put in the wrong link to that KDE bug report. Here's the one I meant:

https://bugs.kde.org/show_bug.cgi?id=324975
Comment 11 Nicolas Lécureuil 2017-08-05 17:28:06 CEST
Fix for https://bugs.kde.org/show_bug.cgi?id=324975 is now in mga6 updates_testing
Comment 12 Florian Hubold 2017-08-05 18:01:05 CEST
(In reply to Nicolas Lécureuil from comment #11)
> Fix for https://bugs.kde.org/show_bug.cgi?id=324975 is now in mga6
> updates_testing

Shouldn't this be assigned to QA team then so it can actually go through QA validation so it will be pushed as an update eventually, or is there anything missing (apart from the package listing for the advisory) ?
Comment 13 Nicolas Lécureuil 2017-08-05 22:41:28 CEST
src.rpms:  task-plasma5-5.8.7-2.1.mga6
           pulseaudio-10.0-1.1.mga6


Advisory:
This update disable flat_volume by default, fix sound resetted by default at login. This update install by default phonon gstreamer engine to allow smooth update from mageia 5

Assignee: kde => qa-bugs

Comment 14 Martin Volf 2017-08-07 11:07:57 CEST
Update tested into VM MGA6 64bit fresh installation:
KDE notification sounds and flat volume is working well now.
Comment 15 James Kerr 2017-08-07 13:17:23 CEST
On mga6-64

Restored default settings and after logout/login confirmed presence of both bugs

Packages installed cleanly:

- lib64pulseaudio0-10.0-1.1.mga6.x86_64
- lib64pulsecommon10.0-10.0-1.1.mga6.x86_64
- lib64pulsecore10.0-10.0-1.1.mga6.x86_64
- lib64pulseglib20-10.0-1.1.mga6.x86_64
- phonon-gstreamer-common-4.9.0-3.mga6.noarch
- phonon4qt5-gstreamer-4.9.0-3.mga6.x86_64
- pulseaudio-10.0-1.1.mga6.x86_64
- pulseaudio-client-config-10.0-1.1.mga6.x86_64
- pulseaudio-module-gconf-10.0-1.1.mga6.x86_64
- pulseaudio-module-x11-10.0-1.1.mga6.x86_64
- pulseaudio-module-zeroconf-10.0-1.1.mga6.x86_64
- pulseaudio-utils-10.0-1.1.mga6.x86_64
- task-plasma5-5.8.7-2.1.mga6.noarch
- task-plasma5-minimal-5.8.7-2.1.mga6.noarch

After logout/login both bugs are fixed.

OK for mga6-64

CC: (none) => jim
Whiteboard: (none) => MGA6-64-OK

nathan giovannini 2017-08-07 20:43:12 CEST

CC: (none) => nathan95, sysadmin-bugs
Keywords: (none) => validated_update
Whiteboard: MGA6-64-OK => MGA6-64-OK MGA6-32-OK

nathan giovannini 2017-08-07 20:44:13 CEST

Keywords: validated_update => (none)

Comment 16 Rémi Verschelde 2017-08-07 23:23:43 CEST
Validating, advisory uploaded.

Keywords: (none) => validated_update
Whiteboard: MGA6-64-OK MGA6-32-OK => advisory MGA6-64-OK MGA6-32-OK

Comment 17 Mageia Robot 2017-08-08 00:17:07 CEST
An update for this issue has been pushed to the Mageia Updates repository.

http://advisories.mageia.org/MGAA-2017-0054.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.