Bug 19258 - KDE (Plasma) installation impossible on i586 lacking SSE2
: KDE (Plasma) installation impossible on i586 lacking SSE2
Status: NEW
Product: Mageia
Classification: Unclassified
Component: Installer
: Cauldron
: i586 Linux
: Normal Severity: normal
: Mageia 6
Assigned To: KDE maintainers
:
:
:
: UPSTREAM
: 19799
:
  Show dependency treegraph
 
Reported: 2016-08-28 04:50 CEST by Renato Dali
Modified: 2017-01-09 16:36 CET (History)
2 users (show)

See Also:
Source RPM: qtdeclarative5
CVE:
Status comment:


Attachments

Description Renato Dali 2016-08-28 04:50:39 CEST
Description of problem:

After installation, there's a message stating "This program requires an X86 processor that supports SSE2 extension, at least Pentium 4 or newer".

After a quick search, one can find the Pentium 4 is a 686 (or 786, according to a commenter). So Plasma (5, I believe) cannot work on my CPU (an AMD 686 without SSE2).

Anyway, I don't know how Plasma 5 fits on a i586 distribution.

Version-Release number of selected component (if applicable):

Mageia 6 sta 1

How reproducible:


Steps to Reproduce:
1. Install Mageia 6 sta 1 i586.
2. Follow the steps described on comment 1 of bug 19257.
3. Watch the above mentioned message being repeated several times during KDE start (and crash).

The Qt5 developers state they will ship binaries requiring SSE2 and that distributions can choose otherwise (please see https://bugreports.qt.io/browse/QTBUG-35430 ).

I'm not aware about what the Mageia stance on that subject is or whether such recompiling is even viable when some distributions (*ubuntu, for instance) already decided against it.

An alternative is to mention in the minimum requirements (if not already done) that the SSE2 extension is required for Plasma installation.
Comment 1 Marja van Waes 2016-08-28 08:58:22 CEST
(In reply to Renato Dali from comment #0)

> 
> Anyway, I don't know how Plasma 5 fits on a i586 distribution.
> 

What do you mean with that sentence? x86_64 isos are usually the ones that grow too fat, first. Or do you mean on a i586 system? In that case:
I have one Plasma5 on a 10yr old laptop:
https://wiki.mageia.org/en/User:Marja/QA/Hardware#IBM_ThinkPad_R50e
It works fine, but, of course, rather slow. 

Assigning to the KDE packagers
Comment 2 Renato Dali 2016-08-28 16:50:45 CEST
(*
First of all, thank you very much and also the other Mageia guys, for your continued dedication. It's offtopic, but the other day I installed Mageia on a notebook on which only two distributions would run: Mageia and Arch. Mageia, in true Mandriva spirit, worked like a charm without any tweaks. That's what I call impressive. *)

Now, about your question, yes, I mean a i586 system (I'm not talking about RAM excessive use).

Your link hasn't that information (which you can get with "cat /proc/cpuinfo", as you probably know).

From quick searches over the internet, I gathered the following facts:
- your processor is a Pentium M of unknown speed (to me);
- it is a i686 (from the links I found, please post your cpuinfo if different);
- it was released one year earlier than mine (AMD Sempron 2300+);
- both are 32-bit (congrats, 64-bit is next to irrelevant for most applications);
- yours has support for the SSE2 instruction extension, mine has not (AMD hasn't licensed it from Intel back then, I can only suppose);
- SSE2 was introduced with the Pentium 4 (a i786, from what I found).

There may be a i586 with SSE2 support. Regardless of that, not all i586s support it, so a i586 distribution using Plasma 5 should mention as requirement a CPU with such feature, at least.

That's what *ubuntu distros have done, AFAIU.

IMHO they should rebrand their distro as i786-only. Mageia does not have such claims, and (as I tested) Xfce installs without any problem on my hardware (it remains to be seen if certain apps still crash because of SSE2 -- like Midori, for instance). But old faithful Firefox is sure to work like a charm, because it takes into consideration the processor capabilities (AFAIU).

==========================================================
TL;DR: You probably have a similar processor to mine, but yours can run Plasma, because it has SSE2 support -- which i586 CPUs usually don't have.
==========================================================

PS:

From what I gather, KDE4 support ended in December 2015.

Regarding being slow, a lot of it can be explained by having not enough memory and also because of slow disk access. I got 1.5 GB RAM and a 7200 RPM disk. Notebooks typically get a 5400RPM one, for power savings. It must be said that free software is a wonderful thing because requirements can even go lower sometimes (as is the case of Libreoffice, I believe).

Example references:

https://support.lenovo.com/br/en/documents/pd013589
http://www.computing.net/answers/cpus/i686-i386-x86-cpu-what-are-these/16889.html
https://en.wikipedia.org/wiki/Pentium_M
https://en.wikipedia.org/wiki/Sempron
http://www.cpu-world.com/Compare/360/AMD_Sempron_2300+_vs_Intel_Pentium_M_1.8_GHz_(RH80535GC0331M).html
https://en.wikipedia.org/wiki/SSE2
Comment 3 Renato Dali 2016-08-29 01:00:29 CEST
I forgot to mention the network speed -- and nowadays computers are glorified html renderers. That makes network speed of utmost importance for the perception of how fast a computer is. A simple machine (e.g. a Chromebook) with a nice connection looks very fast even when compared to a gamer desktop (i7 and lots of RAM) tied to a rural dial-up link.

Finally, I don't block ads (they don't bother me) but I only allow Flash applets on demand (so they don't overload the CPU).
Comment 4 Renato Dali 2016-09-02 15:21:15 CEST
After reading this post:

https://forums.mageia.org/en/viewtopic.php?f=4&t=10947

I decided to save the maintainer the work and tag this bug UPSTREAM myself, as it seems the issue arises from some high-level Qt5 decisions.

That does not remove the liberty from Mageia to maintain its own version of Qt5, though I think there must be more pressing needs to be dealt with before this is assessed.

In light of all that, I won't close this bug... but feel free to tag it as CLOSED, WONTFIX. 

Again, thanks everyone for a superb work, which I really don't want to hinder.
Comment 5 Renato Dali 2016-09-04 19:54:20 CEST
I came upon the following planned warning by Mozilla for Firefox 49 and later (from elsewhere, I learned it will be released on the next September, 13rd). There's a mention about the ESR version being supported until 2017 (a little more time to breathe, so I thank them also for that).

Link:

https://support.mozilla.org/en-US/kb/your-hardware-no-longer-supported

Besides the confusion about newer machines than the Pentium 4 having SSE2 (which seem not to be the case), we're faced with some pragmatic aspects and should deal with them. E.g.:

1. How many machines without SSE2 still work? How many are doing some important task? How many could be reused to provide low cost computing to people or businesses? What possible uses can still be served?

2. SSE2 actually helps machines which have them available. From some tests I've done, it lowers the CPU burden and is specially useful for older machines (e.g. the fabled Pentium 4) which will see therefore an extended period of usefulness. More testing must be done to assess the real impact of that, though.

Even if this is not important for Mageia 6, it may be for a future version.
Comment 6 Renato Dali 2016-10-24 03:03:02 CEST
For a (very) extended discussion of the problems arising from the decision to no longer support processors without Intel's SSE2 opcode -- and a discussion on the meaning of life as well :-/ -- please see Bug 15594.

In comment #17 there, I thought about separating that report in three bugs: one for Midori (Bug 19644), one for Plasma (the present one) and one about Qupzilla (which I won't open right now, because I understand there's an overlap with the Plasma issue, Qt5 requiring SSE2 being the primary reason for that).
Comment 7 Thomas Backlund 2016-10-24 09:09:25 CEST
The "fix" for now is simple, disable SSE2 on 32bit QT packages.

And to be nice to those having sse2, build sse2 versions of atleast
QtCore, QtGui and QtDeclarative installed in  /lib/sse2/
Comment 8 Renato Dali 2016-10-26 03:49:26 CEST
Hi, Thomas, thanks for your reflections on the problem.

Do you mean those suggestions to be applied in Mageia for everyone, or would it better to leave that "as an exercise for the user"? (which is valid from a simplification and economy point-of-view -- BTW, AFAIU this is Ubuntu's approach).
Comment 9 Renato Dali 2016-12-17 20:12:07 CET
Rephrasing my last question, please post a message anyone who does one of the following:

1. makes a non-SSE2 version for older AMD processors (the bug will be RESOLVED/FIXED)
2. decides such non-SSE2 won't be made and Mageia will ship Qt5-based things "as is" (bug resolved as WONTFIX in this case)
3. don't decide anything (the bug won't be solved... ever!)
Comment 10 Renato Dali 2016-12-17 20:19:51 CET
*** Bug 19257 has been marked as a duplicate of this bug. ***
Comment 11 Thomas Backlund 2016-12-17 22:16:01 CET
QT stack is in the process of being reviewed on 32bit to disable sse2 calls or make separate libs for sse2 suppurt so it will be fixed
Comment 12 Renato Dali 2016-12-18 03:48:36 CET
Thanks, Thomas.

Note You need to log in before you can comment on or make changes to this bug.