Bug 1748 - add support for Optimus nVidia cards
Summary: add support for Optimus nVidia cards
Status: RESOLVED OLD
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Low enhancement
Target Milestone: Mageia 4
Assignee: Anssi Hannula
QA Contact:
URL:
Whiteboard: (MGA2)
Keywords:
: 6374 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-11 13:09 CEST by Dimitrios Glentadakis
Modified: 2014-02-16 17:56 CET (History)
14 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Dimitrios Glentadakis 2011-06-11 13:09:53 CEST
I dont know if there is a support allready for Mageia, i searched a little arround but i did nt find any informations.

https://github.com/MrMEEE/bumblebee
http://www.martin-juhl.dk/
Ahmad Samir 2011-06-12 06:26:57 CEST

Assignee: bugsquad => anssi.hannula

Sébastien GUERIN 2011-09-07 10:12:33 CEST

CC: (none) => sebastien.guerin.news

Comment 1 Anssi Hannula 2011-12-16 06:06:05 CET
Support won't likely be added to Mageia 1, changing version.

Don't get your hopes up for Mageia 2 either, as integrating support for this would be quite a lot work as the
bumblebee/ironhide projects work on quite a low level and seem to be designed
as hacks on top of distribution proprietary driver packages, which makes proper
integration harder (but not impossible).

In addition, integration would be hard to test without such a laptop.

Note that AFAIK bumblebee/ironhide is not supported properly out-of-the-box on
any distribution (i.e. it always requires manual installation).

Priority: Normal => Low
Version: 1 => Cauldron
Severity: normal => enhancement

Comment 3 Jan Eriksson 2012-01-12 16:48:23 CET
Anssi, can we use this?

http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee-develop/Mandriva_2011/

CC: (none) => jan-olof.eriksson

Comment 4 Jan Eriksson 2012-01-12 16:50:15 CET
https://qa.mandriva.com/show_bug.cgi?id=64878#c7
Dan Joita 2012-03-07 11:18:19 CET

CC: (none) => djmarian4u
Summary: Add support for Optimus nVidia cards => add support for Optimus nVidia cards

Comment 5 Marja van Waes 2012-05-26 13:06:30 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja

Keywords: (none) => NEEDINFO

Comment 6 Dave Hodgins 2012-06-08 22:00:22 CEST
*** Bug 6374 has been marked as a duplicate of this bug. ***

CC: (none) => vulix

Comment 7 Sébastien GUERIN 2012-06-13 20:04:17 CEST
(In reply to comment #5)
Of course it is !
Marja van Waes 2012-06-13 22:23:09 CEST

CC: (none) => marja11
Target Milestone: --- => Mageia 3
Whiteboard: (none) => (MGA2)

Comment 8 Marja van Waes 2012-06-13 22:24:47 CEST
the (MGA2) on the whiteboard is to indicate it is confirmed it wasn't fixed for Mageia 2

Keywords: NEEDINFO => (none)

Comment 9 Sébastien GUERIN 2012-06-17 09:35:59 CEST
Basic support for NVIDIA Optimus technology using Bumblebee has been implemented in ROSA Marathon 2012 :
http://www.rosalab.com/products/desktop/software_components
Comment 10 Dimitrios Glentadakis 2012-06-17 11:52:41 CEST
In this video Linus Torvalds "gives the sign" about the support in Linux for the optimus nvidia cards:

After the 0:48:08
http://www.youtube.com/watch?v=MShbP3OpASA
Comment 11 Manuel Hiebel 2012-06-17 20:30:59 CEST
bumblebee was imported in mageia3/cauldron today, thanks to simplew and shlomif
Comment 12 Sébastien GUERIN 2012-06-17 21:03:07 CEST
Wow, great job, thanks a lot !
Comment 13 Dimitrios Glentadakis 2012-06-18 06:22:10 CEST
Excellent, congratulations !
Comment 14 Stefano Negro 2012-09-19 23:40:21 CEST
The wiki page of that features could be updated, I believe.

There is also a mandriva wiki page http://wiki.mandriva.com/en/Bumblebee, for our knowledge.

CC: (none) => stblack

Comment 15 Marja van Waes 2012-09-22 20:33:10 CEST
(In reply to comment #14)
> The wiki page of that features could be updated, I believe.
> 
> There is also a mandriva wiki page http://wiki.mandriva.com/en/Bumblebee, for
> our knowledge.

Thanks, Stefano.

Imported that page into our wiki https://wiki.mageia.org/en/Bumblebee

Feel free to import needed pages if the licence allows it and put:
 
"imported from <link to original page>"

in the summary at the bottom of the screen, before you save it.
Marcello Anni 2013-01-02 01:07:55 CET

CC: (none) => marcello.anni

Comment 16 Marcello Anni 2013-01-05 20:17:33 CET
is it possible to have it installed by default in mageia 3 DVDs and CDs? i tried beta 1 Live KDE (1 gb) but bumblebee wasn't installed...
Comment 17 Malo Deniélou 2013-05-03 13:05:06 CEST
Can we close this bug?
BTW, can someone look over https://wiki.mageia.org/en/Bumblebee and see if it still applies for Mageia (and sometimes change the text to refer to Mageia instead of Mandriva)?
I will mark https://wiki.mageia.org/en/Feature:NvidiaOptimusSupport at 100% complete. Thanks.

CC: (none) => pierre-malo.denielou

Comment 18 Marcello Anni 2013-05-11 11:39:57 CEST
news? can we close it?
Olivier FAURAX 2013-05-25 12:04:44 CEST

CC: (none) => olivier

Comment 19 Olivier FAURAX 2013-05-25 12:57:46 CEST
What is the state in Mageia 3?
Comment 20 Pavel Kreuzt 2013-05-29 17:15:50 CEST
You may see https://bugs.mageia.org/show_bug.cgi?id=10218

CC: (none) => pkreuzt

Comment 21 euoar euoar 2013-06-06 12:34:49 CEST
This is a blocker bug for me, and guess for many other users that have laptops with optimus tech. and need 3d acceleration. Would be great having optimus support in mageia...

CC: (none) => muirin.eu

Comment 22 Morgan Leijström 2014-01-09 03:17:20 CET
Marking this as duplicate of 10218 ... not logically correct,
but 10218 is same subject and more recent so it is better to continue there,
and one less open bug :)

*** This bug has been marked as a duplicate of bug 10218 ***

Status: NEW => RESOLVED
CC: (none) => fri
Resolution: (none) => DUPLICATE

Comment 23 Marcello Anni 2014-01-09 16:29:42 CET
this one has been opened against cauldron (hoping to have it fixed in time for mageia 4), that one was against mageia 3. reopening then

Status: RESOLVED => REOPENED
Resolution: DUPLICATE => (none)
Target Milestone: Mageia 3 => Mageia 4

Philippe Makowski 2014-01-09 19:36:14 CET

CC: (none) => makowski.mageia

Comment 24 Rémi Verschelde 2014-02-16 17:55:58 CET
Bumblebee has

Status: REOPENED => RESOLVED
CC: (none) => remi
Resolution: (none) => OLD

Comment 25 Rémi Verschelde 2014-02-16 17:56:33 CET
(In reply to Rémi Verschelde from comment #24)
> Bumblebee has

I meant to write: Bumblebee has been packaged for cauldron (mga5), and will be backported to mga4, but not to mga3.

Note You need to log in before you can comment on or make changes to this bug.