Bug 16917 - Samsung SCX-4521F printer driver is available in cups-drivers-splix but how is user to know?
Summary: Samsung SCX-4521F printer driver is available in cups-drivers-splix but how i...
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia tools maintainers
QA Contact:
Whiteboard: MGA5TOO
Keywords: 6sta1.5, NEEDINFO
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2015-10-07 12:33 CEST by Barry Jackson
Modified: 2018-04-18 11:42 CEST (History)
9 users (show)

See Also:
Source RPM: ldetect
Status comment:

Outputs requested in triage guide (8.36 KB, text/plain)
2016-08-11 13:35 CEST, Barry Jackson

Description Barry Jackson 2015-10-07 12:33:25 CEST
When using 'MCC -> Hardware -> Configure Printing and Scanning' to set up my Samsung SCX-4521F a whole raft of packages are installed and the printer is detected and a 'SCX-4x21 Series' driver is suggested, however this is the wrong driver and it fails to work.

After lots of digging I finally discovered that the correct driver is in the cups-drivers-splix package.
This package and lots more are installed by task-printing, but this is not installed during the printer set-up.

Should not cups-drivers-splix be installed when this printer is detected?

Even with this package installed it still suggests the wrong 'SCX-4x21 Series' driver as 'recommended' however the correct one with the exact 'SCX-4521F' model number is then available from the list, and works perfectly.
Barry Jackson 2015-10-07 12:34:26 CEST

Hardware: i586 => x86_64
Version: Cauldron => 5

Comment 1 Florian Hubold 2015-10-10 22:26:50 CEST
Please check bug 9902 linked in the comment from Alex for further information: https://bugs.mageia.org/show_bug.cgi?id=13083#c1
Information about cups-drivers-splix should be added to our custom backend to s-c-p so that it can automatically install that. Or maybe the hooks are broken so the installation does not happen when the printer is detected, I don't know :/

CC: (none) => doktor5000

Comment 2 Florian Hubold 2015-10-10 22:32:24 CEST
Could be the same issue as with https://bugs.mageia.org/show_bug.cgi?id=14440#c10 and our custom backend to s-c-p is also linked to in the comment above that :)
Samuel Verschelde 2015-10-12 09:58:43 CEST

CC: (none) => luigiwalser, mageia, makowski.mageia, thierry.vignaud, yann.cantin

Comment 3 Philippe Makowski 2016-04-08 10:30:02 CEST
Can you try with system-config-printer-1.5.5-5.2.mga5 or system-config-printer-1.5.7-2.mga6 ?

Comment 4 Barry Jackson 2016-04-10 17:43:59 CEST
(In reply to Philippe Makowski from comment #3)
> Can you try with system-config-printer-1.5.5-5.2.mga5 or
> system-config-printer-1.5.7-2.mga6 ?
> thanks

I first removed cups-drivers-splix and system-config-printer.

I then used mcc->hardware->set up printing..

The dialog saying that s-c-p and other packages were going to be installed appeared which I accepted.

The packages installed - then nothing. It dropped back to mcc->hardware window.

I again clicked the setup printers option and was greeted with a blank full sized drakconf window with no content which would not close.
I eventually ended up with two of these which I killed from a tty.

Now when I try to run the setup printers option in drakconf all I see is a "The program has exited abnormally" dialog.

Running s-c-p from a root terminal is a bit more useful:

[root@jackodesktop baz]# system-config-printer
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 27, in <module>
    import sys, os, time, re, mga_printer_custom
  File "/usr/share/system-config-printer/mga_printer_custom.py", line 80
    cups-drivers-splix = ["samsung"]
SyntaxError: can't assign to operator

So I installed cups-drivers-splix but got the same error again.

It's the same whether the printer is connected or not.
Comment 5 Barry Jackson 2016-04-10 17:46:22 CEST
Sorry - I did not mention that the above was in Cauldron where the printer has yet to work at all. See https://bugs.mageia.org/show_bug.cgi?id=17868
Comment 6 Philippe Makowski 2016-04-10 21:31:12 CEST
sorry, I made a syntax mistake, system-config-printer-1.5.7-3.mga6 and system-config-printer-1.5.5-5.3.mga5 should land soon and should avoid the problem. Thanks for the report.
Comment 7 Barry Jackson 2016-04-11 00:47:36 CEST
Nope - this no longer crashes but I see no improvement.

I first uninstalled cups-drivers-splix and s-c-p.

On selecting mcc->hardware->setup printers I get the dialog telling me that s-c-p , task-printing-server and task-printing-hp will be installed - all OK so far.

I am assuming that s-c-p should now at some point install cups-drivers-splix once it knows what my printer is?

I have tried with the printer connected during the process and it only recommends a generic driver.
If I try to select my printer manually it is not listed.

If I manually install cups-drivers-splix it is listed, but it is still not detected by s-c-p and all that happens during detection is that 'serial port #1' is added to the source list from where it becomes possible to move forward to the dialog where a make/model can be selected manually.

When I print a test page nothing happens - which is the other bug.(17868)
I will test in Mageia 5.
Comment 8 Barry Jackson 2016-04-11 01:18:11 CEST
In Mageia 5:

I first checked the printer was working correctly and printed a test page.

I uninstalled s-c-p and cups-drivers-splix

I enabled updates_testing and installed s-c-p

A printer was detected, but not mine. The suggested driver is SCX-4x21 which I know does not work and is wrong (it's for a colour printer - mine is laser mono).

Going into manual selection my printer is not there which is not surprising since c-d-splix is not installed. :\

lsusb shows my printer as:
Bus 002 Device 002: ID 04e8:3419 Samsung Electronics Co., Ltd Composite Device

(it's a printer/scanner).

After installing splix, still the wrong driver is detected/suggested, but SCX-4521F is available in the Samsung list and can be selected.

However now it fails to print a test page - great :\

Will log out/in
Comment 9 Barry Jackson 2016-04-11 01:38:33 CEST
No, I have downgraded back to the core version of s-c-p and still have no printing - just like Cauldron now - print queue empties instantly - no errors all looks fine but nothing prints.
It's late so will start again tomorrow.
Comment 10 Philippe Makowski 2016-04-11 09:01:20 CEST
Sorry I can't do more.

With system-config-printer-1.5.7-3.mga6 or system-config-printer-1.5.5-5.3.mga5, it install cups-drivers-splix when a Samsung printer is detected.

That's all that I can do.
Comment 11 Barry Jackson 2016-04-11 12:16:28 CEST
(In reply to Philippe Makowski from comment #10)
> Sorry I can't do more.
> With system-config-printer-1.5.7-3.mga6 or
> system-config-printer-1.5.5-5.3.mga5, it install cups-drivers-splix when a
> Samsung printer is detected.
But it does not install cups-drivers-splix in either Mga5 or Mga6 as I reported above.

To summarize:

In Mga6 no printer driver is suggested although  'serial port #1' is selectable allowing access to the manual list.

In Mga5 the wrong (Samsung) driver is detected/suggested but still cups-drivers-splix is not installed, so nothing has changed for me.

> That's all that I can do.

Well that exercise has lost me any means of printing as it was only in Mga5 that it was working.

Maybe if I can remove all global and user printer settings from the machine then a re-install may get it back. Do you know where all printer data is stored on the system?
I have tried removing the 'printer' and re-installing, but this does not for example remove the job count, which must be stored somewhere.

All the jobs that do not print are shown as completed, no errors at all.
Comment 12 Barry Jackson 2016-04-12 13:52:09 CEST

I have re-tested this after spending a day finding the correct URIs for the printer in both systems.



These both work.
How anyone is supposed to guess those I have no clue :\

Testing installs using the updated s-c-p packages by entering the correct URIs first makes no difference, c-d-splix is still not installed.

With c-d-splix pre-installed I can enter the correct URI and then select the printer from the database and printing works OK in both systems.

Whiteboard: (none) => MGA6-1

Comment 13 Barry Jackson 2016-04-15 16:47:27 CEST
Printer info reported by hwinfo:

81: USB 00.1: 10900 Printer
  [Created at usb.122]
  Unique ID: Rx4+.UxyvDriDQ_9
  Parent ID: PYMB.4Nx_qoDfSd7
  SysFS ID: /devices/pci0000:00/0000:00:1d.0/usb4/4-1/4-1.6/4-1.6:1.1
  SysFS BusID: 4-1.6:1.1
  Hardware Class: printer
  Model: "Samsung Electronics Composite Device"
  Hotplug: USB
  Vendor: usb 0x04e8 "Samsung Electronics Co., Ltd"
  Device: usb 0x3419 "Composite Device"
  Revision: "1.00"
  Serial ID: "8P37BABL926239E."
  Driver: "usblp"
  Driver Modules: "usblp"
  Speed: 12 Mbps
  Module Alias: "usb:v04E8p3419d0100dc00dsc00dp00ic07isc01ip02in01"
  Driver Info #0:
    Driver Status: usblp is active
    Driver Activation Cmd: "modprobe usblp"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #75 (Hub)
Marja Van Waes 2016-05-05 10:22:15 CEST

Blocks: (none) => 18367

Comment 14 Marja Van Waes 2016-08-10 19:41:21 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:




@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => marja11

Marja Van Waes 2016-08-10 20:34:55 CEST

Keywords: (none) => 6dev1
Whiteboard: MGA6-1 => (none)

Comment 15 Barry Jackson 2016-08-10 22:13:12 CEST
In a clean net-install I tried to use s-c-p from MCC to install my printer.

task-printing-server and task-printing-hp were installed.

After the port search one serial option appeared which I accepted.

The driver list appeared with Generic (Recommended) which is NOT right.

I looked down the list and my printer was NOT listed (Samsung SCX-4521F) as expected since cups-drivers-splix was not installed. So I cancelled out and installed c-d-splix.

This time my printer was in the list and all went well until I tried to print a test page. Nothing happened - no errors - exactly as it was months ago.

I deleted the printer and started again but this time used the URI that had worked back at Comment #12 rather than letting the device search provide the URI.

Now it works perfectly.

So there is no improvement as far as I can tell, however I have not yet tried inputting the correct URI manually with c-d-splix not installed - maybe if it can communicate with the printer it may decide to install it.
Comment 16 Barry Jackson 2016-08-10 22:24:37 CEST
Providing "serial:/dev/usb/lp1" as the URI manually with c-d-splix not installed changes things slightly in that the Generic is still highlighted but it is not 'recommended'.
Manually selecting Samsung as the manufacturer then offers:
Samsung C48X Series PS (Recommended) !!
Still no sign of it wanting to install c-d-splix - so no improvement. :(
Comment 17 Barry Jackson 2016-08-10 22:31:49 CEST
Ignore #15 and #16 I misread. I assumed cauldron not updates-testing.
Will test again later.
Comment 18 Barry Jackson 2016-08-10 23:54:43 CEST
Hmm... I just re-tested and I see no difference, so #15 and #16 still stand with the following packages installed:

[root@localhost baz]# rpm -qa | grep -E "config-printer|cups"                                                                                                             
cups-drivers-splix-2.0.1-0.20130826svn315.6.mga6 ####### Added manually
Comment 19 Barry Jackson 2016-08-11 00:25:16 CEST
The URI provided by the auto-detection that does *not* work is:

what *does* work is:

Doing some digging:

[baz@localhost ~]$ lsusb|grep Sams
Bus 002 Device 006: ID 04e8:3419 Samsung Electronics Co., Ltd Composite Device

Note that this is a Printer/Scanner.

Grepping the udev rules for the device it is only listed in 60-libsane.rules which I am guessing may be relevant.

[baz@localhost ~]$ cd /lib/udev/rules.d
[baz@localhost rules.d]$ grep -r "04e8"|grep "3419"
60-libsane.rules:ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="3419", MODE="0644", GROUP="usb", ENV{libsane_matched}="yes"
[baz@localhost rules.d]$
Comment 20 Marja Van Waes 2016-08-11 12:03:40 CEST
Thanks for all the feedback, Barry!

Did you ever connect this printer to a Mageia install on different hardware?

Do you then get the "serial:/dev/ttyS0?baud=115200" too?

I don't know whether that counts as hardware detection problem, but it won't harm to attach everything that's suggested here:

Keywords: 6dev1 => 6RC
Version: 5 => Cauldron
Whiteboard: (none) => NGA5TOO

Marja Van Waes 2016-08-11 12:03:57 CEST

Whiteboard: NGA5TOO => MGA5TOO

Comment 21 Barry Jackson 2016-08-11 13:35:29 CEST
Created attachment 8328 [details]
Outputs requested in triage guide

The lspcidrake output is interesting as it shows:
usblp: Samsung|SCX-4x21 Series [Printer|Printer|Bidirectional] (vendor:04e8 device:3419)

That is wrong from past testing as that driver is for a colour printer even though the vendor:device ID is correct according to lsusb.

journalctl shows it looking for that driver and failing even though the printer is set up and working with the SCX-4521F driver from c-d-splix.
Comment 22 Marja Van Waes 2017-06-05 11:35:14 CEST
(In reply to Barry Jackson from comment #21)
> Created attachment 8328 [details]
> Outputs requested in triage guide
> The lspcidrake output is interesting as it shows:
> usblp: Samsung|SCX-4x21 Series [Printer|Printer|Bidirectional] (vendor:04e8
> device:3419)
> That is wrong from past testing as that driver is for a colour printer even
> though the vendor:device ID is correct according to lsusb.
> journalctl shows it looking for that driver and failing even though the
> printer is set up and working with the SCX-4521F driver from c-d-splix.

Is this bug still valid, Barry? If so: both for current cauldron and for Mageia5?

Assigning to ldetect and mageiatools maintainters. Please correct me if that's wrong.
CC'ing kernel & drivers maintainers.

Assignee: bugsquad => mageiatools
Keywords: (none) => NEEDINFO
Source RPM: cups-drivers-splix => ldetect
CC: (none) => kernel

Comment 23 Barry Jackson 2017-06-05 13:31:33 CEST
Checking in Mga6 the situation has improved somewhat.

In a system with no printer ever installed, using MCC to install the Samsung there is an initial install of task-printing-server and task-printing-hp (why the latter I have no idea) plus deps.

Trying to continue then fails because cupsd is not started by the install of the server and the error message does not mention 'cups' so a new user would have no clue to start cupsd (or how) - it simply mentions 'the printing server is not running' iirc.

After starting cupsd from mcc->system->services and then going back to mcc->hardware->set up the printer(s)... it does find the printer and a dialog appears which asks to install two more packages including cups-drivers-splix \o/

The recommended driver is Samsung SCX-4x24 Series PXL which different to previously but is also wrong. I tried to continue with this but it failed to print.

I then added a second 'printer' and selected Samsung-SCX4521F from the list (much lower down and out of sight initially) which does work correctly.

So as I said - much improved as now c-d-splix does get automatically installed, and the URI it is given (usb://Samsung/SCX-4x21%20Series?serial=8) does work.

Remaining issues are:
cupsd does not get started when it is installed.
The 'recommended' printer is incorrect.

I will see if I have a clean (i.e. no printer) Mageia5 real installation to test 
Comment 24 Barry Jackson 2017-06-05 13:49:33 CEST
In a fully updated Mga5 the situation is different.

cupsd IS running after install.

Driver package cups-drivers-misc is installed after selecting Samsung, but NOT cups-drivers-splix. 

I stopped there as the outcome was obvious :\
Comment 25 Morgan Leijström 2018-04-18 11:42:27 CEST
Related: Bug 17868 - Printer setup fine - printing fails - Samsung SCX-4521F

CC: (none) => fri

Note You need to log in before you can comment on or make changes to this bug.