Bug 16850 - Plasma 5 cannot restore its session (running applications not plasmoids)
Summary: Plasma 5 cannot restore its session (running applications not plasmoids)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: release_blocker normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact: Samuel Verschelde
Keywords: UPSTREAM
Depends on:
Blocks: 17523
  Show dependency treegraph
Reported: 2015-09-28 22:47 CEST by Piotr Mierzwinski
Modified: 2017-08-22 01:20 CEST (History)
14 users (show)

See Also:
Source RPM: plasma-workspace-5.8.3, plasma-desktop-5.8.3
Status comment: Works in other distros that ship plasma.

Mageia6_x64_all_packages_Piotr_Mierzwinski (70.39 KB, text/plain)
2016-01-23 02:30 CET, Piotr Mierzwinski
environment in krunner (1.89 KB, text/plain)
2016-01-23 02:35 CET, Piotr Mierzwinski

Description Piotr Mierzwinski 2015-09-28 22:47:21 CEST
Description of problem:
When I logged in to the Plasma 5 I started konsole. After that I logged off and again logged in. I got clear desktop without running konsole.

I have enabled properly option related with restoring of desktop after logging (System settings -> Running -> Desktop session -> Restore previous session).

I tested it on the latest Mageia Couldron version (including updates from evening of 2015/09/28).

I think this is not the Plasma 5 bug, because it's work in Kubuntu 15.04 (Plasma 5.4.1).

Version-Release number of selected component (if applicable):
plasma-workspace-5.4.1, plasma-desktop-5.4.1

How reproducible:

Steps to Reproduce:
1. login to Plasma5
2. start konsole
3. login off
4. login to Plasma5 again

As result is empty desktop (excluding plasmoids).

Tested on real hardware (i5 ivy bridge).


Steps to Reproduce:
Comment 1 Sander Lepik 2015-09-29 07:14:40 CEST
I'm seeing the same thing happening, quite annoying :)

Assignee: bugsquad => mageia
CC: (none) => mageia

Comment 2 Frank Griffin 2015-09-29 14:33:28 CEST
Same here, both under Plasma5 and under cauldron KDE4 with up-to-date updates using --keep (which keeps Plasma5 from installing), for what that's worth.

CC: (none) => ftg

Comment 3 Jin-tong Hu 2015-10-10 06:53:17 CEST
Same here on i586.

CC: (none) => piscestong
Hardware: x86_64 => All

Comment 4 Piotr Mierzwinski 2015-10-12 23:42:40 CEST
Interesting is that applications in Qt (I've tested those using Qt4) are restored.
I've done test for QTerminal and my own Qt application. Both have been restored.
Comment 5 Rémi Verschelde 2016-01-19 11:11:38 CET
It's working for me in the current plasma5, though I also had to activate specifically the option to restore the previous session on boot. I do have one application that does not seem restored on boot, yakuake, but firefox, dolphin, hexchat and others are properly restored.

Blocks: (none) => 17523

Comment 6 Piotr Mierzwinski 2016-01-23 02:30:09 CET
For me it still doesn't work :(. I tested on up-to-dated Mageia Cauldron on day January 23 2016.

After login I start dolphin and konsole (inside is 3 sessions). After re-login I get empty desktop. Of course I have set option related to restore desktop.

I noticed in other distributions where Plasma5 is default desktop (for example KaOS) that in directory "~/.config" is created subdirectory "session". I don't have such directory. I suppose you (@Rémi) have such.

I wonder why it's working for you :/. Maybe you have installed some specific package or some is not installed. I installed plasma5 using task-plasma5 and installed some additional packages.
I attach the list of all installed packages in my system (generated by command: rpm -qa | sort > Mageia6_x64_all_packages_Piotr_Mierzwinski.txt). If this is not problem then please add your list then I will be able to compare both.

$ uname -ri
4.4.0-desktop-2.mga6 x86_64
Comment 7 Piotr Mierzwinski 2016-01-23 02:30:38 CET
Created attachment 7373 [details]
Comment 8 Piotr Mierzwinski 2016-01-23 02:35:37 CET
Created attachment 7374 [details]
environment in krunner
Comment 9 Piotr Mierzwinski 2016-03-21 20:35:43 CET
Related bug report on kde site: https://bugs.kde.org/show_bug.cgi?id=343518
Now in resolved state, but in the past this state was changed changed - bug reopened.
Quoting from this report:
Wolfgang Bauer 2016-02-22 11:44:20 CET
Should be fixed with Qt 5.6 and Frameworks 5.20.

Now in Cauldron we have Qt-5.6 (stable) and KF-5.20. And what? Nothing. For me Mageia restores correctly only non Qt/kde application like Thunderbird, Firefox. Opera is not restored. Again I made a test. I run Thunderbird, run konsole with two tabs, I run kwrite and opened text file. Log off. Log in. And I met only running thunderbird. Directory ~/.config/session has not been created.

I suppose this is not correctly implemented here (Mageia 6). Comparing Kubuntu 15.10 (with backports) and KaOS, where it's working. Sometimes randomly, but works.

@Rémi Verschelde
I don't know what exactly test(s) you made. Please try to run kde/qt based applications and relogin. From mentioned by you only dolphin is kde based. I  don't know what you mean saying "others".
Comment 10 Frank Griffin 2016-03-22 13:42:04 CET
FWIW I notice that in the default Plasma Startup/Shutdown Desktop Settings, "Restore Session" is not checked.  I'm pretty sure Restore Session was the default in KDE4; in fact, I didn't realize there was an option to enable/disable it.  Whether it actually works or not, that may be why so many people think it doesn't.
Comment 11 Nicolas Lécureuil 2016-03-22 18:11:59 CET
maybe this is something we can enable by default then.
Comment 12 Piotr Mierzwinski 2016-03-22 22:26:42 CET
I checked this option before making the tests and it doesn't work. I tested on two (real) machines.
Did you (@Frank, @Nicolas) tested it? Is this works for you? I suppose you (@Frank) didn't tested it :/.

@Frank. It didn't work properly and I'm not sure if now (with Qt-5.6) it works correctly. Please read thread from mentioned by me, link to bugs.kde.org. Then you will find out that it worked randomly.

I tested restoring a session in KaOS with the newest (on this day) updates, so with kernel-4.5, Qt-5.6, Plasma-5.6, KFrameworks-5.20, KApplications-15.12.3 and systemd-229. Almost everything the same like in Mageia Cauldron. And I can say that this option working very well. My test was similar to this one done for Mageia, so I run couple of KDE applications (konsole, Dolphin and KWrite) and Thunerbird. Every application have been restored after re-login and after restart. This test I repeated twice.
Comment 13 Frank Griffin 2016-03-23 00:26:42 CET
No, I didn't test it.  When I switched to Plasma and it didn't work, I just figured that was how it was.  As I said, I didn't even realize there was an option for this, as it had always just worked in KDE4 with no action on my part.
Comment 14 Jüri Ivask 2016-03-23 07:41:07 CET
Made also some tests. My preference has been (already from the days of KDE3) that the session restoring is always off, so I switched it on in systemsettings5. Opened some programs: Telegram Desktop, Thunderbird, Dolphin, Konsole, IM Contacts. Logged off and back on. Only Telegram Desktop was restored, no Dolphin, Konsole, IM Contact or even Thunderbird...
System: real hardware (Thinkpad X200), up-to-date i586 Cauldron with Plasma 5 desktop.

CC: (none) => jyri2000

Comment 15 Morgan Leijström 2016-06-07 10:03:34 CEST
For me restoring session mostly works, however:

1) Firefox is automatically started but with the extra dialog window saying that session could not be restored, then i select last "crashed" session and let it restore, works OK.  (if i close firefox before logging out, and then start it manually it launch with all tabs without complaining)

2) i have listed some some programs to omit from sessions. That works for some, but not other like gkrellm and keepassx

CC: (none) => fri

Comment 16 Piotr Mierzwinski 2016-06-07 19:12:10 CEST
I don't know what version of Plasma do you have. Firefox and for example Thunderbird were restored correctly in Plasma 5.5.x. In next version (5.6.x) some code responsible for restoring session based on old protocol (XSM) have been removed. Whereas most of GTK+ applications still support this protocol. Anyway testoring this code fixes problem. Please check this bug report:
This is refers only to retoring gtk+ application. Issue in Mageia Cauldron is that even KF5 applications are not restored! Directory: ~/.config/session is not creates. I tested it yesterday (with last updates). I don't know why, whereas in other distribution (I tested: Kubuntu 16.04 with plasma 5.6.3, KaOS, Antergos) based on Plasma5 it is working.

In Mageia I also made another test (described in above bug report).
Being in System Settings I switched from "Restore previous session" to "Restore manually saved session" (in Plasma eng. version options might be call a bit different, I translated from polish).
After that in K menu in "Leave" tab I found option "Save session". I clicked it and checked ksmserverrc file - last modification date was changed. After relogin nothing is restored - neither KF5 (konsole, kwrite) nor gtk+ (firefox) applications.
Comment 17 Morgan Leijström 2016-06-07 22:22:45 CEST
Ah sorry, this system is current cauldron 64 bit, Plasma 5.6.4-1.mga6
I do not know the innards of this, just try to use it and gave feedback.
I run cauldron in my workstation :)
Comment 18 Rémi Verschelde 2016-06-26 10:12:08 CEST
Apparently this would be the "fixed" upstream bug reports: https://bugs.kde.org/show_bug.cgi?id=354724

It's actually only fixed for Qt5 applications (and not all of them, Yakuake still doesn't restore properly for me), so... Wait and see, but there's not much we can do.

Toggling ON the "Restore Session" parameter mentioned in comment 10 might be a good thing though, if it partly works. At least we might get the opportunity to fix this post-release if we provide Plasma 5.8 or something.

Keywords: (none) => UPSTREAM

Comment 19 Piotr Mierzwinski 2016-06-26 18:30:36 CEST
Above report refers to old Plasma built with Qt-5.5.x, so this is not related with Cauldron where is uses Qt-5.6.x (Plasma built with this Qt version). Yes. I know that on end of this thread appeared patches required Qt-5.6.
As far as I remember Cauldron from beginning wasn't able to restore KF5/Qt5 applications :(. In times of Plasma 5.5 restored only GTK+ applications. Where other distributions were and are able. How is this possible?
That's why, for me this is bug in Mageia 6. Restoring session is for me very important thing.

Anyway. For me till today (I updated system yesterday) restoring doesn't work. Use option: "Restore last session" or "Restore saved session" gives me the same result.
I didn't tested yet released (only one) iso (Mageia6-dev1). Still I'm testing system upgraded from Mageia 5.

Maybe I will repeat my self a bit, but I will remind (in short) history of this bug (in Plasma).
Qt-5.5 had some bug which made this issue (described in your link) which has been fixed in 5.6 version. About restoring Gtk+ applications. Plasma <= 5.5.x had support for XSM protocol - in short: legacy support of saving state of applications. Please note - till today supported by all GTK+ application - as said Plasma developer: it's shame. In Plasma 5.6 it has been removed from unknown (for me) reason(s) - read this: https://quickgit.kde.org/?p=plasma-workspace.git&a=commit&h=5f0ca1305db4a925dbdbf927f541497be334feff
I reported bug related with restoring GTK+ applications, and before couple of days it has been restored. Check this report: 
https://bugs.kde.org/show_bug.cgi?id=362671 (fix applied in branch 5.6, branch 5.7 and master).
This fix maybe will be included in next Plasma 5.6 or only in 5.7. I'm not sure if Yakuake and (new) Opera will be restored. New Opera is not restored even in KDE4.

Qt/KF5 applications supports XSMP protocol. I don't know why developers of GTK+ libraries didn't include support of this protocol in your libraries.
Comment 20 Nicolas Lécureuil 2016-07-16 20:39:18 CEST
is this bug still valid with plasma 5.7.1 ?
Comment 21 Piotr Mierzwinski 2016-07-17 00:26:55 CEST
For my side still the same. I run firefox, konsole, kwrite. After relogin only firefox is restored. Of course I have set "Restore previous session" in systemsettings. System is up-to-date. Restarted after all updates.
Comment 22 Frank Griffin 2016-07-17 02:00:38 CEST
Yes, exactly as Piotr describes.
Comment 23 Rémi Verschelde 2016-07-17 11:49:58 CEST
Tested on my end too, I've seen that (OK means restored, NOK means not restored):
- Clementine: OK
- Hexchat: OK (that's new, before I had to autostart it with a .desktop file)
- Firefox: OK (with a broken session, but that's another matter)
- Skype: OK
- Redshift (redshift-gtk): NOK
- Yakuake: NOK (even though it's a KF5 app)
Comment 24 Nicolas Lécureuil 2016-07-26 10:51:31 CEST
can you please add this infos in the upstream bugreport too ? ( can help upstream devs ).
Comment 25 Samuel Verschelde 2016-08-22 13:54:44 CEST
Here after a fresh install:
- Firefox does restore
- Kmail doesn't
- Konsole doesn't
Samuel Verschelde 2016-08-22 13:55:03 CEST

CC: (none) => stormi

Samuel Verschelde 2016-08-25 16:25:23 CEST

Assignee: mageia => kde

Comment 26 Diego Bello 2016-08-25 21:46:10 CEST
Just some more info on programs with issues: after restarting a session and starting apps I get this:

- "Open recent documents" is empty in kate after restarting a session. It opens with an empty doc.
- Konsole won't open with previous opened tabs, just a single default tab.
- Kontact is not restored.

CC: (none) => dbello

Comment 27 Samuel Verschelde 2016-09-08 18:00:05 CEST
This one is a huge usability regression, thus setting release_blocker.

Priority: Normal => release_blocker

Comment 28 Samuel Verschelde 2016-09-12 16:18:17 CEST
Could we have a status from KDE maintainers?

QA Contact: (none) => stormi

Samuel Verschelde 2016-09-12 16:41:13 CEST

Status comment: (none) => Needs status about what's doable from our KDE maintainers and/or upstream

Comment 30 Stuart Morgan 2016-11-12 13:32:00 CET
It's been two months since the last update, any fixes upstream yet?

CC: (none) => smorgan

Comment 31 Piotr Mierzwinski 2016-11-14 00:21:34 CET
I checked your list of bugs (check below). Looks like your list is not related with current issue.

* 365237 (reported: 2016-07-08, UNCONFIRMED) - looks like someone broke system installing neon packages. Kubuntu 16.04 is able to restore session. I tested.
* 364680 (reported: 2016-06-23, UNCONFIRMED) - not clear report: sometHing about restoring previous session of Okular. User didn't update report.
* 306257 (reported: 2012-09-04, UNCONFIRMED) - looking at reporting date it seems to be not related with Plasma 5
* 246028 (reported: 2010-07-28, CONFIRMED) - looking at reporting date it seems to be not related with Plasma 5
* 363876 (reported: 2016-06-03, RESOLVED DUPLICATE of 354724) - issue with Konversation - bug outdated
* 149522 (reported: 2007-09-03, CONFIRMED) - looking at reporting date it seems to be not related with Plasma 5
* 365449 (reported: 2016-07-12, UNCONFIRMED) - related with konsole, but konsole is restored properly after relogin only some environment is not set properly. Quoting first sentence from report: "Under Plasma, when I log out then log back in again, two konsole windows are restored.". So no issue with restoring.
* 367737 (reported: 2016-08-23, UNCONFIRMED) - related with extra (unwanted) window konsole run after restoring Plasma session. As far as I remember there was such error bug: 367447), but has been fixed long time ago (2016-08-31)
* 363223 (reported: 2016-05-18, CONFIRMED) - related with not restored window position of Kate

Tell me how it's possible that restoring session works well in other distributions like: Arch/Antergos, KaOS, Kubuntu only in Mageia 6/Cauldron from very beginning it doesn't work? I can check other stable distributions if this will help anyone.

@Stuart Morgan
Unfortunately till now there wasn't any fixes. I tested at Nov 13, 2016. System up-to-date. Only gtk+ applications are restored (like firefox).
Comment 32 Samuel Verschelde 2016-11-14 16:07:09 CET
(In reply to Piotr Mierzwinski from comment #31)
> Tell me how it's possible that restoring session works well in other
> distributions like: Arch/Antergos, KaOS, Kubuntu only in Mageia 6/Cauldron
> from very beginning it doesn't work? I can check other stable distributions
> if this will help anyone.

Just to be sure: it worked in plasma in Mageia cauldron? And it works in plasma in other distributions too?
Comment 33 Piotr Mierzwinski 2016-11-14 19:04:04 CET
As far as I remember it never worked in Mageia Cauldron. Check reporting day for this issue. This was September last year! Of course saying issue I mean restoring Qt and Plasma applications in Plasma 5.
In other distribution it works. I mentioned couple in previous message.

I don't understand what happened with new Mageia it's development takes more and more time in opposite to Mageia 5. Less developers is engaged or I don't know.  Looking at the distrowatch.com the result is visible. Mageia is lower and lower. Some time ago was on 5th position, and now 15th. It is sad :(.
Comment 34 Nicolas Lécureuil 2016-11-15 14:26:09 CET
i don't see this as a blocker bug as we won't fix it ourself and this is a pure upstream bugreport ( reported upstream, etc. ).

CC: (none) => mageia

Comment 35 Morgan Leijström 2016-11-15 15:09:48 CET
Looking quickly at resolved and lingering upstream bugs i get the impression it mostly works on other distros.

IMO we cant delay MGA6 just because of this,
Anyway our Plasma have worse problems than this...

In any case if we release with this regression, it must be noted in errata.
Comment 36 Samuel Verschelde 2016-11-15 15:13:15 CET
(In reply to Nicolas Lécureuil from comment #34)
> i don't see this as a blocker bug as we won't fix it ourself and this is a
> pure upstream bugreport ( reported upstream, etc. ).

It does seem to be a packaging issue, actually, from what Piotr and Morgan say.
Samuel Verschelde 2016-11-15 15:14:39 CET

Status comment: Needs status about what's doable from our KDE maintainers and/or upstream => Works in other distros that ship plasma.

Comment 37 Pieter van Zyl 2016-11-20 07:48:55 CET
Well you guys might not see this as a blocker bug but there are people using KDE on Mageia that might not agree. 

Also worries me if you say "Anyway our Plasma have worse problems than this..."

I am getting tired of setting up my KDE desktop every morning. It doesn't feel like Mageia supports KDE anymore and if I want KDE support with a working Plasma 5 desktop I must look elsewhere it seems......

CC: (none) => pvz1976

Comment 38 Piotr Mierzwinski 2016-11-20 21:49:47 CET
Yesterday I tested the newest OpenSUSE, and guess. Restoring Plasma (5.8.x) sessions works well. This is also rpm distribution. Till now I tested only deb and arch kind.
I wonder if latest version of OpenMandriva has also this problem. I will test it as soon as possible.

Restoring session in Plasma is one of most important thing causing I use this environment, but if this doesn't work in my distribution I change it on that where it works. Actually I did it some time ago.

> ... pure upstream bugreport
I don't understand how this bug report can be "upstream" if restoring Plasma session works in several other distributions.

> Anyway our Plasma have worse problems than this...
What are worse problems than this, if may I know?

Source RPM: plasma-workspace-5.4.1, plasma-desktop-5.4.1 => plasma-workspace-5.8.3, plasma-desktop-5.8.3

Comment 39 Morgan Leijström 2016-11-20 23:10:58 CET
Yes it works on several distributions, but also NOT on several other distributions or at least installations - as people report it... I think it is good to discuss upstream as that may help find a common cause.

And yes please test Openmandriva and tell how it goes.  IF ok maybe developers can try find what cause the difference :)

Web search do find bug reports about plasma session restore on other distros, here is for ubuntu.  I dont know if our developers have looked to see if we could use same remedy  https://bugs.launchpad.net/ubuntu/+source/plasma-workspace/+bug/1446865  I also saw one for mint, at least.

OK sorry: what is worse is of course personal.  I dont need session restore, instead i have a simple script that starts a bunch of applications and files at login. Some need order and timing between so that is for my use *better* than any session restore i have tried, plus it works also when i start into another DE.

The two quirks that bug *me* the most currently is that some start links which let applications start in terminal dont work: Bug 19332, and on my nvidia laptops some desktop icon texts and some programs are garbled after resume: Bug 18904, which are common reported upstream too.
Comment 40 Frank Griffin 2016-11-21 01:21:10 CET
OK, so I guess the pivotal question here is are the bugs due to to things that upstream is unable or unwilling to fix but other distros have, or things that upstream has already fixed but that we and some other distros are blocking in their packaging.

It seems that MGA has moved well away from the MDV philosophy of "it's our distro, and if we don't like what upstream is doing, we'll craft a patch to make it behave as we want".  It will be interesting to see if the objectionable behavior is introduced by upstream or by something we have done.
Comment 41 Neal Gompa 2016-12-03 21:24:54 CET
I can personally attest to this feature generally working in Fedora (24 and 25), as I use Fedora on my workplace workstation with the Plasma 5 desktop.

CC: (none) => ngompa13

Comment 42 Neal Gompa 2016-12-03 22:34:45 CET
Confirmed, the feature works after enabling it in System Settings on Fedora 25 in Plasma 5.8.1 and Plasma 5.8.4. It doesn't work correctly in Mageia Cauldron (fully up to date through "dnf -y distro-sync --allowerasing").

Fresh install of Fedora 25 KDE Spin in a VM, enabled the feature, opened a bunch of KF5, KDE4, and GTK applications (dolphin, okular, firefox, systemsettings, konsole). Reboots showed them coming back. Then "dnf -y distro-sync --allowerasing" to upgrade to Plasma 5.8.4. It still worked.

On Mageia Cauldron, with Plasma 5.8.4, the feature is enabled by default. I attempted the same thing, and on reboot only the KDE4 (Okular) and GTK+ (Firefox) apps came back. Disabled the feature to clear the desktop session settings, rebooted, then enabled it, and tried again. Same problem.
Comment 43 Mike Rambo 2016-12-05 15:50:01 CET
(In reply to Neal Gompa from comment #42)
> Confirmed, the feature works after enabling it in System Settings on Fedora
> 25 in Plasma 5.8.1 and Plasma 5.8.4. It doesn't work correctly in Mageia
> Cauldron (fully up to date through "dnf -y distro-sync --allowerasing").

mga5 ksmserver saves session information in ~/.kde4/share/config/ksmserverrc which in turn refers to data in ~/.kde4/share/config/session/*. On my mga5 all of my konsole tabs are described in .kde4/share/config/session/konsole... (big long number) which is also referenced in ksmserverrc.

ksmserver in cauldron appears to use ~/.config/ksmserverrc which looks like it is either missing session information, or else it has been moved to other files. There is some kde session stuff in ~/.local/share/kded5/* but doesn't look related to me - at least to konsole or other applications.

It might be helpful to know if Fedora 25 saves anything more in ksmserverrc than is currently being saved by cauldron and also whether there is any additional plasma/konsole session information someplace in the user home directory if you wouldn't mind looking.

CC: (none) => mrambo

Comment 44 Mike Rambo 2016-12-05 20:53:05 CET
On a Fedora 25 VB VM I found that as Neal indicated the session related things that are broken on cauldron are indeed working on f25. This includes setting the configuration to restore a manually saved session and also includes restoring multiple tabs in konsole.

When I looked, f25 plasma is saving files similar to those saved by mga5 except they are in .config instead of the kde4 location. In particular, ~/.config/ksmserverrc and ~/.config/session/* has the data relevant to restoring konsole sessions. cauldron is not saving most of this.

I don't see where where the session data for firefox, rhythmbox, or several other things I tested was saved but all of the half dozen applications I tried were restored at reboot.
Comment 45 Piotr Mierzwinski 2016-12-05 21:29:42 CET
About missing ~/.config/session I mentioned in comments: 6 (created at January) and 9 (created at March). I think, no one from Mageia team was interested this issue, or they had more important/serious issues to solve.

All gtk2 applications use outdated session management - check this bug report:
https://bugs.kde.org/show_bug.cgi?id=362671. It is supported in old way (like in KDE4) and in Mageia Cauldron works after patch mentioned in link has been applied.
BTW. Starting Firefox in version 50 (and probably the newest Thunderbird) will be supported modern session management (from gtk3), so with xsmp protocol (check comment 10 in mentioned bug report), so then also these both applications will be not restored in Mageia 6.
Comment 46 Samuel Verschelde 2016-12-12 23:58:23 CET
Could someone check if qt5 and kf5 applications are correctly restored in other desktops than Plasma? This would help in identifying where things are going wrong.
Comment 47 Samuel Verschelde 2016-12-13 00:00:04 CET
Note: I tried to create ~/.config/session but it doesn't change anything. I suppose it will be created automatically once session management correctly works?
Comment 48 Samuel Verschelde 2016-12-13 00:50:09 CET
I submitted a new qt5 to the build system with a build dependency added to pkgconfig(sm), after testing locally that it fixed most of the session restoring issue we are having.

Please test 5.6.2-2.mga6 (provided the build doesn't fail while I'm sleeping)
Comment 49 Pieter van Zyl 2016-12-13 12:21:24 CET
Hi Samuel, I got an update now of Cauldron using 5.6.2-2.mga6 as discussed in Comment 48.

Session restore seems to be working fine for me now.

Konsole tabs and windows restore
Kate restores as well.
Desktop background settings also restore fine now on dual screens.

Thanks! :)

Sorted for me.
Comment 50 David GEIGER 2016-12-13 12:24:38 CET
Confirmed here too, thanks Samuel :)
Comment 51 Samuel Verschelde 2016-12-13 12:42:39 CET
Thanks, this is fixed then!

If any other bug related to session restoring occurs, please open a different bug report. Closing.

Resolution: (none) => FIXED

Comment 52 Piotr Mierzwinski 2016-12-24 00:43:40 CET
Just I confirm, because it was my bug report.
After last update seems it works fine.
Big thanks Samuel.
Comment 53 Bruno Cornec 2017-08-21 18:08:51 CEST
I think this is currently not solved with mga6 official, as I still have that issue (after a mga5 migration using urpmi). Will try to see what I can do to solve and report.

Resolution: FIXED => (none)
CC: (none) => bruno

Comment 54 Piotr Mierzwinski 2017-08-21 20:34:29 CEST
@Bruno Cornec
Have you tested this using pretty new user? Maybe this is some cache or some settings issue related with your current user.
Comment 55 Bruno Cornec 2017-08-22 00:19:51 CEST
No I tested it with my existing user (I'd say of course, like 99% of Mageia old users !).

I'm sure there is some caching effect in place, of changed conf files, but our packages should probably remove these during the update mechanism, or we should document that, ... once we know what :-)
Comment 56 Frédéric "LpSolit" Buclin 2017-08-22 01:20:44 CEST
Please file a separate bug if you still have problems with Plasma. The reporter of this bug and several other testers confirmed that the issue reported here is fixed.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.