Bug 18904 - Plasma+Nvidia: After resume, Plasma desktop icons text fields is unreadable on some systems
Summary: Plasma+Nvidia: After resume, Plasma desktop icons text fields is unreadable o...
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: High major
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL: https://bugreports.qt.io/browse/QTBUG...
Whiteboard:
Keywords: FOR_ERRATA6, UPSTREAM
Depends on:
Blocks:
 
Reported: 2016-07-09 13:24 CEST by Morgan Leijström
Modified: 2017-09-04 17:33 CEST (History)
2 users (show)

See Also:
Source RPM: kwin, qt, nvidia-current
CVE:
Status comment:


Attachments
Screenshot start icons text (59.70 KB, image/png)
2016-07-10 17:50 CEST, Morgan Leijström
Details
The text fields are sometimes also dithered (89.90 KB, image/png)
2016-07-10 17:51 CEST, Morgan Leijström
Details
Screenshot (compressed) with icon texts and MCC blurred (23.82 KB, image/jpeg)
2016-08-18 18:47 CEST, Morgan Leijström
Details
Blurred desktop icon texts after resume on my workstation (116.65 KB, image/png)
2016-12-12 10:54 CET, Morgan Leijström
Details
Photo of garbled sddm breeze login personality icons (26.72 KB, image/jpeg)
2016-12-19 14:25 CET, Morgan Leijström
Details

Description Morgan Leijström 2016-07-09 13:24:25 CEST
To reproduce:
1) on a system with nvidia graphics (at least the ones i have, see below)
2) use proprietary driver
3) use plasma
4) set desktop to folder view
5) have some desktop shortcuts there, i.e "Home"
6) suspend it
7) wake it up and log in
8) see "Home" and other shortcuts text fields displayed like a white or black block, or white text on black block

WORKAROUND 1: log out and in
WORKAROUND 2: use noveau (but a few programs demand nvidia)
WORKAROUND 3: dont care... and possibly clean your desktop ;)

This is a regression since Mageia 5 which worked perfectly to suspend and hibernate and come back up on the same machines.

It have been like this all time i have been running mga6 cauldron.
I think some devs must have seen too this but as i see no progress and find no bug i hereby file one.

Same problem om both my cauldron systems that have Nvidia graphics
Desktop with Nvidia GTX760
Laptop Nvidia Quadro NVS140M

Using noveau driver, that problem does not exist.
Comment 1 Morgan Leijström 2016-07-10 17:50:29 CEST
Created attachment 8150 [details]
Screenshot start icons text
Comment 2 Morgan Leijström 2016-07-10 17:51:37 CEST
Created attachment 8151 [details]
The text fields are sometimes also dithered
Comment 3 Morgan Leijström 2016-07-12 02:01:59 CEST
Still same at current versions: plasma 5.7.0, KDE Applications 16.04.3, kernel 4.7.0-desktop-0.rc7.1.mga6, x11 1.18.3-15.mga6, nvidia340.96-37.mga6

Tests now only performed on the laptop

* Problem is not seen on MATE nor LXDE on the same system *

All while using SDDM login manager.

Summary: Nvidia: After resume, Plasma desktop icons text fields are unreadable: completely white, black or white text on black => Plasma+Nvidia: After resume, Plasma desktop icons text fields are mostly unreadable (OK in other DE, i.e MATE)

Comment 4 Morgan Leijström 2016-08-09 08:00:25 CEST
still valid.
Comment 5 Morgan Leijström 2016-08-14 23:10:40 CEST
I don't see that problem now :)

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 6 Morgan Leijström 2016-08-18 18:47:51 CEST
Created attachment 8353 [details]
Screenshot (compressed) with icon texts and MCC blurred

Reopening. As seen in attachment the problem still persists and now i saw that also the open window MCC is concerned: blurred until resized.
Morgan Leijström 2016-08-18 18:48:06 CEST

Resolution: FIXED => (none)
Status: RESOLVED => REOPENED

Morgan Leijström 2016-08-18 18:48:50 CEST

Summary: Plasma+Nvidia: After resume, Plasma desktop icons text fields are mostly unreadable (OK in other DE, i.e MATE) => Plasma+Nvidia: After resume, Plasma desktop icons text fields and some app is unreadable (OK in other DE, i.e MATE)

Comment 7 Morgan Leijström 2016-10-10 11:35:36 CEST
This is really terribly looking - we cant let put mga6 like this!

I had a drak dialog up, put the laptop to sleep using Fn+F4, wake it up and after entering password i see the dialog completely blurred, and all texts on desktop icons too.

Have tested four setups with three different Nvidia, fresh installs and upgrades from mga5, and they all show this bad looking bug.

Qt5.6.1, kf5.27.0, Plasma5.8.0

Seen on two different Lenovo T61 with different Nvidia chips, one fresh install last week, one fresh install a couple months ago.
Seen on my workstation upgraded from mga5.
And on my sons "gaming machine" fresh install a few months ago.

I wonder if the blurring of just soem apps like the drak tools is hint on what the problem is?

Strange it also is the plasma desktop program launch icons

Priority: Normal => release_blocker
Severity: normal => major

Rémi Verschelde 2016-10-17 14:01:26 CEST

CC: (none) => kde
Status comment: (none) => Needs someone knowing plasma or nvidia to help with debugging
Assignee: bugsquad => kernel

Comment 8 Rémi Verschelde 2016-10-17 14:06:06 CEST
Might be this upstream bug report? https://bugs.kde.org/show_bug.cgi?id=344326
Comment 9 Morgan Leijström 2016-10-17 15:23:02 CEST
Yes, seems like that upstream bug.
Yes all Nvidia i tried (actually all i have) are different Quadros.

Except from the background, this example is kind of identical to what i see after every suspend: https://bugsfiles.kde.org/attachment.cgi?id=100142
Rémi Verschelde 2016-10-17 15:28:07 CEST

CC: kde => kernel
Source RPM: (none) => kwin
URL: (none) => https://bugs.kde.org/show_bug.cgi?id=344326
Assignee: kernel => kde
Keywords: (none) => UPSTREAM

Comment 10 Morgan Leijström 2016-10-29 22:24:10 CEST
Since about a week, the problem seem gone :)
But i leave bug open a while as i have closed it prematurely before...
Comment 11 Morgan Leijström 2016-11-04 09:26:38 CET
Still I have seen  no problem on the larger T61p "Göran", but problem exist on the smaller T61 "Lillen".

Another difference is that on the smaller T61, the sound volume and hibernation buttons etc do not work anymore, so maybe the machine is not correctly recognised so correct settings/drivers are wrong for both these issues?
Comment 12 Morgan Leijström 2016-11-22 17:04:57 CET
Same after updates today including kernel 4.8.10-2 : garbled on "Lillen", OK on "Göran". 

-but volume and suspend etc buttons got fixed some time ago :)
Comment 13 Nicolas Lécureuil 2016-12-03 21:43:16 CET
can you test with current X.org ? ( 1.19 )

CC: (none) => mageia

Comment 14 Samuel Verschelde 2016-12-03 21:46:03 CET
Adjusting priority. It is no longer a blocker given the last comments.

Priority: release_blocker => High

Comment 15 Rémi Verschelde 2016-12-03 21:48:54 CET
Morgan, if the bug is still valid and since it evolved a lot since the original issue, could you either change the summary to match the current state (+ maybe explain in a new comment what the current state is), or alternatively open a new bug report (and close this one as RESOLVED MOVED)?
Comment 16 Morgan Leijström 2016-12-05 11:19:48 CET
I will test when there is a nvidia 340 driver...
Comment 17 Morgan Leijström 2016-12-12 10:54:01 CET
Created attachment 8758 [details]
Blurred desktop icon texts after resume on my workstation

I now tested on my workstation "Svarten":
It do show this problem too on latest kernel, xorg, and Nvidia driver.
Screenshot attached after waking from hibernation.

GPU: Nvidia GK104 [GeForce GTX 760]
Machine: Intel i7, SSD
System: Current Cauldron 64 bit; 
 x11-driver-video-nvidia-current 375.20-2.mga6
 x11-server-xorg 1.19.0-8.mga6
 kernel-desktop-4.8.14-1.mga6

PS it hibernates and resumes nicely in other aspects, nice as /, /home and swap is on an encrypted LVM, /boot a separate ext4  :)  DS
Comment 18 Morgan Leijström 2016-12-12 11:26:05 CET
Adjusted summary because i can no longer reproduce that some apps are blurred, only desktop icons.  (i.e before, MCC window was blurred after suspend-resume)


I wonder if the problem comes from services and whatever are started/initialised asyncronously, and depending on number of cores, speed of disk, installed services and configuration, the problem express itself on some systems but not on other, and earlier i have also seen it come and go between updates on same system (on both "Lillen" and "Goran").

- Is there some way to force some constraints on initialisation ( maybe single threaded / maybe even force whole system to execute on one core only)  - just to test if it makes a difference?

Summary: Plasma+Nvidia: After resume, Plasma desktop icons text fields and some app is unreadable (OK in other DE, i.e MATE) => Plasma+Nvidia: After resume, Plasma desktop icons text fields is unreadable on some systems

Comment 19 Morgan Leijström 2016-12-14 23:05:26 CET
nvidia340-101 came so I updated my laptops "Göran" & "Lillen" mentionned above.
Also with x11-server-xorg 1.19.0, kernel-desktop-4.8.14, KF5 5.29

Problem still on "Lillen" problem is *back* on "Göran"

To summarise: Now 100% of my three Nvidia systems show this bug!
Comment 20 Morgan Leijström 2016-12-14 23:07:53 CET
(workaround: it works OK with nouveau, except for applications requiring Nvidia drivers)
Comment 21 Morgan Leijström 2016-12-19 14:25:02 CET
Created attachment 8800 [details]
Photo of garbled sddm breeze login personality icons

Now i saw that also sddm breeze login personality icons can become garbled.
Comment 22 Morgan Leijström 2017-03-14 17:48:43 CET
Still valid.
Comment 23 Morgan Leijström 2017-04-04 08:35:04 CEST
Case is moving forward!
Possible fix posted (requires running OpenGL 3.1)
https://bugs.kde.org/show_bug.cgi?id=344326#c152
Comment 24 Nicolas Lécureuil 2017-04-04 09:31:02 CEST
Please test next kwin
Comment 25 Nicolas Lécureuil 2017-04-04 09:42:32 CEST
if it compiles of course :)
Comment 26 Morgan Leijström 2017-04-04 09:47:49 CEST
Heh, yes.  Please post again when it is syncing :)
Comment 27 Morgan Leijström 2017-04-15 09:47:23 CEST
Darn... my relevant laptop died - but if you have something to test i can test with caution on my daughters T61 14" thinkpad which also show the problem (now running MATE because of that)
Comment 28 Morgan Leijström 2017-04-15 11:45:26 CEST
Darn... my relevant laptop died - but if you have something to test i can test with caution on my daughters T61 14" thinkpad which also show the problem (now running MATE because of that)
Comment 29 Morgan Leijström 2017-06-24 17:06:08 CEST
Upstream seem to have a solution! :)
https://bugs.kde.org/show_bug.cgi?id=344326
Comment 30 Nicolas Lécureuil 2017-06-24 19:21:29 CEST
iirc, i tested and this does not apply nor compile with kwin 5.8.x :/
Comment 31 Rémi Verschelde 2017-06-25 21:04:30 CEST
I rediffed the latest version from https://phabricator.kde.org/D6344 and pushed it to core/updates_testing (kwin-5.8.7-2.mga6), let's see how it fares.

I can now reproduce the issue on my Optimus laptop thanks to mageia-prime, so I should be able to check it.
Comment 32 Rémi Verschelde 2017-08-03 16:23:38 CEST
FYI, the patch I tested in comment 31 did not work for me.
Comment 33 Rémi Verschelde 2017-08-03 16:30:03 CEST
Actually in https://bugs.kde.org/show_bug.cgi?id=382115 there is a reference to the upstream Qt bug report: https://bugreports.qt.io/browse/QTBUG-56610

It looks like this needs a fix from Qt, but they don't work to work on it because they think it's NVIDIA being buggy... KDE worked it around in KWin, but not in other Qt applications so that fix is only partial.

So... wait and see.

Keywords: (none) => FOR_ERRATA6
Source RPM: kwin => kwin, qt, nvidia-current
Status comment: Needs someone knowing plasma or nvidia to help with debugging => (none)
URL: https://bugs.kde.org/show_bug.cgi?id=344326 => https://bugreports.qt.io/browse/QTBUG-56610

Comment 34 Morgan Leijström 2017-09-04 17:33:38 CEST
Also see, patch, https://bugs.kde.org/show_bug.cgi?id=364766

Note You need to log in before you can comment on or make changes to this bug.