Bug 1471 - Corrupted display on laptop with ATI Radeon (missing firmware in initrd)
: Corrupted display on laptop with ATI Radeon (missing firmware in initrd)
Status: RESOLVED OLD
Product: Mageia
Classification: Unclassified
Component: Installer
: Cauldron
: x86_64 Linux
: Normal Severity: normal
: ---
Assigned To: Mageia Bug Squad
:
:
: Errata, MGA2TOO
:
: 5426
:
  Show dependency treegraph
 
Reported: 2011-05-29 12:40 CEST by Martin Whitaker
Modified: 2014-04-27 19:36 CEST (History)
13 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Martin Whitaker 2011-05-29 12:40:02 CEST
Description of problem:

Installation completes successfully, but on reboot, when the boot process reaches the stage of initialising the drm framebuffer, the display is corrupted (random noise/blocks of colour over all the display). The machine boots successfully and can be remotely accessed via ssh, but the display never recovers (both text and graphic consoles are affected).

Version-Release number of selected component (if applicable):

Mageia 1 RC

How reproducible:

Each time the machine is booted.

Steps to Reproduce:
1. Power on or reboot.
2. Wait for appropriate point in boot cycle.

Workround:

If the "nomodeset" kernel option is used to disable kernel mode setting, all is well.

Hardware details:

HP Compaq 6830s
Intel Mobile 4 Series Chipset
Intel Core2 Duo P8600
ATI Mobility Radeon HD 3430 (ChipID = 0x95c2)

Possible duplicate:

This may be the same as bug 1360, however the description there is not sufficiently clear for me to be sure (and my French is not good enough to follow the linked forum discussion), so I have created a new bug.
Comment 1 Martin Whitaker 2011-05-29 12:47:43 CEST
Additional diagnostics:

Examining the output of dmesg, I found:

[drm] Loading RV620 Microcode
r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
[drm:r600_startup] *ERROR* Failed to load firmware!  

However, installing the radeon-firmware package does not fix the problem, and just filled the dmesg output with messages like this:

WARNING: at drivers/gpu/drm/radeon/radeon_gart.c:176 radeon_gart_bind+0x1ab/0x1c0 [radeon]()
Hardware name: HP Compaq 6830s
trying to bind memory to unitialized GART !
Modules linked in: [snip]
Pid: 4569, comm: plymouthd Tainted: G        W I 2.6.38.6-desktop-1.mga #1
Call Trace:
[<ffffffff81057aff>] ? warn_slowpath_common+0x7f/0xc0
[<ffffffff81057bf6>] ? warn_slowpath_fmt+0x46/0x50
[<ffffffffa0057ce5>] ? ttm_mem_global_alloc_page+0x55/0x60 [ttm]
[<ffffffffa00b6a4b>] ? radeon_gart_bind+0x1ab/0x1c0 [radeon]
[<ffffffffa00b4352>] ? radeon_ttm_backend_bind+0x32/0x90 [radeon]
[<ffffffffa00587c8>] ? ttm_tt_bind+0x58/0x80 [ttm]
[<ffffffffa005a504>] ? ttm_bo_handle_move_mem+0x194/0x3c0 [ttm]
[<ffffffffa005b68e>] ? ttm_bo_move_buffer+0x12e/0x140 [ttm]
[<ffffffff811df0b1>] ? security_inode_alloc+0x21/0x30  
[<ffffffffa005b736>] ? ttm_bo_validate+0x96/0x120 [ttm]
[<ffffffffa005bac6>] ? ttm_bo_init+0x306/0x380 [ttm]
[<ffffffffa00b56e7>] ? radeon_bo_create+0x147/0x2a0 [radeon]  
[<ffffffffa00b5440>] ? radeon_ttm_bo_destroy+0x0/0xc0 [radeon]
[<ffffffffa00cc74c>] ? radeon_gem_object_create+0x8c/0x120 [radeon]
[<ffffffffa00ccb98>] ? radeon_gem_create_ioctl+0x58/0xd0 [radeon]
[<ffffffff8107cfb0>] ? lock_hrtimer_base.clone.25+0x30/0x60
[<ffffffffa00212b4>] ? drm_ioctl+0x3e4/0x4c0 [drm]
[<ffffffffa00ccb40>] ? radeon_gem_create_ioctl+0x0/0xd0 [radeon]
[<ffffffff8107d864>] ? hrtimer_start_range_ns+0x14/0x20  
[<ffffffff811ea76a>] ? tomoyo_init_request_info+0x3a/0x70
[<ffffffff8115ac79>] ? do_vfs_ioctl+0x99/0x570
[<ffffffff8115b1e1>] ? sys_ioctl+0x91/0xa0
[<ffffffff81002e92>] ? system_call_fastpath+0x16/0x1b
---[ end trace a7919e7f17c0a909 ]---
[drm:radeon_ttm_backend_bind] *ERROR* failed to bind 1772 pages at 0x00000000
radeon 0000:01:00.0: object_init failed for (7258112, 0x00000002)
[drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (7258112, 2, 4096, -22)

Another anomaly in the dmesg output is this:

fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver

but this can be elimated by removing the vga=xxx option from the kernel boot options. Doing this makes no noticable difference.

A third anomaly in the dmesg output is this:

WARNING: at drivers/pci/dmar.c:634 warn_invalid_dmar+0x8f/0xa0()
Hardware name: HP Compaq 6830s
Your BIOS is broken; DMAR reported at address 0!
BIOS vendor: Hewlett-Packard; Ver: 68PZD Ver. F.09; Product Version: F.09
Modules linked in:
Pid: 0, comm: swapper Not tainted 2.6.38.6-desktop-1.mga #1
Call Trace:
 [<ffffffff81057aff>] ? warn_slowpath_common+0x7f/0xc0
 [<ffffffff813f92c7>] ? _etext+0x0/0x1
 [<ffffffff81057b9f>] ? warn_slowpath_fmt_taint+0x3f/0x50
 [<ffffffff8175866c>] ? early_ioremap+0x13/0x15
 [<ffffffff8174e6e9>] ? __acpi_map_table+0x13/0x19
 [<ffffffff8124626f>] ? warn_invalid_dmar+0x8f/0xa0
 [<ffffffff81288f6b>] ? acpi_tb_verify_checksum+0x16/0x4e
 [<ffffffff81772098>] ? check_zero_address+0x5d/0x116
 [<ffffffff81288697>] ? acpi_get_table_with_size+0x58/0xb9
 [<ffffffff813f92c7>] ? _etext+0x0/0x1
 [<ffffffff8177216a>] ? detect_intel_iommu+0x19/0xb0
 [<ffffffff8174a1b5>] ? pci_iommu_alloc+0x47/0x72
 [<ffffffff817580ba>] ? mem_init+0x19/0xec
 [<ffffffff81744ab5>] ? start_kernel+0x201/0x405
 [<ffffffff8174432b>] ? x86_64_start_reservations+0x132/0x136
 [<ffffffff81744435>] ? x86_64_start_kernel+0x106/0x115
---[ end trace a7919e7f17c0a725 ]---

A Google search indicates this is a common problem on HP laptops. I did find one discussion that suggested this might affect the ability to use kernel mode setting (because kms makes use of the IOMMU), but could find nothing solid to back this up.
Comment 2 Thomas Backlund 2011-05-30 14:27:55 CEST
(In reply to comment #1)
> Additional diagnostics:
> 
> Examining the output of dmesg, I found:
> 
> [drm] Loading RV620 Microcode
> r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
> [drm:r600_startup] *ERROR* Failed to load firmware!  
> 
> However, installing the radeon-firmware package does not fix the problem, and
> just filled the dmesg output with messages like this:
> 

Yep. this is beacuse radeon gets loaded from initrd, so in order to get a working system: 


If you add 

radeon.modeset=0 

to the kernel command line, it will boot without kms

Then when system is booted,

remove the "radeon.modeset=0"

and do a:

 bootloader-config --action rebuild-initrds

and it will recreate the initrd with the needed firmwares added

[...]

> Another anomaly in the dmesg output is this:
> 
> fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
> 

This is only an informational message by the kernel that it's switching framebuffer driver.
Comment 3 Martin Whitaker 2011-06-02 20:36:13 CEST
OK, I can confirm that once I recreate the initrd with the necessary firmware, the original problem (corrupted display) is fixed.

So the bug is that the installer does not install the necessary firmware and recreate the initrd.

As this is not a widespread problem, I assume this just means the installer is not correctly identifying my particular graphics chip.

Thanks, Thomas.
Comment 4 Valerio Marinelli 2011-06-03 01:30:36 CEST
Well, first of all I thank you both Thomas and Martin.

The workaround works fine for me too, indeed I've got a Mobility Radeon HD3410 on an HP Pavilion DV2 and an HD3200 on a Lenovo Thinkpad Edge, and I had the same corrupted display on boot, or when testing video configuration at the end of install process.

So I would not say that this is "not a widespread problem", neither it should have high priority: I think there are many laptops (maybe desktops too?) affected for this bug.
While an expert user can find it easy to solve in this way, many others would panic or get angry trying re-install Mageia many times (as did I initially) or abandon at all.

So my hope is that you guys shall find a definitive solution.

Anyway, I would like to thank all Mageia's people and community for the excellent job.

Regards,
Valerio
Comment 5 Martin Whitaker 2011-06-03 10:09:23 CEST
By "widespread", I really meant "affects all Radeon cards". I agree this is a serious problem that may put quite a few people off installing Mageia. It definitely needs to go in the Errata, and I would suggest a note should be added to the download page to warn Radeon owners to read the Errata.
Comment 6 Valerio Marinelli 2011-06-06 22:35:47 CEST
Definitely agree with you.

I also wondered if it were an "errata" wiki page, because it is somehow "hidden"... ;-) I mean: if you know what and where you have to search, temporary wiki is ok, but...
Well, no worries, we'll wait patiently when Mageia and its infrastructure will be "mature" :-)

Regards,
Valerio
Comment 7 Ahmad Samir 2011-06-16 06:55:23 CEST
*** Bug 956 has been marked as a duplicate of this bug. ***
Comment 8 Jan Merta 2011-06-18 22:30:09 CEST
I can confirm this bug appears on ASUS K50AB-SX010, which has Ati HD 3200 and Ati HD 4570 graphic cards. I have final Mageia 1.
Comment 9 Ahmad Samir 2011-06-18 22:33:11 CEST
Does the fix/workaround in comment#2 resolve the issue for you?
Comment 10 Valerio Marinelli 2011-06-21 16:15:25 CEST
Well, as I just said on comment#4 the workaround permits to resolve the issue "by hand", as it is possible to boot Mageia and then install radeon-rlc-firmware.

This is valid for me, for Martin and whoever has the great idea to boot at least for once with "radeon.modeset=0" ;-) as I gave this kernel option directly on Grub boot menu (pressed F6 key)

Regards,
Valerio
Comment 11 Ahmad Samir 2011-06-27 21:41:05 CEST
*** Bug 1268 has been marked as a duplicate of this bug. ***
Comment 12 Thierry Vignaud 2011-10-04 17:46:37 CEST
*** Bug 1360 has been marked as a duplicate of this bug. ***
Comment 13 Manuel Hiebel 2011-10-30 02:04:07 CET
Can we resolve this fir mageia2 ?
Comment 14 Palm Pre 2011-11-26 07:24:39 CET
Is anyone still working on this bug?

Mageia-2-alpha2 has it as well.
Comment 15 Frank Griffin 2011-11-26 12:35:19 CET
It gets worse.  See https://bugs.mageia.org/show_bug.cgi?id=3421
Comment 16 Manuel Hiebel 2011-12-14 23:43:17 CET
Added in the errata, it was missing :/
Comment 17 Chris Desjardins 2011-12-14 23:46:03 CET
I am still experiencing this problem on mga1. I have the following video card:

01:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450] (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0342
        Flags: bus master, fast devsel, latency 0, IRQ 41
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f7df0000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at dc00 [size=256]
        Expansion ROM at f7e00000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Kernel driver in use: radeon
        Kernel modules: radeon

I had to boot with radeon.modeset=0, install radeon-firmware, and then run bootloader-config --action rebuild-initrds.
Comment 18 Palm Pre 2011-12-17 19:36:33 CET
Is anyone working here?

I filed original bug 956 in April 2011. Nothing was done and Errata page is just moving from alpha1 to alpha2.

 Of course, I may do "workaround" or Mageia may fix the bug. 
I think latest is the must.
Comment 19 Marja van Waes 2011-12-21 09:06:21 CET
@ Palm

(In reply to comment #18)
> Is anyone working here?
> 

That hurts, I would like to never see your name again.

We work so hard that we can't even imagine someone else doesn't
Comment 20 Marja van Waes 2011-12-25 11:32:27 CET
(In reply to comment #19)
> @ Palm
> 
> (In reply to comment #18)
> > Is anyone working here?
> > 
> 
> That hurts, I would like to never see your name again.
> 
> We work so hard that we can't even imagine someone else doesn't

@ Palm

OK, I don't have a problem with seeing your name any more, because you are partly right. I wasn't aware of that before.

When I started working for Bug Squad, end of last summer, there were 26 persons on our member's list. Even after I managed to remove about half of the names of that list (of members who replied they didn't have time to chase bugs and of those who didn't reply to our mails at all), someone remarked, after having seen the shortened list of Bug Squad members: "where are they all hiding?" 
Well, the list became even shorter after that. Most of our members have very little time to chase bugs, because of other duties, e.g. in other teams, school, jobs and/or their families. Not all of our remembers members do work for our team at the moment, because we don't have time to train them.

Not all teams found time to clean their member's list, so you might wrongly have the impression there are a lot more people helping here than there actually are. On the list of packagers, there are several names of people who don't package for Mageia, aren't being trained to become a Mageia packager, and aren't on the list of people waiting for training.

To give you an impression of what missing those members leads to for the ones really helping:

D Morgan maintains 1120 packages at the moment.
Thierry has 137 bugs to resolve, already resolved a lot, 59 bugs!

Thanks for doing your part by reporting the bugs you encounter.

Regards,
Marja
Comment 21 el loqo 2012-01-30 07:37:03 CET
I'm running 64-bit Mageia 1 final on an HP TX2520ea tablet. It has a Radeon 3200HD graphics card and the graphical corruption documented above by Martin has been a nightmare for me. I've reinstalled several times, almost abandoned Mageia entirely -- and even tried installing and just avoiding the ATI driver!

I'm about to try the workaround... but not 100% confident of the process and slightly scared of restarting my machine, in case I am unable to use it. Again. 
*Fingers crossed*
Comment 22 Marja van Waes 2012-01-30 13:01:45 CET
(In reply to comment #21)
> I'm running 64-bit Mageia 1 final on an HP TX2520ea tablet. It has a Radeon
> 3200HD graphics card and the graphical corruption documented above by Martin
> has been a nightmare for me. I've reinstalled several times, almost abandoned
> Mageia entirely -- and even tried installing and just avoiding the ATI driver!
> 
> I'm about to try the workaround... but not 100% confident of the process and
> slightly scared of restarting my machine, in case I am unable to use it. Again. 
> *Fingers crossed*

@ el loqo 

Thanks for reporting about this issue, unfortunately this is the wrong place

Please don't report in a bug that is against a different version of Mageia than you have and moreover, never change the Mageia version in someone else's bugreport, nor one of yourselves that was already confirmed by others.

I don't have time to look for a bug about your problem against Mga1, my lunchbreak is over

Changing version back to cauldron
Comment 23 Marja van Waes 2012-01-30 16:29:08 CET
@ el loqo

Just found some more time to read this bug.

It is no use to find or file a bug report about this issue for Mageia 1

This bug is about installer not handling Radeon cards correctly. Installer bugs are always set to version cauldron, because once a Mageia stable version is released that version remains as it is, so it can only be solved for a next release. 

A bug report about any installer issue with version 1 will be set to version cauldron, if it doesn't already exist, or be closed if it already exists for cauldron.

Good luck with the workaround. 

https://wiki.mageia.org/en/Mageia_2_Errata#Hardware_issues

(the same as in comment 2, only easier to read and including the advice to install install radeon-firmware from nonfree)
Comment 24 Martin Whitaker 2012-01-30 20:04:44 CET
To be fair, this bug was reported against Mageia 1 RC. I am disappointed it still hasn't been fixed for Mageia 2.
Comment 25 Marja van Waes 2012-01-30 23:29:47 CET
(In reply to comment #24)
> To be fair, this bug was reported against Mageia 1 RC. I am disappointed it
> still hasn't been fixed for Mageia 2.

you might want to try the boot-nonfree.iso Thierry points to here:

https://bugs.mageia.org/show_bug.cgi?id=1405#c13
Comment 26 Martin Whitaker 2012-01-31 00:07:29 CET
I don't think that fixes the fundamental problem. The free DVD should not create an installation that does not work unless the user knows about and applies a special boot option and then does a bit of work on the command line. This is not the way to attract new users!
Comment 27 Marja van Waes 2012-01-31 07:23:19 CET
(In reply to comment #26)
> I don't think that fixes the fundamental problem. The free DVD should not
> create an installation that does not work unless the user knows about and
> applies a special boot option and then does a bit of work on the command line.
> This is not the way to attract new users!

We are volunteers contributing to Mageia in our spare time and we haven't found a way yet to squeeze 48 hours in a day.

The day before yesterday Thomas Backlund wrote this on the dev ml about the boot-nonfree.iso (I should have known that before giving the link about that iso):

> It is the standard boot.iso with added firmwares from nonfree so you can
> install on hw that needs it to work (during install)

> Meaning disk controllers, network cards, ...

> It is still WIP, and has only (for now based on hw I can test):

> kernel-firmware-extra
> radeon-firmware
> iwlwifi-*-ucode

<snip>

> For the radeon-firmware (and other nonfree firmware) issue, we still
> need to fix stage2 installer. 

(The DVD has stage2 installer)

Please continue this discussion on the mageia-discuss ml, if you want to continue it
Comment 28 el loqo 2012-01-31 09:26:16 CET
I apologise. There was mention in this thread that the bug still persists in Mageia 2 alpha. I'm very sorry that I spoke out of place! I'm still finding my bearings here.

Please tell me what "ml" means (link?) and I'll focus my attention there. 

Thank you for your time!
Comment 29 Marja van Waes 2012-01-31 10:04:56 CET
(In reply to comment #28)
> I apologise. There was mention in this thread that the bug still persists in
> Mageia 2 alpha. I'm very sorry that I spoke out of place! I'm still finding my
> bearings here.
> 
> Please tell me what "ml" means (link?) and I'll focus my attention there. 
> 
> Thank you for your time!



reopening, because this problem didn't get fixed

@ el loqo

This is a known bug in Mageia 1 and in cauldron.

At first, when not having enough time to read what it was about, I reacted to your changing the version to 1, that is when I said that this was the wrong place to report the same issue for Mageia 1.

I was too fast saying that, instead I should have said: 

***this is a know issue in 1 as well as Mageia 2 alpha and because it is about installer, we only have a bug report about it against cauldron. It is no use adding comments that you have this issue in Mageia 1.***

ml means mailing list, I suggested Martin to continue the discussion on the ml. To you I'd rather suggest talking about this issue in the forum.
Comment 30 Marja van Waes 2012-01-31 10:25:08 CET
@ el loqo

https://forums.mageia.org/en/
Comment 31 Manuel Hiebel 2012-02-16 20:57:40 CET
*** Bug 4359 has been marked as a duplicate of this bug. ***
Comment 32 Manuel Hiebel 2012-03-03 00:28:40 CET
*** Bug 4776 has been marked as a duplicate of this bug. ***
Comment 33 Manuel Hiebel 2012-03-18 17:50:06 CET
*** Bug 5006 has been marked as a duplicate of this bug. ***
Comment 34 Marja van Waes 2012-04-05 09:00:32 CEST
@ Martin and everyone whose bug was a duplicate of this one

Please read https://bugs.mageia.org/show_bug.cgi?id=3466#c67 

The packages:

drakx-kbd-mouse-x11-0.100-1.mga2
ldetect-lst-0.1.300-1.mga2

should also solve this bug and those or even better versions will go into Mga2b3, expected to be released on April 14th

Please test
Comment 35 Martin Whitaker 2012-04-22 17:21:29 CEST
Now beta 3 is available, I've been able to test this. I think the changes would have fixed the bug - unfortunately there has been a major regression in the free radeon driver, which means it no longer works without the firmware installed, even when you disable kernel mode setting (at least for my card). See bug #5426 for more discussion of this.
Comment 36 Marja van Waes 2012-05-26 13:09:21 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja
Comment 37 Martin Whitaker 2012-05-27 10:32:51 CEST
As noted, bug 5426 makes it impossible to test whether this bug has been fixed.
Comment 38 Manuel Hiebel 2014-04-27 19:36:31 CEST
lets close no update since two years, please reopen if still valid

Note You need to log in before you can comment on or make changes to this bug.