Bug 14392 - Excessive delay when resuming from hibernation
Summary: Excessive delay when resuming from hibernation
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: High major
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-27 21:59 CET by Morgan Leijström
Modified: 2016-12-15 19:47 CET (History)
4 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description Morgan Leijström 2014-10-27 21:59:57 CET
Machine: Thinkpad R61, Nvidia Quadro NVS 140

Basically everything works, also suspend.

But there is a recent regression on hibernation:
When i tell it to hibernate it does its tricks (i presume), shuts power down, and then it powers up again by tiseld showint the BIOS splash screen, grub menu, then the key dialog for the encrypted partition, then screen gets black except for a blinking cursor and it is not responsive on anything but the power button.

Part of this may be a rest of Bug 12712 which i now close. lspci file is there.

I set it as critical as user may loose work.

Reproducible: 

Steps to Reproduce:
Manuel Hiebel 2014-10-28 09:14:00 CET

CC: (none) => tmb

Comment 1 Morgan Leijström 2014-11-11 21:36:44 CET
With kernel 3.17.2-desktop-4.mga5 and other updates the described problem is gone on all systems.

(BTW, The problem also appeared on 32 bit cauldron on two thinkpad T43.)

However this T61 now instead fail to restore after being manually waken up again - could be because it use encrypted LVM?  I only get a blinking cursor on black, which after some seconds also vanish.

I will search and add to or open issue about that separately

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 2 Morgan Leijström 2014-12-11 09:40:36 CET
I have tried hibernation after almost every kernel update for many versions now, and hibernation/restore always fail, but it fails in different ways.

I think probably the hibernation routines are not redesigned virtually every revision, right?  So i got the idea now that this may be some problem regarding things not executing in the right order, like the start problems in Bug 14452 .

Anyhow, can someone tell me what logs may be useful, and how to make them get saved before it crash when trying to hibernate...?

Here are some of the last ways hibernation have been working, with the kernel used as index - but it is probably also dependant on other things.


§ using kernel-desktop-3.18.0-1.mga5
screen blacks out, disk activity, short blipp sound, moon lamp blinks (like when there is kernel panic), power remains on, and screen black.  After manual power off, normal boot.


§ using kernel-desktop-3.18.0-0.rc7.1.mga5 
screen blacks out except for a blinking cursor top left - nothing else happens - need manual power off.


§ using kernel-desktop-3.17.4-1.mga5
screen blacks out, power cycles (!), disc activity, power off.  When I power it on it boots normally (including i get the grub menu, but shoulnt it just go directly to restoring the system?) and after giving the LUKS key (an encrypted LVM contain all partitions except /boot) there is disk activity, then dead hang.

§ 3.17.2: see post above.

To me it looks like someone is throwing a dice about which part of the hibernation routines get run and in which order...

a few months ago i tried fedora 20, with same problems
mageia 3 and 4 also had similar problems.
Fedora 16 on the other hand was working perfectly.
I also remember that on a very similar machine mageia 2 was working OK.

So it is some of the more modern ways of hibernating that stumbles somehow.

Everyting else - including suspend - works since this summer perfectly using cauldron.. mga5 alpha.. beta.

On the T43 systems it have always worked when i have tried. Differences are they yse intel graphics (this use nvidia), thye are 32 bit intel (this 64 bit intel), and i guess the most important thing is this R61 is using SSD so timing when storing is very different.

Can we make it write out some log what happens during going into hibernation to i.e a USB stick? Even if file do not get closed i thing some tool can read it... or spot it out on ethernet and some app on another computer record it?

Or is there some setting i can set to make it execute things differently, one task after the other?

Priority: Normal => High
Status: RESOLVED => REOPENED
Resolution: FIXED => (none)
Summary: At hibernation it reboots by itself and hang => Varying severe problems with hibernate/wake

Comment 3 Morgan Leijström 2014-12-11 09:53:10 CET
Apparently i forgot that it was a short period when hibernation/restore did work, at Kernel 3.15.6-desktop-1.mga5, see my bug 12712 .  Pure luck i guess ;)

I think there is some bolt in the hibernation machinery that is loose, and we need to tighten it before it breaks for many users.
Comment 4 Morgan Leijström 2014-12-11 10:26:10 CET
similar: bug 14710
Comment 5 Morgan Leijström 2014-12-11 10:39:59 CET
CC Colin: do you possibly know about the hibernation process, and how to get some trace saved before it hangs or power-offs there?

CC: (none) => mageia

Comment 6 Morgan Leijström 2015-02-09 18:02:30 CET
Still the same, updated cauldron, both on a R61 with encryption, and a T61p without encryption.  Both however with / on LVM, but separate etx4 /boot.

suspend:OK

hibernate: seem to save for some seconds power off - looks OK so far.
But after power up and grub menu screen is soon black and only the power button works, shutting off.

Any idea how to record what it is doing during boot?
Comment 7 Samuel Verschelde 2015-05-20 10:03:04 CEST
Worth an Errata entry I suppose. Could you propose one in a comment below?

Whiteboard: (none) => FOR_ERRATA

Comment 8 Morgan Leijström 2015-05-20 11:28:10 CEST
I am not sure what it depends on; combinations of luks only, or combination with lvm and my hardware, graphic driver...

Cauldron currently hibernates OK on the T43 thinkpads, but not T61 nor R61. 
The T43 are 32 bit, lvm, no luks, ATI graphics drivers
The x61 are 64 bit, Nvidia drivers.
  T61 no luks, it hangs during hibernation saving with flashing moon LED.
It mostly restore successfully except for wifi when i tried noveau driver, other times i got a solid grey screen instead of desktop, but always fail with Nvidia driver.  And regardless of driver it always fail shutting off power.
  R61 use LVM on luks, restarts during shutdown, then shuts off, hangs black during start up after grub, never asks for key.

All use use LVM, but separate physical /boot.  only R61 use luks.
Suspend works splendid on all.

Debug idea: can we somehow easily redirect all error output to serial port, grab it using another computer, and then issue hibernate command?


Basically: after install and updates.
1) try if suspend works, if not do not use it.
2) try if hibernate works, if not do not use it.
3) update your desktops powersaver to use what works (that settings about what to do after time out, lid close, at power button press)
You may have more luck with another screen saver.
Comment 9 Morgan Leijström 2015-05-20 11:30:38 CEST
"You may have more luck with another screen saver."
make that *driver*, not *saver*...
Samuel Verschelde 2015-05-20 15:12:22 CEST

Whiteboard: FOR_ERRATA => MGA5TOO FOR_ERRATA

Comment 10 Shlomi Fish 2015-06-18 12:51:55 CEST
Removing FOR_ERRATA since it's not clear whose fault it is.

CC: (none) => shlomif
Whiteboard: MGA5TOO FOR_ERRATA => MGA5TOO

Comment 11 Morgan Leijström 2016-05-09 09:24:04 CEST
Mageia6 Cauldron work perfectly on the machines i have tested so far :)

Our newly bought used T60 hibernates and suspends perfectly even with LVM on luks (it use ATI, not Nvidia like the problematic T61 and R61 above, if that makes a difference.)

Everything i have tried cauldron on (also two stationary and a T42p) hibernates and suspends perfectly.

Unfortunately i do no longer have those problematic T61 and R61 above as both now have the infamous GPU physical failure, but i have a T61p with same GPU that will receive cauldron soon, will update this issue then.
Comment 12 Samuel Verschelde 2016-10-10 17:23:48 CEST
(In reply to Morgan Leijström from comment #11)
> Unfortunately i do no longer have those problematic T61 and R61 above as
> both now have the infamous GPU physical failure, but i have a T61p with same
> GPU that will receive cauldron soon, will update this issue then.

Hi Morgan. Can you update the issue now?

Also, it would be better in the future to have separate bug reports for different issues, even if they all share a common theme such as hibernate/wake.

Keywords: (none) => NEEDINFO
Status: REOPENED => NEW

Comment 13 Morgan Leijström 2016-10-10 22:40:53 CEST
Yes... i got tired testing now and then with only negative result on the resume from hibermnation... :(

But if someone is willing to debug it now, tell me what kind of log you need.


That T61p and also another T61 are now on cauldron.
Both have (different) Nvidia GPU.

GOOD: Both behave great resuming from suspend
( - Except when using Plasma: Bug 18904 - Plasma+Nvidia: After resume, Plasma desktop icons text fields and some app is unreadable (OK in other DE, i.e MATE) )

BAD: Both fail resuming any DE from hibernation - actually takes longer than boot! (using SSD drives)... black screen loooong time, then various faults; if plasma then often some error about kmserver

(Also another thinkpad with ATI graphics have problem resuming from hibernate with plasma... not tested for a while though...)

I have also not tried with attaching different screens at sleeping/waking up, that used to crash sessions.  Something to test when it start working with only built-in screen for a start...
Comment 14 Marja van Waes 2016-11-03 10:48:20 CET
Assigning to the kernel and drivers maintainers, because knowing what to do with this report is beyond my knowledge.

Keywords: NEEDINFO => (none)
CC: (none) => marja11
Assignee: bugsquad => kernel

Comment 15 Morgan Leijström 2016-11-03 10:53:09 CET
I will check current state and update this soon.
( New kernel, xorg, plasma, etc... since last fully tested, and i know at least some things have improved :) )
Comment 16 Morgan Leijström 2016-11-05 12:05:37 CET
Still fail 

Testing on my T61 "Lillen":
SDDM, MATE (plasma show bug 18904 on this machine)
Disk is an SSD, all partitions (/, /home, swap) are in LVM, 
( *no* separate /boot )   / and /home are ext4.

Visually it looks like this, from issuing hibernate from MATE menu:
§ "Moon" lamp briefly on, switches to text screen which is black except from § some logged error about some unrelated unit. (Not beautiful but OK)
§ Disk lamp on; it seem to store, Power switches off.
So judging from the looks it hibernates OK (but looking ugly while doing that)

I press power button:
§ It shows Grub menu <-- should it really, when booting hibernated ??
§ After grub timeout screen get black and disk light is almost continously on for a few seconds = i guess it reads hibernated data
  (during normal boot it blinks much more and show mageia background) 
§ "Moon" lamp briefly on
§ screen still black, disk lamp off, power on.
  I do not respond to anything but power button.
= saved session is lost.

To me it looks like the resuming procedure is kind of out of order.
Comment 17 Morgan Leijström 2016-11-05 14:14:42 CET
Another kind of fail on my Thinkpad T61p "Göran"
SDDM, Plasma, SSD disk with triple boot MSW7 MSW19 MGA6;
It have a separate ext4 /boot, rest of mageia partitions in a LVM.

Issuing hibernate from Plasma menu, screen blacks, after a couple seconds disk lamp is lit for a cpouple seconds (it saves pretty quickly on this SSD).  Moon light also blinks during a couple seconds.
Then nothing happens for a few seconds, only power lamp (& bluetooth & charge) is on... Then suddenly the "moon" indicator start blinking.
It do not shut off and do not respond to anything. I did not try power button, but let it be on, and it drained battery...

I connect power and press power button:
§ It shows Grub menu <-- should it really, when booting hibernated ??
§ I select Mageia and it resumes pretty quickly to login screen, i log in and find my desktop restored.

So on this system in short:
§ Save for hibernation: OK
§ Shut off: FAIL - need to hold in power button
§ Resume: OK
Comment 18 Morgan Leijström 2016-12-15 19:45:09 CET
IMPROVEMENTS :)

 nvidia340-101
 x11 1.19.0-8.mga6
 kernel-desktop-4.8.14-1.mga6
 plasma 5.8.4, KF5 5.29

Both my Thinkpads "Göran", and little sister "Lillen" (very similar but slightly smaller GPU) now hibernates and resumes sucessfully but with a very long delay at resume from hibernation:  For over a minute screen is black and i thought it crashed, but waiting long enough they awake and everything is OK.

Suspend/resume is really nice (like it have been for long time)

___Three problems now, worst first___
 (In all respects here the two systems work alike.)

1) The crazy delay at resume from hibernation.  I see nothing in system log i can relate to this; no error, timeout etc.  There is a message about time jumped a minute which may be a symptom but not a cause... 

2) Wireless connection did not resume after hibernation (but works after suspend)

3) Both systems both when resuming from suspend and hibernation show the garbled desktop icon Bug 18904.
Comment 19 Morgan Leijström 2016-12-15 19:47:17 CET
Updated summary and removed MGA5TOO (move on...)

Summary: Varying severe problems with hibernate/wake => Excessive delay when resuming from hibernation
Whiteboard: MGA5TOO => (none)
Severity: critical => major


Note You need to log in before you can comment on or make changes to this bug.