Bug 10077 - Live Installed system should ask for hostname at the same time it asks for username
Summary: Live Installed system should ask for hostname at the same time it asks for us...
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal enhancement
Target Milestone: Mageia 7
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
: 11005 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-12 23:30 CEST by Dave Hodgins
Modified: 2016-11-10 10:36 CET (History)
8 users (show)

See Also:
Source RPM: drakxtools
CVE:
Status comment:


Attachments

Description Dave Hodgins 2013-05-12 23:30:02 CEST
With the kde live iso images, drakx-finish-install does not
ask about configuring the network, so the hostname is localhost.

journalctl -a|grep finish|grep network
May 12 16:16:19 localhost finish-install[1636]: ignoring ask_network
May 12 16:31:20 localhost finish-install[2103]: calling ask_network
May 12 16:32:23 localhost finish-install[2103]: running: /bin/systemctl disable network-auth.service
May 12 16:32:23 localhost finish-install[2103]: modified file /etc/sysconfig/network

It's working with the gnome live iso images.

The wired ethernet connection is working though.


Reproducible: 

Steps to Reproduce:
Manuel Hiebel 2013-05-28 21:54:28 CEST

CC: (none) => sysadmin-bugs
Component: RPM Packages => Release (media or process)
Version: Cauldron => 3

Comment 1 Manuel Hiebel 2013-08-17 16:53:30 CEST
*** Bug 11005 has been marked as a duplicate of this bug. ***

CC: (none) => junk_no_spam

Manuel Hiebel 2013-08-17 16:54:03 CEST

CC: (none) => mageia, thierry.vignaud
Component: Release (media or process) => RPM Packages
Version: 3 => Cauldron
Whiteboard: (none) => MGA3TOO

Comment 2 Bit Twister 2013-08-17 19:30:31 CEST
(In reply to Dave Hodgins from comment #1)
> it's working with the gnome live iso images

It is an intermittent problem. I did a gnome VirtualBox install and no network screen, Did a kde VB install and it did have it. Installed KDE on two different systems and it did not have it.
Comment 3 claire robinson 2015-01-12 16:41:35 CET
Valid 5beta2 Live ISOs. Noticed on all live isos tried so far not just kde ones.

Wired network, which might explain why it skips it but in doing so it allows nowhere to set the hostname.

Same journal extract as comment 0

CC: (none) => eeeemail, tmb
Summary: kde live installs do not ask for network configuration. => live installs do not ask for network configuration
Source RPM: drakxtools-15.50-1.mga3.src.rpm => drakxtools
Whiteboard: MGA3TOO => 5beta2

claire robinson 2015-01-12 16:42:35 CET

Blocks: (none) => 14069

Comment 4 Rémi Verschelde 2015-03-20 01:00:50 CET
Thierry, Thomas, any idea about this one?

CC: (none) => remi

Comment 5 Thomas Backlund 2015-03-20 07:57:56 CET
It's by design.

The live medias have been designed to ask as little questions as possible, so if the system detects working network during bootup, it will skip the question.

The real fix would be to move the changing of hostname maybe to the same pages as setting user names or so... but thats a mga6 thing
Comment 6 Rémi Verschelde 2015-03-20 09:28:31 CET
Thanks, adding to the mga6 tracker.

Blocks: 14069 => 15527

Comment 7 claire robinson 2015-03-20 12:57:51 CET
That would be a good resolution for this yes.
Samuel Verschelde 2015-05-16 19:11:36 CEST

Summary: live installs do not ask for network configuration => Live Installed system should ask for hostname at the same time it asks for username
Whiteboard: 5beta2 => (none)
Severity: normal => enhancement

Samuel Verschelde 2015-06-02 10:05:56 CEST

Target Milestone: --- => Mageia 6

Comment 8 Marja Van Waes 2016-07-12 16:57:07 CEST
Moving to the Mga7 tracker, because afaik there is no action with regard to this issue.

@ tmb

Of course, that doesn't mean it is forbidden to fix it before Mga6 is released ;-)

CC: (none) => marja11
Blocks: 15527 => 18932

Comment 9 Samuel Verschelde 2016-10-10 23:24:20 CEST
(In reply to Marja van Waes from comment #8)
> Moving to the Mga7 tracker, because afaik there is no action with regard to
> this issue.

Setting target milestone field to Mageia 7 then.

Target Milestone: Mageia 6 => Mageia 7

Samuel Verschelde 2016-10-10 23:27:36 CEST

Assignee: bugsquad => mageiatools

Samuel Verschelde 2016-11-10 10:36:01 CET

Blocks: 18932 => (none)


Note You need to log in before you can comment on or make changes to this bug.