Bug 9043 - since it's built without BR ffmpeg-devel audacity can't import wma, aac, and mpc audiofiles
Summary: since it's built without BR ffmpeg-devel audacity can't import wma, aac, and ...
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 4
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: http://bugzilla.audacityteam.org/show...
Whiteboard: MGA4-64-OK advisory
Keywords: validated_update
: 10900 (view as bug list)
Depends on:
Reported: 2013-02-12 11:08 CET by Philippe Didier
Modified: 2014-11-15 20:32 CET (History)
16 users (show)

See Also:
Source RPM: audacity
Status comment:

Audacity screenshot for comment 22 (212.05 KB, image/jpeg)
2014-11-05 11:37 CET, DariuszSki

Description Philippe Didier 2013-02-12 11:08:41 CET
In Mageia2 audacity could import wma, aac or mp4, and mpc (musepack) audiofiles.

In Cauldron, since it is built without ffmpeg, audacity complains not being able to do so : need to convert those files into wav audiofiles before using them.

NB the new ffmpeg brought some problems : see bug 8925 
Audacity must be tested after having been built with ffmpeg, and perhaps patched (same way as gstreamer-ffmpeg, audacious-plugin ?)
Philippe Didier 2013-02-12 11:10:03 CET

CC: (none) => fundawang

Philippe Didier 2013-02-12 11:11:10 CET

CC: (none) => cjw

Comment 2 Funda Wang 2013-02-12 12:36:54 CET
And seems that upstream does not care about that :(

URL: (none) => http://bugzilla.audacityteam.org/show_bug.cgi?id=540

Comment 3 Philippe Didier 2013-02-12 19:03:25 CET
Thanks to have tried ...

and yes, sadly, you are right :
 the problem seems even to remain for the last version (2.0.3) released 21st January 2013 :
 the release notes inform that it is still not compiling with very recent versions of ffmpeg... (though it could be built with ffmpeg 0.10.6... in Mageia2)

So there will be a need to add a Warning for Mageia3 about this regression !
Comment 4 Philippe Didier 2013-02-12 19:12:05 CET
Audacity 2.0.3 and 2.0.2 Release notes extract :

"(Linux) Audacity does not currently compile against very recent FFmpeg (0.10 or later are known to be affected) "

that was not true for 0.10 versions of ffmpeg that audacity 2.0.0 could use inside Mageia2 ...

 but that's true for 1.1 version of ffmpeg in Cauldron and audacity 2.0.2
Adrien D 2013-04-15 22:04:54 CEST

CC: (none) => adrien_d

Comment 5 egc 2013-06-04 01:19:24 CEST
This bug is still valid in Mageia 3 Final x86_64 and audacity-2.0.3-2.mga3.
I can not even import WAV files that are not generated by audacity.

It would be very helpful to have a libavformat.so.52 for audacity!

Version: Cauldron => 3
CC: (none) => egc
Hardware: i586 => x86_64

Comment 6 egc 2013-06-27 11:01:14 CEST
It's incredible, even to use Audacity now you need to have MS Windows ...
Comment 7 Alex Loginov 2013-07-31 09:13:28 CEST
There is no import ac3, aac
Audacity works only with libavformat.so.52, but there is no in repo.
For audacity it's better libav instead ffmpeg.

CC: (none) => loginov_alex

claire robinson 2013-07-31 10:45:43 CEST

CC: (none) => eeeemail

Comment 8 claire robinson 2013-07-31 11:55:20 CEST
From the log..

10:35:28: Audacity 2.0.3
10:35:31: Trying to load FFmpeg libraries...
10:35:31: Trying to load FFmpeg libraries from system paths. File name is 'libavformat.so.52'.
10:35:31: Checking for monolithic avformat from 'libavformat.so.52'.
10:35:31: Error: libavformat.so.52: cannot open shared object file: No such file or directory
10:35:31: Loading avutil from 'libavutil.so.50'.
10:35:31: Error: libavutil.so.50: cannot open shared object file: No such file or directory
10:35:31: Loading avcodec from 'libavcodec.so.52'.
10:35:31: Error: libavcodec.so.52: cannot open shared object file: No such file or directory
10:35:31: Loading avformat from 'libavformat.so.52'.
10:35:31: Error: libavformat.so.52: cannot open shared object file: No such file or directory
10:35:31: Error: Failed to load FFmpeg libraries.
10:35:31: Error: Failed to find compatible FFmpeg libraries.

Our ffmpeg is currently libavformat.so.54 and selecting it doesn't seem to work. Selecting it in 'Libraries' in preferences shows this in the log..

10:52:16: Looking for FFmpeg libraries...
10:52:16: mLibAVFormatPath is empty, starting with path '', name 'libavformat.so.52'.
10:52:37: User-specified path = '/usr/lib64/libavformat.so.54'
10:52:37: User-specified FFmpeg file exists. Success.
10:52:37: Trying to load FFmpeg libraries...
10:52:37: mLibAVFormatPath ('/usr/lib64/libavformat.so.54') is not empty. Loading from it.
10:52:37: Checking for monolithic avformat from '/usr/lib64/libavformat.so.54'.
10:52:37: avformat not monolithic
10:52:37: Loading avutil from '/usr/lib64/libavutil.so.50'.
10:52:37: Error: /usr/lib64/libavutil.so.50: cannot open shared object file: No such file or directory
10:52:37: Loading avcodec from '/usr/lib64/libavcodec.so.52'.
10:52:37: Error: /usr/lib64/libavcodec.so.52: cannot open shared object file: No such file or directory
10:52:37: Loading avformat from '/usr/lib64/libavformat.so.54'.
10:52:37: Error: Unknown dynamic library error
10:52:37: Actual avutil path 
10:52:37: Error: Unknown dynamic library error
10:52:37: Actual avcodec path 
10:52:37: Actual avformat path /usr/lib64/libavformat.so.54.59.106
10:52:37: Importing symbols...
10:52:37: Error: Failed to load symbol av_write_header
10:52:37: Trying to load FFmpeg libraries from system paths. File name is 'libavformat.so.52'.
10:52:37: Checking for monolithic avformat from 'libavformat.so.52'.
10:52:37: Error: libavformat.so.52: cannot open shared object file: No such file or directory
10:52:37: Loading avutil from 'libavutil.so.50'.
10:52:37: Error: libavutil.so.50: cannot open shared object file: No such file or directory
10:52:37: Loading avcodec from 'libavcodec.so.52'.
10:52:37: Error: libavcodec.so.52: cannot open shared object file: No such file or directory
10:52:37: Loading avformat from 'libavformat.so.52'.
10:52:37: Error: libavformat.so.52: cannot open shared object file: No such file or directory
10:52:37: Error: Failed to load FFmpeg libraries.
10:52:37: Error: Failed to find compatible FFmpeg libraries.
Sylvain ZUCCA 2013-08-17 12:14:30 CEST

CC: (none) => sylvainsjc

Sander Lepik 2013-08-17 12:21:25 CEST

Assignee: bugsquad => lists.jjorge
CC: (none) => mageia

Comment 9 David Walser 2013-08-21 00:10:37 CEST
If I remember correctly, audacity wasn't compatible with the version of ffmpeg that we shipped in Mageia 3.  We were waiting for this to be corrected upstream in audacity, but it wasn't fixed in time for the Mageia 3 release, so we had to disable the ffmpeg support in audacity.  Whenever audacity fixes this incompatibility and releases a new version, we can backport and ship it for Mageia 3.  As far as I know, they haven't fixed it yet.
Comment 10 David Walser 2013-08-21 00:11:31 CEST
*** Bug 10900 has been marked as a duplicate of this bug. ***

CC: (none) => laidlaws

Comment 11 Dan TOU 2013-11-28 01:37:43 CET
It's the same for me. Nos sound if Audacity and ffmpg are co-existent.

CC: (none) => dantou

Colegota El Villano 2014-01-16 20:11:40 CET

CC: (none) => el_colegota

Comment 12 Steve 2014-04-28 15:06:13 CEST
Any update on this bug ?
It's a PITA having to go to another OS just to manipulate .acc files.

CC: (none) => kin7500-ffrm

Comment 13 Steve 2014-04-28 15:07:56 CEST
Typo ! should say .aac
Comment 14 Doug Laidlaw 2014-04-28 15:12:44 CEST
It would seem not.  I have Version 2.0.5, and from the project's own Wiki:

     Release Notes 2.0.5 

... run FFmpeg using Audacity's command-line encoder. (Linux) Files exported using the '''FFmpeg native AAC encoder''' included with many system versions of FFmpeg are of very poor quality. This is ... the library itself. '''Workaround:''' When compiling FFmpeg, configure with the libfaac encoder thus: --disable-encoder=aac --enable-libfaac. Note that libfaac has an issue not present in the native FFmpeg encoder ...
Comment 15 Doug Laidlaw 2014-04-28 15:17:20 CEST
I hit the wrong key and got into fullscreen mode.

Here is the link:


Scroll down to your version.
egc 2014-04-28 16:50:11 CEST

CC: egc => (none)

Comment 16 Doug Laidlaw 2014-08-15 13:59:02 CEST
Still present in Mga 4.  I have upodated the version number.

Version: 3 => 4

Comment 17 Christiaan Welvaart 2014-10-30 01:41:21 CET
audacity 2.0.6 packages are now in Mageia 4 core/updates_testing. They are built with ffmpeg libraries and should fix the import problem. Please test, e.g.:

- import of WMA or AAC
- one specific audacity feature you use

and report the results. 

AAC encoding is something else: faac is not available in mageia. The ffmpeg AAC encoders (native and vo-aacenc) should work, though.

Assignee: lists.jjorge => cjw

Comment 18 Doug Laidlaw 2014-10-30 02:05:21 CET
Thanks for the advice.  Actually, I  posted on behalf of a user on alt.support.mageia.  I am posting your reply there.
Comment 19 Steve 2014-10-31 21:00:31 CET
Have just tested a .aac file using audacity 2.0.6-1.mga4 (x86_64) from core/updates_testing and it now imports and plays correctly. Thanks for the update.
Comment 20 Christiaan Welvaart 2014-11-03 22:52:36 CET
Reassigning... MGA4-64 tested according to previous comment.

Source RPM:

Binary RPMS:

Proposed description (bugfix update):

Updated audacity packages fix missing codec support:

The Audacity packages in Mageia 4 were not built against FFMPEG libraries, disabling support for import of files with sound in WMA or AAC (MPEG 4 Audio) format. This has been fixed by linking the program directly against those libraries. Audacity has also been updated to version 2.0.6, providing bug fixes and improvements.

Assignee: cjw => qa-bugs

Comment 21 olivier charles 2014-11-04 14:26:45 CET
Testing on Mageia4-64 real hardware

current package :

$ rpm -q audacity

Launched audacity, tried to open a music file encoded in AAC and another one in WMA.
Audacity complained of an Import error, Audacity can't open this type of file.

Installed update-testing package :
- audacity-2.0.6-1.mga4.x86_64

Launched audacity, opened my WMA file and played it with no problem
Opened the M4A file (AAC encoding), couldn't play it.

Installed :
in place of the ffmpeg-2.0.5-1.mga4
could then play the M4A file.

Just to check, leaving tainted ffmpeg, downgraded audacity to previous version. Couldn't play M4A file (AAC encoding) anymore.

Update-testing audacity version fixes missing support for WMA and AAC format.

CC: (none) => olchal
Whiteboard: (none) => MGA4-64-OK

Comment 22 DariuszSki 2014-11-05 11:33:19 CET
Tested the new / test package with the following results of importing videos to Audacity for audio.

flv (flash) - no problems.
mp4 - if user generated ie in Kdenlive or youtube download, no problems.
mpeg2 - if user generated ie in Kdenlive, no problems.
wmv - no problems.
webm - no problems.

Over-air as broadcast recorded files (unedited):
m2t (MPEG2 and MPEG4) - mp2 and AC3 imports but with issue.
ts - mpga imports but with issues as m2t.

With m2t and ts, the audio imports without throwing errors, but the display shows most the track as silence, then for last bit of the display the waveform of the actual video audio is displayed. It does not seem to matter if it's a normal stereo track or AC3 multi-track, they both display the same (will upload screenshot). I do not know why all the blank audio is being inserted before the actual track. Further testing shows there does not seem to be a fixed amount of blank time being insterted into the audio import, but every time you import the track, the same amount of blank is being inserted before the actual audio.

CC: (none) => linuxstuff

Comment 23 DariuszSki 2014-11-05 11:37:06 CET
Created attachment 5576 [details]
Audacity screenshot for comment 22

Screenshot of Audacity and import problem for (unedited) broadcast MPEG2 + MPEG4.
Comment 24 DariuszSki 2014-11-05 11:50:33 CET
Adding to comment 22, using FFMPEG in tained, on x86_64 system.
Comment 25 Christiaan Welvaart 2014-11-05 16:28:42 CET

Thanks for testing! Does MPEG TS (M2T = MPEG2 TS?) import work with the older audacity packages in Mageia 4: the current audacity-2.0.5-1 or the original audacity-2.0.4-3 ?
Comment 26 DariuszSki 2014-11-05 17:34:53 CET
Jsut to point out, I have not installed any updates to ffmpeg from testing (if there are any), I am using what there is in the normal install, but all up to date.

From Audacity activity log:
16:29:21: Audacity 2.0.6
16:29:21: Retrieving FFmpeg library version numbers:
16:29:21:    AVCodec version 0x371266 - 55.18.102 (built against 0x371266 - 55.18.102)
16:29:21:    AVFormat version 0x370c64 - 55.12.100 (built against 0x370c64 - 55.12.100)
16:29:21:    AVUtil version 0x342664 - 52.38.100 (built against 0x342664 - 52.38.100)

As for Audacity version, 2.0.5 and ALL versions before it for the past approximate two years refused to import ANY video clip for editing of audio. Didn't work with any Audacity versions in Mageia3, and except this test version, doesn't work in Mageia4 releases either. Audacity last worked for me with importing audio from video clips in Mageia2.
Comment 27 Christiaan Welvaart 2014-11-05 18:10:04 CET

I may have managed to reproduce the MPEG2 TS import issue in cauldron: the 24s of audio was still imported but with a lot of silence in front of it. As a workaround I managed to import the audio after converting the format (without changing the data in the audio and video tracks) using ffmpeg:

ffmpeg -i myvideo.ts -c copy myvideo.mp4

Anyway, this issue should not stop the update.
Comment 28 Rémi Verschelde 2014-11-08 14:27:28 CET
Advisory uploaded.

CC: (none) => remi
Whiteboard: MGA4-64-OK => MGA4-64-OK advisory

Comment 29 Herman Viaene 2014-11-11 10:06:07 CET
Test on MGA4-64
wav file created with audacity (version ??? in MGA3) is OK.
Converted file to ac3:
Error on Audacity 2.0.5, file does not getting imported.
On Audacity 2.0.6 , the file is imported and the wave-forms displayed, but only 0.15 seconds of it. Audacity seems play the file.
Surely, the ac3 file plays with KMplayer.

Trying to play an mpg video file with Audacity 2.0.5, results in a message that the audio info should be extracted into a separate audio file
Audacity 2.0.6 starts opening the file, but after a few seconds aborts, leaving message on the CLI:
(Audacity:23132): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
audacity: layer3.c:2633: mad_layer_III: Assertion `stream->md_len + md_len - si.main_data_begin <= (511 + 2048 + 8)' failed.
But in my opinion, the mpg affair is a non-issue. Audacity in it user manual nowhere claims to be handling video files. That it has done so before might be a side effect of using some particular filter in the past. If the developers decide to change these, then there is no guarantee, nor they claim so, that Audacity should process video files.

CC: (none) => herman.viaene

Comment 30 Christiaan Welvaart 2014-11-11 10:44:45 CET
I could import AC3 audio from a video file (.mkv) without issues, got 6 tracks with 43 minutes of audio.

How did you convert the wav file to AC3, with audacity?

.MPG (movie) files with MPEG Audio Layer 2 also get imported.. Tested both in cauldron and MGA4. 

Your error is with MPEG Audio Layer 3 ... But all MPEG files with video I could find have layer 2 audio, while MP3 files (without video track) get imported OK in MGA4.

Anyway, if I understand correctly you did not find any serious regressions in the 2.0.6 package compared to 2.0.5.
Comment 31 Herman Viaene 2014-11-11 10:47:53 CET
Converted with Konvertible.
No regressions found, indeed.
Comment 32 Rémi Verschelde 2014-11-15 19:56:40 CET
This has been tested by at least three persons on mga4 64bit, so let's validate.

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 33 Mageia Robot 2014-11-15 20:32:35 CET
An update for this issue has been pushed to Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.