Bug 8187 - Firefox crashes when opening adblock plus' configuration screen
Summary: Firefox crashes when opening adblock plus' configuration screen
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 2
Hardware: All Linux
: Normal critical
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2012-11-23 16:55 CET by Gaël Duperrey
Modified: 2013-08-28 15:42 CEST (History)
2 users (show)

See Also:
Source RPM: firefox-10.0.10-1.mga2.src.rpm
CVE:
Status comment:


Attachments

Description Gaël Duperrey 2012-11-23 16:55:14 CET
Description of problem:
When you try to install adblock plus for the first time on firefox, from addons.mozilla.org (after a fresh Mageia install from DVD, and a new user), it crashes with a segfault. If you start firefox again, when you will try to configure adblock plus (filters preferences) it will crash each time with a segmentation fault. After some time, when the extension is updated in automatic, it crashes all the time with the segmentation fault (probably it tries to open the configuration page).

I encountered the problem on i586 and x86_64. I reproduced in a virtual machine too.

It could be similar to bug #6299 since the following workaround works:
* urpmi libproxy-webkit
* urpme libprojy-mozjs


Steps to Reproduce:
1.On a new profile of firefox
2.go to the website of addons for firefox (https://addons.mozilla.org/fr/firefox/addon/adblock-plus/?src=ss) and install it
3. just after the install it crashed
4. launch firefox again and try to go to the page to configure it. When you try to edit the filter's preferences, it crashed each time.

Here the stacktrace with gdb :

(gdb) run
Starting program: /usr/bin/firefox
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i686/libthread_db.so.1".
Detaching after fork from child process 3947.
Detaching after fork from child process 3952.
Detaching after fork from child process 3953.
OpenGL Warning: glXChooseFBConfig returning NULL, due to attrib=0x8010, next=0x2
[New Thread 0xb3d44b70 (LWP 3954)]
[New Thread 0xb2f54b70 (LWP 3955)]
[New Thread 0xb2753b70 (LWP 3956)]
[New Thread 0xb1dffb70 (LWP 3957)]
[New Thread 0xb134fb70 (LWP 3958)]
[New Thread 0xb0b4eb70 (LWP 3959)]
[New Thread 0xaf8ffb70 (LWP 3960)]
[New Thread 0xaeeffb70 (LWP 3961)]
[New Thread 0xae2ffb70 (LWP 3962)]
[New Thread 0xadafeb70 (LWP 3963)]
[New Thread 0xad0ffb70 (LWP 3964)]
[New Thread 0x8c5ffb70 (LWP 3965)]
[New Thread 0x8bbffb70 (LWP 3966)]
[New Thread 0x8b3feb70 (LWP 3967)]
[New Thread 0x8a8cab70 (LWP 3968)]
[New Thread 0x8a0c9b70 (LWP 3969)]
[New Thread 0x898c8b70 (LWP 3970)]
[New Thread 0x88cffb70 (LWP 3971)]
[New Thread 0x880ffb70 (LWP 3972)]
[New Thread 0x878feb70 (LWP 3973)]
[New Thread 0x869ffb70 (LWP 3976)]

Program received signal SIGSEGV, Segmentation fault.
0x8a9c255d in ?? () from /usr/lib/libmozjs185.so.1.0

(gdb) bt full
#0  0x8a9c255d in ?? () from /usr/lib/libmozjs185.so.1.0
No symbol table info available.
#1  0x8a91ca77 in ?? () from /usr/lib/libmozjs185.so.1.0
No symbol table info available.
#2  0x8a951f94 in ?? () from /usr/lib/libmozjs185.so.1.0
No symbol table info available.
#3  0xb702d75f in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#4  0xb703281f in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#5  0xb7040039 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#6  0xb704088b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#7  0xb704098b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#8  0xb7057341 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#9  0xb702f65f in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#10 0xb7040039 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#11 0xb704088b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#12 0xb6fc60cc in JS_CallFunctionValue () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#13 0xb6632aaa in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#14 0xb6690bdf in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#15 0xb64b60df in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#16 0xb64b6388 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#17 0xb64d41e2 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#18 0xb64d5085 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#19 0xb64d5387 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#20 0xb641463d in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#21 0xb69a7e8b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#22 0xb703ff27 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#23 0xb702eaec in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#24 0xb7040039 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#25 0xb704088b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#26 0xb704098b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#27 0xb705f2bd in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#28 0xb702ea1f in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#29 0xb7040039 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#30 0xb704088b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#31 0xb6fc60cc in JS_CallFunctionValue () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#32 0xb65fab2b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#33 0xb65ea5d5 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#34 0xb66068d0 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#35 0xb61f5f50 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#36 0xb6610950 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#37 0xb66160b5 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#38 0xb6616be7 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#39 0xb6616ed5 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#40 0xb602857a in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#41 0xb60fb98b in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#42 0xb60087ce in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#43 0xb60088c8 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#44 0xb6e5ddc2 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#45 0xb6e7349f in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#46 0xb6e33838 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#47 0xb6d7fdf3 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#48 0xb6ea1d40 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#49 0xb6c9695d in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#50 0xb6ad6f37 in ?? () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#51 0xb5febf06 in XRE_main () from /usr/lib/firefox-10.0.10/libxul.so
No symbol table info available.
#52 0x080497f6 in ?? ()
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#53 0xb7d433e3 in __libc_start_main () from /lib/i686/libc.so.6
No symbol table info available.
#54 0x08049a59 in _start ()
No symbol table info available.



If you install the addon with the rpm "firefox-ext-adblock-plus", there isn't any problem. It works fine.
Comment 1 Luis Menina 2012-11-24 02:34:32 CET
Confirming, on x86_64 install. The problem is quite critical, as I just couldn't run firefox anymore, it just kept crashing at startup. Unfortunately, the stack trace above is not very useful as debug symbols were not enabled.

It seems Adblock Plus 2.2 has a bug that makes Firefox 10.x to crash. It is supposed to be fixed in 2.2.1, and some users reported it did, but it didn't work for me. Installing a version prior to when the bug was introduced (2.1 in my test) leads to the same results, so maybe mageia's 10.0.11 has a problem here. I'm going to try with official Mozilla builds to see if the problem is there too.
Comment 2 Luis Menina 2012-11-24 03:22:09 CET
The crash doesn't happen on Mozilla's build of Firefox 10.0.11 (even using Adblock Plus 2.2), but it does with Mageia's build of 10.0.11. FYI, both versions I tested are 64 bits.
Comment 3 Luis Menina 2012-11-24 03:28:49 CET
Changing severity to critical as in my case, Firefox ended up crashing at each run, before any UI was shown, and with no other user action (as if the first thing it wanted to do was showing something adblock-related wich triggered the crash). Only moving my profile out of the way allowed me to run Firefox again.
Comment 4 Luis Menina 2012-11-24 03:36:16 CET
Oh, and in my case, the bug first happened on my day-to-day profile, not on a new one like in comment 1. It also happens on a fresh one too, of course. Adblock Plus makes Firefox crash during the install too, not only when the user tries to show Adblock config panel.
Comment 5 Manuel Hiebel 2012-11-24 10:12:16 CET
does firefox 17 in updates_testing working ?
does the suggested workaround working ?
Comment 6 Luis Menina 2013-08-28 15:33:45 CEST
As I already said, that was an Adblock Plus bug, not a Firefox one. An that's too late for me to test, as I've switched to Mageia 3. The original poster might be able to do it...
Comment 7 Gaël Duperrey 2013-08-28 15:37:13 CEST
I've switched to Mageia 3 too and i hasn't this problem since.
Comment 8 Samuel Verschelde 2013-08-28 15:42:24 CEST
And I still have Mageia 2 but never got this problem. And I think it might have been fixed in bug #6299. Let's close it.

Note You need to log in before you can comment on or make changes to this bug.