Bug 7659 - Update linux kernel to version >= 3.5 (current stable is 3.3.4) OR backport wacom driver into an earlier version for Intuos 5 support
: Update linux kernel to version >= 3.5 (current stable is 3.3.4) OR backport w...
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 2
: All Linux
: Normal Severity: enhancement
: ---
Assigned To: Jehan Hysseo
:
:
:
:
: 8068
:
  Show dependency treegraph
 
Reported: 2012-10-01 13:01 CEST by Jehan Hysseo
Modified: 2013-01-18 07:39 CET (History)
1 user (show)

See Also:
Source RPM: kernel-desktop
CVE:


Attachments
Backport of wacom driver from 3.5.4 into 3.4.11 linux kernel (in particular Wacom Intuos 5 support) (43.41 KB, patch)
2012-10-02 19:31 CEST, Jehan Hysseo
Details | Diff

Description Jehan Hysseo 2012-10-01 13:01:18 CEST
Wacom tablets are the most used graphical tablets, and Intuos 5 is the last of them. It has now been out for exactly 6 months and is not supported by Mageia (when I say *not supported*, I don't even mean it is an expensive mouse, but rather a brick: you plug, nothing happens).
The reason is that it is supported since Linux Kernel 3.5.

If Mageia 3 was out in a few month, I say that's no big deal. But we have like nearly one year to wait, so that will make more than a year without a support of the latter version of the most used graphical tablet, which would basically push digital artists out of our distribution.

So I have tried the desktop kernels 3.5.3 and 3.5.4 from cauldron for the last 2 weeks (on 2 machines, mine where I test; and the one of an animator artist who works with her Intuos 5 every day). Works great.

I would suggest 2 solutions:

- update Mageia 2 to version >= 3.5.

- backport the Wacom Intuos 5 feature as a patch to an earlier version of the kernel.

I guess you don't want to upgrade the kernel to 3.5 (though that would be easier, and I would personally prefer), but Thomas Backlund told on the dev mailing list that the plan is to upgrade pretty soon Mageia 2 to kernel 3.4 and that it would be worth patching it with the newer Wacom driver.

Here the discussion on the mailing list: http://thread.gmane.org/gmane.linux.mageia.devel/18602/focus=18623

So I open this ticket as a reminder because it would be great to have this support.

Note also that I have been a packager for a few days (apprentice). So I would be happy to help, and of course test with the Intuos 5.

I tried to compile and build a rpm with the current spec, but failed though, because it seems it is asking me for the already existing patches:

jehan@DarkMarmot ~/rpm/SPECS $ LC_ALL=C rpmbuild -ba kernel.spec
error: File /home/jehan/rpm/SOURCES/linux-3.4.11-mga2.tar.xz: No such file or directory

But I don't know where I must get it from. Not present in the SOURCES/ of Mageia repo. Where do I get/make this from?

Also I am already compiling right now, in parallel, a kernel 3.4.11 from vanilla sources where I simply patched the wacom driver to the last stable version. The driver compiled fine (but the whole kernel is not finished compiling yet, so more news later probably).
Comment 1 Jehan Hysseo 2012-10-02 19:29:19 CEST
Follow up on this topic.
As I said yesterday, I compiled a kernel 3.4.11 and have been using it the whole day. Until now, no problem, no kernel crash, and the Intuos 5 graphic tablet is now working fine with a 3.4 kernel.
I am attaching the patch.

This patch has been made in a pretty simple way, no fancy stuff: I got the vanilla source for kernel 3.4.11 (current stable: http://www.kernel.org/pub/linux/kernel/v3.0/linux-3.4.11.tar.bz2) and replace the 4 following files with their equivalent in 3.5.4 (also stable: http://www.kernel.org/pub/linux/kernel/v3.0/patch-3.5.4.bz2):
linux-3.4.11/drivers/input/tablet/wacom.h
linux-3.4.11/drivers/input/tablet/wacom_sys.c
linux-3.4.11/drivers/input/tablet/wacom_wac.c
linux-3.4.11/drivers/input/tablet/wacom_wac.h

And that works fine. I will continue the test on my own computer for a while.

Also I chose 3.4.11 because Thomas Backlund said there is plan to update Mageia 2 to 3.4 branch, so I assumed it would be 3.4.11.
If you think I should make and test the patch on another version (for instance 3.3.8, current version on Mageia 2), I would do so.

As soon as I get a kernel version preference, I will modify the spec file with adding this patch and propose it. And I will personally test it daily.

Thanks!

P.S.: can I assign this ticket to myself?
Comment 2 Jehan Hysseo 2012-10-02 19:31:38 CEST
Created attachment 2904 [details]
Backport of wacom driver from 3.5.4 into 3.4.11 linux kernel (in particular Wacom Intuos 5 support)

I assigned the bug to myself. If I am not allowed to do it, please tell me. Sorry I don't know assignment rules yet.
Comment 3 Thomas Backlund 2012-10-08 23:18:48 CEST
There is now 3.4.13 series of core, -tmb and -rt kernels in updates_testing that have Intuos 5 support, please test it out...
Comment 4 Jehan Hysseo 2012-10-09 13:27:31 CEST
Hi,

just tested the Desktop kernel. Worked well, nothing particular to report (= good). I will test the 2 others later (as I have to reboot). And in particular I will install the desktop one on my graphical artist's computer, as she is the one actually using the Intuos 5 daily (other than just making a 2-minute test). If she reports no issue (or if she does report one), I will tell it here in a few days.
Comment 5 Jehan Hysseo 2012-10-16 16:12:45 CEST
Thomas > so we used this kernel for the last week. And in particular my friend graphical animator used her Intuos 5 daily, and very intensively (hours and hours every day on GIMP, and other, with the tablet) with this patched kernel.

Nothing particular to report (Intuos 5 works, no crash).
We are going to leave for 2 weeks from Thursday, so I won't be able to report anything else or answer any question, except from today. If you plan on releasing the update, I would say you could consider it works (as for this patch at least).
Thanks!
Comment 6 Thomas Backlund 2013-01-18 01:54:11 CET
Update pushed:
https://wiki.mageia.org/en/Support/Advisories/MGASA-2013-0010
Comment 7 Jehan Hysseo 2013-01-18 07:39:46 CET
Awesome, thanks!

That's not showing up yet in the repositories, but I guess there is some syncing time to take into account.
Thanks again!

Note You need to log in before you can comment on or make changes to this bug.