Bug 6181 - Can't Start Arduino in Mageia 2 x86-64
: Can't Start Arduino in Mageia 2 x86-64
Status: RESOLVED OLD
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 2
: All Linux
: Normal Severity: normal
: ---
Assigned To: Mageia Bug Squad
:
:
:
:
: 5411
:
  Show dependency treegraph
 
Reported: 2012-05-31 04:12 CEST by Jan Pihlgren
Modified: 2013-11-23 16:16 CET (History)
6 users (show)

See Also:
Source RPM: rxtx-2.1.7.2-2.mga2, arduino
CVE:
Status comment:


Attachments

Description Jan Pihlgren 2012-05-31 04:12:11 CEST
Description of problem:


The same as in bug 5411
I now have test the problem in Mageia 2 final.
The workaround is the same.
Comment 1 Marja van Waes 2012-05-31 18:45:15 CEST
(In reply to comment #0)
> Description of problem:
> 
> 
> The same as in bug 5411
> I now have test the problem in Mageia 2 final.
> The workaround is the same.

Thanks, Jan.

We have started to put "MGA2TOO" on the whiteboard of cauldron bugs that are also valid for Mageia 2 (and even MGA1TOO when a bug is also valid for Mageia 1), so you don't need to copy a report for a different Mageia version anymore
Comment 2 Alejandro Vargas 2012-06-03 14:12:42 CEST
Please, can you try the packets from Blogdrake and report for bugs?

http://ftp.blogdrake.net/mageia/mageia2/free/noarch/arduino-1.0-11bdk.mga2.noarch.rpm

(and dependences)
Comment 3 Jan Pihlgren 2012-06-03 14:36:48 CEST
When I try to install the mentioned package I get the following error message:
(translated from Swedish)
Some asking packages can't be installed:
arduino-1.0-11bdk.mga2.noarch (because of
 insufficient arduino-core(== 1.1.0-11bdk.mga2])
Do yu want to proceed anyway?

I answered NO.
Comment 4 Alejandro Vargas 2012-06-03 16:34:26 CEST
You will need to add the hole repository: free/noarch and free/i586 or free/x86_64 because there is no only one package for Arduino. It needs arduino, arduino-core, arduino-doc, arduino-suexec and the new libraries for rxrx that are binaries (specific for your platform). Google for info about adding extra repositories.
Comment 5 Jan Pihlgren 2012-06-03 17:30:55 CEST
I have installed the following package:
arduino       noarch
arduino-core  noarch
arduino-doc   noarch

No more package available.

I have the arduino upp and running.
 What I informed about is that in x86-64 the problem is the same as in i586 (bugg 5411)  
So the bugg still exist and have to be solved.
Comment 6 Alejandro Vargas 2012-06-03 17:47:42 CEST
Jan: you missed the installation of the platform-specific files.

You have 2 alternatives:

1) add the repositories:

For i586

urpmi.addmedia --wget --update BDK-Free-i586 ftp://ftp.blogdrake.net/mageia/mageia2/free/i586/
urpmi.addmedia --wget --update BDK-Free-noarch ftp://ftp.blogdrake.net/mageia/mageia2/free/noarch/
urpmi.addmedia --wget --update BDK-NonFree-noarch ftp://ftp.blogdrake.net/mageia/mageia2/non-free/noarch/
urpmi.addmedia --wget --update BDK-NonFree-i586 ftp://ftp.blogdrake.net/mageia/mageia2/non-free/i586/

For x86_64

urpmi.addmedia --wget --update BDK-Free-x86_64 ftp://ftp.blogdrake.net/mageia/mageia2/free/x86_64/
urpmi.addmedia --wget --update BDK-Free-noarch ftp://ftp.blogdrake.net/mageia/mageia2/free/noarch/
urpmi.addmedia --wget --update BDK-NonFree-noarch ftp://ftp.blogdrake.net/mageia/mageia2/non-free/noarch/
urpmi.addmedia --wget --update BDK-NonFree-x86_64 ftp://ftp.blogdrake.net/mageia/mageia2/non-free/x86_64/

And then: 

urpmi arduino





2) download all the requested files to a specific directory and install all of them:

mkdir /tmp/arduino
cd /tmp/arduino

For i586:
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/i586/arduino-suexec-1.0-1bdk.mga2.i586.rpm
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/i586/librxtx2.2-2.2-0.2.pre2bdk.mga2.i586.rpm
ftp://ftp.blogdrake.net/mageia/mageia2/free/i586/rxtx-2.2-0.2.pre2bdk.mga2.i586.rpm

For x86_64:
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/x86_64/arduino-suexec-1.0-1bdk.mga2.x86_64.rpm
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/x86_64/lib64rxtx2.2-2.2-0.2.pre2bdk.mga2.x86_64.rpm
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/x86_64/rxtx-2.2-0.2.pre2bdk.mga2.x86_64.rpm


For all platforms:
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/noarch/arduino-1.0-11bdk.mga2.noarch.rpm
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/noarch/arduino-core-1.0-11bdk.mga2.noarch.rpm
wget ftp://ftp.blogdrake.net/mageia/mageia2/free/noarch/arduino-doc-1.0-11bdk.mga2.noarch.rpm

Then, from this directory and as root install all of this packages:

cd /tmp/arduino
urpmi *rpm
Comment 7 Alejandro Vargas 2012-06-18 14:11:20 CEST
I has been working on a new version of Arduino that can run without suexec.

I solved the permissions problems with udev rules. You can find the sources here:

ftp://ftp.blogdrake.net/incoming/SRPMS/arduino-1.0.1-13bdk.mga2.src.rpm
Comment 8 Alejandro Vargas 2013-06-19 10:42:36 CEST
Just informing that I created an RPM packet for Mageia 3

The official Mageia binaries does not work. Also, Mageia binaries has another problem: it uses a newer version of AVR-GCC that is not compatible with all Arduino sources. Then I created a new packet based on the official binaries with a little changes. The packet "just works" and don't need to change any permissions or groups.


Instruction for usage:

For 32 bits:

Alternative 1 (better because it auto-updates with new versions):

Code:
urpmi.addmedia --wget --distrib http://ftp.blogdrake.net/mageia/mageia3/i586 
urpmi arduino
Alternative 2 (manual install):

Code:
urpmi http://ftp.blogdrake.net/mageia/mageia3/free/i586/arduino-1.0.5-1bdk.mga3.i586.rpm
For 64 bits:
Alternative 1 (better because it auto-updates with new versions):

Code:
urpmi.addmedia --wget --distrib http://ftp.blogdrake.net/mageia/mageia3/x86_64 
urpmi arduino
Alternative 2 (manual install):

Code:
urpmi http://ftp.blogdrake.net/mageia/mageia3/free/x86_64/arduino-1.0.5-1bdk.mga3.x86_64.rpm

The packet is also available for mageia 2 and should work in other rpm based distros.

Explanation of the changes:
The packet includes all the official binaries for maximum compatibility except for:
I replaced the RXTX library with the following changes from official binaries:
Disabled port locking avoiding the need of adding the user to lock group
Added /dev/ttyACM and /dev/arduino devices
I added a new udev rule that:
Sets the default permissions of the arduino device to 666 for avoiding the need of adding the user to dialout group.
Added a link to the device named arduino for auto creating the /dev/arduino device

"Source" (not really source because it uses official binaries) packet available at: http://ftp.blogdrake.net/mageia/mageia3/SRPMS/arduino-1.0.5-1bdk.mga.src.rpm
Comment 9 Manuel Hiebel 2013-10-22 12:20:04 CEST
This message is a reminder that Mageia 2 is nearing its end of life.
Approximately one month from now Mageia will stop maintaining and issuing updates for Mageia 2. At that time this bug will be closed as WONTFIX (EOL) if it remains open with a Mageia 'version' of '2'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Mageia version prior to Mageia 2's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Mageia 2 is end of life.  If you would still like to see this bug fixed and are able to reproduce it against a later version of Mageia, you are encouraged to click on "Version" and change it against that version of Mageia.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Mageia release includes newer upstream software that fixes bugs or makes them obsolete.

-- 
The Mageia Bugsquad
Comment 10 Manuel Hiebel 2013-11-23 16:16:11 CET
Mageia 2 changed to end-of-life (EOL) status on ''22 November''. Mageia 2 is no
longer maintained, which means that it will not receive any further security or
bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of Mageia
please feel free to click on "Version" change it against that version of Mageia
and reopen this bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

--
The Mageia Bugsquad

Note You need to log in before you can comment on or make changes to this bug.