Bug 6120 - missing libraries "libsane-mustek_usb2"
Summary: missing libraries "libsane-mustek_usb2"
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 2
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: mga2-32-ok mga2-64-ok
Keywords: Junior_job, PATCH, Triaged, validated_update
Depends on:
Reported: 2012-05-27 23:08 CEST by nexus nexus
Modified: 2013-09-20 07:48 CEST (History)
12 users (show)

See Also:
Source RPM: sane-1.0.22-7.1.mga2.src.rpm
Status comment:


Description nexus nexus 2012-05-27 23:08:36 CEST
Description of problem:
I have the "Mustek BearPaw 2448TA Pro" scanner and it is not detected by the Mageia 2. From what I checked the cause may be the lack of library "libsane-mustek_usb2".
In the source "ftp://ftp2.sane-project.org/pub/sane/sane-backends-1.0.22/" this file is present, as in other distributions such as Fedora.

Version-Release number of selected component (if applicable):

How reproducible:
No file "libsane-mustek_usb2.so*" in "/usr/lib64/sane/".

Steps to Reproduce:
Manuel Hiebel 2012-05-28 11:17:48 CEST

Keywords: (none) => Junior_job
Source RPM: sane-backends-1.0.22-7.mga2.x86_64.rpm => sane

Comment 1 nexus nexus 2012-12-19 00:51:19 CET
(In reply to comment #0)
> Description of problem:
> I have the "Mustek BearPaw 2448TA Pro" scanner and it is not detected by the
> Mageia 2. From what I checked the cause may be the lack of library
> "libsane-mustek_usb2".
> In the source "ftp://ftp2.sane-project.org/pub/sane/sane-backends-1.0.22/" this
> file is present, as in other distributions such as Fedora.
> Version-Release number of selected component (if applicable):
> sane-backends-1.0.22-7.mga2.x86_64.rpm
> How reproducible:
> No file "libsane-mustek_usb2.so*" in "/usr/lib64/sane/".
> Steps to Reproduce:
> 1.
> 2.
> 3.

Probably I found solution of the problem:

But I do not know how to create the correct rpm file with this solution.
Can someone help me with this?
Comment 2 nexus nexus 2012-12-23 19:43:52 CET
The lack of any response from half of the year. Maybe something will change after the change of the priority?
nexus nexus 2012-12-23 19:47:03 CET

Target Milestone: --- => Mageia 3
Priority: Normal => release_blocker
CC: (none) => nexus9
Severity: normal => critical

Comment 3 Manuel Hiebel 2012-12-23 22:08:07 CET
not necessarily
Comment 4 Christiaan Welvaart 2012-12-24 06:42:31 CET
Changing the priority doesn't help a bit, but nagging sometimes helps. BTW there are several other bugs about scanners not working (mostly epson so probably not related to this issue).

The problem here is that enabling the 2 missing backends requires flipping a global switch that also modifies some of the other backends. This is generally not acceptable for a stable release. Instead, I changed the configure script to just build those 2 backends with pthreads (AFAICT all the other backends do not use pthreads at all). This is of course not supported by upstream so still quite risky. This updated package is now in mga2 updates_testing. Getting it released as an update will require some (1 or 2) people to verify if the existing backends still work. I have no idea if/how we are going to do this - I do not have a scanner so could not test this package at all.

Please test with sane packages 1.0.22-7.1.mga2 .

Priority: release_blocker => Normal
CC: (none) => cjw
Target Milestone: Mageia 3 => ---
Severity: critical => normal

Comment 5 nexus nexus 2012-12-27 13:16:01 CET
With "Mustek BearPaw 2448TA Pro" scanner work excellent!!! Thank you very much.
I hope that this change does not broke handle other scanners and will go to the stable version of Mageia 2 (also 3).
Comment 6 Morgan Leijström 2013-05-30 01:13:56 CEST
Can you arrange one in mga3 updates testing please?
I have an Epson perfection 1660 photo that worked on mga1 but not mga3.
(i skipped mga2 here in my office)

BTW there are some posts on [discuss] ml today about general epson problems.

CC: (none) => fri

Comment 7 Morgan Leijström 2013-05-30 01:23:04 CEST
*** Bug 7018 has been marked as a duplicate of this bug. ***

CC: (none) => jcm

Helge Hielscher 2013-06-03 18:01:18 CEST

CC: (none) => hhielscher

Comment 8 Samuel Verschelde 2013-08-28 22:42:33 CEST
So, if I'm correct, there's an update candidate for Mageia 2, but it wasn't pushed to updates, and there's a request for the same fix in Mageia 3. What about cauldron?

Assigning to the maintainer by the way.

Keywords: (none) => PATCH, Triaged
CC: (none) => stormi
Assignee: bugsquad => dmorganec

Comment 9 Rémi Verschelde 2013-09-07 11:41:21 CEST
IIUC, Christiaan provided a patch to sane (sane-backends-1.0.23-have-pthread.patch) which fixes this bug.

An updated package was pushed to 2/core_updates-testing (see http://mageia.madb.org/package/show/release/2/application/0/name/sane-backends), and the patch was also included in Cauldron at that time (thus making it in 3/core_release, and it is still present in 4/core_release).

AFAIC, this bug should be assigned to QA for validation on Mageia 2 only.

@Morgan: It seems to me that bug 7018 is not a duplicate of this bug. The Mageia 3 package also contains the fix from comment 4, so you are likely hit by another bug (which should be discussed in another bug report).

CC: (none) => remi

Comment 10 Morgan Leijström 2013-09-07 12:06:08 CEST
Reopened 7018, asking reporter for input
Comment 11 Rémi Verschelde 2013-09-07 18:50:38 CEST
Assigning to QA for testing on Mageia 2.

sane should be tested against all types of scanners, to see if everything still works as intended (it's worth noting that the patch is also used in Mageia 3 and cauldron). nexus confirmed in comment 5 that the update candidate works on Mageia 2 64bit.

SRPM: sane-1.0.22-7.1.mga2.i586.rpm

Assignee: dmorganec => qa-bugs

Rémi Verschelde 2013-09-07 18:51:46 CEST

Source RPM: sane => sane-1.0.22-7.1.mga2.i586.rpm

Comment 12 Rémi Verschelde 2013-09-07 18:53:40 CEST
Small mistake in last comment, the SRPM should be:

Source RPM: sane-1.0.22-7.1.mga2.i586.rpm => sane-1.0.22-7.1.mga2.src.rpm

Comment 13 nexus nexus 2013-09-10 13:52:24 CEST
With "Mustek BearPaw 2448TA Pro" and Mageia 3 also works perfectly.
Comment 14 Dave Hodgins 2013-09-12 22:57:00 CEST
Which two backends were changed? We need an advisory, before this can
be validated.

CC: (none) => davidwhodgins

Comment 15 claire robinson 2013-09-16 14:20:31 CEST
# urpmf libsane1 | grep libsane-mustek_usb

# urpmf libsane1 --media Testing | grep libsane-mustek_usb

Canon scanner works as well after the update as it did before in vbox.
Comment 16 claire robinson 2013-09-16 14:20:44 CEST
Mageia 2

exact match

*** Arch: i586 ***

RPMs from 'core-updates_testing'

SRPMs from 'core-updates_testing'

*** Arch: x86_64 ***

RPMs from 'core-updates_testing'

SRPMs from 'core-updates_testing'
claire robinson 2013-09-16 14:21:01 CEST

Whiteboard: (none) => mga2-32-ok?

Comment 17 claire robinson 2013-09-16 18:33:43 CEST
$ urpmf lib64sane1 | grep libsane-mustek_usb

$ urpmf lib64sane1 --media Testing | grep libsane-mustek_usb

Testing with canon scanner mga2 64

Anybody else have scanners to test with?

Whiteboard: mga2-32-ok? => mga2-32-ok? mga2-64-ok?

Comment 18 Bill Wilkinson 2013-09-18 02:29:11 CEST
Downloaded updates for mga2-32, as that's my only machine with a SCSI card.  tested with HP ScanJet 5p SCSI, all OK, no regressions.

CC: (none) => wrw105

Comment 19 William Kenney 2013-09-18 16:43:47 CEST
(In reply to claire robinson from comment #17)

> Anybody else have scanners to test with?

The only thing I can add here is that I have an HP scanner
and XSane on M2 & M3 have always worked just fine for me.

CC: (none) => wilcal.int

Comment 20 Dave Hodgins 2013-09-19 03:12:56 CEST
I've tested with a cannon pixma mp150 all in one.

We still need an advisory before the update can be validated.
Comment 21 Dave Hodgins 2013-09-19 23:21:04 CEST
Advisory 6120.adv committed to svn. Validating the update.

Someone from the sysadmin team please push 6120.adv to updates.

Keywords: (none) => validated_update
Whiteboard: mga2-32-ok? mga2-64-ok? => mga2-32-ok mga2-64-ok
CC: (none) => sysadmin-bugs

Comment 22 Thomas Backlund 2013-09-20 07:48:20 CEST
Update pushed:

CC: (none) => tmb
Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.