Bug 6104 - Live CD doesn't boot on Dell Latitude with wide screen
Summary: Live CD doesn't boot on Dell Latitude with wide screen
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: 2
Hardware: i586 Linux
Priority: High major
Target Milestone: Mageia 3
Assignee: Mageia Bug Squad
QA Contact:
Depends on:
Reported: 2012-05-26 18:08 CEST by Thomas Spuhler
Modified: 2012-12-31 22:29 CET (History)
5 users (show)

See Also:
Source RPM:
Status comment:


Description Thomas Spuhler 2012-05-26 18:08:54 CEST
Live CD starts but then cannot show anything on the screen when it should start asking config questions
Teh same happens when on the docking station when a wide screen monitor is connected. There is no problem on the docking station with a 1280x1024 size monitor

This problem wasn't there with the RC
Comment 1 Reco Sambi 2012-05-26 19:51:06 CEST
I can confirm it. 

The screen of my laptop turns off and the keyboard seems to not function, so I can't install mageia 2 using the liveCD.

RC version worked perfectly. Tested on both 32 and 64 bits.

CC: (none) => recosambi

Comment 2 Manuel Hiebel 2012-05-28 12:46:09 CEST
strange, and your graphic card is ?

CC: (none) => mageia, sysadmin-bugs, tmb
Component: Installer => Release (media or process)
Target Milestone: --- => Mageia 3

Comment 3 Thomas Spuhler 2012-05-28 18:07:19 CEST
Hardrake reports:
Comment 4 Reco Sambi 2012-05-28 18:49:27 CEST
I have two PC's with Intel graphic cards.
Comment 5 Lutz Lacher 2012-05-29 12:50:22 CEST
Same problem here, GPU is 
[root@localhost ~]# lspci | grep -i disp
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)

Last line i see at normal boot:

using '/etc/ld.so.conf.d/GL/standard.conf to provide gl_conf'

then the screen goes black and i can only reboot with sysreq b

Booting works if boot into runlevel 3, start drakx11, test screen and then change to runlevel 5

CC: (none) => l.lacher

Comment 6 Lutz Lacher 2012-05-30 11:30:57 CEST
After some further testing i found another workaround:

add xdriver=vesa to kernel command and it boots to gui directly
Comment 7 Reco Sambi 2012-06-02 13:08:37 CEST
Yes, using workaround in comment 6 allows me to load the live cd. After installing I can use the intel driver perfectly.
Comment 8 Reco Sambi 2012-06-22 20:37:26 CEST
Don't you think this bug should appear in the Errata? Here you can see another affected user: http://linuxblog.darkduck.com/2012/06/mageia-2-kde-first-glance.html . See the first paragraph of section "First boot"

The text in the Errata could be something like:

LiveCDs may not boot when using an intel graphic card. To workaround it add xdriver=vesa to kernel command and the system will boot. Once installed you can use the intel driver without any problem.
Comment 9 Thomas Spuhler 2012-07-08 11:17:02 CEST
No, it boots correctly if the connected monitor has a ratio of 1280x1024
Comment 10 Reco Sambi 2012-10-15 22:16:56 CEST
It also happens with Mageia 3 alfa 2
Comment 11 Thomas Spuhler 2012-11-24 00:29:04 CET
I am going to increase severity

Priority: Normal => High

Comment 12 Lutz Lacher 2012-12-11 23:26:46 CET
It's still valid for me with Mga 3a3.

IMHO the problem is that there are two modules missing in initrd:


I've created a modified initrd with the modules above added and it boots to RL5 direcly with the intel driver (at least on my machine, ymmv).
Comment 13 Thomas Spuhler 2012-12-15 18:43:14 CET
Could someone create a live CD with his patch included. I would be glad to test.
Comment 14 Reco Sambi 2012-12-20 18:57:26 CET
This seems fixed with mageia 3 beta 1. I have been able to boot the 5 times I tried.

Comment 15 Lutz Lacher 2012-12-20 23:06:59 CET
Yes, fixed for me too with 3 beta 1
Comment 16 Thomas Spuhler 2012-12-31 22:29:18 CET
seems to work here too with mga3 b1.
So I will close it as solved.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.