Bug 6026 - Evolution 3.4.1 in Mga2 no smtp auth after upgrade from Evolution 2.32 and Mga1
: Evolution 3.4.1 in Mga2 no smtp auth after upgrade from Evolution 2.32 and Mga1
Status: RESOLVED WORKSFORME
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 2
: i586 Linux
: High Severity: major
: ---
Assigned To: Mageia Bug Squad
:
: http://www.eracc.com/other/screen-sho...
:
: Triaged
:
:
  Show dependency treegraph
 
Reported: 2012-05-22 21:27 CEST by Gene Alexander
Modified: 2013-08-27 17:33 CEST (History)
3 users (show)

See Also:
Source RPM: evolution-3.4.1-1.mga2.src.rpm
CVE:
Status comment:


Attachments

Description Gene Alexander 2012-05-22 21:27:44 CEST
Description of problem:
Evolution 3.4.1 is not allowing me to send e-mail through my hosted SMTP today following my upgrade from Mga1 to Mga2. When I open the account dialog to check what is supported, all methods get a line through them. See the screen-shot in the included URL on this report. No matter what supported port and encryption I choose, it still fails. This WAS WORKING to send e-mail through the exact same SMTP server last night before the upgrade commenced.

A log created from xterm using 'export CAMEL_DEBUG=all' is here:

http://www.eracc.com/other/logs/20120522_evolution.log.tar.gz

If there is any other information needed from me, please ask and give me specifics.
Comment 1 Gene Alexander 2012-05-22 21:34:46 CEST
For the record, I did test the smtp server using telnet:

telnet smtp.eracc.com 25
Trying 65.254.250.107...
Connected to smtp.eracc.com (65.254.250.107).
Escape character is '^]'.
220 ESMTP Tue, 22 May 2012 14:35:47 -0400: UCE strictly prohibited
EHLO 10.10.10.4
250-authsmtp05.yourhostingaccount.com Hello 10.10.10.4 [69.167.229.84]
250-SIZE 34603008
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
QUIT
221 authsmtp05.yourhostingaccount.com closing connection
Connection closed by foreign host.
Comment 2 Gene Alexander 2012-05-22 22:11:11 CEST
Further information.

As a test I created a new user on my PC - testuser. I created a new mail account on my mail host - mailtest. Then I started evolution under the user 'testuser' and set up the account 'mailtest@mydomain.com'. I can receive mail sent to that account, but cannot send mail from that account using the smtp server. I get the same error messages I see with the "old" e-mail accounts on my user account on this PC.
Comment 3 Gene Alexander 2012-05-22 22:17:10 CEST
I just created another log from the testuser account with evolution. This account is using the recommended settings from our web / mail host for mail accounts. Here is where one can get that log:

http://www.eracc.com/other/logs/20120522-testuser-evolution.log.tar.gz
Comment 4 Gene Alexander 2012-05-23 01:46:01 CEST
Finally, to add insult to injury, there is this:

I installed evolution 3.4.1 from Mageia 2 on another PC that has a fresh install of Mageia 2 and runs icewm desktop. Still cannot send e-mail via our SMTP host from there using Evolution 3.4, but can with Thunderbird. I *loathe* Thunderbird "binary blob" mail. :(
Comment 5 Manuel Hiebel 2012-05-23 21:29:12 CEST
personnly I see nothing, maybe you can make a diff with the same test case and both evolution in mga1 and 2
Comment 6 Gene Alexander 2012-05-23 21:59:01 CEST
Okay, I will install Mga1 in a VM and create 'testuser' to test with that mailtest account. Will post a log from that here. I will also retest with the testuser on Mga2 and 'diff' the logs. This will be a chance to see if VirtualBox is still working at the least.
Comment 7 Gene Alexander 2012-05-24 01:06:05 CEST
New log files created under both Mageia 1 + Evolution 2.32 and Mageia 2 + Evolution 3.4.1 can be found here:

http://www.eracc.com/other/logs/20120523_testuser_mga1_evo232.log.gz
http://www.eracc.com/other/logs/20120523_testuser_mga2_evo34.log.gz
http://www.eracc.com/other/logs/evo232-evo341_diff.txt.gz

Note that 20120522_evolution.log.tar.gz has been deleted as it may contain sensitive information I do not want "out there".
Comment 8 Gene Alexander 2012-05-24 01:29:37 CEST
Can anyone else following this bug report please test sending via SMTP with Evolution 3.4.1 installed from Mageia 2? I would really like to know if anyone else using Mageia 2 sees this problem. I really need to get past this and get my mail working to send messages. Having my e-mail not be able to send with my preferred mail application is a huge problem.

FYI, I see nothing related at the Gnome bugzilla:

https://bugzilla.gnome.org/buglist.cgi?quicksearch=evolution+smtp

Which leads me to the belief, either this is a problem just with Evolution 3.4.1 and my hosting provider or it is a bug introduced in Mageia's Evolution 3.4.1 package only and should fail with all or most SMTP hosts.
Comment 9 Gene Alexander 2012-05-24 03:03:01 CEST
I do not see Evolution 3.4.1 listed as a stable package here:

http://projects.gnome.org/evolution/download.shtml

Or here:

http://projects.gnome.org/evolution/previous.shtml

Because I am *desperate* to have working outgoing SMTP mail in Evolution, I have attempted to download and build Evolution 3.4.2 this evening. Unfortunately, it needs library versions that are not available (yet) on Mageia:
----------------------------------------------------------
configure: error: Package requirements (camel-1.2 >= 3.4.2
	 libebook-1.2 >= 3.4.2
	 libecal-1.2 >= 3.4.2
	 libedataserver-1.2 >= 3.4.2
	 libedataserverui-3.0 >= 3.4.2
	 libebackend-1.2 >= 3.4.2) were not met:

Requested 'camel-1.2 >= 3.4.2' but version of camel is 3.4.1
Requested 'libebook-1.2 >= 3.4.2' but version of libebook is 3.4.1
Requested 'libecal-1.2 >= 3.4.2' but version of libecal is 3.4.1
Requested 'libedataserver-1.2 >= 3.4.2' but version of libedataserver is 3.4.1
Requested 'libedataserverui-3.0 >= 3.4.2' but version of libedataserverui is 3.4.1
Requested 'libebackend-1.2 >= 3.4.2' but version of libebackend is 3.4.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
----------------------------------------------------------

So, I was going to download and build the stable release of 3.4.1 for myself, only to find there is no stable release of 3.4.1 at http://projects.gnome.org/evolution to be had. This is more badness. :(
Comment 10 Gene Alexander 2012-05-24 04:01:03 CEST
This is interesting. I attempted to take the advice of Manuel H. (leuhmanu on #mageia channel) and install another distribution in a VM that uses Evolution 3.4.1 to test with. Here is what I found when looking for one today:

----------------------------------------------------------
DistroWatch from the top 10
Distribution Releases (not development) that use Evolution 3.4.1

Mageia 2
----------------------------------------------------------

I could keep going, but Mageia is the only distribution in the top 10 at DistroWatch that has Evolution 3.4.1 so far. I am wondering if anyone at Mageia would be willing to provide a fast update to Evolution 3.4.2 that can be pushed out soon? Heck, put it in Cauldron! I will test it.
Comment 11 Funda Wang 2012-05-24 04:10:56 CEST
Well, svn hasn't been branched yet. We will need to wait a few days.
Comment 12 Gene Alexander 2012-05-24 08:20:52 CEST
I will make a formal request in another Bugzilla post.
Comment 13 Manuel Hiebel 2012-05-24 14:48:10 CEST
>Can anyone else following this bug report please test sending via SMTP with
>Evolution 3.4.1 installed from Mageia 2?

I have tested with my provider (gandi.net) and using an old (pre-final Mageia 2) install an it works fine here.

And like evolution, olav wanted to updates all gnome packages to the 3.4.2 iirc.
Comment 14 Olav Vitters 2012-05-24 18:56:08 CEST
My plan is to update everything to 3.4.2. I actually already tried to do that, but it was not yet allowed.

I can also build a Evolution 3.4.2 package for you to test (should be as easy as building evolution-data-server, then evolution), but that would be for my machine; x86_64. If you have that arch, I compile it.
Comment 15 Gene Alexander 2012-05-24 19:38:27 CEST
I have i586 at this point. There is not enough RAM on my PC to need a 64-bit OS yet. My wife's newer PC is on x86_64 Mga1, but she said if I upgrade her system before these things are fixed, she will have to hurt me. :)

If you folk think an update to 3.4.2 will be out within the next 7 days or so, I can work around this until then. I figured out I can use the webmail interface at my host to send messages in the interim.
Comment 16 Gene Alexander 2012-05-26 22:18:52 CEST
(In reply to comment #13)
> >Can anyone else following this bug report please test sending via SMTP with
> >Evolution 3.4.1 installed from Mageia 2?
> 
> I have tested with my provider (gandi.net) and using an old (pre-final Mageia
> 2) install an it works fine here.

Do you still have that "pre-final" Evolution installed somewhere? What version of Evolution is it? I have an installed Cauldron VM up through RC for Mga2, but did not think to check Evolution during my testing. I will do that from now on though. :)
Comment 17 Manuel Hiebel 2012-05-28 10:51:42 CEST
well the contain of the iso is the same as the final beside 10 packages added or removed, so this will change nothing
Comment 18 Olav Vitters 2012-05-28 23:45:05 CEST
(In reply to comment #14)
> My plan is to update everything to 3.4.2. I actually already tried to do that,
> but it was not yet allowed.

Evolution and evolution-data-server 3.4.2 are now available from Cauldron.
Comment 19 Gene Alexander 2012-05-29 01:44:12 CEST
"Oh bother", said Pooh.

I just updated my Cauldron VM and tested with 3.4.2 - same problem. It is as if Evolution does not see the response from our mail host's server about supported AUTH types when it issues the "EHLO ###.###.###.###". But again, if I use telnet to test the server, all appears well:

[root@eramgatest ~]# telnet smtp.eracc.com 25
Trying 65.254.250.107...
Connected to smtp.eracc.com.
Escape character is '^]'.
220 ESMTP Mon, 28 May 2012 19:29:37 -0400: UCE strictly prohibited
EHLO [10.10.10.214]
250-authsmtp03.yourhostingaccount.com Hello [10.10.10.214] [69.167.229.84]
250-SIZE 34603008
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
QUIT
221 authsmtp03.yourhostingaccount.com closing connection
Connection closed by foreign host.

I am pretty darn puzzled by this if it is working for everyone but me. The old Evolution 2.32.2 in my Mga1 VM install still works for sending e-mail with the exact same server. I just sent myself another test message from 2.32.2 to verify that. Unfortunately I am stuck with an apparently "borked" Evolution 3.4.x on Mga2.
Comment 20 Gene Alexander 2012-05-29 04:30:25 CEST
Here is a portion of the message header as proof the test message from the Mga1 + Evolution 2.32.2 did arrive in my personal webmail box:

...
Received: from [69.167.229.84] (helo=[10.10.10.242])
	by authsmtp02.yourhostingaccount.com with esmtpa (Exim)
	id 1SZ9ZW-0004LO-2O
	for (removed); Mon, 28 May 2012 19:41:58 -0400
Subject: Mga1 Evolution 2.32.2 Test Send
From: Test User <mailtest@eracc.com>
To: (removed)
Content-Type: text/plain
Date: Mon, 28 May 2012 18:41:49 -0500
Message-ID: <1338248509.2498.0.camel@mga1vbox.eracc.uucp>
Mime-Version: 1.0
X-Mailer: Evolution 2.32.2-2.mga1 
...

So, my question is, what has changed with Evolution 3.4.x that causes it to not "see" the AUTH data from our SMTP host? It has obviously changed in a manner that causes it to not work with our mail hosting provider. For the record, they run Debian boxes with (I think) Exim for authenticated SMTP. SMTP send on this host works with every other mailer I have tried to date ... except for Evolution 3.4.x on Mageia 2. :(
Comment 21 Gene Alexander 2012-06-10 23:36:01 CEST
Okay, I have to have e-mail that works to send messages with my mail provider. So I have abandoned Evolution and moved to Claws-Mail. Claws-Mail works just fine to send the messages that Evolution refused to send. However, since I reported this problem, if anyone has something new for Evolution they need me to test in Cauldron let me know. I will not be going back to Evolution but I will try to help resolve this bug I reported if someone works on it. If no one is going to work on it, then just close this report.
Comment 22 Samuel Verschelde 2013-08-27 17:33:45 CEST
Closing since we could not reproduce, the only one who could has stopped trying (although trying hard) and no one else looked at this problem closely. So, per comment #21, let's close it.

Note You need to log in before you can comment on or make changes to this bug.