Bug 5561 - libx11_6-devel conflicts with lib64x11_6-devel
: libx11_6-devel conflicts with lib64x11_6-devel
Status: RESOLVED OLD
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 1
: x86_64 Linux
: Normal Severity: normal
: ---
Assigned To: Mageia Bug Squad
:
: https://forums.mageia.org/en/viewtopi...
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-04-22 20:13 CEST by Dane Mutters
Modified: 2012-10-11 09:08 CEST (History)
1 user (show)

See Also:
Source RPM: libx11-1.4.3-1.mga1.src.rpm
CVE:


Attachments

Description Dane Mutters 2012-04-22 20:13:16 CEST
Description of problem:
In order to satisfy WINE1.5's build dependencies, I have to install both the 64-bit version of the above-stated package (upon which many -devel requirements depend), plus the 32-bit version.  When I attempt to do so, I get this (sorry for the long paste):

[code]
1 installation transactions failed
There was a problem during the installation:
file /usr/share/doc/libX11/Compose/C.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/am_ET.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/armscii-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/el_GR.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/en_US.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/fi_FI.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/georgian-academy.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/georgian-ps.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ibm-cp1133.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/index.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iscii-dev.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/isiri-3342.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-1.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-10.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-11.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-13.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-14.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-15.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-2.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-3.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-4.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-5.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-6.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-7.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-9.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/iso8859-9e.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja.JIS.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja.S90.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja.SJIS.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja.U90.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ja_JP.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ko.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ko_KR.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/koi8-c.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/koi8-r.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/koi8-u.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/microsoft-cp1251.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/microsoft-cp1255.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/microsoft-cp1256.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/mulelao-1.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/nokhchi-1.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/pt_BR.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/ru_RU.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/tatar-cyr.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/th_TH.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/th_TH.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/tscii-0.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/vi_VN.tcvn.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/vi_VN.viscii.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_CN.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_CN.gb18030.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_CN.gbk.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_CN.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_HK.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_HK.big5.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_HK.big5hkscs.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_TW.UTF-8.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_TW.big5.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/Compose/zh_TW.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/XIM/xim.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/XKB/xkblib.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/framework/framework.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/libX11.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/localedb/localedb.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
file /usr/share/doc/libX11/trans/trans.html from install of libx11_6-devel-1.4.3-1.mga1.i586 conflicts with file from package lib64x11_6-devel-1.4.3-1.mga1.x86_64
[/code]

Version-Release number of selected component (if applicable):
1.4.3-1.mga1


How reproducible:
Install the 64-bit version, then the 32-bit version of this package.


Steps to Reproduce:
1. Install the packages recommended here (64-bit versions): 
http://wiki.winehq.org/Recommended_Packages
I used the Fedora list, searching for each one in RPMDrake, so as to get the proper Mageia name for the 64-bit versions.
2. Download and decompress WINE 1.5.2.  Run "./configure --enable-wine64" and observe the following error message:
[CODE]
configure: error: X 32-bit development files not found. Wine will be built
without X support, which probably isn't what you want. You will need
to install 32-bit development packages of Xlib/Xfree86 at the very least.
Use the --without-x option if you really want this.
[/CODE]
3. Go into the package manager (RPMDrake) and attempt to install the 32-bit version of the aforementioned package; observe the error message noted earlier in this bug report.
4. Attempt to remove the 64-bit version to make way for the 32-bit version; note the following warning:
[code]
Because of their dependencies, the following package(s) also need to be removed:

- lib64aa-devel-1.4.0-0.rc5.22.mga1.x86_64
- lib64cairo-devel-1.10.2-3.mga1.x86_64
- lib64dmx-devel-1.1.1-1.mga1.x86_64
- lib64dmx-static-devel-1.1.1-1.mga1.x86_64
- lib64ecore-devel-1.0.0-1.mga1.x86_64
- lib64e_dbus-devel-1.0.0-1.mga1.x86_64
- lib64gdk_pixbuf2.0-devel-2.22.1-3.1.mga1.x86_64
- lib64ggi-devel-2.2.2-16.mga1.x86_64
- lib64gii-devel-1.0.2-15.mga1.x86_64
- lib64glpng-devel-1.45-5.2.mga1.x86_64
- lib64gtk+2.0-devel-2.24.4-1.mga1.x86_64
- lib64mesagl1-devel-7.10.2-4.mga1.x86_64
- lib64mesaglu1-devel-7.10.2-4.mga1.x86_64
- lib64mesaglut3-devel-7.10.2-4.mga1.x86_64
- lib64mesaglw1-devel-7.10.2-4.mga1.x86_64
- lib64oldx6-devel-1.0.1-8.mga1.x86_64
- lib64oldx6-static-devel-1.0.1-8.mga1.x86_64
- lib64pango1.0-devel-1.28.4-1.mga1.x86_64
- lib64SDL-devel-1.2.14-4.1.mga1.x86_64
- lib64SDL_net-devel-1.2.7-7.mga1.x86_64
- lib64windowswm-devel-1.0.1-2.mga1.x86_64
- lib64windowswm-static-devel-1.0.1-2.mga1.x86_64
- lib64xaw-devel-1.0.9-1.mga1.x86_64
- lib64xaw-static-devel-1.0.9-1.mga1.x86_64
- lib64xcomposite1-devel-0.4.3-1.mga1.x86_64
- lib64xcomposite1-static-devel-0.4.3-1.mga1.x86_64
- lib64xcursor-devel-1.1.11-1.mga1.x86_64
- lib64xcursor-static-devel-1.1.11-1.mga1.x86_64
- lib64xdamage-devel-1.1.3-1.mga1.x86_64
- lib64xdamage-static-devel-1.1.3-1.mga1.x86_64
- lib64xevie-devel-1.0.3-1.mga1.x86_64
- lib64xevie-static-devel-1.0.3-1.mga1.x86_64
- lib64xext6-devel-1.2.0-2.mga1.x86_64
- lib64xext6-static-devel-1.2.0-2.mga1.x86_64
- lib64xfixes3-devel-5.0-1.mga1.x86_64
- lib64xfixes3-static-devel-5.0-1.mga1.x86_64
- lib64xfontcache1-devel-1.0.5-2.mga1.x86_64
- lib64xfontcache1-static-devel-1.0.5-2.mga1.x86_64
- lib64xft-devel-2.2.0-1.mga1.x86_64
- lib64xft-static-devel-2.2.0-1.mga1.x86_64
- lib64xi-devel-1.4.2-1.mga1.x86_64
- lib64xi-static-devel-1.4.2-1.mga1.x86_64
- lib64xinerama1-devel-1.1.1-2.mga1.x86_64
- lib64xinerama1-static-devel-1.1.1-2.mga1.x86_64
- lib64xkbfile-devel-1.0.7-1.mga1.x86_64
- lib64xkbfile-static-devel-1.0.7-1.mga1.x86_64
- lib64xkbui-devel-1.0.2-8.mga1.x86_64
- lib64xkbui-static-devel-1.0.2-8.mga1.x86_64
- lib64xmu6-devel-1.1.0-2.mga1.x86_64
- lib64xmu6-static-devel-1.1.0-2.mga1.x86_64
- lib64xorg-x11-devel-7.5-7.mga1.x86_64
- lib64xpm-devel-3.5.9-2.mga1.x86_64
- lib64xpm-static-devel-3.5.9-2.mga1.x86_64
- lib64xrandr2-devel-1.3.1-2.mga1.x86_64
- lib64xrandr2-static-devel-1.3.1-2.mga1.x86_64
- lib64xrender1-devel-0.9.6-1.mga1.x86_64
- lib64xrender1-static-devel-0.9.6-1.mga1.x86_64
- lib64xres1-devel-1.0.5-1.mga1.x86_64
- lib64xres1-static-devel-1.0.5-1.mga1.x86_64
- lib64xscrnsaver1-devel-1.2.1-2.mga1.x86_64
- lib64xscrnsaver1-static-devel-1.2.1-2.mga1.x86_64
- lib64xt-devel-1.1.1-2.mga1.x86_64
- lib64xt-static-devel-1.1.1-2.mga1.x86_64
- lib64xtrap-devel-1.0.0-11.mga1.x86_64
- lib64xtrap-static-devel-1.0.0-11.mga1.x86_64
- lib64xtst6-devel-1.2.0-1.mga1.x86_64
- lib64xtst6-static-devel-1.2.0-1.mga1.x86_64
- lib64xv1-devel-1.0.6-1.mga1.x86_64
- lib64xv1-static-devel-1.0.6-1.mga1.x86_64
- lib64xvmc1-devel-1.0.6-1.mga1.x86_64
- lib64xvmc1-static-devel-1.0.6-1.mga1.x86_64
- lib64xxf86dga-devel-1.1.2-1.mga1.x86_64
- lib64xxf86dga-static-devel-1.1.2-1.mga1.x86_64
- lib64xxf86misc-devel-1.0.3-1.mga1.x86_64
- lib64xxf86misc-static-devel-1.0.3-1.mga1.x86_64
- lib64xxf86vm-devel-1.1.1-2.mga1.x86_64
- lib64xxf86vm-static-devel-1.1.1-2.mga1.x86_64
- x11-server-devel-1.10.1-1.1.mga1.x86_64

0B of additional disk space will be used.
[/code]
5. Pull hair out (optional).  :-)

Note: I hesitate to say just how severe this bug is, since it has only really caused me problems in one (relatively minor) area.  However, I was told on the forum (see web site link, above) that there's an ongoing problem with conflicts like this; and since it prevents compiling software that builds fine on other distros--thus breaking a certain amount of "source compatibility" (as I understand the term), it could be seen as a major problem.  I'm putting it down as "normal;" please modify it as you developers (who know more about this than I do) see fit.

For completeness, here's a list of my active media sources:
[code]
Core Release
Core Updates
Core Updates Testing
Core Backports
Core Backports Testing
Nonfree Release
Nonfree Updates
Nonfree Updates Testing
Nonfree Backports
Nonfree Backports Testing
Tainted Release
Tainted Updates
Tainted Updates Testing
Tainted Backports
Tainted Backports Testing
Core 32bit Release
Core 32bit Updates
Core 32bit Updates Testing
Core 32bit Backports
Core 32bit Backports Testing
Mirror list: Core Release (distrib1)
Mirror list: Core Updates (distrib3)
Mirror list: Core Updates Testing (distrib5)
Mirror list: Core Backports (distrib7)
Mirror list: Core Backports Testing (distrib9)
Mirror list: Nonfree Release (distrib11)
Mirror list: Nonfree Updates (distrib13)
Mirror list: Nonfree Updates Testing (distrib15)
Mirror list: Nonfree Backports (distrib17)
Mirror list: Nonfree Backports Testing (distrib19)
Mirror list: Nonfree Tainted Release (distrib21)
Mirror list: Nonfree Tainted Updates (distrib23)
Mirror list: Nonfree Tainted Updates Testing (distrib25)
Mirror list: Nonfree Tainted Backports (distrib27)
Mirror list: Nonfree Tainted Backports Testing (distrib29)
Mirror list: Core 32bit Release (distrib31)
Mirror list: Core 32bit Updates (distrib33)
Mirror list: Core 32bit Updates Testing (distrib35)
Mirror list: Core 32bit Backports (distrib37)
Mirror list: Core 32bit Backports Testing (distrib39)
[/code]

As of today, all my packages are fully-updated.
Comment 1 Dane Mutters 2012-04-22 20:37:45 CEST
On the previously-linked forum thread, doktor5000 suggested that I try doing this:

[CODE]
wget ftp://ftp.mandrivauser.de/mirrors/Mageia/distrib/cauldron/SRPMS/core/release/wine-1.4-1.mga2.src.rpm
urpmi rpm-build
urpmi --buildrequires wine-1.4-1.mga2.src.rpm
rpmbuild --rebuild wine-1.4-1.mga2.src.rpm
[/CODE]

Unfortunately, it didn't work, since the dependencies of that WINE source rpm aren't available in the current repositories (without adding the cauldron ones and breaking glibc, among other things).  Here's the output I got:

[CODE]
[root@orchestrator wine]# urpmi --buildrequires wine-1.4-1.mga2.src.rpm
A requested package cannot be installed:
wine-1.4-1.mga2.src (due to unsatisfied valgrind-devel)
[/CODE]

...so, after finding that there isn't a valgrind-devel in the current repos, I downloaded and attempted to install the appropriate valgrind (which the -devel depends on) and valgrind-devel from here (cauldron versions):
ftp://rpmfind.net/linux/mageia/distrib/cauldron/x86_64/media/core/release/valgrind-3.7.0-1.mga2.x86_64.rpm
ftp://rpmfind.net/linux/mageia/distrib/cauldron/x86_64/media/core/release/valgrind-devel-3.7.0-1.mga2.x86_64.rpm
...and got this:

[CODE]
[root@orchestrator wine]# rpm -ivh valgrind*
error: Failed dependencies:
libc.so.6(GLIBC_2.14)(64bit) is needed by valgrind-3.7.0-1.mga2.x86_64
[/CODE]

The required version of glibc isn't in any of the Mageia 1 repos, so I stopped here.

I don't know if this is helpful (please let me know if I'm being too detailed), but hopefully it sheds some light on the problem.

--Dane
Comment 2 Manuel Hiebel 2012-04-22 21:43:53 CEST
your bug in unreadable, next time use attachments instead of copy-paste
Comment 3 Dane Mutters 2012-04-22 22:04:09 CEST
Sorry about that.  Should I re-do it, or can it slide this time?  (I'll avoid doing that in the future.)
Comment 4 Dane Mutters 2012-05-20 07:45:39 CEST
Update: I've solved this by using the release candidate of Mageia 2, and following the steps outlined in the following post (same thread as before):

https://forums.mageia.org/en/viewtopic.php?f=8&t=2283&p=16934#p18151

Since MGA2 seems to have fixed the relevant library conflicts, this bug seems to no longer be important, except for those wishing to fix it in MGA1 (if that's even possible).

Have a nice day.
Comment 5 Thierry Vignaud 2012-10-07 20:04:46 CEST
Closing then
Comment 6 Manuel Hiebel 2012-10-11 09:08:09 CEST
really

Note You need to log in before you can comment on or make changes to this bug.