Bug 4394 - Compiz can't be reenabled when enabled and then disabled
Summary: Compiz can't be reenabled when enabled and then disabled
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact:
Depends on:
Reported: 2012-02-03 10:23 CET by Jaromír Cápík
Modified: 2012-02-13 23:41 CET (History)
4 users (show)

See Also:
Source RPM: drak3d-1.30-1.mga1.src.rpm
Status comment:

compiz-package-name-change.patch (539 bytes, patch)
2012-02-04 14:01 CET, Jaromír Cápík
Details | Diff
1.30 -> 1.31 diff (59.83 KB, patch)
2012-02-05 20:20 CET, Jaromír Cápík
Details | Diff
drak3d-1.31-mga-broken-localization.patch (16.45 KB, patch)
2012-02-12 11:25 CET, Jaromír Cápík
Details | Diff

Description Jaromír Cápík 2012-02-03 10:23:31 CET
Description of problem:
Hello. When I enable compiz using drak3, it installs all required packages. When I disable 3D effects and then try to enable compiz again, drak3d wants to install 'compiz-fusion' package again, but since it is already installed, the installation fails and the configuration is terminated and compiz is not enabled.
I solved the issue by uninstalling the compiz package manually.

Bug 3763 might be related even if it is already closed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Enable compiz using drak3d
2. Disable compiz by disabling 3D effects in drak3d
3. Try to enable compiz again.
Comment 1 Manuel Hiebel 2012-02-04 02:04:55 CET
Indeed I can reproduce

Was there a change in urpmi ? (as drak3d has not changed since last year)

CC: (none) => dmorganec, ennael1, thierry.vignaud

Comment 2 Jaromír Cápík 2012-02-04 13:37:58 CET
Maybe it's caused by the package name change. Even if compiz provides compiz-fusion, there might be some internal check in drak3d causing this to fail. I had no time to look at the code yet ...
Comment 3 Jaromír Cápík 2012-02-04 14:01:28 CET
Created attachment 1491 [details]

Like I said ... it's really caused by the internal package name check. 
drak3d searches for 'compiz-fusion', but it isn't found since it has been renamed to 'compiz'. So ... it seems there's no 'Provides' check in drak3d and it isn't even able to recognise the 'already installed' status.

The attached simple patch solves the issue in my case.
Comment 4 Manuel Hiebel 2012-02-04 17:42:51 CET
Mh ok, Julien does your recent change fix that ?

CC: (none) => julien.moragny

Comment 5 Jaromír Cápík 2012-02-04 18:30:28 CET
I looked at the Julien's patch attached to Bug 3763 and it seems to be absolutely identical to mine, so ... if You talk about that, it should fix it. Anyway ... the change hadn't been commited when I checked out the repository. Is there a separate repository for drak3d sources? 

Comment 6 Julien Moragny 2012-02-05 11:29:43 CET

the change I proposed in bug 3763 hasn't been commited to drak3d.
I'm not a programmer so I prefer having an ack from the maintainer of drak3d before breaking something.

Comment 7 Manuel Hiebel 2012-02-05 11:38:54 CET
In fact i was referring to the change in the spec of compiz sorry O:)

(& seems we loose the maintainer of drak3d)
Comment 8 Julien Moragny 2012-02-05 11:49:40 CET
Manuel> oh, I don't think I can fix the problem in compiz end (except in resurrecting compiz-fusion which I don't want to), drak3d seems to search for the name of the package in some places and not in the provides.
Comment 9 Jaromír Cápík 2012-02-05 14:04:59 CET
The package name change in drak3d is sufficient and easy. There's no need for any kind of "universal solution" since the whole drak3d design is simply not flexible enough for that. It would need to be completely redesigned and that's needless at the moment.
We just need to know if anything like "upstream" repository for drak3d exists. There's no source URL in the spec and I'm unsure how to change the package version and content.
Of course I could unpack the sources, apply the change, then create a new archive and use it in the spec, but that could cause a code split if the upstream still exists.
Comment 10 Manuel Hiebel 2012-02-05 14:10:53 CET
It's in the svn


(also maybe we can remove metisse in the same time, bug 3702)
Manuel Hiebel 2012-02-05 14:12:12 CET

CC: ennael1 => mageia

Comment 11 Jaromír Cápík 2012-02-05 14:56:13 CET
Thank You. 
Has anyone tried to fix the Metisse build?

Comment 12 Julien Moragny 2012-02-05 16:11:28 CET
I have just submitted a new drak3d, can you try and report if it fixes your problem ?
Comment 13 Manuel Hiebel 2012-02-05 19:37:31 CET
Works for me.

I have notice that the translation don't work. Result of the fix of metisse missing ?
Comment 14 Jaromír Cápík 2012-02-05 19:59:56 CET
I did a directory diff and see that there were changes in .po files and the result .mo files contain invalid multichar sequences.
Comment 15 Jaromír Cápík 2012-02-05 20:10:06 CET
It's probably caused by this ...

-"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Type: text/plain; charset=CHARSET\n"
Comment 16 Jaromír Cápík 2012-02-05 20:13:52 CET
Yes ... that was the trick ... 

moreover ... the newly created .po files contain clean headers where the list of previous translators is missing and that's stealing their credits ...
Comment 17 Jaromír Cápík 2012-02-05 20:20:14 CET
Created attachment 1498 [details]
1.30 -> 1.31 diff

This diff file is documenting differences between 1.30 and 1.31
Comment 18 Jaromír Cápík 2012-02-05 20:28:16 CET
As You see, the changes are inconsistent ... sometimes there's more info in the new versions and sometimes in the older ones ... that would need a manual merge (one by one) and a final check :]

Julien, are You going to fix that? Or should I?
Comment 19 Julien Moragny 2012-02-05 20:54:28 CET
(In reply to comment #18)
> Julien, are You going to fix that? Or should I?

If you can, feel free to do it. :)
I didn't touch the translation, so I assume it may be a problem with transifex ?
Comment 20 Jaromír Cápík 2012-02-12 10:10:15 CET
Ok ... hopefully I'll find some time this evening.

Assignee: bugsquad => tavvva

Comment 21 Jaromír Cápík 2012-02-12 11:25:23 CET
Created attachment 1529 [details]

This patch hopefully fixes the broken localization issue ...
Comment 22 Julien Moragny 2012-02-12 12:03:27 CET
drak3d 1.32 has been submitted with your patch, thank you.
Comment 23 Jaromír Cápík 2012-02-12 12:05:21 CET
Ohhhh :D I was just doing the update in svn.mageia.org/svn/soft/drak3d and my commit failed ... You were faster.
Comment 24 Jaromír Cápík 2012-02-13 23:41:04 CET
seems it works correctly now .... closing ...

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.