Bug 32572 - Some issues to run Skanpage
Summary: Some issues to run Skanpage
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
Depends on:
Blocks: 32953
  Show dependency treegraph
Reported: 2023-11-27 11:34 CET by Jose Manuel López
Modified: 2024-03-16 13:35 CET (History)
2 users (show)

See Also:
Source RPM: skanpage-23.04.1-1.mga9
Status comment:

Skanpage terminal output (945 bytes, text/plain)
2023-11-27 11:35 CET, Jose Manuel López

Description Jose Manuel López 2023-11-27 11:34:26 CET
Description of problem:Skanpage takes too long to start. After trying to launch it from terminal, I have seen some errors appear.

Version-Release number of selected component (if applicable):Skanpage in Mageia 9

How reproducible: Install skanpage and run from terminal
Comment 1 Jose Manuel López 2023-11-27 11:35:05 CET
Created attachment 14185 [details]
Skanpage terminal output

This output show the issues to run Skanpage
Comment 2 Morgan Leijström 2023-11-27 16:34:44 CET
I have never used skanpage, installed it right now.

I get the same terminal output, but it launch in less than two seconds.

I let it scan and it scans a page.
I click again and it display two pages scanned.

Except from the errors in terminal does it not work for you?

__Now i try next step:
From terminal output when launching:
   Failed loading language 'eng'
   Tesseract couldn't load any languages!

Tesseract is needed for OCR. I find lib64tesseract5 installed.

I select to install language file tesseract-swe, and it also install tesseract and tesseract-eng.

Now launching skanpage, it segfaulted... 

Then i tried launching it with English locale:
$ LC_ALL=C skanpage
Cannot initialize model with data QJsonObject(). missing: QJsonValue(string, "urls")
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:209: ReferenceError: page is not defined

So: much less messages. And it show the GIU. I abort an now try again:

$ skanpage
Cannot initialize model with data QJsonObject(). missing: QJsonValue(string, "urls")
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:209: ReferenceError: page is not defined
qrc:/qml/SettingsWindow.qml:28:5: QML FormLayout: Binding loop detected for property "implicitHeight"
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:161:5: QML FormLayout: Binding loop detected for property "implicitHeight"
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/FormLayout.qml:101:5: QML GridLayout: Binding loop detected for property "knownItemsImplicitWidth"
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:209: ReferenceError: page is not defined

And shows GUI, but as there is less problems with LC_ALL=C skanpage, i close it and launch it as such.  Scanning made it segfault shorty after scanner started moving.  Launching again, (and power cycling scanner to free up the interface) it succeed.

OCR is selected in the "Export PDF" dialogue.
I opened the resulting pdf in Okular: it show the complete scan as image, and i can select text areas and copy as text.

Works for me minus occasional segfault at launch or scanning.

Another issue, probably upstream (or in tesseract-swe package?):
As the rpm description say, I believe it is Swedish - as it recognise Swedish characters - but in Skanpage "Export PDF" dialogue it is listed as "Kiswahili [swe]"!

I guess first step is to see if there is an updated scanpage upstream and try if it works better.

CC last packager, assigning all.

Assignee: bugsquad => pkg-bugs
CC: (none) => fri, geiger.david68210
Source RPM: Skanpage => skanpage-23.04.1-1.mga9

Comment 3 Jose Manuel López 2023-11-27 18:44:26 CET
The program works as expected, but in my case it takes longer than 2 seconds to start. Possibly because it has the scanner on the network and has to recognize it?

Anyway, I'm planning a clean reinstall of Mageia 9 on this machine, so I'll report back after installing.
Comment 4 Morgan Leijström 2023-11-29 01:45:37 CET
I believe DavidG is on to it as he pushed skanpage-24.01.75-2.mga10 to build system yesterday, but there was and is again problem with the build system getting stuck... http://pkgsubmit.mageia.org/
Comment 5 David GEIGER 2023-11-29 06:15:39 CET
I just added missing runtime dependencies for now.

I think if there is an issue it would be better to file a new bug upstream at https://bugs.kde.org/  product "Skanpage"
David GEIGER 2024-03-09 09:13:13 CET

Blocks: (none) => 32953

Comment 6 Morgan Leijström 2024-03-09 17:05:23 CET
Since all three Plasma updates steps.
(actually *everything* in testing repo, feeling adventorous...)

Fixed: requiring tesseract

Operation not better not worse:
§ Same console output.
§ First scan OK
§ Second scan segfault.
§ Restart efter segfault: scanner not found.

Anyhow, i think the Plasma update should not depend on this bug.
Comment 7 Jose Manuel López 2024-03-16 08:58:15 CET

Since the last updates, skanpage works fine on my computer.

In addition to installing the testing version 23.04.3, I have several computers in the office working with Skanpage and none of them have given me an error report, so I understand that it is working well on the rest of the computers.

So we can close this error.
Comment 8 Morgan Leijström 2024-03-16 13:35:49 CET
OK so the problem of slow start, for which you opened the bug, is solved for you.  So closing.

Although we still do not know what was the actual problem.

I never saw that problem, but another one, per Comment 2:
I can still with the Plasma updates (all updates in testing actually) still reproduce the problem for my system: 

1) Launch skanpage and scan: OK
2) Scan another page: OK
3) Close skanpage
4) Launch skanpage: OK
5) Scan: Segfault

And the scanner need be power cyckled in order to be used by any program again.

I can on same system do the same procedure using xsane, without problems.

Anyway, that is for another bug if someone want to open it... I'm tired...

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.