Bug 32456 - Flightgear 2020.3.19
Summary: Flightgear 2020.3.19
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://www.flightgear.org/
Whiteboard: MGA9-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2023-10-27 18:22 CEST by Ami age
Modified: 2024-03-01 07:27 CET (History)
3 users (show)

See Also:
Source RPM: flightgear-2020.3.18-1.1.mga9,flightgear-data-2020.3.18-1.3.mga9,simgear-2020.3.18-1.1.mga9
Status comment:


Description Ami age 2023-10-27 18:22:00 CEST
Description of problem:


Flightgear version 2020.3.19 has just been released.
Can you put it in the Mageia 9 testing repositories before putting it in the release repositories if the tests are ok?



Flightgear en version 2020.3.19 vient d'etre publiée.
Pouvez vous la mettre dans les dépots testing de Mageia 9 avant de la mettre dans les dépots release si les tests sont ok ?



Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Comment 1 Marja Van Waes 2023-10-29 13:28:55 CET
It'll need to land in cauldron, first.

Since it is a bugfix release, it can then be pushed to updates_testing, for QA to test it before it gets pushed as regular update.

Please keep an eye on this report and help QA team to test the updated package. 

Version: 9 => Cauldron
Assignee: bugsquad => eatdirt
CC: (none) => marja11
Whiteboard: (none) => MGA9TOO

Comment 2 Chris Denice 2023-10-29 17:36:00 CET
Hi there,
there is no need to, the last version I pushed 2020. already included the patches that have been officially incorporated into 2019.3.19.

So we're good till 2020.3.20.

Comment 3 Ami age 2023-10-31 18:14:47 CET
I would have tested this 2020.3.19 because currently, there are texture bugs with the 2020.3.18 provided in mageia 9 (which was not available in mageia 8, I had tested it)
J'aurais bien testé cette 2020.3.19 car actuellement, il y des bugs de textures avec la 2020.3.18 fournie dans mageia 9 (qu'il n'y avait pas dans mageia 8, je l'avais testée)
Comment 4 Chris Denice 2023-11-02 21:52:22 CET
The version 2020. is exactly the same as the publicly released 2020.3.19. In our last bug fixing, I've backported all the patches that went in into 2020.3.19 afterwards.

For the texturing problem, it won't help then. But, please, open a bug report for the texturing issues. This possibly come from the compositor I have enabled for mga9.

Please test with this option added to "fgfs", it you're not doing that already:

fgfs --compositor=Compositor/als
Comment 5 Ami age 2023-11-05 16:42:58 CET
Translated with google:
Good morning,

here is the test report.

1) with the version provided 2020.3.18 now by mageia 9, the ground is well displayed, the main bug has been corrected

2) there are still some texture issues (a few rare missing textures and red-orange road pieces)

3) by trying with ALS, or without, via the flightgear menu, or by adding the text "--compositor=Compositor/als" in the start / Setting menu, it's almost the same thing.

Without ALS I have some extra textures OK,
but with or without, there are always red bits of road.
so nothing convincing.

A user with the appimage version indicates that he does not have red road pieces.

That's why I was curious to test 2020.3.19 to see.
(But if you say it's exactly the same as the 2020.3.18 provided by mageia...)


voici le compte rendu des tests.

1) avec la version fournie 2020.3.18 à présent par mageia 9, le sol est bien affiché, le bug principal a bien été corrigé 

2) il demeure quelques problèmes de textures (quelques rares textures manquantes et des morceaux de route rouges-orangées)

3) en essayant avec ALS, ou sans, via le menu de flightgear, ou en ajoutant le texte "--compositor=Compositeur/als" dans le menu de démarrage / Setting, c'est quasiment la même chose.

Sans ALS, j'ai quelques textures supplémentaires OK, 
mais avec ou sans, il y a toujours des morceaux de route rouges.
donc rien de probant.

Un utilisateur avec la version appimage indique qu'il n'a pas morceaux de route rouges.

C'est pourquoi j'étais curieux de tester la 2020.3.19 pour voir.
(Mais si vous dites que c'est exactement la même que la 2020.3.18 fournie par mageia...)
Comment 6 Chris Denice 2024-02-28 15:52:12 CET
Ok, I've manage to confirm using a computer with an old nvidia card. The compositor is not robust to different hardware, so I am going to push an update disabling it for mga9.

On Cauldron, I'll push the latest snapshot 2020.4.0, which is working quite well 
Thanks for the bug report, and sorry for the delays.
Comment 7 Chris Denice 2024-02-28 22:26:44 CET

landing in core/updates_testing, built with compositor OFF. The rendering issues should be gone. Let me know how it works.
Chris Denice 2024-02-29 09:59:08 CET

Assignee: eatdirt => qa-bugs

Comment 8 Thomas Andrews 2024-02-29 16:51:11 CET
(In reply to Chris Denice from comment #6)
> Ok, I've manage to confirm using a computer with an old nvidia card. The
> compositor is not robust to different hardware, so I am going to push an
> update disabling it for mga9.
> On Cauldron, I'll push the latest snapshot 2020.4.0, which is working quite
> well 
> Thanks for the bug report, and sorry for the delays.

I take it from this that this is no longer a Cauldron bug. Switching it to Mageia 9...

CC: (none) => andrewsfarm
Whiteboard: MGA9TOO => (none)
Version: Cauldron => 9

Comment 9 Thomas Andrews 2024-03-01 00:26:41 CET
MGA9-64 Plasma, i5-7500, Nvidia Quadro K620 graphics, using nvidia-current.

Installed Flightgear and dependencies, then updated with no issues. 

I ran it, and played around. Autostarted the Cessna, but it must have still been tied down because it wouldn't move. So, I found a setting that would put it in the air, flying at settings I only guessed about. I flew it for a while, threatening to lose control at any moment. I think I ran out of fuel, because eventually it just stopped. 

Seems to be OK, as far as I can tell. Validating.

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update
Whiteboard: (none) => MGA9-64-OK

katnatek 2024-03-01 04:49:34 CET

Source RPM: (none) => flightgear-2020.3.18-1.1.mga9,flightgear-data-2020.3.18-1.3.mga9,simgear-2020.3.18-1.1.mga9
Keywords: (none) => advisory

Comment 10 Mageia Robot 2024-03-01 07:27:06 CET
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.