Bug 32309 - Cannot manually update npm using npm install -g npm@latest because node 18.7.0 and above is needed
Summary: Cannot manually update npm using npm install -g npm@latest because node 18.7....
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: christian squidf
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 32176 32341
Blocks:
  Show dependency treegraph
 
Reported: 2023-09-21 14:59 CEST by Kristoffer Grundström
Modified: 2023-09-28 18:47 CEST (History)
0 users

See Also:
Source RPM: nodejs-18.16.1-2.mga9.src.rpm
CVE:
Status comment:


Attachments

Description Kristoffer Grundström 2023-09-21 14:59:57 CEST
Description of problem: I see a message running npm install when building tutanota-desktop that there's a new npm version available.

Running npm install -g npm@latest gives me the following error:

npm ERR! code EBADENGINE
npm ERR! engine Unsupported engine
npm ERR! engine Not compatible with your version of node/npm: npm@10.1.0
npm ERR! notsup Not compatible with your version of node/npm: npm@10.1.0
npm ERR! notsup Required: {"node":"^18.17.0 || >=20.5.0"}
npm ERR! notsup Actual:   {"npm":"9.5.1","node":"v18.16.1"}

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/kristoffer/.npm/_logs/2023-09-21T12_48_21_411Z-debug-0.log

node -v shows:
v18.16.1

npm -v shows:
9.5.1

Version-Release number of selected component (if applicable): v18.16.1

How reproducible: All the time when trying to update.

Steps to Reproduce:
1. Install npm and nodejs with urpmi or dnf.
2. Run npm install -g npm@latest.
3. Update will fail.
Comment 1 Lewis Smith 2023-09-21 21:12:05 CEST
Thank you for the report.
Is your system up-to-date? We have had version: 18.17.1 in Cauldron for 5 weeks, 
so you should have got it then. Perhaps it got stuck in M9 version freeze.

Assigning to squidf who updates nodejs.

Source RPM: npm => nodejs-18.16.1-2.mga9.src.rpm
Assignee: bugsquad => chb0

Comment 2 christian squidf 2023-09-21 21:24:47 CEST
Hi

With the error:
npm ERR! notsup Required: {"node":"^18.17.0 || >=20.5.0"}

It looks like you need nodejs (>=18.17.0 and <19.0.0) or >=20.5.0

18.17.1 has been somehow stuck in core/updates_testing. It is now validated by QA and you should get it soon as an update.
If you cannot wait, get it from core/updates_testing.

Depends on: (none) => 32176

Comment 3 Kristoffer Grundström 2023-09-21 21:41:50 CEST
(In reply to Lewis Smith from comment #1)
> Thank you for the report.
> Is your system up-to-date? We have had version: 18.17.1 in Cauldron for 5
> weeks, 
> so you should have got it then. Perhaps it got stuck in M9 version freeze.
> 
> Assigning to squidf who updates nodejs.

Even though I love Cauldron when it's updated frequently I prefer to only use Core release and Core updates on it so having an update in Updates Testing.

I'll have to wait until it gets moved to Core Updates I guess.
Marja Van Waes 2023-09-28 18:47:28 CEST

Depends on: (none) => 32341


Note You need to log in before you can comment on or make changes to this bug.