Bug 32263 - rapid-photo-downloader does not launch
Summary: rapid-photo-downloader does not launch
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Depends on:
Reported: 2023-09-08 03:23 CEST by Mike Rambo
Modified: 2023-09-24 20:35 CEST (History)
3 users (show)

See Also:
Source RPM: rapid-photo-downloader-0.9.33-1.mga9
Status comment:


Description Mike Rambo 2023-09-08 03:23:06 CEST
Description of problem:
rapid-photo-downloader does not launch does not launch from GUI. When launched from CLI fails with the following error.

[mrambo@mga9tmp243 ~]$ rapid-photo-downloader 
Traceback (most recent call last):
  File "/usr/bin/rapid-photo-downloader", line 33, in <module>
    sys.exit(load_entry_point('rapid-photo-downloader==0.9.33', 'gui_scripts', 'rapid-photo-downloader')())
  File "/usr/bin/rapid-photo-downloader", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib64/python3.10/importlib/metadata/__init__.py", line 171, in load
    module = import_module(match.group('module'))
  File "/usr/lib64/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 883, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3.10/site-packages/raphodo/rapid.py", line 152, in <module>
    from raphodo.folderpreviewmanager import FolderPreviewManager
  File "/usr/lib/python3.10/site-packages/raphodo/folderpreviewmanager.py", line 31, in <module>
    from raphodo.interprocess import OffloadData
  File "/usr/lib/python3.10/site-packages/raphodo/interprocess.py", line 66, in <module>
    from raphodo.proximity import TemporalProximityGroups
  File "/usr/lib/python3.10/site-packages/raphodo/proximity.py", line 33, in <module>
    from PyQt5.Qt import QWIDGETSIZE_MAX
ImportError: cannot import name 'QWIDGETSIZE_MAX' from 'PyQt5.Qt' (/usr/lib64/python3.10/site-packages/PyQt5/Qt.abi3.so)
Comment 1 Mike Rambo 2023-09-08 17:34:38 CEST
FYI... I noticed version 0.9.34 was uploaded for cauldron since I created this bug. I tried rapid-photo-downloader-0.9.34-1.mga10 on one of my cauldron installations and it fails with the same error as 0.9.33 does on mga9.
Comment 2 David GEIGER 2023-09-09 05:47:11 CEST
Could you report this upstream at https://github.com/damonlynch/rapid-photo-downloader/issues , please?

Thanks in advance!

CC: (none) => geiger.david68210

Comment 4 Damon Lynch 2023-09-11 22:41:04 CEST
Hello, Rapid Photo Downloader upstream developer here. It looks like you have a packaging or compilation bug in PyQt5 or Qt5. This is terminal output relating to the upstream PyQt5 package in a virtual environment on Linux:

(venv) damon@X570:~/rapid-photo-downloader$ python3 -m pip show PyQt5
Name: PyQt5
Version: 5.15.9
Summary: Python bindings for the Qt cross platform application toolkit
Home-page: https://www.riverbankcomputing.com/software/pyqt/
Author: Riverbank Computing Limited
Author-email: info@riverbankcomputing.com
License: GPL v3
Location: /home/damon/venv/lib/python3.10/site-packages
Requires: PyQt5-Qt5, PyQt5-sip
(venv) damon@X570:~/rapid-photo-downloader$ python3
Python 3.10.12 (main, Jun 11 2023, 05:26:28) [GCC 11.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from PyQt5.Qt import QWIDGETSIZE_MAX

Note the lack of error from the last output.

CC: (none) => damonlynch

Comment 5 Mike Rambo 2023-09-12 01:48:03 CEST
I know next to nothing about this, but is this due to a version mismatch?

[mrambo@baggins ~]$ urpmq -Y PyQt5
[mrambo@baggins ~]$ urpmq --provides python3-pyqt5-sip
python-pyqt5-sip[== 1:4.19.24-1.mga8]
python3-pyqt5-sip[== 1:4.19.24-1.mga8]
python3-pyqt5-sip(x86-64)[== 1:4.19.24-1.mga8]
python3-pyqt5-sip-api(12)[== 12.7]
python3.8dist(pyqt5-sip)[== 4.19.24] <<<<< we are at 3.10 for most things
python3dist(pyqt5-sip)[== 4.19.24]
Comment 6 David GEIGER 2023-09-12 06:38:01 CEST
Hmmm! interesting!

I don't know where it could come from but if I patch the file "raphodo/proximity.py" by changing:

"from PyQt5.Qt import QWIDGETSIZE_MAX" with "from PyQt5.QtWidgets import QWIDGETSIZE_MAX"

now it works and starts properly.
Comment 7 Damon Lynch 2023-09-12 07:39:42 CEST
David your patch also works with the upstream implementation of PyQt5, so I see no reason not to incorporate that change in the code as a failsafe in case the first import fails. Thanks for your input.
Comment 8 Lewis Smith 2023-09-12 21:19:16 CEST
Thanks to everyone for fast and +ve action.

No hands more capable than DavidG for it to be with; assigning thus.

Assignee: bugsquad => geiger.david68210

Comment 9 Mike Rambo 2023-09-16 02:17:53 CEST
Installed rapid-photo-downloader-0.9.33-1.1.mga9.x86_64.rpm from the updates_testing repository. The problem is fixed by this update. The application launches without problem from both GUI and CLI. Took a bit to get the settings right but it also transferred some photos off my phone. Looks to me like it works as it should. Thanks to DavidG and Damon.
Comment 10 David GEIGER 2023-09-16 03:51:46 CEST
Assigning to QA,

Packages in 9/Core/Updates_testing:


Assignee: geiger.david68210 => qa-bugs

Comment 11 Guillaume Royer 2023-09-24 20:35:51 CEST
Installed with QA repo.

No issues at installation. Software seems works fine.
I maked basic tests

CC: (none) => guillaume.royer

Note You need to log in before you can comment on or make changes to this bug.