Bug 31208 - Backports must not be used unless enabled
Summary: Backports must not be used unless enabled
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: release_blocker major
Target Milestone: Mageia 9
Assignee: Mageia tools maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-12-01 00:39 CET by Dave Hodgins
Modified: 2022-12-31 17:56 CET (History)
1 user (show)

See Also:
Source RPM: rpmdrake-6.32-2.mga9.src.rpm
CVE:
Status comment:


Attachments

Description Dave Hodgins 2022-12-01 00:39:40 CET
This bug is being opened as a duplicate of bug 29830, but for the mageia 9.

It will be a release blocker for Mageia 9.

Either the broken rpmdrake "feature" allowing selecting packages from disabled
media must be reverted or a way created to prevent building backports testing
packages if the srpm or a rpm built from it matches one already used in release
or updates.
Dave Hodgins 2022-12-01 00:40:01 CET

Priority: Normal => release_blocker

Comment 1 Dave Hodgins 2022-12-01 00:46:06 CET
If the broken rpmdrake feature is kept, it will likely require the build
system being modified to prevent packages being mistakenly created in the
backports testing repos that already exist in the release or updates repos,
since any packager can build packages there, immediately impacting users.
Dave Hodgins 2022-12-01 00:48:05 CET

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=29830

Morgan Leijström 2022-12-31 17:56:02 CET

CC: (none) => fri
Target Milestone: --- => Mageia 9


Note You need to log in before you can comment on or make changes to this bug.