Bug 31087 - Soundcard stays SUSPENDed using pipewire+pulseaudio after pausing a video
Summary: Soundcard stays SUSPENDed using pipewire+pulseaudio after pausing a video
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard:
Keywords: FOR_ERRATA9
Depends on:
Blocks:
 
Reported: 2022-11-07 18:40 CET by Guillaume Bedot
Modified: 2022-12-29 09:51 CET (History)
4 users (show)

See Also:
Source RPM: pulseaudio
CVE:
Status comment:


Attachments

Description Guillaume Bedot 2022-11-07 18:40:40 CET
Description of problem:
When I play a video under cauldron (whatever player I tried vlc, videos, mplayer), if i click pause, I have no more sound when I click play a few seconds later.

Version-Release number of selected component (if applicable):
pulseaudio 16.1-5
wireplumber 0.4.12-2
pipewire 0.3.59-2

How reproducible:
Everytime

Steps to Reproduce:
1. Configure audio volume that suits you (me: master at 100%)
2. Play a video
3. Pause the video for a few seconds (not sure what the suspend-on-idle default is, say 5s)
4. play again: no sound
Comment 1 Guillaume Bedot 2022-11-07 18:50:35 CET
I have first found the following workaround :
1. unplug the speakers
2. replug the speakers
3. play the video (quickly?)
4. tune the volumes again

not very handy, isn't it ?

2nd workaround: disable pulseaudio suspend-on-idle module

3rd workaround switch from pulseaudio to pipewire-pulseaudio

Good news ! i didn't know pipewire alone supported bluetooth yet !

So, where are we feature-wise regarding pipewire vs pulseaudio ?
Comment 2 Guillaume Bedot 2022-11-07 19:06:03 CET
In case my hardware/hardware drivers are at fault, i'm using a very old own-built desktop with hda audio:
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
Comment 3 Lewis Smith 2022-11-08 09:36:20 CET
Re your hardware, please post the O/P of:
 $ inxi -Axx

I have tested your problem on a couple of videos with sound, and various players (under LxQt):
 Gnome Videos misbehaved all round initially, but eventually worked OK.
 Parole
 VLC
 Xine exited immediately!
 XPlayer
Where the videos played correctly, it was always possible to pause & resume - sound included.

Bug 30997 has a lot of discussion on this. Please look at that. The essential that came out was using pavucontrol:
- ensure the correct Output Device is shown.
[On my own Cauldron system, headphones, no speakers, the headphones are incorrectly shown 'not connected', and the Ouput device defaults to Speakers (none)].
- and that the Configuration choice is correct.

CC'ing Giuseppe especially re comment 1.

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=30997
CC: (none) => ghibomgx, lewyssmith

Comment 4 Giuseppe Ghibò 2022-11-08 15:22:47 CET
Yes using pavucontrol could mitigate, but in some case after a reboot or a few minutes later everything is back as before.

4th workaround: install pipewire-media-session (this would remove wireplumber as they are mutually exclusive). Rather than pipewire vs pulseaudio, the debate is "pipewire-media-session" vs "wireplumber".

5th workaround: remove both wireplumber and pipewire-media-session.

6th workaround: remove all pipewire packages, including wireplumber and pipewire-media-session.

And reboot after every attempt.

Beyond what already reported on bug #30997, there were also a recent report on wireplumber github|gitlab commits, which seems related to similar problems. In particular a fix in this commit:

https://github.com/PipeWire/wireplumber/commit/f79a330849ebf320c42d03c123f48fec6b9ad3a8

(that we don't yet include in our wireplumber package), and that refers to a fix for a description of the problem with audio not much far from ours, which was this one:

https://github.com/Audio4Linux/JDSP4Linux/issues/74
Comment 5 Guillaume Bedot 2022-11-08 18:57:55 CET
This is the output of inxi -Axx:

Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M3A78-EH driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383
  Sound API: ALSA v: k6.0.7-desktop-1.mga9 running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
Comment 6 Lewis Smith 2022-11-09 21:56:18 CET
Thanks Giuseppe for your comment 4, and Guillaume for those details.
Looking also at Bug 30997, I am lost between:
 pulseaudio
 pulseaudio-volume-control
 pipewire
 pipewire-media-session
 wireplumber
Can you G say what combinations of these make sense?

Noting that
 $ rpm -qa | grep -E -s 'pipewire|wireplum' | sort
gives for M8 just:
 lib64pipewire0.3_0-0.3.19-1.mga8
while Cauldron (an M8 upgrade) shows:
 kpipewire-5.25.90-2.mga9
 lib64kpipewire5-5.25.90-2.mga9
 lib64kpipewirerecord5-5.25.90-2.mga9
 lib64pipewire0.3_0-0.3.59-2.mga9
 lib64wireplumber0-0.4.12-2.mga9
 pipewire-0.3.59-2.mga9
 wireplumber-0.4.12-2.mga9
In both cases Configuration needed correcting with pavucontrol to Analogue Stereo to get sound, also ensuring Port|Ouput is set to [in my case] Headphones.
Comment 7 Giuseppe Ghibò 2022-11-09 23:59:10 CET
1st combination) from your actual do:

urpmi pipewire-media-session

it will prompt:

The following package has to be removed for others to be upgraded:
wireplumber-0.4.12-2.mga9.x86_64
 (due to conflicts with pipewire-session-manager) (y/N) 

-> answer y

then reboot and see if system is more stable. This would be the same configuration as earlier cauldron.

2nd combination) from your initial one, do:

urpme wireplumber lib64wireplumber0

this would remove wireplumber and also pipewire too. Would keep libpipewire0.3_0. This should be a configuration similar to what in mga8 with PA only.

BTW, how many times it requires to correct the output profile in pavucontrol? At every boot? At every desktop session? At every pause of playing?
Comment 8 Lewis Smith 2022-11-12 09:49:13 CET
> how many times it requires to correct the output profile in pavucontrol?
> At every boot? At every desktop session? At every pause of playing?
RE pavucontrol, my particular system:
Configuration 'Analogue Stereo' sticks permanently after the one-off initial correction, that is OK.
For the Output Device, Port, I have to re-set it at least at each boot (I have not checked, but will, between logins) from Speakers to Headphones, but this may be a fault of my box because the headphones are shown "(unplugged)" whereas they are plugged in; so defaulting to Speakers has some sense [even though there are none].
I must cross-check this with Mageia 8 on the same box.

It will need somebody else with headphones & no speakers to see whether this happens elsewhere, or whether it is a peculiarity of my box.
CC'ing Ben who might be able to compare, with current ISOs.

For the record (see comment 6 Cauldron for installed pkgs):
 $ inxi -Axx
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: Fujitsu Micro driver: snd_hda_intel v: kernel bus-ID: 00:0e.0
    chip-ID: 8086:3198
  Sound API: ALSA v: k6.0.7-desktop-1.mga9 running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: no

Given that the M8 system works with so few packages (comment 6), is it worth me removing packages one by one (except 'lib64pipewire0.3_0') to see what still flies?

CC: (none) => westel

Comment 9 Lewis Smith 2022-11-12 10:28:34 CET
Still on Cauldron, talking of pauvcontrol, I confirm that between different sessions on the same boot:
* The Configuration sticks correctly.
* The Output Device, Port, after having been corrected from Speakers to Headphones (shown disconnected) in one session, always reverts to Speakers for the next one.
Comment 10 Lewis Smith 2022-11-12 11:09:04 CET
Under M8 on the same box, exactly the same behaviour as previous comment. Probably due to the box itself resulting in Headphones shown 'unplugged'.

All this should experimentation really have been on Bug 30997 !
---------------------------------------------------------------
Let's get back to Guillaume's original complaint about paused video sound not resuming.

@Guillaume
1. You talked just of video sound. What happened for straight audio, paused then resumed?

2.
> 3rd workaround switch from pulseaudio to pipewire-pulseaudio
Are you able to say what package combinations of pipewire/wireplumber caused then fixed the problem?
 $ rpm -qa | grep -E -s 'pipewire|wireplum' | sort
It looks as if just pipewire is involved, not wireplummer at all.

3. From comment 2: "In case my hardware/hardware drivers are at fault"
It was not clear whether you think the problem was down to that. Given that you found workarounds, it would seem not. Can you clarify whether this is relevant?
Comment 11 Guillaume Bedot 2022-11-12 21:04:04 CET
I've reinstalled the packages as the default install of alpha1 for gnome.

At the reboot I see the right volume in pavucontrol (instead of 40% before), the right output (headphones), the right config (stereo duplex or analog stereo work).

But no sound in rythmbox...
In pavucontrol, I change to some unavailable config (5.1 or something) and back to analog stereo: the sound plays, i've found yet another workaround !

So now if I close pavucontrol, hit pause in rythmbox, wait 5s, the sound is gone again...

$ pactl list short|grep alsa
6	module-alsa-card	device_id="0" name="pci-0000_00_14.2" card_name="alsa_card.pci-0000_00_14.2" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"	
8	alsa_output.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
10	alsa_output.pci-0000_00_14.2.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
11	alsa_input.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
0	alsa_card.pci-0000_00_14.2	module-alsa-card.c
Comment 12 Guillaume Bedot 2022-11-12 21:12:19 CET
workaround #5 (urpmi pipewire-media-session) works for me
Comment 13 Guillaume Bedot 2022-11-12 21:24:00 CET
@Lewis Yes it happens for sound only (rhythmbox) and I indicated the versions in the first post

The output of inxi -Axx after I reinstalled the default packages :
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M3A78-EH driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383
  Sound API: ALSA v: k6.0.8-desktop-1.mga9 running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes

(it doesn't mention about pipewire-media-session or wireplumber, so I think it's the same)
Comment 14 Ben McMonagle 2022-11-12 22:54:10 CET
(In reply to Lewis Smith from comment #8)

> CC'ing Ben who might be able to compare, with current ISOs.
> 
thanks Lewis.

writing a new Gnome Live now.
Comment 15 Ben McMonagle 2022-11-12 23:05:01 CET
(In reply to Guillaume Bedot )

Gnome on wayland?

gnome on x11?
Comment 16 Giuseppe Ghibò 2022-11-12 23:36:48 CET
(In reply to Lewis Smith from comment #10)

> Under M8 on the same box, exactly the same behaviour as previous comment.
> Probably due to the box itself resulting in Headphones shown 'unplugged'.
> 
> All this should experimentation really have been on Bug 30997 !

Apparently this bug is more subdle, and IMHO is more than one.

For instance in wireplumber+pipewire mode, if you type

wpctl status

which should show you the status of wireplumber, similar to what "pactl info" does for PA, but instead if show an error, and the crashes:

 pw.conf ../src/pipewire/conf.c:939:try_load_conf: can't load config client.conf: No such file or directory
 
 wp_core_constructed: assertion 'self->pw_context' failed
Segmentation fault (core dumped)

for this I've already a fix for pipewire (for the upcoming 0.3.60).
Comment 17 Ben McMonagle 2022-11-12 23:40:12 CET
Gnome (on wayland)

Videos(totem) play (20s), pause (10s), play to end ok: .m4v, .mp3, .mp4, .webm, .wma, .mkv.

pulse audi set to video stream 100%
pulse audio volume control set to "built-in audio analogue stereo"
port : switches correctly between headphones or built-in speaker


selected  output from inxi -Fxxx:

System:
  Host: localhost Kernel: 6.0.7-desktop-1.mga9 arch: x86_64 bits: 64
    compiler: gcc v: 12.2.1 Desktop: GNOME v: 43.0 tk: GTK v: 3.24.34
    wm: gnome-shell dm: GDM v: 43.0 Distro: Mageia 9
Machine:
  Type: Laptop System: TOSHIBA product: PORTEGE R930 v: PT331A-0DD04301
CPU:
  Info: dual core model: Intel Core i5-3340M bits: 64 type: MT MCP
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound API: ALSA v: k6.0.7-desktop-1.mga9 running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: no
Comment 18 Ben McMonagle 2022-11-12 23:54:52 CET
same behaviour using Gnome on Xorg.

rhythmbox works fine too

will try different hardware.
Comment 19 Ben McMonagle 2022-11-12 23:55:36 CET
gnome was installed via Gnome Live alpha1 .iso
Comment 20 Ben McMonagle 2022-11-13 01:54:54 CET
2nd install via alpha1 CI x86_64 Gnome only.

no issues with audio playback (Toshiba L650)

both installs pulse-audio is default install.
Comment 21 Lewis Smith 2022-11-14 21:58:38 CET
Thanks for your tests, Ben.
Can you please show which relevant pkgs are installed?
 $ rpm -qa | grep -E -s 'pipewire|wireplum' | sort
(It looks as if just pipewire is involved, not wireplummer)
---------------------------------------------------------------
I still need to try what packages are needed (from the many I have, comment 6, Cauldron) for sound to work. Copying Guillaume's useful look-see comment 11, here is the equivalent before playing anything; playing something; pausing it; resuming it. Headphones explicitly chosen, Speakers listed but none. Output trimmed to what changes:

Initial idle:
 $ pactl list short | grep alsa
0	alsa_output.pci-0000_00_0e.0.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
0	alsa_output.pci-0000_00_0e.0.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
0	alsa_card.pci-0000_00_0e.0	module-alsa-card.c

Playing & listening:
 $ pactl list short | grep alsa
0	alsa_output.pci-0000_00_0e.0.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	RUNNING
0	alsa_output.pci-0000_00_0e.0.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 44100Hz	IDLE
0	alsa_card.pci-0000_00_0e.0	module-alsa-card.c

Pause:
 $ pactl list short | grep alsa
0	alsa_output.pci-0000_00_0e.0.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
0	alsa_output.pci-0000_00_0e.0.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
0	alsa_card.pci-0000_00_0e.0	module-alsa-card.c

Resume:
 $ pactl list short | grep alsa
0	alsa_output.pci-0000_00_0e.0.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	RUNNING
0	alsa_output.pci-0000_00_0e.0.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 44100Hz	IDLE
0	alsa_card.pci-0000_00_0e.0	module-alsa-card.c

Keywords: (none) => FOR_ERRATA9

Comment 22 Ben McMonagle 2022-11-14 23:48:27 CET
(In reply to Lewis Smith from comment #21)
> Thanks for your tests, Ben.
> Can you please show which relevant pkgs are installed?
>  $ rpm -qa | grep -E -s 'pipewire|wireplum' | sort
> (It looks as if just pipewire is involved, not wireplummer)
> ---------------------------------------------------------------
$ rpm -qa | grep -E -s 'pipewire|wireplum' | sort
lib64pipewire0.3_0-0.3.59-2.mga9
lib64wireplumber0-0.4.12-2.mga9
pipewire-0.3.59-2.mga9
wireplumber-0.4.12-2.mga9

soundcard info:
Machine:
  Type: Laptop System: TOSHIBA product: Satellite C50D-B v: PSCN4A-01600H

Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Toshiba driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Toshiba driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Sound API: ALSA v: k6.0.8-desktop-3.mga9 running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: no

$ pactl list short | grep alsa

not playing a .m4v file via *Videos* (Totem):

0	alsa_output.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 48000Hz	SUSPENDED
0	alsa_output.pci-0000_00_14.2.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 48000Hz	SUSPENDED
1	alsa_input.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED

playing the .m4v file:

$ pactl list short | grep alsa

0	alsa_output.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 48000Hz	RUNNING
0	alsa_output.pci-0000_00_14.2.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 48000Hz	IDLE
1	alsa_input.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED

paused .m4v file playback:

$ pactl list short | grep alsa

0	alsa_output.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 48000Hz	SUSPENDED
0	alsa_output.pci-0000_00_14.2.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 48000Hz	SUSPENDED
1	alsa_input.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED

and when playback has started again:

$ pactl list short | grep alsa
	
0	alsa_output.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 48000Hz	RUNNING
0	alsa_output.pci-0000_00_14.2.analog-stereo.monitor	module-alsa-card.c	s16le 2ch 48000Hz	IDLE
1	alsa_input.pci-0000_00_14.2.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
Comment 23 Lewis Smith 2022-11-15 21:36:23 CET
Your results parallel mine.
Here is the "what is really needed?" test:

1. Start point, inherent in this system M8->Cauldron
 kpipewire-5.25.90-2.mga9
 lib64kpipewire5-5.25.90-2.mga9
 lib64kpipewirerecord5-5.25.90-2.mga9
 lib64pipewire0.3_0-0.3.60-3.mga9.tainted   ***
 lib64wireplumber0-0.4.12-2.mga9
 pipewire-0.3.60-3.mga9.tainted   ***
 wireplumber-0.4.12-2.mga9
One thing to note is the 'tainted' pkgs, which I have not seen before (compare comment 6).

2. Removed 'kpipewire' which took with it 'lib64kpipewirerecord5', leaving:
 lib64kpipewire5-5.25.90-2.mga9
 lib64pipewire0.3_0-0.3.60-3.mga9.tainted
 lib64wireplumber0-0.4.12-2.mga9
 pipewire-0.3.60-3.mga9.tainted
 wireplumber-0.4.12-2.mga9
Sound still worked.

3. Tried removing 'lib64kpipewire5', but that wanted to take out Plasma!

4. You can remove pipewire and leave wireplumer; if you remove wireplumer, that takes also pipewire. But they both also remove:
 'xdg-desktop-portal' &
 'xdg-desktop-portal-gtk
So I removed all 4, leaving
 lib64kpipewire5-5.25.90-2.mga9
 lib64pipewire0.3_0-0.3.60-3.mga9.tainted
 lib64wireplumber0-0.4.12-2.mga9
and sound still worked.

5. Removing finally 'lib64wireplumber0' to leave just:
 lib64kpipewire5-5.25.90-2.mga9
 lib64pipewire0.3_0-0.3.60-3.mga9.tainted
Sound still worked, including on videos pausing/resuming.

Re-installing the two xdg pks, pulled in also
 pipewire-0.3.60-3.mga9.tainted.x86_64 +
 wireplumber | pipewire-media-session (I chose the latter for a change)
-----------------------------------------------------------------------
(In reply to Guillaume Bedot from comment #12)
> workaround #5 (urpmi pipewire-media-session) works for me
If this is still true, can we close this?

@Giuseppe
Your comment 7 agrees with all this: wireplumber & pipewire-media-session are mutually exlusive, and you suggested the latter.
Can we ensure this on installation media?
Comment 24 Giuseppe Ghibò 2022-11-15 23:00:14 CET
Pipewire was already in tainted (I guess because the tainted version was built against the tainted gstreamer), only that before there were pipewire-0.3.58 in tainted and 0.3.59 in core/release so that the version in core/release prevailed. Now we have 0.3.60-3.mga9 in tainted and 0.3.59-1.mga9 in core/release and the tainted one prevails. Since you have tested anyway the latest version I don't think it's matter for this bug. At some point they'll be in sync :-)

Well, for the tests, depends also whether sound is redirected to PA or pipewire. 
Anyway in wireplumber there is still another problem, i.e. when using:

wpctl status

it crashes, but I think it's not related to this bug, probably we need to open a new one.

IMHO what we should avoid if we don't want to hit these problems again during upgrades from 8, is forcing the wireplumber migration, which is triggered by this commit entry:

https://svnweb.mageia.org/packages/cauldron/meta-task/current/SOURCES/prefer.vendor.list?r1=1654169&r2=1790623

without that, the pipewire-media-session should be keepen. Actually the config with pipewire-media-session is the one that had less troubles. IMHO the config with wireplumber works (at least at current stage) only when tuned manually/clean installed.
Comment 25 Lewis Smith 2022-11-16 11:33:48 CET
(In reply to Giuseppe Ghibò from comment #24)
> Anyway in wireplumber there is still another problem, i.e. when using:
> wpctl status
> it crashes, but I think it's not related to this bug, probably we need to
> open a new one.
Will do.

The end of your previous comment "IMHO what we should avoid..." seems to be a definitive conclusion, different to what I thought earlier. Now:
* 'wireplumber' is normally to be preferred to 'pipewire-media-session':
- will be enforced in M8-M9 upgrades
- works on clean installs.

* If it does not work, use instead 'pipewire-media-session'.

---
Ping Guillaume for confirmation (hope) that your pause/resume problem does not happen with 'pipewire-media-session', comment 12.
Comment 26 Guillaume Bedot 2022-11-22 09:39:08 CET
(In reply to Ben McMonagle from comment #15)
> (In reply to Guillaume Bedot )
> 
> Gnome on wayland?
> 
> gnome on x11?

Gnome on wayland
Comment 27 Guillaume Bedot 2022-11-22 09:43:07 CET
> (In reply to Guillaume Bedot from comment #12)
> > workaround #5 (urpmi pipewire-media-session) works for me
> If this is still true, can we close this?
> 
IIRC, I had issues with bluetooth with this workaround, I wouldn't recommend it.
Comment 28 Guillaume Bedot 2022-11-22 13:49:31 CET
(In reply to Guillaume Bedot from comment #27)
> > (In reply to Guillaume Bedot from comment #12)
> > > workaround #5 (urpmi pipewire-media-session) works for me
> > If this is still true, can we close this?
> > 
> IIRC, I had issues with bluetooth with this workaround, I wouldn't recommend
> it.

I tested again, the headset connected right away, i add to close vlc and restart, but the headset worked.

With the latest packages at least
# rpm -qa *pulsea* *pipew* *wirep*
lib64wireplumber0-0.4.12-2.mga9
libalsa-plugins-pulseaudio-1.2.7.1-2.mga9
task-pipewire-2018.0-2.mga9
pulseaudio-client-config-16.1-6.mga9
lib64pulseaudio0-16.1-6.mga9
pulseaudio-utils-16.1-6.mga9
libpulseaudio0-16.1-6.mga9
lib64pipewire0.3_0-0.3.60-5.mga9.tainted
pipewire-0.3.60-5.mga9.tainted
pipewire-utils-0.3.60-5.mga9.tainted
pipewire-v4l2-0.3.60-5.mga9.tainted
pipewire-alsa-0.3.60-5.mga9.tainted
pulseaudio-16.1-6.mga9
pulseaudio-module-gsettings-16.1-6.mga9
pulseaudio-module-zeroconf-16.1-6.mga9
pulseaudio-module-x11-16.1-6.mga9
task-pulseaudio-2018.0-3.mga9
pulseaudio-module-bluetooth-16.1-6.mga9
pipewire-media-session-0.4.1-2.mga9
Comment 29 Lewis Smith 2022-11-22 21:01:21 CET
So for the moment, ça va?
Comment 30 Guillaume Bedot 2022-12-11 20:59:12 CET
I found out that commenting out:
["alsa.reserve"] = true
in /usr/share/wireplumber/main.lua.d/50-alsa-config.lua
fixes the issue too.

Please choose one of the solutions and apply it :)
Comment 31 Lewis Smith 2022-12-12 21:51:21 CET
Well, thank you for this fine touch.
Assigning this bug globally, because several packagers are looking at the Cauldron sound issues. The main ones are CC'd.

CC: lewyssmith => jani.valimaa
Assignee: bugsquad => pkg-bugs

Lewis Smith 2022-12-20 19:54:19 CET

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=31235

Comment 32 Lewis Smith 2022-12-26 21:59:18 CET
@Guillaume

After much recent action on the sound front, this
 https://bugs.mageia.org/show_bug.cgi?id=31235#c40
fixed sound in a big way; needing
 mageia-release-common-9-0.28.mga9
So workaround for others. As root
# rpm -e --nodeps pipewire wireplumber
# urpmi pipewire wireplumber
reboot
See to check:
 https://bugs.mageia.org/show_bug.cgi?id=31235#c51
 https://bugs.mageia.org/show_bug.cgi?id=31235#c54

Are you able to see whether this fixes your original problem?

CC: (none) => lewyssmith

Comment 33 Guillaume Bedot 2022-12-29 09:51:48 CET
Thank you for the explanation with the steps to fix.

With the same packages installed, I now have a working pulseaudio.

It's still strange to allow multiple sound servers to be installed at the same time though, but if draksound gets updated to choose from alsa, pulseaudio, pipewire (and maybe jack?) and activate only the needed services, maybe it's ok.

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.