Bug 30455 - Deja Dup's Google support will break in September 2022 for versions < 43.3
Summary: Deja Dup's Google support will break in September 2022 for versions < 43.3
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: High normal
Target Milestone: ---
Assignee: Jani Välimaa
QA Contact:
Depends on:
Reported: 2022-05-20 17:00 CEST by Michael Terry
Modified: 2023-10-23 14:04 CEST (History)
3 users (show)

See Also:
Source RPM: deja-dup-42.6-1.mga8.src.rpm
Status comment:


Description Michael Terry 2022-05-20 17:00:03 CEST
Hello! I'm the upstream maintainer of Deja Dup. Google will be removing a particular oauth workflow that Deja Dup uses in September.

This means that any new authentications for users trying to connect Deja Dup to their Google account will fail after that date (existing users that have already authenticated themselves will continue to work).

If possible, updating to 43.3 will fix this. But for older releases (Mageia 7 uses 40.x and Mageia 8 uses 42.x), I recommend a backported patch.

Here's a wiki page for more information about the issue, including backported patches for older versions: https://wiki.gnome.org/Apps/DejaDup/GoogleAuthChange2022
Comment 1 sturmvogel 2022-05-20 17:36:10 CEST
Changed package source versions and version to cauldron/MGA8TOO as MGA7 is EOL since june 2021.

Whiteboard: (none) => MGA8TOO
Source RPM: deja-dup-40.6-1.mga7.src.rpm => deja-dup-43.2-1.mga9.src.rpm; deja-dup-42.6-1.mga8.src.rpm
Version: 7 => Cauldron

Comment 2 Jani Välimaa 2022-05-20 20:38:15 CEST
Pushed deja-dup-43.3-1.mga9 to Cauldron.

CC: (none) => jani.valimaa

Comment 3 Jani Välimaa 2022-05-20 20:40:19 CEST
Pushed deja-dup-42.9-1.mga8 with a patch to mga8 core/updates_testing. Please test.


Source RPM: deja-dup-43.2-1.mga9.src.rpm; deja-dup-42.6-1.mga8.src.rpm => deja-dup-42.6-1.mga8.src.rpm
Assignee: bugsquad => qa-bugs
Whiteboard: MGA8TOO => (none)
Version: Cauldron => 8

Comment 4 Thomas Andrews 2022-05-28 21:49:32 CEST
I want to start this by saying that I have never used this app before, and don't have a clue about what I am doing. That said...

Attempting to test in a MGA8-64 Plasma Vbox guest, using the Google Drive account that came with the Gmail account I use with my Android phone and tablet. I do not use it for cloud storage, except for what my phone puts there on its own.

Installed deja-dupwhich drew in duplicity along with several dependencies, most of which included "python" in their names. Used qarepo to download the deja-dup update, which installed without issues.

Attempted to set the app to back up a single folder that contained a single .jpg photo to my Google Drive account. When I started the backup, it said It needed Drive access. I went through the now-familiar (went through it with Thunderbird) procedure of logging into my Drive account. That was successful, because I got a security email from Google about a new device accessing the account. 

But that was as far as it got. I got a popup labeled "backup failed" with this text inside:

BackendException: PyDrive backend requires PyDrive and Google API client installation.
Please read the manpage for setup details.
Exception: No module named 'httplib2'

It's more than possible that this is from user error, but it really doesn't feel like that. Even if it is, the process ought to be more transparent than this, if newbies are to get it to operate.

CC: (none) => andrewsfarm

Comment 5 Thomas Andrews 2022-05-28 21:56:24 CEST
Just tried again, this time backing up to a local folder inside the guest. That appears to work as designed.
Comment 6 Jani Välimaa 2022-05-29 13:18:22 CEST
Looks like python-pydrive2 [1] and its reqs needs to be imported and required.

[1] https://pypi.org/project/PyDrive2/
Comment 7 Jani Välimaa 2022-05-29 18:13:48 CEST
(In reply to Jani Välimaa from comment #6)
> Looks like python-pydrive2 [1] and its reqs needs to be imported and
> required.
> [1] https://pypi.org/project/PyDrive2/

Mageia 8 is a bit problematic. Also a couple of new python pkgs needs to be introduced and a version update for protobuf.
Comment 8 Thomas Andrews 2022-06-16 21:39:10 CEST
Adding the feedback flag until the python-pydrive2 issue is resolved.

Keywords: (none) => feedback

Comment 9 Morgan Leijström 2022-09-19 09:26:03 CEST
(In reply to Michael Terry from comment #0)
> Google will be removing a
> particular oauth workflow that Deja Dup uses in September.

That means now...

Priority: Normal => High
CC: (none) => fri

Comment 10 Thomas Andrews 2023-10-22 21:19:38 CEST
Well over a year, and no response. Mageia 8 will be EOL before long, and it's looking like this will be a "won't fix," but I'm re-assigning it anyway.

Assignee: qa-bugs => jani.valimaa
Keywords: feedback => (none)

Comment 11 Morgan Leijström 2023-10-23 12:39:36 CEST
We could say users should uprgade to mga9, but then it is good to make a backup first, and if they are used to DejaDup...

DejaDup is available as flatpak.
If that works on mga8, working on this is less needed.
Comment 12 Thomas Andrews 2023-10-23 14:04:22 CEST
As I understand this, the issue only affects Google Drive access, and indeed the app worked for me to back up a single file locally - as if I were backing up to an external drive, for example.

Since Google Drive access hasn't worked for over a year, surely regular Mageia 8 DejaDup users have sought out and found alternatives by now. (I use Lucky Backup to an external drive, for example.)

The flatpak version should work, I would think, but I've never tried it so I can't say for sure.

Note You need to log in before you can comment on or make changes to this bug.