Bug 30370 - Update flightgear to bug fix release 2020.3.13
Summary: Update flightgear to bug fix release 2020.3.13
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA8-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2022-05-03 23:32 CEST by Chris Denice
Modified: 2022-05-12 12:25 CEST (History)
4 users (show)

See Also:
Source RPM: flightgear-2020.3-12.2.mga8.src.rpm
Status comment:


Description Chris Denice 2022-05-03 23:32:32 CEST
A bug fix release for flightgear has been pushed upstream https://www.flightgear.org/
Comment 1 Chris Denice 2022-05-03 23:35:23 CEST
Simgear, flightgear and flightgear-data 2020.3.13 landing in updates_testing.

To test, install them, and, in a terminal enter:

fgfs --launcher

Play around. If you want to fly a plane, don't forget to allow "enabling terrasync", which downloads the scenery where you start. If you don't, you'll be in water.

Suggested advisory:

Updated simgear, flightgear and flightgear-data packages to bug fix release version 2020.3.13


Updated packages in core/updates_testing:

Source RPMs: 

Assignee: eatdirt => qa-bugs
CC: (none) => eatdirt

Comment 2 sturmvogel 2022-05-04 05:32:32 CEST
Only changed Mageia version as you built the packages for MGA updates_testing :)

Source RPM: flightgear-2020.4.0-12.2.mga8.src.rpm => flightgear-2020.3-12.2.mga8.src.rpm
Version: Cauldron => 8

Comment 3 Chris Denice 2022-05-04 10:20:43 CEST
Arf, thanks!
Comment 4 Thomas Andrews 2022-05-09 16:16:31 CEST
No installation issues using qarepo to update over the old version.

Started using the Plasma menu. It spent some time loading data of various kinds, then the gui came up. Tried switching the plane to "ufo" which was successful, but being very inexperienced at this could not figure out how to do anything.

Switched back to the Cessna and started it using autostart. advanced the throttle, managed to steer the plane down the runway but was too slow at the controls and crashed into a parked plane. Engine continued to run.

Shut it down, and ran it again. This time I was a little better at the controls and got off the ground, but steering with the keyboard was... an experience. Somehow manged to fly around, buzzed a hangar without hitting it, and landed again. Still not sure how I managed that last part.

Anyway, it seems to be working as designed. OKing, and validating. Advisory in Comment 1.

Whiteboard: (none) => MGA8-64-OK
CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update

Dave Hodgins 2022-05-12 00:11:26 CEST

CC: (none) => davidwhodgins
Keywords: (none) => advisory

Comment 5 Mageia Robot 2022-05-12 12:25:47 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.