Bug 29698 - Update request: systemd-246.16-1.mga8
Summary: Update request: systemd-246.16-1.mga8
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-25 21:03 CET by Thomas Backlund
Modified: 2021-11-28 23:35 CET (History)
5 users (show)

See Also:
Source RPM: systemd
CVE:
Status comment:


Attachments

Description Thomas Backlund 2021-11-25 21:03:47 CET
systemd bugfixes:
- Bridge FDB: Cannot add entries with IPv6 as Destination
- timesync: fix wrong type for receiving timestamp in nanoseconds
- systemd-timesyncd fails to sync time from NTP server with IPv6 address
- journal,network,timesync: fix segfault on 32bit timeval/timespec systems



SRPM:
systemd-246.16-1.mga8.src.rpm


i586:
libsystemd0-246.16-1.mga8.i586.rpm
libudev1-246.16-1.mga8.i586.rpm
libudev-devel-246.16-1.mga8.i586.rpm
nss-myhostname-246.16-1.mga8.i586.rpm
systemd-246.16-1.mga8.i586.rpm
systemd-devel-246.16-1.mga8.i586.rpm
systemd-homed-246.16-1.mga8.i586.rpm
systemd-tests-246.16-1.mga8.i586.rpm


x86_64:
lib64systemd0-246.16-1.mga8.x86_64.rpm
lib64udev1-246.16-1.mga8.x86_64.rpm
lib64udev-devel-246.16-1.mga8.x86_64.rpm
nss-myhostname-246.16-1.mga8.x86_64.rpm
systemd-246.16-1.mga8.x86_64.rpm
systemd-devel-246.16-1.mga8.x86_64.rpm
systemd-homed-246.16-1.mga8.x86_64.rpm
systemd-tests-246.16-1.mga8.x86_64.rpm
Comment 1 Herman Viaene 2021-11-26 16:14:10 CET
MGA8-64 Plasma on Lenovo B50
No installation issues.
Rebooted after installation:wifi, internet access, different LO file formats, NFS access to shares on desktop PC, sound all OK

CC: (none) => herman.viaene

Comment 2 Morgan Leijström 2021-11-26 17:34:36 CET
64 bit OK for me, incl kernel 5.15.4-desktop-1, and glibc in testing.

 on my workstation "svarten": Mainboard: Sabertooth P67, CPU: i7-3770, GM107 [GeForce GTX 750] using nvidia-current Disk: SSD with LUKS & LVM 

Tested my normal usage under Plasma, and testing VirtualBox 6.1.30

No regression noted

Possibly one problem fixed: 
BOINC World Community Grid GPU workloads "OpenPandemics - COVID-19 - GPU" earlier crashed shortly after resuming - and all fresh such workunits crashed too until I rebooted.  I assumed then it was a bug with the workunits as other kinds of BOINC GPU works have been able to resume earlier.  There was still problem after last nvidia and kernel updates, but not after glibc and systemd update.  So either this update, or some problem in the workunits have got fixed :)

CC: (none) => fri

Comment 3 Thomas Andrews 2021-11-27 15:19:53 CET
Tried this in conjunction with glibc on two 64-bit Plasma systems.

On one, updated glibc first, rebooted, then updated systemd and rebooted again. Tried a few commands, specifically checked the status of the fstrim.timer service. As expected, it had not been started on this system. Started it, then checked the status again, and it was running.

On the other, updated both glibc and systemd in one operation. Again tried a few commands. The fstrim.timer service had been started on this system months ago, and was still active after the update.

No issues noted on either system.

CC: (none) => andrewsfarm

Comment 4 Guillaume Royer 2021-11-27 20:09:16 CET
MGA 64 XFCE Core I3 and Nvidia GeForce 520M

No installation issues

System ok after reboot

CC: (none) => guillaume.royer

Comment 5 Thomas Andrews 2021-11-27 23:49:29 CET
Dell Inspiron 5100, 32-bit P4, Radeon RV200 graphics, 32-bit Xfce system using the desktop kernel.

Installed glibc and systemd in one operation. After a reboot, no regressions noted.
Comment 6 Brian Rockwell 2021-11-28 23:35:54 CET
AMD x3-450, Nvidia 730GT (390), Plasma

The following 9 packages are going to be installed:

- glibc-2.32-22.mga8.x86_64
- glibc-devel-2.32-22.mga8.x86_64
- lib64systemd0-246.16-1.mga8.x86_64
- nss-myhostname-246.16-1.mga8.x86_64
- perl-5.32.1-1.1.mga8.x86_64
- perl-base-5.32.1-1.1.mga8.x86_64
- perl-doc-5.32.1-1.1.mga8.noarch
- systemd-246.16-1.mga8.x86_64
- systemd-devel-246.16-1.mga8.x86_64


-- rebooted

Lived with for several hours, so far no issues.

CC: (none) => brtians1


Note You need to log in before you can comment on or make changes to this bug.