Bug 29380 - qarte not working anymore
Summary: qarte not working anymore
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://launchpad.net/qarte
Whiteboard: MGA8-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2021-08-17 21:19 CEST by philippe malloci
Modified: 2021-09-14 20:45 CEST (History)
5 users (show)

See Also:
Source RPM: qarte-4.11.0-1.mga8.src.rpm
CVE:
Status comment:


Attachments

Description philippe malloci 2021-08-17 21:19:37 CEST
Description of problem:
the application qarte was used to work but it is now failing with the rror message given below. the same version of the application is working fine with Linux Mint (tricia).

Version-Release number of selected component (if applicable):
        Qarte vers: 4.11.0

    Copyright (C) 2011-2020 Vincent Vande Vyvre <vincent.vandevyvre@oqapy.eu>
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

How reproducible: always

Steps to Reproduce:
1.run qarte -d
2.the IHM is briefly displayed and then disappears
3.trace:

21:12:18: INFO - qarte Qarte-4.11.0
21:12:18: INFO - qarte Python 3.8.11 on Linux-5.10.56-desktop-1.mga8-x86_64-with-glibc2.2.5
21:12:18: INFO - qarte File system encoding: utf-8
21:12:18: INFO - qarte System encoding: utf-8
21:12:18: INFO - qarte Locale encoding: ('fr_FR', 'UTF-8')
21:12:18: INFO - core Set workspace
21:12:18: INFO - core Config not found, use default
21:12:18: INFO - core with video player: True
21:12:18: INFO - core Build main window
21:12:18: INFO - artetv Fetch page: https://www.arte.tv/fr/guide/20210807/
Traceback (most recent call last):
  File "/usr/bin/qarte", line 117, in <module>
    main = Core(args)
  File "/usr/share/qarte/core.py", line 69, in __init__
    self.artetv.config_parser()
  File "/usr/share/qarte/artetv.py", line 94, in config_parser
    self.parser = Parser(ARTE_TV.replace('fr', self.lang))
  File "/usr/share/qarte/artetv.py", line 1216, in __init__
    raw = self.extract_json(page)
  File "/usr/share/qarte/artetv.py", line 1271, in extract_json
    part = content.split("window.__INITIAL_STATE__ =")[1]
IndexError: list index out of range
Comment 1 Lewis Smith 2021-08-17 22:00:28 CEST
Thank you for reporting this problem.
I confirmed that things happen as described above.

This version 4.11.0 is the latest in Cauldron.
The error is already bugged upstream:
 https://bugs.launchpad.net/qarte/+bug/1938087
 https://bugs.launchpad.net/qarte/+bug/1938087/comments/5 says:
"Changed in qarte: status:	New → Fix Released"
and
 https://bugs.launchpad.net/qarte/+bug/1938087/comments/7 says:
"qarte-4.12.0-1.homemade.fc34.noarch works fine"

so it looks like a version update should fix it.

David G has done the most recent updates to this SRPM, so assigning the bug to you. CC'ing Rémi as the listed maintainer.

URL: (none) => https://launchpad.net/qarte
Assignee: bugsquad => geiger.david68210
CC: (none) => rverschelde

Comment 2 Marja Van Waes 2021-09-03 22:23:12 CEST
This issue is valid for Cauldron, too. I built qarte-4.14.0 locally and it works fine. 
I don't think version 4.14.0 contains new shiny features, I only see bug fixes, but maybe https://bazaar.launchpad.net/~vincent-vandevyvre/qarte/qarte-4/changes/64?start_revid=64 wasn't the right place to look?

Anyway, qarte 4.14.0 was committed to cauldron and is waiting for someone to push it.

CC: (none) => marja11
Version: 8 => Cauldron
Whiteboard: (none) => MGA8TOO

Comment 3 Marja Van Waes 2021-09-05 18:14:01 CEST
Thanks to barjac, qarte-4.14.0-1.mga9 is in cauldron now.
The same version was committed to Mageia 8 and is waiting for someone to push it to updates_testing

Whiteboard: MGA8TOO => (none)
Version: Cauldron => 8

Comment 4 Marja Van Waes 2021-09-06 07:58:09 CEST
Thanks Barry, for pushing Qarte to updates_testing

Philippe, can you please test qarte-4.14.0-1.mga8.noarch.rpm from the updates_testing repository and report here whether Qarte no longer crashes on start up?


Advisory:
========================

Qarte-4.11 crashed immediately when started. This version contains the fix and a few smaller additional fixes.

========================

Packages in 8/core/updates_testing:
========================
qarte-4.14.0-1.mga8.noarch.rpm

Source RPM:
========================
qarte-4.14.0-1.mga8.src.rpm

Assignee: geiger.david68210 => qa-bugs

Comment 5 Len Lawrence 2021-09-06 09:19:26 CEST
mga8, x64

$ qarte -d
07:46:05: INFO - qarte Qarte-4.11.0
07:46:05: INFO - qarte Python 3.8.11 on Linux-5.10.62-desktop-1.mga8-x86_64-with-glibc2.2.5
07:46:05: INFO - qarte File system encoding: utf-8
07:46:05: INFO - qarte System encoding: utf-8
07:46:05: INFO - qarte Locale encoding: ('en_GB', 'UTF-8')
07:46:05: INFO - core Set workspace
07:46:05: INFO - core Load config from: /home/lcl/.Qarte/user_config
07:46:05: INFO - core with video player: True
07:46:05: INFO - core Build main window
07:46:05: INFO - artetv Fetch page: https://www.arte.tv/fr/guide/20210827/
Traceback (most recent call last):
  File "/usr/bin/qarte", line 117, in <module>
    main = Core(args)
  File "/usr/share/qarte/core.py", line 69, in __init__
    self.artetv.config_parser()
  File "/usr/share/qarte/artetv.py", line 94, in config_parser
    self.parser = Parser(ARTE_TV.replace('fr', self.lang))
  File "/usr/share/qarte/artetv.py", line 1216, in __init__
    raw = self.extract_json(page)
  File "/usr/share/qarte/artetv.py", line 1271, in extract_json
    part = content.split("window.__INITIAL_STATE__ =")[1]
IndexError: list index out of range

After updating qarte worked fine for arte TV.  Downloaded four episodes of  
"L'odyssée interstellaire" with French subtitles.  The videos played fine in vlc with the subtitles.

Whiteboard: (none) => MGA8-64-OK
CC: (none) => tarazed25

Comment 6 Thomas Andrews 2021-09-14 02:53:41 CEST
I'm going to validate based on Len's test. Philippe, please feel free to comment in answer to Marja's request, even though the update has been validated. 

Advisory in Comment 4.

CC: (none) => andrewsfarm

Thomas Andrews 2021-09-14 02:54:20 CEST

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update

Comment 7 philippe malloci 2021-09-14 20:45:09 CEST
Qarte version 4.14.0 successfully installed and tested. No more crash on start up and downloads running fine. Merci beaucoup!!!

Note You need to log in before you can comment on or make changes to this bug.