Bug 28225 - Installer: grub-image not loaded
Summary: Installer: grub-image not loaded
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal minor
Target Milestone: Mageia 8
Assignee: ISO building group
QA Contact:
URL:
Whiteboard:
Keywords: IN_ERRATA8
Depends on:
Blocks:
 
Reported: 2021-01-26 17:44 CET by Marc Krämer
Modified: 2021-02-13 19:06 CET (History)
5 users (show)

See Also:
Source RPM:
CVE:
Status comment: netinstall iso


Attachments

Description Marc Krämer 2021-01-26 17:44:55 CET
netinstaller: beta 2:
grub loading and shows 
error: ../../grub-core/video/readers/png.c:595 invalid filter value

after this message grub is loaded without background image.
Comment 1 Aurelien Oudelet 2021-01-28 20:56:12 CET
Hi, thanks reporting this.
This is against M8 Netinstall ISO.

This error occurs after installing M8 or when booting the netinstall ISO?

Can you provide me some details about your partitions setup, please and the architecture?

We can't reproduce it with default presets.

CC: (none) => ouaurelien

Aurelien Oudelet 2021-01-28 20:56:24 CET

Keywords: (none) => 8rc1
Version: 8 => Cauldron
Target Milestone: --- => Mageia 8

Comment 2 Lewis Smith 2021-01-28 21:03:52 CET
[Collision with Aurélien, so some repetition]

Marc, can you please provide some system information?
 inxi -MSDop
and some background. Does this happen at the end of installation? Or at first re-boot? Or has it arisen in an established system? You say 'beta 2', which is quite old; but if you have kept it up-to-date, it would be just that. A new netinstall (I guess) would use up-to-date packages.

I can find no reference to any part of /grub-core/video/readers/png.c in our packages. Please say what bits & version of Grub you have:
 $ rpm -qa | grep grub

CC: (none) => lewyssmith

Comment 3 Marc Krämer 2021-01-29 10:29:12 CET
This happens on the ISO itself!
I've downloaded the netinstaller for mga8 as provided on the mageia page. I chose netinstall because the packages itself come from cauldron. So I had a new uptodate system.

Copied the image to a boot stick, started the stick and the error is shown. Afterwards I had the textual grub (which works, but is just not very nice on first startup)

After the installation of grub2, everything works as intended.
Comment 4 Aurelien Oudelet 2021-01-29 11:17:01 CET
Yeah Marc.

To be sure, this is against netinstall iso.
x86_64 or i586. UEFI boot or legacy bios?

I have not yet reproduce.

Status comment: (none) => netinstall iso

Comment 5 Chris B 2021-01-29 11:31:12 CET
I can't reproduce this error.
I downloaded the 'newest' netinstall non-free 64 bit iso.
Booted in legacy, non-uefi mode. No error, just the normal text based boot screen, what is supposed to be without graphical grub.
Booted in uefi mode, graphical grub, no errors.

Maybe Marc just had bad luck, with a netinstall iso (which changes with every new kernel), and when we were just switching to the new Mageia theme and it didn't make it to the netinstall iso?

CC: (none) => shybluenight

Comment 6 Marc Krämer 2021-01-29 13:27:14 CET
This was on x86_64, with UEFI enabled. Unfortunately I don't have this laptop anymore (was already shipped)

I tested the same scenario on onther laptop. Booting UEFI shows graphical boot screen, with legacy enabled I just get the textual screen.

I'll do some more tests on other hardware - strange behaviour.
Comment 7 Marc Krämer 2021-01-29 17:45:00 CET
I've tested again. It is wired.
Legacy: On all machines (x86_64) boot only shows text screen

UEFI: on some machines I get a graphical screen and on some I get the error above and then a textual screen.

It's just looking bad, but not severe.

Priority: Normal => Low

Comment 8 Lewis Smith 2021-01-30 14:23:42 CET
(In reply to Marc Krämer from comment #0)
> netinstaller
> grub loading and shows 
> error: ../../grub-core/video/readers/png.c:595 invalid filter value
> after this message grub is loaded without background image.
...
(In reply to Marc Krämer from comment #7)
> Legacy: On all machines (x86_64) boot only shows text screen
> UEFI: on some machines I get a graphical screen and on some I get the error
> above and then a textual screen.
So we are happy about the text menu for BIOS/MBR booting; normal & correct.
The variablility for EFI booting is fortunately cosmetic, with no functional consequences.

This looks good for ERRATA8. When is the bug closed? After M8 is pushed, with its ERRATA?

Keywords: 8rc1 => FOR_ERRATA8

Comment 9 Morgan Leijström 2021-02-05 20:31:19 CET
As operation is not affected, i think we need not put this in Errata.
At least not in RC stage.

But it could look better.

Raising to normal and... iso buiding group - if incorrect please adjust.

Assignee: bugsquad => isobuild
CC: (none) => fri
Priority: Low => Normal

Comment 10 Morgan Leijström 2021-02-11 20:09:22 CET
Is this ugly looking enough for errata?
Comment 11 Lewis Smith 2021-02-12 20:49:14 CET
I think yes; not because the text menu itself is ugly (other distros use nothing else), but an error message is always worrying:
 error: ../../grub-core/video/readers/png.c:595 invalid filter value

Thanks to Marc for pinning it down. Suggest ERRATA:
"NetInstaller
On some UEFI machines the NetInstaller boots with a Grub error message:
 error: ../../grub-core/video/readers/png.c:595 invalid filter value
then shows a text Grub2 menu rather than the normal graphical one. Functionality is not effected; it is just a cosmetic quirk."

CC: lewyssmith => (none)

Comment 12 Morgan Leijström 2021-02-13 09:11:49 CET
Thanks
https://wiki.mageia.org/en/Mageia_8_Errata#NetInstaller

Keywords: FOR_ERRATA8 => IN_ERRATA8

Comment 13 Barry Jackson 2021-02-13 13:28:39 CET
Has the background image in that .iso been tested with pngcheck?

CC: (none) => zen25000

Comment 14 Martin Whitaker 2021-02-13 19:06:13 CET
@Barry, I've just tested and pngcheck reports OK. In any case, it displays fine on  many machines.

@Marc, do you see the same failure with the classical installer or Live ISOs?
(only need to test one - they all have the same background image)

CC: (none) => mageia


Note You need to log in before you can comment on or make changes to this bug.