Bug 28048 - Nextcloud-client update to 3.1.x
Summary: Nextcloud-client update to 3.1.x
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-09 18:38 CET by Morgan Leijström
Modified: 2021-01-18 11:45 CET (History)
4 users (show)

See Also:
Source RPM: nextcloud-client-3.0.3-1.mga7.src.rpm
CVE:
Status comment:


Attachments

Description Morgan Leijström 2021-01-09 18:38:16 CET
We need to keep nextcloud client updated.

We can skip 3.1.0; there is already point release 3.1.1 with some fixes

https://github.com/nextcloud/desktop/releases
Comment 1 Morgan Leijström 2021-01-09 18:39:21 CET
Cauldron is at 3.1.0
Mageia 7 at 3.0.3

CC last packager

Whiteboard: (none) => MGA7TOO
CC: (none) => mageia
Version: 7 => Cauldron

Morgan Leijström 2021-01-09 19:00:11 CET

Assignee: bugsquad => pkg-bugs

Comment 2 Nicolas Lécureuil 2021-01-10 01:03:16 CET
pushed in mageia 7 updates_testing
src:
    nextcloud-client-3.1.0-1.mga7

CC: (none) => mageia
Assignee: pkg-bugs => qa-bugs

Comment 3 Aurelien Oudelet 2021-01-10 17:43:29 CET
Assigning for M7 updates
But, as Morgan said, it will be useful to have 3.1.1 version.
Meanwhile, here is adv:


Suggested advisory:
========================

Updated nextcloud-client package improves compatibility

The updated nextcloud-client package improves compatibility
and fixes bugs.
See upstream release notes.

references:
- https://github.com/nextcloud/desktop/releases/tag/v3.1.0
========================

Updated packages in core/updates_testing:
========================

lib(64)nextcloud-client-devel-3.1.0-1.mga7
lib(64)nextcloudsync0-3.1.0-1.mga7
nextcloud-client-3.1.0-1.mga7
nextcloud-client-caja-3.1.0-1.mga7
nextcloud-client-dolphin-3.1.0-1.mga7
nextcloud-client-nautilus-3.1.0-1.mga7
nextcloud-client-nemo-3.1.0-1.mga7

from SRPM
nextcloud-client-3.1.0-1.mga7

CC: (none) => ouaurelien
Version: Cauldron => 7
Whiteboard: MGA7TOO => (none)

Comment 4 Aurelien Oudelet 2021-01-10 17:49:07 CET
s/package improves/packages improve
s/fixes/fix
in adv.
Comment 5 Morgan Leijström 2021-01-10 17:49:57 CET
Mageia 7 64 bit client 3.1.0 to 20.0.2 server:

In short i think packaging is OK, thanks

- but I doubt upstream quality.

Running version 3.0.3, updated cleanly, reboot: Version 3.1.0 simply autostarted and kept on syncing without issues, and the previously paused syncs remained paused.  I also created new folder syncing, confirmed it works both ways, and i could remove it later.

So far so good... but! :

For another server (same app was syncing to two servers): when i removed an existing syncing folder, the app immediately disappeared from screen and as process...  Restarting it, it continued syncing.  I added a new sync, confirmed it worked, and deleted it, then i could delete also another, the last, sync with that server without crash.  A problem is it sometimes take 100% CPU for seconds when i select that server and interface is unresponsive in that time.  Restarted the client - same problem. Right clicked that server and selected to remove it -> Segfault.  Restart -> segfault in a couple seconds, never a GUI.  Having it create a log file it produce 56 KB of normal output before crash, and it tell no reason.

Brobably broken upstream.  That said I do not think i tried to remove a server from 3.0.3.  Quick web search gave no hit for this problem.
Comment 6 Morgan Leijström 2021-01-10 18:22:10 CET
Probably downgrading from 3.1 to 3.0 is not supported due to 
   desktop#2616 Move journaldb files back to sync folders

Could you please package 3.1.1 and by chance this problem that at least I hit is fixed.

Assignee: qa-bugs => pkg-bugs

Comment 7 Morgan Leijström 2021-01-11 08:45:07 CET
Also remember that we must not supply a version on mga7 higher than we release in mga8. But 3.1.1 can remain in testing until updated to in mga8.

If 3.1.1 do fix significant bugs we should ask to update to it in mga8.

CC Brian who use to test this package

CC: (none) => brtians1

Comment 8 Nicolas Lécureuil 2021-01-11 15:14:54 CET
nextcloud-client 3.1.1 is now in cauldron
Comment 9 Brian Rockwell 2021-01-11 15:31:39 CET
Testing in MGA8 - so far so good.

Able to sync and post files.
Comment 10 Morgan Leijström 2021-01-11 15:41:33 CET
Can you add and sync with a second server, and remove the first server?

I can give you a test account to try with.
Comment 11 Brian Rockwell 2021-01-11 16:20:25 CET
I was able to add an external account I have and it is syncing.

Was also able to remove the account after the sync.  Seems to be working.
Comment 12 Morgan Leijström 2021-01-11 16:45:25 CET
Thank you Brian

So at least we know 3.1.1 it works in a new install, where 3.1.0 failed update the real world scenario i borked.

( I assume this was a new install, no old configuration? )

@ Nicolas, please package 3.1.1 for mga7.
3.1.0 is not needed - even better avoided - so please remove.
Comment 13 Brian Rockwell 2021-01-12 04:32:13 CET
MGA7 - 64

$ uname -a
Linux linux.local 5.7.19-desktop-3.mga7 #1 SMP Sun Oct 18 15:46:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

The following 25 packages are going to be installed:

- lib64cloudproviders0-0.3.0-2.mga7.x86_64
- lib64gnome-keyring0-3.12.0-11.mga7.x86_64
- lib64minizip1-1.2.11-7.mga7.x86_64
- lib64nextcloudsync0-3.1.1-1.mga7.x86_64
- lib64ocsync0-3.1.1-1.mga7.x86_64
- lib64qt5keychain1-0.9.1-2.mga7.x86_64
- lib64qt5positioning5-5.12.6-1.mga7.x86_64
- lib64qt5printsupport5-5.12.6-4.mga7.x86_64
- lib64qt5quickcontrols2_5-5.12.6-1.mga7.x86_64
- lib64qt5quicktemplates2_5-5.12.6-1.mga7.x86_64
- lib64qt5quickwidgets5-5.12.6-1.mga7.x86_64
- lib64qt5sensors5-5.12.6-1.mga7.x86_64
- lib64qt5webchannel5-5.12.6-1.mga7.x86_64
- lib64qt5webengine5-5.12.6-1.mga7.x86_64
- lib64qt5webenginecore5-5.12.6-1.mga7.x86_64
- lib64qt5webenginewidgets5-5.12.6-1.mga7.x86_64
- lib64qt5webkit5-5.212.0-1.alpha3.1.mga7.x86_64
- lib64qt5webkitwidgets5-5.212.0-1.alpha3.1.mga7.x86_64
- lib64re2_0-20190401-1.mga7.x86_64
- lib64snappy1-1.1.7-2.mga7.x86_64
- libgnome-keyring-i18n-3.12.0-11.mga7.noarch
- nextcloud-client-3.1.1-1.mga7.x86_64
- qtquickcontrols25-5.12.6-1.mga7.x86_64
- qtsensors5-5.12.6-1.mga7.x86_64
- qtwebengine5-5.12.6-1.mga7.x86_64

---

start nextcloud client and set up local machine running Nextcloud 20.0.4.

I was able to sync fine.  Works for me though I don't really like the new panel icon.
Comment 14 Morgan Leijström 2021-01-12 11:29:03 CET
Hurray!
In comment 5, testing on mga7 update dual account use on 3.0.3 to to 3.1.0 got into unusable state where it segfaulted at start.

Now updated to 3.1.1 and it runs perfectly.
And i could add and remove account too.

Whiteboard: (none) => MGA7-64-OK
Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 15 Morgan Leijström 2021-01-12 11:30:27 CET
Ah wait, advisory was for 3.1.0...

CC: sysadmin-bugs => (none)
Keywords: validated_update => (none)

Comment 16 Morgan Leijström 2021-01-18 11:45:26 CET
This only need updated advisory (version) uploaded, and then we ship.

Note You need to log in before you can comment on or make changes to this bug.