Bug 278 - Improve the user interface of the Network Control Center
Summary: Improve the user interface of the Network Control Center
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal enhancement
Target Milestone: Mageia 7
Assignee: Olivier Blin
QA Contact:
URL:
Whiteboard: (MGA2)
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-04 22:42 CET by Juergen Harms
Modified: 2019-02-19 19:25 CET (History)
4 users (show)

See Also:
Source RPM: drakx-net
CVE:
Status comment:


Attachments

Description Juergen Harms 2011-03-04 22:42:57 CET
Description of problem:


Version-Release number of selected component (if applicable):0.93-3.mga1


How reproducible:


Steps to Reproduce:
1. Launch draknetcenter
2. Select "Wireless (Wifi)"
3. Hit the Connect / Disconnect button (assuming the the Wlan interface is already configured)

When configuring / (dis)connecting a wlan interface, the user interface to draknetcenter does not provide sufficient user-feedback on the success of connect / disconnect actions. In particular, the user would expect the network center to

- update the icon in the "Wireless (Wifi)... " line (1st line of the
   "wlan" section) of the display - icon with a red checkbox (disconnected),
   resp. a transmitter icon (connected),

 - update the label of the "Connect/Disconnect" button (right bottom below
   the display of available interfaces) to reflect the new state,

 - update the icon in the selected line of the list available networks that
   represents the connection state of the network

At present, hitting the connect / disconnect button makes a small window
appear, which after some labour goes away without providing information on the
success of the operation. To verify whether the connect / disconnect really has been done, the network center must be closed and re-launched.

There is a minor issue that should be easy to improve:
- the antenna icon used is difficult to discern against the background,
  in particular the difference between the icon with a single circle
  (disconnected) or serveral circles (connected).

It would be of big help, if the yellow popup window that results from hovering over the network icon in the system tray could not only indicate details of the wired connection, but also that of a connected wlan - but this might be a KDE ("upstream") issue.


Reproducible: 

Steps to Reproduce:
Comment 1 Marja Van Waes 2011-10-02 21:50:29 CEST
Sorry for responding so late.

Do you mind giving an update about these issues in current Cauldron?

CC: (none) => m.van.waes

Comment 2 Juergen Harms 2011-10-04 08:03:49 CEST
Thank you for picking this up. Things have slightly evolved - here is a list modifications to be applied to the original bug report:

1. The version is now "1" and not "Cauldron" any more

2. Version-Release number is now drakx-net-0.97-1.mga1

3. The GUI has changed - best if I reword my bug description to reflect these changes, but also to make it easier to understand

-------------------------

When configuring / (dis)connecting a wlan interface, the user interface to
draknetcenter applet practically does not provide any feedback on success or failure of the operation:

- the "Wireless (Wifi)... " line (1st line of the "wlan" section) of the display
sufficient user-feedback on the success of remains in its initial state (red or green) - which represent that state of the connection at the moment the applet was launched: it should change from red to green when, after hitting the "Connect button" (and having waited some time) the state of the connection changes to green - and vice-versa for disconnecting

 - the Action selection button keeps its initial label and action (e.g. label = Connect, action = launch connection if the initial state was "disconnected", resp. Disconnect and launch disconnection if the initial state was "connected"). The label and action attached to the button should toggle once an action has succes: it should switch from Connect to Disconnect.

Some "moralising": at present, the user does not get feedback on the success of what he asked to be done - the "connecting" resp. "disconnecting" popup just disappears after some time, the user must quit the applet and launch it again to verify if the action terminated with success or not.

A secondary benefit would be, that - whithout re-launching the applet - one could do the opposite action (e.g. disconnect after a connect), for instance while testing a connection.

It would be of big help, if the popup window that results from hovering
over the network icon in the system tray could not only indicate details of the
wired connection, but also that of a connected wlan - but this might be a KDE
("upstream") issue.

--------------------------

While doing this rewording, I hit another item that would be nice to tackle if time is invested on improving the user interface of the draknet applet: the draknet applet should allow to switch between profiles. Background:

At present, a switch between existing profiles can only be done by in the Mageia control center (configure network configuration branch).

However, the Draknet applet has a clear distinction of its functionality with respect to what is done in the Control Center: it allows to select between already existing alternatives, it allows to do this without root privileges, and it is tailoured for use by a simple user. Changing a profile comes into this category, having that option in the applet would make the applet a substantially more powerful tool.

Usage example: on my laptop, I have added a "home" profile (connection to my home access point) and a "roaming" profile (to use when I am travelling, for instance in a meeting with a guest access point) - I am retired, otherwise I might also have a "work" profile.
Comment 3 Manuel Hiebel 2011-10-04 12:40:07 CEST
(In reply to comment #2)
> Thank you for picking this up. Things have slightly evolved - here is a list
> modifications to be applied to the original bug report:
> 
> 1. The version is now "1" and not "Cauldron" any more
But for the enhancement request, the work is for the new release and not for the stable. ;)

(But we don't have a drakx-net maintainer for now :/ )

Source RPM: drakx-net-0.93-3.mga1 => drakx-net

Comment 4 Juergen Harms 2011-10-04 16:59:33 CEST
Sure - that was my understanding. Let me add some priorities to my wish list:

1.  Give the user feedback on what he is achieving (base the implementation on sound GUI principles)

10. Add a "select-profile feature"
12. Show the state of the wireless connection in the popup window

(using a scale of 1 ... 20)
Marja Van Waes 2011-10-24 21:24:54 CEST

Assignee: bugsquad => mageia

Marcello Anni 2011-12-12 15:29:03 CET

CC: (none) => marcello.anni

Comment 5 Marja Van Waes 2012-05-26 13:10:08 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja

Keywords: (none) => NEEDINFO

Manuel Hiebel 2012-06-12 21:35:56 CEST

Keywords: NEEDINFO => (none)

Comment 6 Juergen Harms 2012-06-12 22:53:14 CEST
It is valid for Mageia 2 - for instance, see the discussions in the forum on the lack of feedback on connection status
Comment 7 Marja Van Waes 2012-06-12 23:25:36 CEST
(In reply to comment #6)
> It is valid for Mageia 2 - for instance, see the discussions in the forum on
> the lack of feedback on connection status

Thanks, Juergen :)

When I pinged all those bugs I didn't have time to look at each on of them, I had to mass-select them.

Whiteboard: (none) => MGA2TOO

Comment 8 Manuel Hiebel 2012-06-12 23:27:32 CEST
well we can't new feature in a stable release
Comment 9 Marja Van Waes 2012-06-13 08:14:37 CEST
(In reply to comment #8)
> well we can't new feature in a stable release

ouch, you're right.

Changing MGA2TOO to (MGA2)

Whiteboard: MGA2TOO => (MGA2)

Comment 10 Juergen Harms 2012-06-13 10:59:30 CEST
Well, there is the alternative to make this a features proposals for Mageia 3 - but I think it is better to keep it as an enhancement bug: the suggestion is to improve (some details in) an existing application, without getting into the discussion on concepts of configuring a network interface.

Is MGA2 the right whiteboard keyword for an enhancement to be considered during pre-release cauldron?
Comment 11 Marja Van Waes 2012-06-13 12:05:23 CEST
(In reply to comment #10)

> Is MGA2 the right whiteboard keyword for an enhancement to be considered during
> pre-release cauldron?

No that is "Target Milestone: Mageia 3"

Thanks for asking :)

I use (MGA2) to show the bug wasn't solved for Mageia 2, because months after Mageia 1 release I still saw open bug reports against old cauldron, that had never been confirmed for Mageia 1 and/or for cauldron after Mageia 1 release. Many of those bugs weren't valid anymore.

Target Milestone: --- => Mageia 3

Comment 12 Marja Van Waes 2015-04-19 14:13:19 CEST
Sorry, but this bug saw no action since more than 2 yrs ago. 
No cauldron package has stayed the same since then.

Closing as OLD

Please reopen if this report is still valid for _current_ cauldron and/or fully
updated Mageia 4

Resolution: (none) => OLD
Status: NEW => RESOLVED

Comment 13 Samuel Verschelde 2015-04-19 15:46:44 CEST
Let's not close enhancement requests, those can remain valid for a long time.

Status: RESOLVED => REOPENED
Resolution: OLD => (none)
CC: (none) => stormi

Comment 14 Juergen Harms 2015-04-19 18:54:49 CEST
Samuel is right - but: the description of the bug, and the suggestion how to go about improving the interface is slightly outdated.

The interface to wifi configuration is still poor, and not adapted to what naive users expect. It violates one of the basic principles of user-interface design: when a user requests an action, there should be an acknowledgement, and the user should get informed about success or failure - that is a generalisation of my initial suggestion for an enhancement.
Comment 15 Marja Van Waes 2015-04-19 18:57:59 CEST
CC'ing anaselli, in case he intends to have a libyui port of drakx-net, too

CC: (none) => anaselli

Comment 16 Juergen Harms 2015-04-19 19:11:11 CEST
@Anaselli: if you think that a second set of fingers could be of help, tell me. I dropped supporting packages since (given age and health) I cannot commit any more to do urgent-response work, but this is a kind of project where I think that I can contribute.
Comment 17 Angelo Naselli 2015-04-20 11:07:37 CEST
@Juergen Harms (comment #16) i think drakx-net is almost all to be ported yet, matteo
started to work on it, just because he needed that to work on manahost and manawall 
(firewall). If you think you can contribute please contact me privately via mail 
and let's see what you can/would like to do. There are a lot of things in manatools to
work on yet, but that is a bit OT here :)
Comment 18 Juergen Harms 2019-02-19 19:22:24 CET
Still valid (Mageia-7 Beta-1) - the arguments to keep this as an enhancement request are still valid too.
Juergen Harms 2019-02-19 19:25:33 CET

Target Milestone: Mageia 3 => Mageia 7
Hardware: i586 => All


Note You need to log in before you can comment on or make changes to this bug.