Bug 27340 - FreeCAD sometimes segfaults on Open FreeCAD material editor (FEM)
Summary: FreeCAD sometimes segfaults on Open FreeCAD material editor (FEM)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA7-64-OK
Keywords: IN_ERRATA8, advisory, validated_update
Depends on:
Reported: 2020-09-30 01:46 CEST by Herbert Poetzl
Modified: 2021-03-30 22:10 CEST (History)
8 users (show)

See Also:
Source RPM: freecad-0.18.2-1.mga7.src.rpm
Status comment:


Description Herbert Poetzl 2020-09-30 01:46:58 CEST
Description of problem:
When selecting 'Open FreeCAD material editor from the FEM Workbench, FreeCAD segfaults.

Version-Release number of selected component (if applicable):
FreeCAD 0.18, Libs: 0.18RUnknown

How reproducible:

Steps to Reproduce:
1. Start FreeCAD
2. Create new document
3. Select FEM Workbench
4. Press the icon with the three yellow balls

FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

locations to look for material cards:

Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3caf0) [0x7f4fa6523af0]
#1  /lib64/libexpat.so.1(XML_SetHashSalt+0x1b) [0x7f4fa40e47cb]
#2  /usr/lib64/python3.7/lib-dynload/_elementtree.cpython-37m-x86_64-linux-gnu.so(+0x9ed5) [0x7f4ef800bed5]
#3  /lib64/libpython3.7m.so.1.0(+0x181a02) [0x7f4fa753fa02]
#4  /lib64/libpython3.7m.so.1.0(_PyObject_FastCallKeywords+0xd3) [0x7f4fa74da083]
#5  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x2825) [0x7f4fa7428ee5]
#6  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x8fe) [0x7f4fa74d9b3e]
#7  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x93) [0x7f4fa74d9e73]
#8  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x68af) [0x7f4fa742cf6f]
#9  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x8fe) [0x7f4fa74d9b3e]
#10  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x93) [0x7f4fa74d9e73]
#11  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6f0d) [0x7f4fa742d5cd]
#12  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x8fe) [0x7f4fa74d9b3e]
#13  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallKeywords+0x93) [0x7f4fa74d9e73]
#14  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x5dcd) [0x7f4fa742c48d]
#15  /lib64/libpython3.7m.so.1.0(+0x685f3) [0x7f4fa74265f3]
#16  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x68af) [0x7f4fa742cf6f]
#17  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x8fe) [0x7f4fa74d9b3e]
#18  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0xae) [0x7f4fa74da3be]
#19  /lib64/libpython3.7m.so.1.0(_PyObject_Call_Prepend+0xcd) [0x7f4fa74da94d]
#20  /lib64/libpython3.7m.so.1.0(+0x150a31) [0x7f4fa750ea31]
#21  /lib64/libpython3.7m.so.1.0(+0x181a02) [0x7f4fa753fa02]
#22  /lib64/libpython3.7m.so.1.0(_PyObject_FastCallKeywords+0xd3) [0x7f4fa74da083]
#23  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x2825) [0x7f4fa7428ee5]
#24  /lib64/libpython3.7m.so.1.0(+0x685f3) [0x7f4fa74265f3]
#25  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x6f0d) [0x7f4fa742d5cd]
#26  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x8fe) [0x7f4fa74d9b3e]
#27  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x3e) [0x7f4fa74d9dae]
#28  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f4fa74d9ddb]
#29  /lib64/libpython3.7m.so.1.0(+0x1bb394) [0x7f4fa7579394]
#30  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x75) [0x7f4fa7579455]
#31  0x7f4fa7faf594 in Gui::Application::sDoCommand(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x84
#32  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x2f9) [0x7f4fa7490a29]
#33  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x25) [0x7f4fa7490ae5]
#34  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x7170) [0x7f4fa742d830]
#35  /lib64/libpython3.7m.so.1.0(+0x685f3) [0x7f4fa74265f3]
#36  /lib64/libpython3.7m.so.1.0(_PyFunction_FastCallDict+0x2e2) [0x7f4fa74da5f2]
#37  /lib64/libpython3.7m.so.1.0(_PyObject_Call_Prepend+0xcd) [0x7f4fa74da94d]
#38  /lib64/libpython3.7m.so.1.0(PyObject_Call+0x75) [0x7f4fa7477f65]
#39  /usr/lib64/freecad/lib/libFreeCADBase.so(PP_Run_Method+0xd3) [0x7f4fa7831043]
#40  0x7f4fa77cd989 in Base::InterpreterSingleton::runMethodVoid(_object*, char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x29
#41  0x7f4fa8024f88 in Gui::PythonCommand::activated(int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#42  0x7f4fa8027f14 in Gui::Command::invoke(int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x54
#43  0x7f4fa6adbf68 in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x6b8
#44  0x7f4fa6eccbc2 in QAction::triggered(bool) from /lib64/libQt5Widgets.so.5+0x32
#45  0x7f4fa6ecef80 in QAction::activate(QAction::ActionEvent) from /lib64/libQt5Widgets.so.5+0xf0
#46  /lib64/libQt5Widgets.so.5(+0x24b0cd) [0x7f4fa6fb70cd]
#47  0x7f4fa6fb72e0 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5Widgets.so.5+0xc0
#48  0x7f4fa7095dba in QToolButton::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5Widgets.so.5+0xa
#49  0x7f4fa6f0fb88 in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x1c8
#50  0x7f4fa7095e53 in QToolButton::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x23
#51  0x7f4fa6ed2c81 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x81
#52  0x7f4fa6edac98 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x1228
#53  0x7f4fa7ffabd8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#54  0x7f4fa6ab37a9 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x189
#55  0x7f4fa6ed928f in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /lib64/libQt5Widgets.so.5+0x19f
#56  /lib64/libQt5Widgets.so.5(+0x1bd88c) [0x7f4fa6f2988c]
#57  /lib64/libQt5Widgets.so.5(+0x1c0678) [0x7f4fa6f2c678]
#58  0x7f4fa6ed2c81 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x81
#59  0x7f4fa6ed9c70 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x200
#60  0x7f4fa7ffabd8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#61  0x7f4fa6ab37a9 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x189
#62  0x7f4fa4f1ae3b in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /lib64/libQt5Gui.so.5+0x6cb
#63  0x7f4fa4f1c165 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /lib64/libQt5Gui.so.5+0x105
#64  0x7f4fa4ef953b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Gui.so.5+0xbb
#65  /lib64/libQt5XcbQpa.so.5(+0x6fe3a) [0x7f4fa041ce3a]
#66  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x135) [0x7f4fa4588665]
#67  /lib64/libglib-2.0.so.0(+0x4d9e8) [0x7f4fa45889e8]
#68  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f4fa4588a6c]
#69  0x7f4fa6b04387 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x67
#70  0x7f4fa6ab249b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x12b
#71  0x7f4fa6aba108 in QCoreApplication::exec() from /lib64/libQt5Core.so.5+0x88
#72  0x7f4fa7f999b2 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x14c2
#73  /usr/lib64/freecad/bin/FreeCAD(main+0x6b7) [0x404777]
#74  /lib64/libc.so.6(__libc_start_main+0xeb) [0x7f4fa650db0b]
#75  /usr/lib64/freecad/bin/FreeCAD(_start+0x2a) [0x404a7a]
Comment 1 Lewis Smith 2020-09-30 21:40:11 CEST
Thank you for reporting this.
Tried it on Mageia 7 under Xfce. For non-FreeCad habitués, Steps to Reproduce:
1. Start FreeCAD
 It has menu + 2 toolbars.
2. Create new document
 Click the big 'Create new' icon on the opening page.
3. Select FEM Workbench
 Menu View-Workbench-FEM, adds a third toolbar between the existing two.
4. Press the icon with the three yellow balls
 Hover caption "Opens the FreeCAD material editor"
then the segfault exactly as shown above.

Cauldron/Mageia 8 is at version 0.18.4, but there have been several fixes to that, which could make an update/backport for Mageia 7 difficult.
I will try this on M8 to see whether it happens there.

Can you first post this problem on the FreeCAD forum:
There are several threads about segfaults relating to FEM, but none seem the same as yours. It is important to establish whether other people have seen the same problem on other distributions; or whether it is known to be fixed by a more recent version.
If they suggest raising a bug with them (UPSTREAM), please do, and report back. Leaving this with Bugsquad until hearing from you. I doubt that we can fix things like this.

CC'in DavidG for info, he has done some of the recent patches, and is better placed to know about the update possibilities for M7.

CC: (none) => geiger.david68210, lewyssmith

Comment 2 Herbert Poetzl 2020-09-30 21:58:27 CEST
Hello Lewis,

I don't think that the FreeCAD folks will spend a lot of time looking into this (please try with latest stable :) but I might get around testing with their AppImages which could work to reproduce the issue there ...


CC: (none) => herbert

Comment 3 David GEIGER 2020-10-01 07:07:41 CEST
Please test freecad-0.18.2-1.1.mga7 in Core/Updates_testing repo!

It was rebuild against Qt 5.12.6.
Comment 4 Lewis Smith 2020-10-02 21:51:40 CEST
Thank you Lightning David for another immediate update.

FWIW I tried it under Mageia 8; it did not crash, cannot tell whether it did what it was supposed to:
 $ FreeCAD
FreeCAD 0.18.3, Libs: 0.18.3RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Running the Python command 'FEM_MaterialEditor' failed:
<unknown exception traceback>
'NoneType' object has no attribute 'hide'

* The console command is, unusually, 'FreeCAD'.
* Installing it: freecad-0.18.4-7.mga8.x86_64.rpm, but it itself shows 0.18.3,
as does Help-About FreeCAD.

I will try David's update under Mageia 7 - tomorrow!
Comment 5 Lewis Smith 2020-10-03 09:55:24 CEST
Mageia 7, Xfce.
 $ rpm -q freecad
 $ rpm -q freecad-data

Trying the update changes nothing, alas:
 $ FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
then exactly as in comment 0 after following the prescribed path.

It is curious that this software has run so long before this fault came to light. It seems as if the FEM Workbench is a relatively recent enhancement which caused several problems upstream.
I have downgraded the severity because it is just this specific feature which does not work, but generally the software does.

@Herbert: Re comment 2, if you do try the AppImage, please report back.
@DavidG: it looks as if it may have to be closed 'wontfix' (meaning 'cannot fix'), but you are the better judge.

Keywords: (none) => UPSTREAM
Severity: critical => major

Morgan Leijström 2020-12-22 02:59:24 CET

CC: (none) => fri

Comment 6 Lewis Smith 2021-02-01 14:19:17 CET
Ping Herbert.
Ping DavidG.

I have just installed (+140 pkgs, including texlive ! and hundreds of Mb) & tried the latest M8 version: freecad-0.18.5-4.mga8
and it is even worse.
It starts up OK; clicking the giant '+' to create a new project crashes it:
(running Plasma on Wayland, x-type select/paste does not work, so you will have to believe me). I re-type the 1st line:
 Program received signal SIGSEGV. Segmentation fault.
then screenfuls of numbered error lines.

@DavidG : do you want a new bug for this?
Comment 7 Aurelien Oudelet 2021-03-14 17:35:21 CET
An update for Mageia 8 has been validated here:

CC: (none) => ouaurelien, smelror

Comment 8 Aurelien Oudelet 2021-03-14 17:49:14 CET
under Mageia 8

1. Start FreeCAD
2. Create new document
3. Select FEM Workbench
4. Press the icon with the three yellow balls

No segfault under Mageia 8 x86_64 VirtuaBox Client with Plasma and VMSVGA 3D accelerated drivers. Not tested on real hardware.

Note that it needs nearly 202 packages in order to be installed.

GConf2                         3.2.6        19.mga8       x86_64  
  R-base                         4.0.3        4.mga8        x86_64  
  cdialog                        1.3          1.20160828.3> x86_64  
  dconf                          0.38.0       1.mga8        x86_64  (recommandé)
  freecad                        0.18.5       4.mga8        x86_64  
  freecad-data                   0.18.5       4.mga8        noarch  
  hdf5                           1.10.7       3.mga8        x86_64  
  lib643mf1                      1.8.1        2.mga8        x86_64  
  lib64GConf2_4                  3.2.6        19.mga8       x86_64  
  lib64assimp3                   3.3.1        5.mga8        x86_64  
  lib64boost_program_options1.7> 1.75.0       1.mga8        x86_64  
  lib64boost_python38_1.75.0     1.75.0       1.mga8        x86_64  
  lib64boost_regex1.75.0         1.75.0       1.mga8        x86_64  
  lib64brotlienc1                1.0.9        2.mga8        x86_64  
  lib64cgal13                    4.14.3       5.mga8        x86_64  
  lib64coin80                    4.0.0        3.mga8        x86_64  
  lib64glew2.2                   2.2.0        2.mga8        x86_64  
  lib64gypsy0                    0.9          9.mga8        x86_64  
  lib64hdf5_103                  1.10.7       3.mga8        x86_64  
  lib64hdf5_hl100                1.10.7       3.mga8        x86_64  
  lib64hwloc15                   2.3.0        1.mga8        x86_64  
  lib64ibverbs1                  1.2.1        4.mga8        x86_64  
  lib64imagequant0               2.13.1       1.mga8        x86_64  
  lib64jsoncpp24                 1.9.4        1.mga8        x86_64  
  lib64kpathsea6                 20200406     9.mga8        x86_64  
  lib64netcdf18                  4.7.4        3.mga8        x86_64  
  lib64opencascade7              7.4.0p1      5.mga8        x86_64  
  lib64opencsg1                  1.4.2        6.mga8        x86_64  
  lib64opengl0                   1.3.2        16.mga8       x86_64  
  lib64openmpi40                 4.0.5        2.mga8        x86_64  
  lib64openpmix2                 3.2.2        1.mga8        x86_64  
  lib64phdf5_103                 1.10.7       3.mga8        x86_64  
  lib64phdf5_hl100               1.10.7       3.mga8        x86_64  
  lib64phdf5_tools102            1.10.7       3.mga8        x86_64  
  lib64poly2tri1.0               1.0          0.20160413.3> x86_64  
  lib64polyclipping22            6.4.2        3.mga8        x86_64  
  lib64potrace0                  1.16         2.mga8        x86_64  
  lib64proj19                    7.2.0        1.mga8        x86_64  
  lib64ptexenc1                  20200406     9.mga8        x86_64  
  lib64pyside2-python3.8_5.15    5.15.2       1.mga8        x86_64  
  lib64qhull8.0                  2020.2       4.mga8        x86_64  
  lib64qscintilla2_qt5_15        2.11.6       1.mga8        x86_64  
  lib64qt53danimation5           5.15.2       1.mga8        x86_64  
  lib64qt53dcore5                5.15.2       1.mga8        x86_64  
  lib64qt53dextras5              5.15.2       1.mga8        x86_64  
  lib64qt53dinput5               5.15.2       1.mga8        x86_64  
  lib64qt53dlogic5               5.15.2       1.mga8        x86_64  
  lib64qt53dquick5               5.15.2       1.mga8        x86_64  
  lib64qt53dquickanimation5      5.15.2       1.mga8        x86_64  
  lib64qt53dquickextras5         5.15.2       1.mga8        x86_64  
  lib64qt53dquickinput5          5.15.2       1.mga8        x86_64  
  lib64qt53dquickrender5         5.15.2       1.mga8        x86_64  
  lib64qt53dquickscene2d5        5.15.2       1.mga8        x86_64  
  lib64qt53drender5              5.15.2       1.mga8        x86_64  
  lib64qt5datavisualization5     5.15.2       1.mga8        x86_64  
  lib64qt5gamepad5               5.15.2       1.mga8        x86_64  
  lib64qt5help5                  5.15.2       2.mga8        x86_64  
  lib64qt5location5              5.15.2       1.mga8        x86_64  
  lib64qt5positioningquick5      5.15.2       1.mga8        x86_64  
  lib64qt5remoteobjects5         5.15.2       1.mga8        x86_64  
  lib64qt5scripttools5           5.15.2       1.mga8        x86_64  
  lib64qt5scxml5                 5.15.2       1.mga8        x86_64  
  lib64qt5serialport5            5.15.2       1.mga8        x86_64  
  lib64qt5websockets5            5.15.2       1.mga8        x86_64  
  lib64rdmacm1                   1.1.0        4.mga8        x86_64  
  lib64shiboken2-python3.8_5.15  5.15.2       1.mga8        x86_64  
  lib64soqt20                    1.6.0        3.mga8        x86_64  
  lib64spnav0                    0.2.3        5.mga8        x86_64  
  lib64synctex2                  20200406     9.mga8        x86_64  
  lib64tbb2                      2020.3       1.mga8        x86_64  
  lib64texlua5                   20200406     9.mga8        x86_64  
  lib64vtk1                      8.2.0        19.mga8       x86_64  
  lib64woff2enc1.0.2             1.0.2        3.mga8        x86_64  
  lib64zziplib13                 0.13.71      1.mga8        x86_64  
  med                            4.0.0        5.mga8        x86_64  
  openscad                       2019.05      10.mga8       x86_64  
  perl-B-Hooks-EndOfScope        0.240.0      4.mga8        noarch  
  perl-Class-Data-Inheritable    0.80.0       9.mga8        noarch  
  perl-Crypt-RC4                 2.20.0       9.mga8        noarch  
  perl-Devel-GlobalDestruction   0.140.0      3.mga8        noarch  
  perl-Devel-StackTrace          2.40.0       2.mga8        noarch  
  perl-Digest-Perl-MD5           1.900.0      7.mga8        noarch  
  perl-Digest-SHA1               2.130.0      28.mga8       x86_64  
  perl-Dist-CheckConflicts       0.110.0      7.mga8        noarch  
  perl-Email-Date-Format         1.5.0        5.mga8        noarch  
  perl-Eval-Closure              0.140.0      3.mga8        noarch  
  perl-Exception-Class           1.440.0      3.mga8        noarch  
  perl-ExtUtils-CBuilder         0.280.235    1.mga8        noarch  (recommandé)
  perl-File-Copy-Recursive       0.450.0      2.mga8        noarch  
  perl-File-HomeDir              1.6.0        1.mga8        noarch  
  perl-File-Which                1.230.0      2.mga8        noarch  
  perl-Font-AFM                  1.200.0      9.mga8        noarch  
  perl-HTML-Form                 6.70.0       1.mga8        noarch  
  perl-HTML-Formatter            2.160.0      5.mga8        noarch  
  perl-HTML-Tree                 5.70.0       4.mga8        noarch  
  perl-Jcode                     2.70.0       23.mga8       x86_64  
  perl-Log-Dispatch              2.700.0      1.mga8        noarch  
  perl-Log-Log4perl              1.530.0      1.mga8        noarch  
  perl-MIME-Charset              1.12.2       3.mga8        noarch  
  perl-MIME-Lite                 3.31.0       2.mga8        noarch  
  perl-MIME-Types                2.180.0      1.mga8        noarch  
  perl-MRO-Compat                0.130.0      3.mga8        noarch  
  perl-Mail-Sender               0.903.0      3.mga8        noarch  
  perl-Mail-Sendmail             0.800.0      4.mga8        noarch  
  perl-Module-Build              0.423.100    2.mga8        noarch  
  perl-Module-Implementation     0.90.0       7.mga8        noarch  
  perl-Module-Runtime            0.16.0       3.mga8        noarch  
  perl-OLE-Storage_Lite          0.200.0      2.mga8        noarch  
  perl-Package-Stash             0.390.0      1.mga8        noarch  
  perl-Package-Stash-XS          0.290.0      4.mga8        x86_64  
  perl-Params-ValidationCompiler 0.300.0      3.mga8        noarch  
  perl-Parse-RecDescent          1.967.15     3.mga8        noarch  
  perl-Role-Tiny                 2.1.4        2.mga8        noarch  
  perl-Specio                    0.460.0      1.mga8        noarch  
  perl-Spreadsheet-ParseExcel    0.650.0      8.mga8        noarch  
  perl-Spreadsheet-WriteExcel    2.400.0      9.mga8        noarch  
  perl-Sub-Exporter-Progressive  0.1.13       3.mga8        noarch  
  perl-Sub-Identify              0.140.0      8.mga8        x86_64  
  perl-Sub-Quote                 2.6.6        2.mga8        noarch  
  perl-Test-Fatal                0.16.0       1.mga8        noarch  
  perl-Text-CSV_XS               1.450.0      1.mga8        x86_64  
  perl-Tk                        804.35.0     3.mga8        x86_64  
  perl-Unicode-LineBreak         2019.1.0     6.mga8        x86_64  
  perl-Unicode-Map               0.112.0      32.mga8       x86_64  
  perl-Variable-Magic            0.620.0      6.mga8        x86_64  
  perl-WWW-Mechanize             2.30.0       1.mga8        noarch  
  perl-XML-DOM                   1.460.0      3.mga8        noarch  
  perl-XML-RegExp                0.40.0       9.mga8        noarch  
  perl-XML-XPath                 1.440.0      2.mga8        noarch  
  perl-XString                   0.5.0        1.mga8        x86_64  
  perl-YAML-Tiny                 1.730.0      3.mga8        noarch  
  perl-libxml-perl               0.80.0       10.mga8       noarch  
  perl-namespace-autoclean       0.290.0      3.mga8        noarch  
  perl-namespace-clean           0.270.0      4.mga8        noarch  
  python3-collada                0.6.0        3.mga8        noarch  
  python3-cycler                 0.10.0       8.mga8        noarch  
  python3-kiwisolver             1.3.1        1.mga8        x86_64  
  python3-matplotlib             3.3.3        1.mga8        x86_64  
  python3-matplotlib-data        3.3.3        1.mga8        noarch  
  python3-matplotlib-data-fonts  3.3.3        1.mga8        noarch  
  python3-matplotlib-tk          3.3.3        1.mga8        x86_64  
  python3-pillow                 8.1.0        2.mga8        x86_64  
  python3-pivy                   0.6.5b       2.mga8        x86_64  
  python3-pyparsing              2.4.7        1.mga8        noarch  
  python3-pyside2                5.15.2       1.mga8        x86_64  
  python3-pyside2-3danimation    5.15.2       1.mga8        x86_64  
  python3-pyside2-3dcore         5.15.2       1.mga8        x86_64  
  python3-pyside2-3dextras       5.15.2       1.mga8        x86_64  
  python3-pyside2-3dinput        5.15.2       1.mga8        x86_64  
  python3-pyside2-3dlogic        5.15.2       1.mga8        x86_64  
  python3-pyside2-3drender       5.15.2       1.mga8        x86_64  
  python3-pyside2-charts         5.15.2       1.mga8        x86_64  
  python3-pyside2-concurrent     5.15.2       1.mga8        x86_64  
  python3-pyside2-core           5.15.2       1.mga8        x86_64  
  python3-pyside2-datavisualiza> 5.15.2       1.mga8        x86_64  
  python3-pyside2-gui            5.15.2       1.mga8        x86_64  
  python3-pyside2-help           5.15.2       1.mga8        x86_64  
  python3-pyside2-location       5.15.2       1.mga8        x86_64  
  python3-pyside2-multimedia     5.15.2       1.mga8        x86_64  
  python3-pyside2-multimediawid> 5.15.2       1.mga8        x86_64  
  python3-pyside2-network        5.15.2       1.mga8        x86_64  
  python3-pyside2-opengl         5.15.2       1.mga8        x86_64  
  python3-pyside2-openglfunctio> 5.15.2       1.mga8        x86_64  
  python3-pyside2-positioning    5.15.2       1.mga8        x86_64  
  python3-pyside2-printsupport   5.15.2       1.mga8        x86_64  
  python3-pyside2-qml            5.15.2       1.mga8        x86_64  
  python3-pyside2-quick          5.15.2       1.mga8        x86_64  
  python3-pyside2-quickcontrols2 5.15.2       1.mga8        x86_64  
  python3-pyside2-quickwidgets   5.15.2       1.mga8        x86_64  
  python3-pyside2-remoteobjects  5.15.2       1.mga8        x86_64  
  python3-pyside2-script         5.15.2       1.mga8        x86_64  
  python3-pyside2-scripttools    5.15.2       1.mga8        x86_64  
  python3-pyside2-scxml          5.15.2       1.mga8        x86_64  
  python3-pyside2-sensors        5.15.2       1.mga8        x86_64  
  python3-pyside2-serialport     5.15.2       1.mga8        x86_64  
  python3-pyside2-sql            5.15.2       1.mga8        x86_64  
  python3-pyside2-svg            5.15.2       1.mga8        x86_64  
  python3-pyside2-test           5.15.2       1.mga8        x86_64  
  python3-pyside2-texttospeech   5.15.2       1.mga8        x86_64  
  python3-pyside2-uitools        5.15.2       1.mga8        x86_64  
  python3-pyside2-webchannel     5.15.2       1.mga8        x86_64  
  python3-pyside2-webengine      5.15.2       1.mga8        x86_64  
  python3-pyside2-webenginecore  5.15.2       1.mga8        x86_64  
  python3-pyside2-webenginewidg> 5.15.2       1.mga8        x86_64  
  python3-pyside2-websockets     5.15.2       1.mga8        x86_64  
  python3-pyside2-widgets        5.15.2       1.mga8        x86_64  
  python3-pyside2-x11extras      5.15.2       1.mga8        x86_64  
  python3-pyside2-xml            5.15.2       1.mga8        x86_64  
  python3-pyside2-xmlpatterns    5.15.2       1.mga8        x86_64  
  python3-shiboken2              5.15.2       1.mga8        x86_64  
  qscintilla2-qt5-common         2.11.6       1.mga8        x86_64  
  qt3d5                          5.15.2       1.mga8        x86_64  
  qtdatavis3d5                   5.15.2       1.mga8        x86_64  
  qtgamepad5                     5.15.2       1.mga8        x86_64  
  qtpositioning5                 5.15.2       1.mga8        x86_64  
  qtremoteobjects5               5.15.2       1.mga8        x86_64  
  qtscxml5                       5.15.2       1.mga8        x86_64  
  qttools5-assistant             5.15.2       2.mga8        x86_64  
  texlive                        20200406     9.mga8        x86_64  
  texlive-collection-basic       20200406     5.mga8        noarch  
  tkinter3                       3.8.7        2.mga8        x86_64  
  x11-font-adobe-100dpi          1.0.3        9.mga8        noarch
Comment 9 Morgan Leijström 2021-03-15 00:51:29 CET
Did you also try freecad-0.18.6-1.mga8 ?
Comment 10 Lewis Smith 2021-03-15 10:49:27 CET
I can confirm that for M8: freecad-0.18.6-1.mga8 (Bug 28459) that update *does* resolve the specific problem in this bug.
Any chance for M7? If not, better to close this bug 'wontfix'. Stig - who did the M8 update - is already CC'd.
Comment 11 Stig-Ørjan Smelror 2021-03-15 11:18:00 CET
(In reply to Lewis Smith from comment #10)
> I can confirm that for M8: freecad-0.18.6-1.mga8 (Bug 28459) that update
> *does* resolve the specific problem in this bug.
> Any chance for M7? If not, better to close this bug 'wontfix'. Stig - who
> did the M8 update - is already CC'd.

Thanks for testing.

I'm looking into updating to 0.18.6. If it's straight forward without a lot of changes, I will do it. If it needs a ton of other updates, I think "WONTFIX" is the way to go because it works in Mageia 8 with the updated version.

Comment 12 Stig-Ørjan Smelror 2021-03-16 10:37:57 CET
Version 0.18.6 pushed to updates_testing and will go through the validation process once the compilation has completed and the QA team have the time.

Comment 13 Stig-Ørjan Smelror 2021-03-16 11:34:28 CET

FreeCAD has been updated to version 0.18.6 to fix a segfault while opening the FEM Workbench.



Uploaded to core/updates_testing


from freecad-0.18.6-1.mga7.src.rpm

Assignee: bugsquad => qa-bugs

Comment 14 Morgan Leijström 2021-03-16 13:32:55 CET
Thanks Stig.

Now this is weird: I updated to new version, and in a second attempt i uninstalled then installed only the new, which rpm confirms:

[morgan@svarten ~]$ rpm -qif `which FreeCAD` | grep Version
Version     : 0.18.6

But launching it, it say it is the old version:

[morgan@svarten ~]$ FreeCAD
FreeCAD 0.18.3, Libs: 0.18.3RUnknown

And crash in same test as before.
Comment 15 Stig-Ørjan Smelror 2021-03-16 17:05:43 CET

What's the output of

ls -l `which freecad`

It _should_ be today's date (2021/03/16).

Comment 16 Morgan Leijström 2021-03-16 18:13:52 CET
[morgan@svarten ~]$ ls -l `which FreeCAD`
-rwxr-xr-x 1 root root 91 mar 16 10:55 /usr/bin/FreeCAD*

Now I also installed freecad-0.18.6-1.mga7 in a laptop that have never had FreeCAD, and it is the same situation: it reports itself as 0.18.3.
Oddly it does *not* crash in the same test.
Comment 17 Lewis Smith 2021-03-16 21:20:13 CET
Thanks for tackling the M7 affair.
BEFORE update: freecad-0.18.2-1.1.mga7
AFTER: I have just installed from Updates/Testing:
$ rpm -q freecad

Starting it from menu, it announced itself as '0.18.3';
and following the steps in comment 1 - it crashed.

From terminal:
$ FreeCAD
FreeCAD 0.18.3, Libs: 0.18.3RUnknown
 [and doing the same manipulation, ends:]
Program received signal SIGSEGV, Segmentation fault

So no doubt that what the package thinks is '0.18.6' really is '0.18.3'.
Comment 18 Dave Hodgins 2021-03-16 23:47:03 CET
With freecad-0.18.6-1.1.mga8 (didn't try the prior version), I'm just
getting a black display in the FreeCAD dialog so can't try creating a new

# lspcidrake -v|grep Card
Card:ATI Volcanic Islands and later (amdgpu): Advanced Micro Devices, Inc. [AMD/ATI]|Renoir [DISPLAY_VGA] (vendor:1002 device:1636 subv:1043 subd:1e21) (rev: c6)
Card:NVIDIA GeForce 635 series and later: NVIDIA Corporation|TU106M [GeForce RTX 2060 Mobile] [DISPLAY_VGA] (vendor:10de device:1f15 subv:1043 subd:1e21) (rev: a1)

CC: (none) => davidwhodgins

Comment 19 Dave Hodgins 2021-03-17 01:47:50 CET
Tried in a new user where I haven't changed things like the mouse cursor
to redglass, and it does open ok and it does not crash when selecting
the material editor icon, so appears to have fixed the current bug though
I've identified a new bug with my normal user.

I'll try to figure out which change I've made in my normal user that's
interfering with FreeCAD.

Help/About FreeCAD shows 0.18.6 as the version.
Comment 20 David GEIGER 2021-03-17 01:57:09 CET
I updated freecad to fix the version in about freecad dialog.

- freecad-0.18.6-1.1.mga8
- freecad-0.18.6-1.1.mga7
Comment 21 Dave Hodgins 2021-03-17 03:51:15 CET
Used strace to obtain a list of files FreeCAD accessed in the login where it
fails to display a gui in /home.

One at a time, I renamed the files it was accessing, rebooted, then checked
to see if the gui would display.

Renaming ~.mozilla allowed it to then work. The only file it's accessing is
~/.mozila/plugins/mozplugger0.so from that directory.

617855 openat(AT_FDCWD, "/home/dave/.mozilla/plugins", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 52
617855 openat(AT_FDCWD, "/home/dave/.mozilla/plugins/mozplugger0.so", O_RDONLY|O_CLOEXEC) = 52
617855 openat(AT_FDCWD, "/home/dave/.cache/mozplugger/0.helpers", O_RDONLY) = 52

$ cat /home/dave/.cache/mozplugger/0.helpers
# This is autogenerated from /etc/mozpluggerrc
name    MozPlugger base Plugin
version 2.1.6
linker  /usr/bin/mozplugger-linker
helper  /usr/bin/mozplugger-helper
controller      /usr/bin/mozplugger-controller

The only firefox plugin installed is
OpenH264 Video Codec provided by Cisco Systems, Inc.

No idea why .mozilla would cause it to stop displaying the gui, but it does.
Comment 22 Dave Hodgins 2021-03-17 05:13:22 CET
I was looking at the wrong firefox profile above. In addition to the
OpenH264 plugin, the .mozilla directory that stops FreeCad from displaying
a gui also has the plugin ...
Widevine Content Decryption Module provided by Google Inc.
Comment 23 Dave Hodgins 2021-03-17 05:52:01 CET
More testing with the new user showed that installing Widevine had no affect
on FreeCAD. I don't know where ~/.mozilla/plugins/mozplugger0.so came from
or what I did to get it included for the affected user, but have confirmed
that just removing that one file allows FreeCAD to work.
Comment 24 David GEIGER 2021-03-17 06:00:02 CET
New updated packages list:

Packages in 8/core/updates_testing:

Packages in 7/core/updates_testing:

Source RPM: 
Comment 25 Morgan Leijström 2021-03-17 06:00:48 CET
@Dave: good hunting!  Have yo searched FreeCAD bug system?  I think this should be reported.

Thank you David:
 freecad-0.18.6-1.1.mga7 test OK here for:
§ Displays correct version
§ Do not crash in FEM material editor

64 bit Plasma, Nvidia⨪current

Minor issue:
§ Pressing F1 or menu Help > Help say that /usr/share/doc/freecad/freecad.qhc is missing and i may need to install the documentation package.
In the same menu links to upstream wiki etc are working.

( I dont understand why it crashed in previous revision, my comment 14. I then uninstalled FreeCAD, deleted config files, and reinstalled, but that did not help then. Strange. )
Comment 26 Dave Hodgins 2021-03-17 06:56:35 CET
Reported at https://tracker.freecadweb.org/view.php?id=4597

The file is from Mageia 7. I'd copied my firefox directory over to my Mageia 8
installation for watching Netflix. :-)
Comment 27 David GEIGER 2021-03-17 16:39:39 CET
New updated packages list which fixes missing freecad.qhc doc files:

Packages in 8/core/updates_testing:

Packages in 7/core/updates_testing:

Source RPM: 
Comment 28 Morgan Leijström 2021-03-17 21:20:44 CET
Great David:
freecad-0.18.6-1.2.mga7 include help, and also the example drawings accessible from the start page.

Good report Dave.
That issue is nothing we can do something about i presume.
0.18.6 is the last 0.18.x, but you gave them the procedure so they can test it with 0.19.x

Whiteboard: (none) => MGA7-64-OK

Comment 29 Lewis Smith 2021-03-17 22:01:46 CET
Have to thank Stig & DavidG for pursuing this.
Testing M7 64-bit, Mate: freecad-0.18.6-1.2.mga7

When, it starts, terminal, GUI splash, it correctly says 0.18.6.
Also from Help-About.

Alas, running the original bug test comment 1:
$ FreeCAD
FreeCAD 0.18.6, Libs: 0.18.6RUnknown
Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3ca30) [0x7f210dd8fa30]
#1  /lib64/libexpat.so.1(XML_SetHashSalt+0x1b) [0x7f210b9817cb]
#2  /usr/lib64/python3.7/lib-dynload/_elementtree.cpython-37m-x86_64-linux-gnu.so(+0x9fa5) [0x7f2077402fa5]
#3  /lib64/libpython3.7m.so.1.0(+0x181be2) [0x7f210edabbe2]
#73  /usr/lib64/freecad/bin/FreeCAD(main+0x6b7) [0x404777]
#74  /lib64/libc.so.6(__libc_start_main+0xeb) [0x7f210dd79b0b]
#75  /usr/lib64/freecad/bin/FreeCAD(_start+0x2a) [0x404a7a]

Off to try M8 again.
Comment 30 Dave Hodgins 2021-03-17 23:01:03 CET
(In reply to Lewis Smith from comment #29)
> Have to thank Stig & DavidG for pursuing this.
> Testing M7 64-bit, Mate: freecad-0.18.6-1.2.mga7
> When, it starts, terminal, GUI splash, it correctly says 0.18.6.
> Also from Help-About.
> Alas, running the original bug test comment 1:
> $ FreeCAD
> FreeCAD 0.18.6, Libs: 0.18.6RUnknown
>  [splash]
> Program received signal SIGSEGV, Segmentation fault.

Testing Mageia 7 under Mate, I cannot recreate the segfault. It's working
properly here. Please try creating a new user to see if it's something
system wide or something in the /home configuration.
Comment 31 Lewis Smith 2021-03-20 10:37:35 CET
Testing again Mageia 7 (Mate), freecad-0.18.6-1.2.mga7

1. Confirm the problem crash with currently installed pkg & all existing config files: it crashed.

2. Removed all its config files:
 $ rm ./.config/FreeCAD/FreeCAD.conf
 $ rm ./.FreeCAD/*
 rm: remove regular empty file './.FreeCAD/cookies'? y
 rm: remove regular file './.FreeCAD/system.cfg'? y
 rm: remove regular file './.FreeCAD/user.cfg'? y
then re-ran it; same crash.

3. Removed freecad:
 $ sudo urpme freecad
 To satisfy dependencies, the following 2 packages will be removed (333MB):
   (freecad-data == 0.18.6-1.2.mga7 heb ei foddloni)
   (freecad >= 0.18.6-1.2.mga7 heb ei foddloni)
 Tynnu 2 becyn? (y/N) y

4. Re-installed it from UpdatesTesting:
 $ sudo urpmi --media 'Core Updates Testing' freecad
 I fodloni dibyniaethau, gosodir y pecynnau canlynol:
  Pecyn                          Fersiwn      Rhifyn        Arch    
 (cyfrwng "Core Updates Testing")
  freecad                        0.18.6       1.2.mga7      x86_64  
  freecad-data                   0.18.6       1.2.mga7      noarch  
then re-ran the test. Still same crash.

But it is only me, both Morgan & Dave report this test OK.
Since this specific bug is very easy to test (comment 1), I think this should have another QA tester (I removed the 64-OK to cause this), and if it works be generally OK'd & validated.
It is certainly an improvement on the original (& still current) freecad-0.18.2-1.mga7.
Can *you* please try this new version.

Severity: major => normal
Keywords: UPSTREAM => (none)
Whiteboard: MGA7-64-OK => (none)

Comment 32 Morgan Leijström 2021-03-20 10:44:54 CET
Good tests, Lewis.

One more potentially: Create a new user and test it there.
- To see if it is anything in users settings, or in system/graphics that trigs the problem.

If we can not find out what it is i think we should release soon anyway, there are more stuff improved than just this partially solved problem.

In some months in mga8 step up to 0.19
(there will come no more releases of 0.18 - any bug fix and improvments are in 0.19)
Comment 33 Herman Viaene 2021-03-21 10:55:36 CET
MGA7-64 MATE on Peaq C1011
No installation issues with version 0.18.6-1.2 (should be the latest one).
This notebook has never seen FreeCAD before, so it is all default
Followed instructions as per Comment 8 anf got:
$ FreeCAD
FreeCAD 0.18.6, Libs: 0.18.6RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3ca30) [0x7fe0d242ea30]
#1  /lib64/libexpat.so.1(XML_SetHashSalt+0x1b) [0x7fe0d00207cb]
and a long list up to #75

CC: (none) => herman.viaene

Comment 34 Morgan Leijström 2021-03-21 16:54:10 CET
Good to know it is not only on Lewis system that bug is still there.

FreeCAD is available as both Appimage and Flatpak.

It may be interesting to see if they work or not where our rpm does not.
Comment 35 Lewis Smith 2021-03-21 20:44:29 CET
Thanks Herman. Sad news.

(In reply to Morgan Leijström from comment #32)
> If we can not find out what it is i think we should release soon anyway,
> there are more stuff improved than just this partially solved problem.
I agree. Even as it stands, it is worth pushing as an M7 'update' update.
The M8 update has already gone (Bug 28459). It would have been neater to push the update for both releases there, leaving this bug open. Too late.

This FreeCAD update brings several bugfixes and small improvements.

> Packages in 7/core/updates_testing:
> ========================
> freecad-0.18.6-1.2.mga7
> freecad-data-0.18.6-1.2.mga7
> Source RPM: 
> ========================
> freecad-0.18.6-1.2.mga7.src.rpm

For this bug in particular, pushing this update will I think close the bug. We must then remember to re-open it! If others agree, can somebody validate it as-is so it can go out?

Summary: FreeCAD segfaults on Open FreeCAD material editor (FEM) => FreeCAD sometimes segfaults on Open FreeCAD material editor (FEM)

Comment 36 Morgan Leijström 2021-03-21 22:20:17 CET
Upstream already have 0.19 as supported version, and default download version.
I think we should get this last 0.18 one out ASAP, and try to package 0.19 which is what users expect, and which is receiving updates and bugfixes.  Possibly it does not show this bug this update partially solves.

So yes, out this goes.

Advisory in comment 35

Assignee: qa-bugs => sysadmin-bugs
Whiteboard: (none) => MGA7-64-OK
Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 37 Morgan Leijström 2021-03-22 00:24:20 CET
(In reply to Morgan Leijström from comment #34)
> FreeCAD is available as both Appimage and Flatpak.

  Testing on mga7-64:

segfault directly at launch on mga7-64:
Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3ca30) [0x7f401d650a30]
#1  /tmp/.mount_FreeCAESmUwP/usr/bin/../lib/libQt5XcbQpa.so.5(+0x569d3) [0x7f4018ee29d3]
...etc up to #16

FreeCAD 0.19.1 Flatpak:
runs, but selecting the material editor the text output window say "No module named 'yaml'" No crash.
Comment 38 Dave Hodgins 2021-03-27 14:48:11 CET
Workaround documented in https://wiki.mageia.org/en/Mageia_8_Errata#Various_software

Keywords: (none) => IN_ERRATA8
Resolution: (none) => WONTFIX

Comment 39 Dave Hodgins 2021-03-27 14:49:09 CET
Oops. Reopening as the issue in comment 38 is not about the segfaults.

Resolution: WONTFIX => (none)

Comment 40 Morgan Leijström 2021-03-27 17:13:49 CET
This should get moved to release.
Then we can try packaging 0.19.
Comment 41 Lewis Smith 2021-03-27 21:05:00 CET
(In reply to Dave Hodgins from comment #39)
> Oops. Reopening as the issue in comment 38 is not about the segfaults.
Can this Mageia 7 update be advisoried (comment 35) so it can at least go out without pretending to always fix the specific crash. It is an improvement (comment 32) in any case, and Stig & DavidG worked to make it possible.
Lewis Smith 2021-03-27 21:06:19 CET

CC: lewyssmith => (none)
Assignee: sysadmin-bugs => qa-bugs

Comment 42 Aurelien Oudelet 2021-03-30 20:45:51 CEST

This FreeCAD update brings several bugfixes and small improvements.

Packages in 7/core/updates_testing:

Source RPM: 

Keywords: (none) => advisory

Comment 43 Mageia Robot 2021-03-30 22:10:26 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.