Bug 27283 - Update candidate: godot 3.2.3 (with minor updates to bullet and wslay)
Summary: Update candidate: godot 3.2.3 (with minor updates to bullet and wslay)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA7-64-OK
Keywords: advisory, has_procedure, validated_update
Depends on:
Reported: 2020-09-17 12:40 CEST by Rémi Verschelde
Modified: 2020-09-21 21:47 CEST (History)
4 users (show)

See Also:
Source RPM: godot-3.2.3-1.mga7, bullet-2.89-1.1.mga7, wslay-1.1.1-1.mga7
Status comment:


Description Rémi Verschelde 2020-09-17 12:40:09 CEST
This update provides the new 3.2.3 version of Godot Engine (package `godot`), for which I'm the upstream maintainer. This update should be compatible with the current 3.2.1 package in Mageia 7.

I also updated the wslay library which Godot uses (and it's the only package using it), as well as added a patch to bullet 2.89 which is required by Godot (otherwise I'd have to use the bundled bullet version).


Updated godot packages provide new upstream release

  This update provides Godot Engine version 3.2.3, which is compatible with
  the previously packaged version 3.2.1. See the release notes for details on
  new features, enhancements and bugfixes in 3.2.2 and 3.2.3.

  An upstream patch was backported for the bullet library used by Godot, which
  is necessary for a bugfix in Godot 3.2.3.
  The wslay library used by Godot was also updated to version 1.1.1 (minor


- https://godotengine.org/article/maintenance-release-godot-3-2-2
- https://godotengine.org/article/maintenance-release-godot-3-2-3
- https://github.com/tatsuhiro-t/wslay/releases/tag/release-1.1.1
- https://github.com/bulletphysics/bullet3/pull/2748

SRPMs in core/updates_testing:


RPMs in core/updates_testing:




Testing procedure:


Note: The mbedtls update candidate from bug 27282 is also used by Godot, so they can be tested at the same time. They can however be validated independently, Godot does not depend on this mbedtls update.
Rémi Verschelde 2020-09-17 12:40:21 CEST

Keywords: (none) => has_procedure

Rémi Verschelde 2020-09-17 12:40:32 CEST

Source RPM: (none) => godot-3.2.3-1.mga7 bullet-2.89-1.1.mga7 wslay-1.1.1-1.mga7

Rémi Verschelde 2020-09-17 12:40:56 CEST

Source RPM: godot-3.2.3-1.mga7 bullet-2.89-1.1.mga7 wslay-1.1.1-1.mga7 => godot-3.2.3-1.mga7, bullet-2.89-1.1.mga7, wslay-1.1.1-1.mga7

Comment 1 Herman Viaene 2020-09-19 14:04:19 CEST
MGA7-64 Plasma on Lenovo B50
Installed this together with the updates for mbedtls.
Ref to my previous experiences with godot in bug 26327, the result is even worse now.
Start godot at CLI, get its main window plus the one for "empty project" opening window for Asset Manager. This results in a completely frozen system, notthing worked anymore: no mouse action, no keyboard (thus no Ctrl-Alt-Backspace ot AltF2), no response from desktop PC to this laptop, no ssh login possible, no answer on ping.
Had to power off.
Leaving it here.

CC: (none) => herman.viaene

Comment 2 Len Lawrence 2020-09-19 15:40:05 CEST
@Herman.  OK, having a look at this.

CC: (none) => tarazed25

Comment 3 Len Lawrence 2020-09-19 16:14:30 CEST
mga7, x64

It is not clear what the procedural differences are here and in comment 1.
It looks to be working at this end.
Updated to these packages:
- godot-3.2.3-1.mga7.x86_64
- godot-headless-3.2.3-1.mga7.x86_64
- godot-runner-3.2.3-1.mga7.x86_64
- godot-server-3.2.3-1.mga7.x86_64
- lib64bullet-devel-2.89-1.1.mga7.x86_64
- lib64bullet2.89-2.89-1.1.mga7.x86_64
- lib64mbedcrypto3-2.16.8-1.mga7.x86_64
- lib64mbedtls-devel-2.16.8-1.mga7.x86_64
- lib64mbedtls12-2.16.8-1.mga7.x86_64
- lib64mbedx509_0-2.16.8-1.mga7.x86_64
- lib64wslay-devel-1.1.1-1.mga7.x86_64
- lib64wslay1-1.1.1-1.mga7.x86_64

Tried the game engine - fullscreen gui - chose a new project (noobie) and browsed the asset library.
Downloaded and installed some modules and also browsed https files on github.
$ rm -rf godot
$ godot
Godot Engine v3.2.3.stable.mageia - https://godotengine.org
OpenGL ES 3.0 Renderer: GeForce GTX 970/PCIe/SSE2

Editing project: /home/lcl/godot (::home::lcl::godot)
Godot Engine v3.2.3.stable.mageia - https://godotengine.org

<There were a few errors reported, which could well be something to do with lack of knowledge about handling the engine although there were no apparent problems - it all ran smoothly>
ERROR: store_buffer: Condition "!p_src" is true.
   At: drivers/unix/file_access_unix.cpp:278.
WARNING: _image_request_completed: Error getting image file from URL: https://raw.githubusercontent.com/Zylann/godot_heightmap_native_plugin/master/addons/zylann.hterrain/screenshots/2018_04_02.png
   At: editor/plugins/asset_library_editor_plugin.cpp:815.
ERROR: open_dynamic_library: Can't open dynamic library: /home/lcl/godot/addons/zylann.hterrain/native/bin/linux/hterrain_native.so. Error: /usr/bin/../lib/hterrain_native.so: cannot open shared object file: No such file or directory
   At: drivers/unix/os_unix.cpp:426.
ERROR: get_symbol: No valid library handle, can't get symbol from GDNative object
   At: modules/gdnative/gdnative.cpp:501.

$ tree godot
├── addons
│   ├── json_minifier
│   │   ├── json_minifier.gd
│   │   └── LICENSE
│   ├── luisboch.field_of_view
│   │   ├── demo
│   │   │   ├── Block.tscn
    ├── rmsmartshape
│   │   ├── asset_library_icon-new.png
│   │   ├── asset_library_icon-new.png.import
│   │   ├── asset_library_icon.png
│   │   ├── asset_library_icon.png.import
│   │   ├── assets
│   │   │   ├── Anchor.svg
│   │   │   ├── Anchor.svg.import
│   │   │   ├── closed_shape.png
        │       └── editor_util.gd
│       └── util
│           ├── direct_mesh_instance.gd
│           ├── direct_multimesh_instance.gd
│           ├── errors.gd
│           ├── grid.gd
│           ├── image_file_cache.gd
│           ├── logger.gd
│           ├── quad_tree_lod.gd
│           └── util.gd
├── default_env.tres
├── icon.png
├── icon.png.import
├── project.godot
└── README.md

44 directories, 387 files

This is all probably OK.
Comment 4 Herman Viaene 2020-09-21 14:49:53 CEST
Tx Len, OK'ing then as in previous update.

Whiteboard: (none) => MGA7-64-OK

Comment 5 Aurelien Oudelet 2020-09-21 17:41:47 CEST
Can we validate this?

(In reply to Herman Viaene from comment #4)
> Tx Len, OK'ing then as in previous update.

If so,
Advisory and Packages in Comment 1.

Keywords: (none) => advisory, validated_update
CC: (none) => ouaurelien, sysadmin-bugs

Comment 6 Rémi Verschelde 2020-09-21 20:07:44 CEST
Yeah the errors seen by Len are not critical, and not related to the package itself but are bugs of the upstream project (which is outside our scope, unless it breaks the package).

As for Herman's issues, it's more concerning for me as Godot developer, but also not related to the Mageia package as far as I know. So it should be good to go.

@ Aurelien: Note that the "advisory" keyword should be added when the advisory has been uploaded to SVN already. Did you do it?
Comment 7 Mageia Robot 2020-09-21 21:47:03 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.