Bug 27219 - VirtualBox-Guest-Additions in Mageia 7 as Host: the bidirectional shared clipboard doesn't work with M8 VM
Summary: VirtualBox-Guest-Additions in Mageia 7 as Host: the bidirectional shared clip...
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal major
Target Milestone: Mageia 7
Assignee: All Packagers
QA Contact:
Depends on: 27113 27479
  Show dependency treegraph
Reported: 2020-08-28 18:57 CEST by Alex Kotov
Modified: 2020-12-22 09:31 CET (History)
3 users (show)

See Also:
Source RPM: VirtualBox v6.0.24r139119
Status comment:

vbox-additions-6.1.14-3-kernel-5.8.8-1 (156.43 KB, image/png)
2020-09-11 11:46 CEST, Alex Kotov
Host<->Guest copy check (314.12 KB, image/png)
2020-12-22 09:29 CET, Alex Kotov

Description Alex Kotov 2020-08-28 18:57:10 CEST
Description of problem:
Hello. The bidirectional Shared clipboard does not work on the Mageia-8 VM

Version-Release number of selected component (if applicable):

How reproducible:
To make sure that the shared clipboard in The mageia-8 guest system does not work, install Mageia-8 on the VM, enable the Shared clipboard (bidirectional), and copy the text from the Guest OS (Mageia-8) to the Host's text editor.

Host: Mageia-7.1-x86_64 + Any DE + VirtualBox v6.0.24r139119 + VBoxExtPack +  bidirectional Shared clipboard is enabled

Guest: Mageia-8.0-x86_64-kernel-5.8.5-desktop-1.mga8 + Any DE + virtualbox-guest-additions-6.1.12-8.mga8.x86_64.rpm

Solving the problem (operations inside the guest Mageia-8.0):

urpme virtualbox-guest-additions-6.1.12-8.mga8.x86_64.rpm

wget  https://download.virtualbox.org/virtualbox/6.0.24/VBoxGuestAdditions_6.0.24.iso
mkdir /111; mount -o loop,ro ./VBoxGuestAdditions_6.0.24.iso /111; cd /111; sh ./VBoxLinuxAdditions.ru; reboot

p.s. I apologize for my poor English (this is an online translator)...
Aurelien Oudelet 2020-08-28 19:00:59 CEST

Depends on: (none) => 27113

Comment 1 Aurelien Oudelet 2020-08-28 19:10:38 CEST
Thanks reporting this,

Sadly, current Linux kernel version 5.8 is not supported either as Host nor Guest in Virtualbox upstream.

As soon an update on this will be published upstream, we will provide updated packages.

(In reply to Alex Grant from comment #0)
> Solving the problem (operations inside the guest Mageia-8.0):
> su
> password
> urpme virtualbox-guest-additions-6.1.12-8.mga8.x86_64.rpm
> wget 
> https://download.virtualbox.org/virtualbox/6.0.24/VBoxGuestAdditions_6.0.24.
> iso
> mkdir /111; mount -o loop,ro ./VBoxGuestAdditions_6.0.24.iso /111; cd /111;
> sh ./VBoxLinuxAdditions.ru; reboot

This is a dirty workaround obtain by chance. You use an older VBoxGuestAdditions version : 6.0.24 < 6.1.12-8 provided by our RPM.

> p.s. I apologize for my poor English (this is an online translator)...
Don't excuse you! We can read well ;)

Holding this in Bugsquad until upstream updates come.

Keywords: (none) => Triaged, UPSTREAM

Comment 2 Alex Kotov 2020-08-28 19:21:13 CEST
Okay, Aurelien Oudelet. :)
Comment 3 Aurelien Oudelet 2020-08-28 19:23:49 CEST
Also as a workaround,
In your mga8 guest VM, you can still use kernel-5.7.9-desktop-1.mga8 which still works.
Comment 4 Alex Kotov 2020-08-28 19:33:29 CEST
Thank you, but it doesn't suit me. I install Mageia through the network and collect live-usb-flash drives with different DE from them. So I need all the latest stuff usually. In addition, this fits into the General concept of testing: You update and I collect, I collect - You update, etc.
Aurelien Oudelet 2020-09-02 17:51:57 CEST

CC: (none) => ouaurelien

Comment 5 Aurelien Oudelet 2020-09-10 21:41:25 CEST
Virtualbox updated to version 6.1.14 and fixes run on 5.8 kernel series.
This should resolve this bug.


Comment 6 Alex Kotov 2020-09-11 11:46:16 CEST
Created attachment 11875 [details]
Comment 7 Alex Kotov 2020-09-11 11:47:42 CEST
Good afternoon, Aurelien Oudelet. For a clean check, I installed a new Mageia-8 VM over the network in which virtualbox-guest-additions = 6.1.14-3 and kernel = 5.8.8-1. The bidirectional clipboard still doesn't work (see the screenshot of vbox-additions-6.1.14-kernel-5.8.8-1). Let me remind you that my host system is Mageia-7.1 and it has VirtualBox 6.0.24 r139119 + Oracle_VM_VirtualBox_Extension_Pack-6.0.24.vbox-extpack. As the main desktop environment, I use "Budgie-10.5.1" and additional - "MATE-1.22.1". I don't know how a guy with a similar problem from a related topic is doing right now, but I still have the same result - in both environments, the result is negative. I am very sorry... :(
Comment 8 Aurelien Oudelet 2020-09-11 11:56:24 CEST
So sorry to see this.
Seems virtualbox additions are outdated in Mageia 7.1

Requesting an update if possible.
Assigning to all packagers, no registered one.
CC'ing recent commiters.

CC: (none) => ghibomgx
Version: Cauldron => 7
Assignee: bugsquad => pkg-bugs
Severity: normal => major
Source RPM: (none) => VirtualBox v6.0.24r139119
Target Milestone: --- => Mageia 7
Keywords: NEEDINFO => (none)

Aurelien Oudelet 2020-09-11 11:57:09 CEST

Summary: VirtualBox-Guest-Additions in Mageia-8; the bidirectional shared clipboard doesn't work => VirtualBox-Guest-Additions in Mageia 7 as Host: the bidirectional shared clipboard doesn't work with M8 VM

Comment 9 Alex Kotov 2020-09-11 12:07:10 CEST
In other words, there are drastic changes between these versions that do not allow you to work with a higher release from a lower release? It's weird. This is the first time I have such problems, usually with the clipboard it has never been like this. Could partially not work Drag & Drop in different DE, but the buffer... Weird. :) Thank you for your assistance.
Aurelien Oudelet 2020-12-01 10:56:10 CET

Depends on: (none) => 27479
Keywords: Triaged => (none)

Comment 10 Thomas Andrews 2020-12-01 19:46:09 CET
I was unable to confirm the problem when communicating between M7 virtualbox 6.0.24 host and an M8 guest, as for some reason my vbox 6.0.24 would fail to create an M8 64-bit guest. Mageia 64-bit was not an option under "New." Updating to 6.1.16 has eliminated that problem.

I was able to try the bidirectional clipboard after the update, and problems with that seem to have disappeared, as well.

Someone else should confirm, but it looks to me like this one is fixed by updating M7 to vbox 6.1.16.

CC: (none) => andrewsfarm

Comment 11 Alex Kotov 2020-12-01 21:46:27 CET
Hi, Thomas Andrews.

On my Mageia-7.1, I updated the following packages from "Mageia Core Updates Testing":
- cpupower-5.9.11-3.mga7.x86_64
- dkms-vboxadditions-6.1.16-1.mga7.noarch
- dkms-virtualbox-6.1.16-1.mga7.noarch
- kernel-desktop-devel-5.9.11-3.mga7-1-1.mga7.x86_64
- kernel-desktop-devel-latest-5.9.11-3.mga7.x86_64
- virtualbox-6.1.16-1.mga7.x86_64
- virtualbox-guest-additions-6.1.16-1.mga7.x86_64
- virtualbox-kernel-5.7.19-desktop-3.mga7-6.1.16-1.mga7.x86_64
- virtualbox-kernel-desktop-latest-6.1.16-1.mga7.x86_64

My "Guest" - Mageia-8-Cauldron-MATE-x86_64, Kernel-5.9.11-desktop-3.mga8

After the update, the problem with the bidirectional clipboard is no longer there. It works well. I will say more, even "Drag and Drop" works.

So everything is fine. :)
Comment 12 Alex Kotov 2020-12-22 09:27:55 CET
Now the bidirectional shared clipboard works perfectly.

Host (Mageia-7.1):
> rpm -qi virtualbox
Name        : virtualbox
Version     : 6.1.16
Release     : 4.mga7
Architecture: x86_64
Install Date: Вт 22 дек 2020 11:17:01
Group       : Emulators
Size        : 125842199
License     : GPLv2
Signature   : RSA/SHA256, Чт 17 дек 2020 03:50:39, Key ID b742fa8b80420f66
Source RPM  : virtualbox-6.1.16-4.mga7.src.rpm
Build Date  : Чт 17 дек 2020 03:08:17
Build Host  : localhost
Relocations : (not relocatable)
Packager    : tmb <tmb>
Vendor      : Mageia.Org
URL         : https://www.virtualbox.org/
Summary     : A general-purpose full virtualizer for x86 hardware
Description :
VirtualBox is a general-purpose full virtualizer for x86 hardware.
> uname -a
Linux localhost 5.7.19-desktop-3.mga7 #1 SMP Sun Oct 18 15:46:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Guest (Mageia-8-Cauldron):
> uname -a
Linux localhost 5.10.2-desktop-1.mga8 #1 SMP Mon Dec 21 13:01:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Thank You for your cooperation.

For more information, see the screenshot "Host<->Guest copy check".
Comment 13 Alex Kotov 2020-12-22 09:29:01 CET
Created attachment 12133 [details]
Host<->Guest copy check
Comment 14 Alex Kotov 2020-12-22 09:31:11 CET
I will close this bug so as not to distract You from more important things.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.