Bug 27209 - Trouble flashing iso with iso dumper
Summary: Trouble flashing iso with iso dumper
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2020-08-27 11:24 CEST by Guillaume Royer
Modified: 2020-09-02 17:42 CEST (History)
7 users (show)

See Also:
Source RPM: isodumper-1.21-1.mga7.src.rpm
CVE:
Status comment:


Attachments
Command udisksctl dump (42.62 KB, text/plain)
2020-08-27 11:26 CEST, Guillaume Royer
Details
Screenshot (68.18 KB, image/png)
2020-08-27 11:27 CEST, Guillaume Royer
Details
Udisksctl dump file 2 (42.84 KB, text/plain)
2020-08-29 21:35 CEST, Guillaume Royer
Details
Screenshot 2020-08-29 (69.72 KB, image/png)
2020-08-29 21:36 CEST, Guillaume Royer
Details

Description Guillaume Royer 2020-08-27 11:24:43 CEST
Description of problem:
When i try to write iso to flash drive, i have message:

"this device is too small to contain the iso image"

Version-Release number:

Isodumper 1.2


See on attached file result of command udidisksctl dump
Comment 1 Guillaume Royer 2020-08-27 11:26:43 CEST
Created attachment 11841 [details]
Command udisksctl dump

Result of command udisksctl dump
Comment 2 Guillaume Royer 2020-08-27 11:27:58 CEST
Created attachment 11842 [details]
Screenshot

Screenshot of the problem
Comment 3 Aurelien Oudelet 2020-08-27 11:34:16 CEST
Hi,
Thanks reporting this.

Your flash drive seems have sufficient capacity (>= 7Go) for a netinstall.iso.

Have you ever tried to completely format your flash drive with a single empty partition in gparted?

isodumper can't use a particular partition on a drive and must use all volumes on it in order to create a boot partition and dump ISO file on it. All partitions present shall be removed.
Comment 4 Guillaume Royer 2020-08-27 12:02:38 CEST
Yes i have tried to format my flash drive with a single empty partition in gparted.

i tried to format with isodumper too
Comment 5 Dave Hodgins 2020-08-27 17:26:34 CEST
Make sure the partition is not mounted.

CC: (none) => davidwhodgins

Comment 6 Guillaume Royer 2020-08-27 20:51:56 CEST
If partition isn't mounted i can't see flash drive in list of devices
Comment 7 Dave Hodgins 2020-08-28 21:35:13 CEST
The partition must not be mounted. I'm guessing you can't see the device due
to the use of automount, and the way it's being unmounted.

The device manager option to safely remove a device doesn't just umount the
file system, it logically ejects the drive making it unavailable until the
bus is rescanned, usually by removing and reinserting the device or rebooting. 

To avoid that disable automounting or manually unmount any filesystems on that
device using the umount command (run as root).
Comment 8 Guillaume Royer 2020-08-29 21:33:59 CEST
I make new udisks dump file after trying to flash usb drive.
See attached file.

With Papoteur we have modified error message to have Iso size and Device size.
See attached scrennshot.
Comment 9 Guillaume Royer 2020-08-29 21:35:42 CEST
Created attachment 11858 [details]
Udisksctl dump file 2
Comment 10 Guillaume Royer 2020-08-29 21:36:50 CEST
Created attachment 11859 [details]
Screenshot 2020-08-29
Comment 11 Dave Hodgins 2020-08-29 22:51:23 CEST
It seems to be taking the size from the device
/org/freedesktop/UDisks2/block_devices/mmcblk2boot0:
rather then
/org/freedesktop/UDisks2/block_devices/sdb

Any chance a small sd card is being selected by mistake?
Comment 12 Guillaume Royer 2020-08-30 11:23:04 CEST
No chance...

My computer is Asus T100TA:

https://www.asus.com/fr/2-in-1-PCs/ASUS_Transformer_Book_T100TA/

So there is 3 devices:

- one MMC where Mageia is intalled 32Go named mmcblk2
- one SD card 64Go named mmcblk0 where is located in my screen
- one dock with hdd 1To named sda

 and my flash drive sdb.

It's seems disks management is special on my system...
Comment 13 papoteur 2020-09-01 06:58:42 CEST
Isodumper 1.21 is coming.

CC: (none) => yves.brungard_mageia

Comment 14 papoteur 2020-09-01 08:39:48 CEST
Isodumper 1.21 is to test for Mageia 7.

Assignee: bugsquad => qa-bugs

Comment 15 papoteur 2020-09-01 09:04:57 CEST
Advisory
====================================
In some cases, when device was reported without Vendor nor Model by udisks, the selected device was not used but the one without info instead.
This fix assures that the wanted device is selected.
====================================
isodumper-1.21-1.mga7
Comment 16 Herman Viaene 2020-09-01 11:49:27 CEST
MHA7-64 Plasma on Lenovo B50
There is no previous version of isodumper on this laptop, but when selecting the 1.21 version in MCC I get:
"Sorry, the following package cannot be selected:

- isodumper-1.21-1.mga7.noarch (due to conflicts with isodumper-gtk-1.20-1.mga7.noarch)"

CC: (none) => herman.viaene

Comment 17 Thomas Andrews 2020-09-01 14:20:14 CEST
Herman, problem is we don't have a full list of the rpms. If you use "isodumper*" in qarepo, you will download all three rpms of the update.

CC: (none) => andrewsfarm

Aurelien Oudelet 2020-09-01 21:18:07 CEST

Source RPM: (none) => isodumper-1.21-1.mga7.src.rpm

Comment 18 David GEIGER 2020-09-01 22:22:11 CEST
List of packages:

Packages in 7/core/updates_testing:
========================
isodumper-1.21-1.mga7.noarch.rpm
isodumper-qt-1.21-1.mga7.noarch.rpm
isodumper-gtk-1.21-1.mga7.noarch.rpm

Source RPM: 
========================
isodumper-1.21-1.mga7.src.rpm

CC: (none) => geiger.david68210

Comment 19 ben mcmonagle 2020-09-02 00:48:23 CEST
Mga8 on Asus T100TA-DK

(yes, I know, not Mga7)

To satisfy dependencies, the following packages are going to be installed:
  Package                        Version      Release       Arch    
(medium "Core Release (distrib1)")
  isodumper                      1.21         1.mga8        noarch  
  isodumper-gtk                  1.21         1.mga8        noarch  
  libyui12-gtk                   2.49.0       4.mga8        i586    
  libyui12-mga-gtk               1.1.0        2.mga8        i586    
  python3-argparse               1.4.0        6.mga8        noarch  
  python3-gettext                4.0          3.mga8        noarch  
  python3-gnupg                  0.4.5        2.mga8        noarch  
  python3-manatools              0.0.3        1.mga8        noarch  
  python3-parted                 3.11.6       1.mga8        i586    
  python3-psutil                 5.6.7        2.mga8        i586    
  python3-pydbus                 0.6.0        6.mga8        noarch  
  python3-yaml                   5.3.1        1.mga8        i586    
  python3-yui                    2.0.2        1.mga8        i586    
7.1MB of additional disk space will be used.
1.7MB of packages will be retrieved.
Proceed with the installation of the 13 packages? (Y/n) y

$ isodumper

Target Device: Kingston DataTraveler G3 (/dev/sda) 3.604 GiB
Image : /home/home/Downloads/Mageia-7.1-netinstall-nonfree-x86_64.iso
Executing copy from /home/home/Downloads/Mageia-7.1-netinstall-nonfree-x86_64.iso to /dev/sda
Image Mageia-7.1-netinstall-nonfree-x86_64.iso successfully written to /dev/sda
Bytes written: 89128960
SHA3 sum: FDEF0C5BA646D87988A6F61D9E972832B89926169A5BE5BAB68C435999DF7C3AB9241C176C69550B97A6DBF8EF06F7E1C9213B77DA3FD189AD4B4EE03C5033C5

CC: (none) => westel

Comment 20 Herman Viaene 2020-09-02 14:58:48 CEST
MGA7-64 Plasma on Lenovo B50
No installation issues with the 3 rpms.
Ref to Comment 8  I tried to write a 4Gb iso on a 2Gb stick
$ isodumper --qt
Target Device: General UDisk (/dev/sdb) 1.875 GiB
Image : /mnt/tools/QaISO/Mageia-8-beta1-x86_64/Mageia-8-beta1-x86_64.iso
The device is too small to contain the ISO file.
This feedback was also shown in the isodumper window.
In view of Ben's test in Comment 19, OK for me.

Whiteboard: (none) => MGA7-64-OK

Aurelien Oudelet 2020-09-02 16:30:59 CEST

Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 21 Aurelien Oudelet 2020-09-02 16:34:01 CEST
Advisory Comment 15 and packages comment 18
Aurelien Oudelet 2020-09-02 16:46:35 CEST

Keywords: (none) => advisory

Comment 22 Mageia Robot 2020-09-02 17:42:29 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2020-0201.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.